cleanup: Remove expired ports:
2022-06-30 irc/unreal: Very outdated, listed as end of life in 2016 and has known security issues
This commit is contained in:
parent
e310ef59cf
commit
e4d9ab98ed
17 changed files with 1 additions and 589 deletions
1
MOVED
1
MOVED
|
@ -17486,3 +17486,4 @@ x11/i3status|deskutils/i3status|2022-07-01|move desktop utility to its right cat
|
|||
x11/xcbautolock|deskutils/xcbautolock|2022-07-01|move desktop utility to its right category
|
||||
x11/havoc|deskutils/havoc|2022-07-01|move desktop utility to its right category
|
||||
devel/go-glide||2022-07-01|Has expired: use go mod instead of glide
|
||||
irc/unreal||2022-07-01|Has expired: Very outdated, listed as end of life in 2016 and has known security issues
|
||||
|
|
|
@ -107,7 +107,6 @@
|
|||
SUBDIR += thales
|
||||
SUBDIR += tircproxy
|
||||
SUBDIR += undernet-ircu
|
||||
SUBDIR += unreal
|
||||
SUBDIR += weechat
|
||||
SUBDIR += weechat-otr
|
||||
SUBDIR += znc
|
||||
|
|
|
@ -1,147 +0,0 @@
|
|||
# Created by: Gerrit Beine (<tux@pinguru.net>)
|
||||
|
||||
PORTNAME= Unreal
|
||||
PORTVERSION= 3.2.10.7
|
||||
CATEGORIES= irc
|
||||
MASTER_SITES= http://www.unrealircd.com/downloads/
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Unreal - the next generation ircd
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
DEPRECATED= Very outdated, listed as end of life in 2016 and has known security issues
|
||||
EXPIRATION_DATE=2022-06-30
|
||||
|
||||
BROKEN_aarch64= Fails to link: missing sbrk
|
||||
BROKEN_riscv64= Fails to link: missing sbrk
|
||||
|
||||
LIB_DEPENDS= libcares.so:dns/c-ares
|
||||
|
||||
MODULESDIR= ${PREFIX}/lib/${PORTNAME}
|
||||
CONFIGDIR= ${PREFIX}/etc/${PORTNAME}
|
||||
RUNDIR= /var/run/ircd
|
||||
LOGDIR= /var/log/ircd
|
||||
|
||||
USES= pkgconfig cpe
|
||||
HAS_CONFIGURE= yes
|
||||
USE_RC_SUBR= unrealircd
|
||||
|
||||
USERS= ircd
|
||||
GROUPS= ircd
|
||||
CPE_VENDOR= unrealircd
|
||||
CPE_PRODUCT= unrealircd
|
||||
|
||||
SUB_LIST+= RUNDIR=${RUNDIR}
|
||||
SUB_LIST+= USERS=${USERS}
|
||||
SUB_LIST+= GROUPS=${GROUPS}
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CFLAGS+= ${CPPFLAGS}
|
||||
CONFIGURE_ARGS= --with-listen=5 \
|
||||
--with-dpath=${CONFIGDIR} \
|
||||
--with-spath=${PREFIX}/libexec/ircd \
|
||||
--with-nick-history=2000 \
|
||||
--with-sendq=3000000 \
|
||||
--with-bufferpool=18 \
|
||||
--with-permissions=0600 \
|
||||
--with-fd-setsize=1024 \
|
||||
--with-system-cares \
|
||||
--enable-dynamic-linking
|
||||
|
||||
OPTIONS_DEFINE= HUB NOSPOOF ZIPLINKS SSL IPV6 PREFIXAQ REMOTE DOCS
|
||||
OPTIONS_DEFAULT= HUB SSL
|
||||
HUB_DESC= Configure as a hub (otherwise configure as a leaf)
|
||||
NOSPOOF_DESC= Enable anti-spoof protection
|
||||
ZIPLINKS_DESC= Enable ziplinks support
|
||||
PREFIXAQ_DESC= Enable prefixes for chanadmin and chanowner
|
||||
REMOTE_DESC= Enable remote includes
|
||||
|
||||
PORTDOCS= *
|
||||
DOCS= Donation doc/Authors doc/coding-guidelines \
|
||||
doc/example.conf doc/tao.of.irc \
|
||||
doc/translations.txt doc/unreal32docs.html \
|
||||
doc/technical/005.txt doc/technical/base64.txt \
|
||||
doc/technical/protoctl.txt doc/technical/token.txt \
|
||||
doc/technical/vl.txt
|
||||
|
||||
HUB_CONFIGURE_ENABLE= hub
|
||||
NOSPOOF_CONFIGURE_ENABLE= nospoof
|
||||
ZIPLINKS_CONFIGURE_ENABLE= ziplinks
|
||||
IPV6_CONFIGURE_ENABLE= inet6
|
||||
SSL_CONFIGURE_ENABLE= ssl
|
||||
SSL_USES= ssl
|
||||
REMOTE_LIB_DEPENDS= libcurl.so:ftp/curl
|
||||
REMOTE_CONFIGURE_ENABLE= --enable-libcurl=${LOCALBASE}
|
||||
PREFIXAQ_CONFIGURE_ENABLE= prefixaq
|
||||
|
||||
SQLMOD= ${PORTNAME}/SQLMod.tar.gz
|
||||
|
||||
# Upstream dead, don't expect a proper fix.
|
||||
CFLAGS+= -fcommon
|
||||
|
||||
.if exists(${DISTDIR}/${SQLMOD})
|
||||
USES+= mysql
|
||||
WITH_SQLMOD= yes
|
||||
MAKE_ARGS= all custommodule MODULEFILE=m_sqlmod
|
||||
PLIST_SUB+= SQLMOD=""
|
||||
.else
|
||||
PLIST_SUB+= SQLMOD="@comment "
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
.if defined(WITH_SQLMOD)
|
||||
@${TAR} xfz ${DISTDIR}/${SQLMOD} -C ${WRKSRC}
|
||||
@${MV} ${WRKSRC}/SQLMod* ${WRKSRC}/SQLMod
|
||||
@${CP} -r ${WRKSRC}/SQLMod/m_sqlmod.c ${WRKSRC}/src/modules
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," \
|
||||
-e "s,%%RUNDIR%%,${RUNDIR}," \
|
||||
-e "s,%%USERS%%,${USERS}," \
|
||||
-e "s,%%GROUPS%%,${GROUPS}," \
|
||||
-e "s,%%LOGDIR%%,${LOGDIR}," ${WRKSRC}/include/config.h
|
||||
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," \
|
||||
-e "s,%%LOGDIR%%,${LOGDIR}," ${WRKSRC}/doc/example.conf
|
||||
@${REINPLACE_CMD} -e "s,%%RUNDIR%%,${RUNDIR}," ${WRKSRC}/src/ircd.c
|
||||
@${REINPLACE_CMD} -e "s,%%RUNDIR%%,${RUNDIR}," ${WRKSRC}/src/modules.c
|
||||
@${REINPLACE_CMD} -e "s,%%RUNDIR%%,${RUNDIR}," ${WRKSRC}/src/s_conf.c
|
||||
@${REINPLACE_CMD} -e "s,%%RUNDIR%%,${RUNDIR}," ${WRKSRC}/src/url.c
|
||||
.if defined(WITH_SQLMOD)
|
||||
@${PATCH} -d ${WRKSRC} < ${WRKSRC}/SQLMod/patch
|
||||
.endif
|
||||
@${REINPLACE_CMD} -e "/Your system does not support IPv6/ s|as_fn_error|echo|" ${WRKSRC}/configure
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/ircd ${STAGEDIR}${PREFIX}/libexec/ircd
|
||||
${MKDIR} ${STAGEDIR}${MODULESDIR}
|
||||
${MKDIR} ${STAGEDIR}${CONFIGDIR} || true
|
||||
${MKDIR} ${STAGEDIR}${CONFIGDIR}/aliases || true
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/aliases
|
||||
${MKDIR} ${STAGEDIR}${RUNDIR}/tmp
|
||||
${MKDIR} ${STAGEDIR}${LOGDIR}
|
||||
${TOUCH} ${STAGEDIR}${CONFIGDIR}/ircd.motd
|
||||
${TOUCH} ${STAGEDIR}${CONFIGDIR}/ircd.rules
|
||||
${INSTALL_DATA} ${WRKSRC}/badwords.*.conf ${STAGEDIR}${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/help.conf ${STAGEDIR}${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/spamfilter.conf ${STAGEDIR}${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/example.conf ${STAGEDIR}${EXAMPLESDIR}/unrealircd.conf
|
||||
${INSTALL_DATA} ${WRKSRC}/aliases/*.conf ${STAGEDIR}${EXAMPLESDIR}/aliases
|
||||
${INSTALL} ${WRKSRC}/src/modules/*.so ${STAGEDIR}${MODULESDIR}
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for file in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
|
||||
.if defined(WITH_SQLMOD)
|
||||
@${CP} ${WRKSRC}/SQLMod/sample.conf ${STAGEDIR}${CONFIGDIR}/m_sqlmod.conf
|
||||
@${CP} ${WRKSRC}/SQLMod/Changes ${STAGEDIR}${DOCSDIR}/Changes.sqlmod
|
||||
@${CP} ${WRKSRC}/SQLMod/README ${STAGEDIR}${DOCSDIR}/README.sqlmod
|
||||
@${CP} ${WRKSRC}/SQLMod/LICENSE ${STAGEDIR}${DOCSDIR}/LICENSE.sqlmod
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
TIMESTAMP = 1473082474
|
||||
SHA256 (Unreal3.2.10.7.tar.gz) = 472e12cd42d2e725a1795e2bead4786062775782bd015a07697c2edf400d4047
|
||||
SIZE (Unreal3.2.10.7.tar.gz) = 3539026
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.in.orig 2016-09-03 19:34:06 UTC
|
||||
+++ Makefile.in
|
||||
@@ -38,7 +38,7 @@ IRCDLIBS=@IRCDLIBS@ @TRE_LIBS@ @CARES_LI
|
||||
CRYPTOLIB=@CRYPTOLIB@
|
||||
OPENSSLINCLUDES=
|
||||
|
||||
-XCFLAGS=@TRE_CFLAGS@ @CARES_CFLAGS@ @CFLAGS@
|
||||
+XCFLAGS=-I@TREINCDIR@ @TRE_CFLAGS@ @CFLAGS@
|
||||
#
|
||||
# use the following on MIPS:
|
||||
#CFLAGS= -systype bsd43 -DSYSTYPE_BSD43 -I$(INCLUDEDIR)
|
|
@ -1,59 +0,0 @@
|
|||
--- configure.orig 2016-09-03 19:34:06 UTC
|
||||
+++ configure
|
||||
@@ -3918,6 +3918,47 @@ fi
|
||||
|
||||
|
||||
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for RAND_egd in -lcrypto" >&5
|
||||
+$as_echo_n "checking for RAND_egd in -lcrypto... " >&6; }
|
||||
+if ${ac_cv_lib_crypto_RAND_egd+:} false; then :
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ ac_check_lib_save_LIBS=$LIBS
|
||||
+LIBS="-lcrypto $LIBS"
|
||||
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+
|
||||
+/* Override any GCC internal prototype to avoid an error.
|
||||
+ Use char because int might match the return type of a GCC
|
||||
+ builtin and then its argument prototype would still apply. */
|
||||
+#ifdef __cplusplus
|
||||
+extern "C"
|
||||
+#endif
|
||||
+char RAND_egd ();
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+return RAND_egd ();
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+if ac_fn_c_try_link "$LINENO"; then :
|
||||
+ ac_cv_lib_crypto_RAND_egd=yes
|
||||
+else
|
||||
+ ac_cv_lib_crypto_RAND_egd=no
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext \
|
||||
+ conftest$ac_exeext conftest.$ac_ext
|
||||
+LIBS=$ac_check_lib_save_LIBS
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_crypto_RAND_egd" >&5
|
||||
+$as_echo "$ac_cv_lib_crypto_RAND_egd" >&6; }
|
||||
+if test "x$ac_cv_lib_crypto_RAND_egd" = xyes; then :
|
||||
+
|
||||
+$as_echo "#define HAVE_RAND_EGD 1" >>confdefs.h
|
||||
+
|
||||
+fi
|
||||
|
||||
|
||||
|
||||
@@ -6537,7 +6578,7 @@ fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_ip6" >&5
|
||||
$as_echo "$ac_cv_ip6" >&6; }
|
||||
if test "$ac_cv_ip6" = "no"; then
|
||||
- as_fn_error $? "Your system does not support IPv6 so it will not be enabled" "$LINENO" 5
|
||||
+ echo $? "Your system does not support IPv6 so it will not be enabled" "$LINENO" 5
|
||||
else
|
||||
|
||||
$as_echo "#define INET6 /**/" >>confdefs.h
|
|
@ -1,22 +0,0 @@
|
|||
--- doc/example.conf.orig 2016-09-03 19:34:06 UTC
|
||||
+++ doc/example.conf
|
||||
@@ -33,8 +33,8 @@
|
||||
*/
|
||||
|
||||
/* FOR *NIX, uncomment the following 2lines: */
|
||||
-//loadmodule "src/modules/commands.so";
|
||||
-//loadmodule "src/modules/cloak.so";
|
||||
+loadmodule "/usr/local/lib/Unreal/commands.so";
|
||||
+loadmodule "/usr/local/lib/Unreal/cloak.so";
|
||||
|
||||
/* FOR Windows, uncomment the following 2 lines: */
|
||||
//loadmodule "modules/commands.dll";
|
||||
@@ -379,7 +379,7 @@ drpass {
|
||||
* };
|
||||
*/
|
||||
|
||||
-log "ircd.log" {
|
||||
+log "/var/log/ircd/ircd.log" {
|
||||
/* Delete the log file and start a new one when it reaches 2MB, leave this out to always use the
|
||||
same log */
|
||||
maxsize 2097152;
|
|
@ -1,40 +0,0 @@
|
|||
--- include/config.h.orig 2016-09-03 19:34:06 UTC
|
||||
+++ include/config.h
|
||||
@@ -242,16 +242,16 @@
|
||||
* line argument. These used as the default values for options absent from the user's
|
||||
* unrealircd.conf.
|
||||
*/
|
||||
-#define CPATH "unrealircd.conf" /* server configuration file */
|
||||
-#define MPATH "ircd.motd" /* server MOTD file */
|
||||
-#define SMPATH "ircd.smotd" /* short MOTD file */
|
||||
-#define RPATH "ircd.rules" /* server rules file */
|
||||
-#define OPATH "oper.motd" /* Operators MOTD file */
|
||||
-#define LPATH "debug.log" /* Where the debug file lives, if DEBUGMODE */
|
||||
-#define PPATH "ircd.pid" /* file for server pid */
|
||||
-#define VPATH "ircd.svsmotd" /* Services MOTD append. */
|
||||
-#define BPATH "bot.motd" /* Bot MOTD */
|
||||
-#define IRCDTUNE "ircd.tune" /* tuning .. */
|
||||
+#define CPATH "/usr/local/etc/Unreal/unrealircd.conf" /* server configuration file */
|
||||
+#define MPATH "/usr/local/etc/Unreal/ircd.motd" /* server MOTD file */
|
||||
+#define SMPATH "/usr/local/etc/Unreal/ircd.smotd" /* short MOTD file */
|
||||
+#define RPATH "/usr/local/etc/Unreal/ircd.rules" /* server rules file */
|
||||
+#define OPATH "/usr/local/etc/Unreal/oper.motd" /* Operators MOTD file */
|
||||
+#define LPATH "/var/log/ircd/debug.log" /* Where the debug file lives, if DEBUGMODE */
|
||||
+#define PPATH "/var/run/ircd/ircd.pid" /* file for server pid */
|
||||
+#define VPATH "/usr/local/etc/Unreal/ircd.svsmotd" /* Services MOTD append. */
|
||||
+#define BPATH "/usr/local/etc/Unreal/bot.motd" /* Bot MOTD */
|
||||
+#define IRCDTUNE "/var/run/ircd/ircd.tune" /* tuning .. */
|
||||
|
||||
/* CHROOTDIR
|
||||
*
|
||||
@@ -277,8 +277,8 @@
|
||||
* define IRC_USER to that user name. This should only be defined if you
|
||||
* are running as root and even then perhaps not.
|
||||
*/
|
||||
-/* #define IRC_USER "<user name>" */
|
||||
-/* #define IRC_GROUP "<group name>" */
|
||||
+#define IRC_USER "ircd"
|
||||
+#define IRC_GROUP "ircd"
|
||||
|
||||
|
||||
/* SHOW_INVISIBLE_LUSERS
|
|
@ -1,17 +0,0 @@
|
|||
--- src/ircd.c.orig 2016-09-03 19:34:06 UTC
|
||||
+++ src/ircd.c
|
||||
@@ -1422,12 +1422,12 @@ int InitwIRCD(int argc, char *argv[])
|
||||
}
|
||||
#endif
|
||||
#ifndef _WIN32
|
||||
- mkdir("tmp", S_IRUSR|S_IWUSR|S_IXUSR); /* Create the tmp dir, if it doesn't exist */
|
||||
+ mkdir("/var/run/ircd/tmp", S_IRUSR|S_IWUSR|S_IXUSR); /* Create the tmp dir, if it doesn't exist */
|
||||
#if defined(USE_LIBCURL) && defined(REMOTEINC_SPECIALCACHE)
|
||||
mkdir("cache", S_IRUSR|S_IWUSR|S_IXUSR); /* Create the cache dir, if using curl and it doesn't exist */
|
||||
#endif
|
||||
#else
|
||||
- mkdir("tmp");
|
||||
+ mkdir("/var/run/ircd/tmp");
|
||||
#if defined(USE_LIBCURL) && defined(REMOTEINC_SPECIALCACHE)
|
||||
mkdir("cache");
|
||||
#endif
|
|
@ -1,58 +0,0 @@
|
|||
--- src/modules.c.orig 2016-09-03 19:34:06 UTC
|
||||
+++ src/modules.c
|
||||
@@ -183,12 +183,12 @@ void DeleteTempModules(void)
|
||||
{
|
||||
char tempbuf[PATH_MAX+1];
|
||||
#ifndef _WIN32
|
||||
- DIR *fd = opendir("tmp");
|
||||
+ DIR *fd = opendir("/var/run/ircd/tmp");
|
||||
struct dirent *dir;
|
||||
|
||||
if (!fd) /* Ouch.. this is NOT good!! */
|
||||
{
|
||||
- config_error("Unable to open 'tmp' directory: %s, please create one with the appropriate permissions",
|
||||
+ config_error("Unable to open '/var/run/ircd' directory: %s, please create one with the appropriate permissions",
|
||||
strerror(errno));
|
||||
if (!loop.ircd_booted)
|
||||
exit(7);
|
||||
@@ -199,19 +199,19 @@ void DeleteTempModules(void)
|
||||
{
|
||||
if (!strcmp(dir->d_name, ".") || !strcmp(dir->d_name, ".."))
|
||||
continue;
|
||||
- strcpy(tempbuf, "tmp/");
|
||||
+ strcpy(tempbuf, "/var/run/ircd/tmp/");
|
||||
strcat(tempbuf, dir->d_name);
|
||||
remove(tempbuf);
|
||||
}
|
||||
closedir(fd);
|
||||
#else
|
||||
WIN32_FIND_DATA hData;
|
||||
- HANDLE hFile = FindFirstFile("tmp/*", &hData);
|
||||
+ HANDLE hFile = FindFirstFile("/var/run/ircd/tmp/*", &hData);
|
||||
if (hFile != INVALID_HANDLE_VALUE)
|
||||
{
|
||||
if (strcmp(hData.cFileName, ".") || strcmp(hData.cFileName, ".."))
|
||||
{
|
||||
- strcpy(tempbuf, "tmp/");
|
||||
+ strcpy(tempbuf, "/var/run/ircd/tmp/");
|
||||
strcat(tempbuf, hData.cFileName);
|
||||
remove(tempbuf);
|
||||
}
|
||||
@@ -220,7 +220,7 @@ void DeleteTempModules(void)
|
||||
{
|
||||
if (!strcmp(hData.cFileName, ".") || !strcmp(hData.cFileName, ".."))
|
||||
continue;
|
||||
- strcpy(tempbuf, "tmp/");
|
||||
+ strcpy(tempbuf, "/var/run/ircd/tmp/");
|
||||
strcat(tempbuf, hData.cFileName);
|
||||
remove(tempbuf);
|
||||
}
|
||||
@@ -329,7 +329,7 @@ char *Module_Create(char *path_)
|
||||
path = path_;
|
||||
|
||||
|
||||
- tmppath = unreal_mktemp("tmp", unreal_getfilename(path));
|
||||
+ tmppath = unreal_mktemp("/var/run/ircd/tmp", unreal_getfilename(path));
|
||||
if (!tmppath)
|
||||
return "Unable to create temporary file!";
|
||||
#ifndef _WIN32
|
|
@ -1,11 +0,0 @@
|
|||
--- src/parse.c.orig 2016-09-03 19:34:06 UTC
|
||||
+++ src/parse.c
|
||||
@@ -156,7 +156,7 @@ void ban_flooder(aClient *cptr)
|
||||
/*
|
||||
* This routine adds fake lag if needed.
|
||||
*/
|
||||
-inline void parse_addlag(aClient *cptr, int cmdbytes)
|
||||
+static inline void parse_addlag(aClient *cptr, int cmdbytes)
|
||||
{
|
||||
if (!IsServer(cptr) && !IsNoFakeLag(cptr) &&
|
||||
#ifdef FAKELAG_CONFIGURABLE
|
|
@ -1,11 +0,0 @@
|
|||
--- src/s_bsd.c.orig 2016-09-03 19:34:06 UTC
|
||||
+++ src/s_bsd.c
|
||||
@@ -455,7 +455,7 @@ int inetport(aClient *cptr, char *name,
|
||||
*/
|
||||
if (cptr->fd == -1)
|
||||
{
|
||||
- cptr->fd = socket(AFINET, SOCK_STREAM, 0);
|
||||
+ cptr->fd = socket(AFINET, SOCK_STREAM, IPPROTO_TCP);
|
||||
}
|
||||
if (cptr->fd < 0)
|
||||
{
|
|
@ -1,11 +0,0 @@
|
|||
--- src/s_conf.c.orig 2016-09-03 19:34:06 UTC
|
||||
+++ src/s_conf.c
|
||||
@@ -9841,7 +9841,7 @@ static void conf_download_complete(const
|
||||
{
|
||||
char *urlfile = url_getfilename(url);
|
||||
char *file_basename = unreal_getfilename(urlfile);
|
||||
- char *tmp = unreal_mktemp("tmp", file_basename);
|
||||
+ char *tmp = unreal_mktemp("/var/run/ircd/tmp", file);
|
||||
free(urlfile);
|
||||
|
||||
if (cached)
|
|
@ -1,20 +0,0 @@
|
|||
--- src/url.c.orig 2016-09-03 19:34:06 UTC
|
||||
+++ src/url.c
|
||||
@@ -174,7 +174,7 @@ char *download_file(const char *url, cha
|
||||
CURLcode res;
|
||||
char *file = url_getfilename(url);
|
||||
char *filename = unreal_getfilename(file);
|
||||
- char *tmp = unreal_mktemp("tmp", filename ? filename : "download.conf");
|
||||
+ char *tmp = unreal_mktemp("/var/run/ircd/tmp", filename ? filename : "download.conf");
|
||||
FILE *fd;
|
||||
|
||||
|
||||
@@ -359,7 +359,7 @@ void download_file_async(const char *url
|
||||
{
|
||||
char *file = url_getfilename(url);
|
||||
char *filename = unreal_getfilename(file);
|
||||
- char *tmp = unreal_mktemp("tmp", filename ? filename : "download.conf");
|
||||
+ char *tmp = unreal_mktemp("/var/run/ircd/tmp", filename ? filename : "download.conf");
|
||||
FileHandle *handle = MyMallocEx(sizeof(FileHandle));
|
||||
handle->fd = fopen(tmp, "wb");
|
||||
if (!handle->fd)
|
|
@ -1,36 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# PROVIDE: unrealircd
|
||||
# REQUIRE: NETWORKING SERVERS
|
||||
# BEFORE: DAEMON
|
||||
# KEYWORD: shutdown
|
||||
|
||||
#
|
||||
# Add the following line to /etc/rc.conf to enable Unreal IRCd:
|
||||
# unrealircd_enable (bool): Set to "NO" by default.
|
||||
# Set it to "YES" to enable Unreal IRCd
|
||||
#
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name=unrealircd
|
||||
rcvar=unrealircd_enable
|
||||
load_rc_config $name
|
||||
|
||||
: ${unrealircd_enable:=NO}
|
||||
|
||||
command=%%PREFIX%%/libexec/ircd
|
||||
pidfile=%%RUNDIR%%/ircd.pid
|
||||
start_precmd=unreal_prestart
|
||||
|
||||
required_files="%%PREFIX%%/etc/Unreal/unrealircd.conf"
|
||||
|
||||
unreal_prestart()
|
||||
{
|
||||
if [ ! -d ${pidfile%/*} ]; then
|
||||
install -d -o %%USERS%% -g %%GROUPS%% ${pidfile%/*}
|
||||
install -d -o %%USERS%% -g %%GROUPS%% ${pidfile%/*}/tmp
|
||||
fi
|
||||
}
|
||||
|
||||
run_rc_command "$1"
|
|
@ -1,3 +0,0 @@
|
|||
Unreal IRCd - the next generation ircd
|
||||
|
||||
WWW: http://www.unrealircd.com
|
|
@ -1,139 +0,0 @@
|
|||
%%ETCDIR%%/ircd.motd
|
||||
%%ETCDIR%%/ircd.rules
|
||||
lib/Unreal/cloak.so
|
||||
lib/Unreal/commands.so
|
||||
lib/Unreal/m_addline.so
|
||||
lib/Unreal/m_addmotd.so
|
||||
lib/Unreal/m_addomotd.so
|
||||
lib/Unreal/m_admin.so
|
||||
lib/Unreal/m_adminchat.so
|
||||
lib/Unreal/m_akill.so
|
||||
lib/Unreal/m_away.so
|
||||
lib/Unreal/m_botmotd.so
|
||||
lib/Unreal/m_cap.so
|
||||
lib/Unreal/m_chatops.so
|
||||
lib/Unreal/m_chghost.so
|
||||
lib/Unreal/m_chgident.so
|
||||
lib/Unreal/m_chgname.so
|
||||
lib/Unreal/m_close.so
|
||||
lib/Unreal/m_connect.so
|
||||
lib/Unreal/m_cycle.so
|
||||
lib/Unreal/m_dccallow.so
|
||||
lib/Unreal/m_dccdeny.so
|
||||
lib/Unreal/m_eos.so
|
||||
lib/Unreal/m_globops.so
|
||||
lib/Unreal/m_guest.so
|
||||
lib/Unreal/m_help.so
|
||||
lib/Unreal/m_htm.so
|
||||
lib/Unreal/m_invite.so
|
||||
lib/Unreal/m_ison.so
|
||||
lib/Unreal/m_issecure.so
|
||||
lib/Unreal/m_join.so
|
||||
lib/Unreal/m_kick.so
|
||||
lib/Unreal/m_kill.so
|
||||
lib/Unreal/m_knock.so
|
||||
lib/Unreal/m_lag.so
|
||||
lib/Unreal/m_links.so
|
||||
lib/Unreal/m_list.so
|
||||
lib/Unreal/m_locops.so
|
||||
lib/Unreal/m_lusers.so
|
||||
lib/Unreal/m_map.so
|
||||
lib/Unreal/m_message.so
|
||||
lib/Unreal/m_mkpasswd.so
|
||||
lib/Unreal/m_mode.so
|
||||
lib/Unreal/m_motd.so
|
||||
lib/Unreal/m_nachat.so
|
||||
lib/Unreal/m_names.so
|
||||
lib/Unreal/m_netinfo.so
|
||||
lib/Unreal/m_nick.so
|
||||
lib/Unreal/m_nopost.so
|
||||
lib/Unreal/m_oper.so
|
||||
lib/Unreal/m_opermotd.so
|
||||
lib/Unreal/m_part.so
|
||||
lib/Unreal/m_pass.so
|
||||
lib/Unreal/m_pingpong.so
|
||||
lib/Unreal/m_protoctl.so
|
||||
lib/Unreal/m_quit.so
|
||||
lib/Unreal/m_rakill.so
|
||||
lib/Unreal/m_rping.so
|
||||
lib/Unreal/m_rules.so
|
||||
lib/Unreal/m_sajoin.so
|
||||
lib/Unreal/m_samode.so
|
||||
lib/Unreal/m_sapart.so
|
||||
lib/Unreal/m_sasl.so
|
||||
lib/Unreal/m_sdesc.so
|
||||
lib/Unreal/m_sendsno.so
|
||||
lib/Unreal/m_sendumode.so
|
||||
lib/Unreal/m_server.so
|
||||
lib/Unreal/m_sethost.so
|
||||
lib/Unreal/m_setident.so
|
||||
lib/Unreal/m_setname.so
|
||||
lib/Unreal/m_silence.so
|
||||
lib/Unreal/m_sjoin.so
|
||||
lib/Unreal/m_sqline.so
|
||||
lib/Unreal/m_squit.so
|
||||
lib/Unreal/m_starttls.so
|
||||
lib/Unreal/m_stats.so
|
||||
lib/Unreal/m_svsfline.so
|
||||
lib/Unreal/m_svsjoin.so
|
||||
lib/Unreal/m_svskill.so
|
||||
lib/Unreal/m_svslusers.so
|
||||
lib/Unreal/m_svsmode.so
|
||||
lib/Unreal/m_svsmotd.so
|
||||
lib/Unreal/m_svsnick.so
|
||||
lib/Unreal/m_svsnline.so
|
||||
lib/Unreal/m_svsnolag.so
|
||||
lib/Unreal/m_svsnoop.so
|
||||
lib/Unreal/m_svso.so
|
||||
lib/Unreal/m_svspart.so
|
||||
lib/Unreal/m_svssilence.so
|
||||
lib/Unreal/m_svssno.so
|
||||
lib/Unreal/m_svswatch.so
|
||||
lib/Unreal/m_swhois.so
|
||||
lib/Unreal/m_time.so
|
||||
lib/Unreal/m_tkl.so
|
||||
lib/Unreal/m_topic.so
|
||||
lib/Unreal/m_trace.so
|
||||
lib/Unreal/m_tsctl.so
|
||||
lib/Unreal/m_umode2.so
|
||||
lib/Unreal/m_undccdeny.so
|
||||
lib/Unreal/m_unkline.so
|
||||
lib/Unreal/m_unsqline.so
|
||||
lib/Unreal/m_unzline.so
|
||||
lib/Unreal/m_user.so
|
||||
lib/Unreal/m_userhost.so
|
||||
lib/Unreal/m_userip.so
|
||||
lib/Unreal/m_vhost.so
|
||||
lib/Unreal/m_wallops.so
|
||||
lib/Unreal/m_watch.so
|
||||
lib/Unreal/m_who.so
|
||||
lib/Unreal/m_whois.so
|
||||
lib/Unreal/m_whowas.so
|
||||
libexec/ircd
|
||||
@sample %%EXAMPLESDIR%%/aliases/aliases.conf etc/Unreal/aliases/aliases.conf
|
||||
@sample %%EXAMPLESDIR%%/aliases/anope.conf etc/Unreal/aliases/anope.conf
|
||||
@sample %%EXAMPLESDIR%%/aliases/atheme.conf etc/Unreal/aliases/atheme.conf
|
||||
@sample %%EXAMPLESDIR%%/aliases/auspice.conf etc/Unreal/aliases/auspice.conf
|
||||
@sample %%EXAMPLESDIR%%/aliases/cygnus.conf etc/Unreal/aliases/cygnus.conf
|
||||
@sample %%EXAMPLESDIR%%/aliases/epona.conf etc/Unreal/aliases/epona.conf
|
||||
@sample %%EXAMPLESDIR%%/aliases/generic.conf etc/Unreal/aliases/generic.conf
|
||||
@sample %%EXAMPLESDIR%%/aliases/genericstats.conf etc/Unreal/aliases/genericstats.conf
|
||||
@sample %%EXAMPLESDIR%%/aliases/ircservices.conf etc/Unreal/aliases/ircservices.conf
|
||||
@sample %%EXAMPLESDIR%%/aliases/operstats.conf etc/Unreal/aliases/operstats.conf
|
||||
@sample %%EXAMPLESDIR%%/badwords.channel.conf etc/Unreal/badwords.channel.conf
|
||||
@sample %%EXAMPLESDIR%%/badwords.message.conf etc/Unreal/badwords.message.conf
|
||||
@sample %%EXAMPLESDIR%%/badwords.quit.conf etc/Unreal/badwords.quit.conf
|
||||
@sample %%EXAMPLESDIR%%/help.conf etc/Unreal/help.conf
|
||||
@sample %%EXAMPLESDIR%%/spamfilter.conf etc/Unreal/spamfilter.conf
|
||||
@sample %%EXAMPLESDIR%%/unrealircd.conf etc/Unreal/unrealircd.conf
|
||||
%%SQLMOD%%%%ETCDIR%%/m_sqlmod.conf
|
||||
%%SQLMOD%%lib/Unreal/m_sqlmod.so
|
||||
@owner ircd
|
||||
@group ircd
|
||||
@dir %%ETCDIR%%/aliases
|
||||
@dir %%ETCDIR%%
|
||||
@dir /var/log/ircd
|
||||
@dir /var/run/ircd/tmp
|
||||
@dir /var/run/ircd
|
||||
@owner root
|
||||
@group wheel
|
Loading…
Reference in a new issue