- Update to 0.0.9
PR: ports/70498 Submitted by: Marcus von Appen <mva@sysfault.org> (maintainer)
This commit is contained in:
parent
ed54f0c3fc
commit
e4e25ab80c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116385
6 changed files with 30 additions and 27 deletions
|
@ -6,7 +6,7 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= emelfm2
|
PORTNAME= emelfm2
|
||||||
PORTVERSION= 0.0.8
|
PORTVERSION= 0.0.9
|
||||||
CATEGORIES= x11-fm
|
CATEGORIES= x11-fm
|
||||||
MASTER_SITES= http://dasui.prima.de/~tooar/
|
MASTER_SITES= http://dasui.prima.de/~tooar/
|
||||||
|
|
||||||
|
@ -16,7 +16,6 @@ COMMENT= The gtk2 port of emelfm, a fast graphical filemanager
|
||||||
USE_GNOME= gtk20
|
USE_GNOME= gtk20
|
||||||
USE_X_PREFIX= yes
|
USE_X_PREFIX= yes
|
||||||
USE_GMAKE= yes
|
USE_GMAKE= yes
|
||||||
USE_GCC= 3.2
|
|
||||||
USE_GETOPT_LONG=yes
|
USE_GETOPT_LONG=yes
|
||||||
INSTALLS_SHLIB= yes
|
INSTALLS_SHLIB= yes
|
||||||
|
|
||||||
|
@ -26,6 +25,12 @@ PLUGINDIR= ${WRKSRC}/objs/plugins
|
||||||
PLUGINS= cdburner.so clone.so copy_to_clipboard.so cpbar.so du.so for_each.so \
|
PLUGINS= cdburner.so clone.so copy_to_clipboard.so cpbar.so du.so for_each.so \
|
||||||
glob.so mvbar.so pack.so rename_ext.so sort_by_ext.so unpack.so view.so
|
glob.so mvbar.so pack.so rename_ext.so sort_by_ext.so unpack.so view.so
|
||||||
|
|
||||||
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
.if ${OSVERSION} < 500000
|
||||||
|
USE_GCC= 3.3
|
||||||
|
.endif
|
||||||
|
|
||||||
.if defined(NOPORTDOCS)
|
.if defined(NOPORTDOCS)
|
||||||
do-install::
|
do-install::
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||||
|
@ -35,4 +40,4 @@ do-install::
|
||||||
.endfor
|
.endfor
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.post.mk>
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
MD5 (emelfm2-0.0.8.tar.gz) = 70baf819021f2d733c122e3350764483
|
MD5 (emelfm2-0.0.9.tar.gz) = d627839065b51ad90ded488e9d34c4a8
|
||||||
SIZE (emelfm2-0.0.8.tar.gz) = 350725
|
SIZE (emelfm2-0.0.9.tar.gz) = 467516
|
||||||
|
|
|
@ -1,9 +1,9 @@
|
||||||
--- Makefile.orig Fri Apr 30 13:17:57 2004
|
--- Makefile.orig Tue Aug 10 01:43:19 2004
|
||||||
+++ Makefile Mon May 3 00:31:28 2004
|
+++ Makefile Sun Aug 15 20:25:56 2004
|
||||||
@@ -97,10 +97,10 @@
|
@@ -98,10 +98,10 @@
|
||||||
|
lLIBS_CFLAGS += -shared -fPIC -DPIC
|
||||||
lLDFLAGS = $(LDFLAGS)
|
lLDFLAGS = $(LDFLAGS)
|
||||||
lLDFLAGS += `pkg-config --libs gtk+-2.0`
|
lLDFLAGS += `pkg-config --libs gtk+-2.0 gthread-2.0`
|
||||||
# gthread-2.0
|
|
||||||
-ifeq ($(OPSY),FreeBSD)
|
-ifeq ($(OPSY),FreeBSD)
|
||||||
-OSREL = $(shell sysctl -n kern.osreldate)
|
-OSREL = $(shell sysctl -n kern.osreldate)
|
||||||
-lLDFLAGS += $(shell if test $(OSREL) -lt 500041 ; then echo "-lgnugetopt"; fi)
|
-lLDFLAGS += $(shell if test $(OSREL) -lt 500041 ; then echo "-lgnugetopt"; fi)
|
||||||
|
@ -14,4 +14,4 @@
|
||||||
+#endif
|
+#endif
|
||||||
|
|
||||||
.PHONY: all plugins install install_plugins uninstall uninstall_plugins doc \
|
.PHONY: all plugins install install_plugins uninstall uninstall_plugins doc \
|
||||||
clean deps marshals gettext i18n install_i18n uninstall_i18n test test2
|
clean deps marshals gettext i18n install_i18n uninstall_i18n \
|
||||||
|
|
|
@ -1,9 +1,9 @@
|
||||||
--- Makefile.config.orig Fri Apr 30 13:17:57 2004
|
--- Makefile.config.orig Thu Jul 15 21:36:56 2004
|
||||||
+++ Makefile.config Mon May 3 00:34:01 2004
|
+++ Makefile.config Sun Aug 15 20:24:40 2004
|
||||||
@@ -16,7 +16,7 @@
|
@@ -32,7 +32,7 @@
|
||||||
|
|
||||||
#CFLAGS += -O2 -Wall
|
#CFLAGS += -O2 -Wall
|
||||||
#CFLAGS += -O3 -Wall -march=athlon-tbird -mcpu=athlon-tbird
|
#CFLAGS += -O3 -Wall -march=athlon-tbird -mtune=athlon-tbird
|
||||||
|
#CFLAGS += -O3 -Wall -march=pentium -mtune=pentium4
|
||||||
-CFLAGS += -Wall
|
-CFLAGS += -Wall
|
||||||
+CFLAGS ?= -Wall
|
+CFLAGS ?= -Wall
|
||||||
|
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- src/utils/e2_utils.h.orig Mon Apr 26 11:20:59 2004
|
|
||||||
+++ src/utils/e2_utils.h Mon May 3 13:37:26 2004
|
|
||||||
@@ -21,6 +21,7 @@
|
|
||||||
#ifndef E2_UTILS_H
|
|
||||||
# define E2_UTILS_H
|
|
||||||
|
|
||||||
+#include <sys/types.h>
|
|
||||||
#include <gtk/gtk.h>
|
|
||||||
#include "debug.h"
|
|
||||||
|
|
|
@ -12,7 +12,10 @@ lib/emelfm2/plugins/rename_ext.so
|
||||||
lib/emelfm2/plugins/sort_by_ext.so
|
lib/emelfm2/plugins/sort_by_ext.so
|
||||||
lib/emelfm2/plugins/unpack.so
|
lib/emelfm2/plugins/unpack.so
|
||||||
lib/emelfm2/plugins/view.so
|
lib/emelfm2/plugins/view.so
|
||||||
|
share/applications-registry/emelfm2.applications
|
||||||
|
share/applications/emelfm2.desktop
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
|
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
|
||||||
|
%%PORTDOCS%%%%DOCSDIR%%/HACKING
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/CREDITS
|
%%PORTDOCS%%%%DOCSDIR%%/CREDITS
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/GPL
|
%%PORTDOCS%%%%DOCSDIR%%/GPL
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||||
|
@ -36,15 +39,20 @@ share/pixmaps/emelfm2/icon_emelfm2_064.png
|
||||||
share/pixmaps/emelfm2/icon_emelfm2_128.png
|
share/pixmaps/emelfm2/icon_emelfm2_128.png
|
||||||
share/pixmaps/emelfm2/icon_emelfm2_256.png
|
share/pixmaps/emelfm2/icon_emelfm2_256.png
|
||||||
share/pixmaps/emelfm2/icon_emelfm2_alt_016.png
|
share/pixmaps/emelfm2/icon_emelfm2_alt_016.png
|
||||||
share/pixmaps/emelfm2/icon_emelfm2_alt_022.png
|
share/pixmaps/emelfm2/icon_emelfm2_alt_024.png
|
||||||
share/pixmaps/emelfm2/icon_emelfm2_alt_032.png
|
share/pixmaps/emelfm2/icon_emelfm2_alt_032.png
|
||||||
share/pixmaps/emelfm2/icon_emelfm2_alt_048.png
|
share/pixmaps/emelfm2/icon_emelfm2_alt_048.png
|
||||||
|
share/pixmaps/emelfm2/icon_emelfm2_alt_064.png
|
||||||
|
share/pixmaps/emelfm2/icon_emelfm2_alt_128.png
|
||||||
|
share/pixmaps/emelfm2/icon_emelfm2_alt_256.png
|
||||||
share/pixmaps/emelfm2/icon_emelfm2_alt_346.png
|
share/pixmaps/emelfm2/icon_emelfm2_alt_346.png
|
||||||
share/pixmaps/emelfm2/icon_move2_24.png
|
share/pixmaps/emelfm2/icon_move2_24.png
|
||||||
share/pixmaps/emelfm2/icon_move_24.png
|
share/pixmaps/emelfm2/icon_move_24.png
|
||||||
share/pixmaps/emelfm2/icon_up.xpm
|
share/pixmaps/emelfm2/icon_up.xpm
|
||||||
@dirrm share/pixmaps/emelfm2
|
@dirrm share/pixmaps/emelfm2
|
||||||
@dirrm share/pixmaps
|
@dirrm share/pixmaps
|
||||||
|
@dirrm share/applications-registry
|
||||||
|
@dirrm share/applications
|
||||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||||
@dirrm lib/emelfm2/plugins
|
@dirrm lib/emelfm2/plugins
|
||||||
@dirrm lib/emelfm2
|
@dirrm lib/emelfm2
|
||||||
|
|
Loading…
Reference in a new issue