Update to 1.3.8 for Qt4 [1]

Update to 1.3.9 [2]
Pass maintainership to submitter.

PR:		ports/149849 [1]
Submitted by:	Loic BARTOLETTI <coder at tuxfamily.org> [1], bsam@ [2]
Feature safe:	yes
This commit is contained in:
Max Brazhnikov 2011-01-20 22:33:56 +00:00
parent 502bdd8be4
commit e4e44d1466
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=268063
6 changed files with 1664 additions and 491 deletions

View file

@ -2,17 +2,17 @@
# Date created: Mar 15, 2002
# Whom: ijliao
#
# $Carpetsmoker: ports/print/scribus/Makefile,v 1.2 2007/09/24 08:06:52 carpetsmoker Exp $
# $FreeBSD$
#
PORTNAME= scribus
PORTVERSION= 1.3.3.14
PORTVERSION= 1.3.9
CATEGORIES= print editors
MASTER_SITES= SF \
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-devel/${PORTVERSION} \
http://www.scribus.net/downloads/${PORTVERSION}/
PKGNAMESUFFIX= -devel
MAINTAINER= sylvio@FreeBSD.org
MAINTAINER= coder@tuxfamily.org
COMMENT= A comprehensive desktop publishing program
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
@ -21,24 +21,35 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
cups.2:${PORTSDIR}/print/cups-base \
freetype.9:${PORTSDIR}/print/freetype2 \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
podofo.0:${PORTSDIR}/graphics/podofo \
boost_thread.4:${PORTSDIR}/devel/boost-libs \
aspell.16:${PORTSDIR}/textproc/aspell \
cairo.2:${PORTSDIR}/graphics/cairo \
execinfo:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging
${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging \
update-mime-database:${PORTSDIR}/misc/shared-mime-info
USE_BZIP2= yes
USE_QT_VER= 3
USE_GNOME= gnometarget libartlgpl2 libxml2
USE_QT_VER= 4
QT_COMPONENTS= gui linguist_build moc_build qmake_build rcc_build uic_build xml network
USE_GNOME= desktopfileutils gnometarget libartlgpl2 libxml2 pkgconfig
USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
USE_PERL5_BUILD=yes
USE_LDCONFIG= yes
USE_MOTIF= yes
USE_CMAKE= yes
CMAKE_USE_PTHREAD= yes
MAKE_JOBS_SAFE= yes
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
PLIST_SUB+= SCRIBUS_VERSION=${PORTVERSION}
MAN1= scribus.1
MANLANG= "" pl de
MANCOMPRESSED= no
post-install:
${LN} ${DATADIR}/icons/scribus.png ${PREFIX}/share/pixmaps/
-update-desktop-database
-update-mime-database ${PREFIX}/share/mime
.include <bsd.port.mk>

View file

@ -1,3 +1,2 @@
MD5 (scribus-1.3.3.14.tar.bz2) = 347f9dd7f9e1924218c5975811abf05a
SHA256 (scribus-1.3.3.14.tar.bz2) = dec70068ffe69d4b3f0089e7d3b3eedb13f9ccba7f42b3eda5f261d8b7e9e7c5
SIZE (scribus-1.3.3.14.tar.bz2) = 15062170
SHA256 (scribus-1.3.9.tar.bz2) = fb172f6b9a812f3b0a9de911b245012a067a9aad50473fa1da1d1c5861641eac
SIZE (scribus-1.3.9.tar.bz2) = 35729860

View file

@ -1,26 +0,0 @@
--- CMakeLists.txt.orig 2010-03-25 09:44:43.000000000 -0300
+++ CMakeLists.txt 2010-03-25 09:47:21.000000000 -0300
@@ -116,7 +116,7 @@
ENDIF (WANT_VERSIONING AND NOT CACHED_VERSIONING)
#MAN
-SET(MANDIR "share/man/")
+SET(MANDIR "man/")
SET(SHAREDIR "share/${MAIN_DIR_NAME}${TAG_VERSION}/")
ADD_DEFINITIONS("-DSHAREDIR=\\\"${CMAKE_INSTALL_PREFIX}/${SHAREDIR}\\\"")
#SHARE
@@ -169,7 +169,7 @@
ENDIF(ARCH64BIT AND NOT LIB_SUFFIX)
-SET(LIB_DIR_NAME "lib${LIB_SUFFIX}")
+SET(LIB_DIR_NAME "lib")
SET(LIBDIR "${LIB_DIR_NAME}/${MAIN_DIR_NAME}${TAG_VERSION}/")
ADD_DEFINITIONS("-DLIBDIR=\\\"${CMAKE_INSTALL_PREFIX}/${LIBDIR}\\\"")
@@ -518,4 +518,5 @@
## I'll make this prettier later - ignore any tarballs in the root
SET(CPACK_SOURCE_IGNORE_FILES CMakeCache.txt scribus-1.3.3.14.tar.bz2 scribus-1.3.3.14.tar.Z scribus-1.3.3.14.tar.gz "~$" "\\\\.cvsignore$" "^${PROJECT_SOURCE_DIR}.*/CVS/" "^${PROJECT_SOURCE_DIR}/debian/" "^${PROJECT_SOURCE_DIR}/old/" "^${PROJECT_SOURCE_DIR}.*/CVSROOT/" "^${PROJECT_SOURCE_DIR}.*/autom4te.cache/")
INCLUDE(CPack)
+ SET_TARGET_PROPERTIES(scribus PROPERTIES LINK_FLAGS -Wl,-E)
ENDIF(EXISTS "${CMAKE_ROOT}/Modules/CPack.cmake")

View file

@ -0,0 +1,26 @@
--- CMakeLists.txt.orig 2010-11-27 01:06:01.000000000 +0300
+++ CMakeLists.txt 2011-01-12 17:53:37.638940558 +0300
@@ -250,7 +250,7 @@ ENDIF (APPLEBUNDLE)
#Setp all the directories we will use
#MAN
CMAKE_POLICY(SET CMP0005 OLD)
-SET(MANDIR "share/man/")
+SET(MANDIR "man/")
SET(SHAREDIR "share/${MAIN_DIR_NAME}${TAG_VERSION}/")
ADD_DEFINITIONS("-DSHAREDIR=\\\"${CMAKE_INSTALL_PREFIX}/${SHAREDIR}\\\"")
@@ -792,10 +792,10 @@ INSTALL(FILES
## PL We may not need this anymore
#Install the desktop file
-## INSTALL(FILES
- # scribus.desktop
- # #DESTINATION ${DESKTOPDIR}
-#)
+INSTALL(FILES
+ scribus.desktop
+ DESTINATION ${DESKTOPDIR}
+)
#If building an Apple bundle, install these specific files
IF(APPLEBUNDLE)

View file

@ -1,23 +0,0 @@
--- scribus/manpages/CMakeLists.txt.orig 2009-06-25 16:46:04.000000000 -0300
+++ scribus/manpages/CMakeLists.txt 2009-06-25 16:51:42.000000000 -0300
@@ -4,12 +4,17 @@
INSTALL(FILES
scribus.1
+ DESTINATION ${MANDIR}/man1
+)
+
+INSTALL(FILES
scribus.1.de
- DESTINATION ${MANDIR}man1
+ DESTINATION ${MANDIR}de/man1
+ RENAME scribus.1
)
INSTALL(FILES
scribus.1.pl
DESTINATION ${MANDIR}pl/man1
RENAME scribus.1
-)
\ No newline at end of file
+)

File diff suppressed because it is too large Load diff