Passage is meant to be a memento mori game. It presents an entire
life, from young adulthood through old age and death, in the span of five minutes. Of course, it's a game, not a painting or a film, so the choices that you make as the player are crucial. There's no "right" way to play Passage, just as there's no right way to interpret it. WWW: http://hcsoftware.sourceforge.net/passage PR: ports/123031 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
This commit is contained in:
parent
22e92995ab
commit
e4fc25bb69
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=212090
6 changed files with 84 additions and 0 deletions
|
@ -560,6 +560,7 @@
|
|||
SUBDIR += p5-Games-Tournament-RoundRobin
|
||||
SUBDIR += pachi
|
||||
SUBDIR += palomino
|
||||
SUBDIR += passage
|
||||
SUBDIR += pathological
|
||||
SUBDIR += pcgen
|
||||
SUBDIR += pear-Games_Chess
|
||||
|
|
40
games/passage/Makefile
Normal file
40
games/passage/Makefile
Normal file
|
@ -0,0 +1,40 @@
|
|||
# New ports collection makefile for: passage
|
||||
# Date created: 23 Apr 2008
|
||||
# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= passage
|
||||
PORTVERSION= 3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/hcsoftware
|
||||
DISTNAME= Passage_v${PORTVERSION}_UnixSource
|
||||
|
||||
MAINTAINER= amdmi3@amdmi3.ru
|
||||
COMMENT= An experimental video game by Jason Rohrer
|
||||
|
||||
USE_SDL= sdl
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/gamma256/gameSource
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lSDL||' ${WRKSRC}/Makefile.GnuLinux
|
||||
@${REINPLACE_CMD} -e 's|"graphics"|"${DATADIR}/graphics"|' \
|
||||
${WRKSRC}/common.cpp
|
||||
@${REINPLACE_CMD} -e 's|"music"|"${DATADIR}/music"|' \
|
||||
${WRKSRC}/musicPlayer.cpp
|
||||
@${REINPLACE_CMD} -e 's|"settings"|"${DATADIR}/settings"|' \
|
||||
${WRKDIR}/${DISTNAME}/minorGems/util/SettingsManager.cpp
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && ${CAT} Makefile.GnuLinux Makefile.all > Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/Passage ${PREFIX}/bin
|
||||
${MKDIR} ${DATADIR}
|
||||
.for d in graphics music settings
|
||||
cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
3
games/passage/distinfo
Normal file
3
games/passage/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (Passage_v3_UnixSource.tar.gz) = 183c9dac9e10dbad8d53a9f60972cd8d
|
||||
SHA256 (Passage_v3_UnixSource.tar.gz) = 67bf36415a8cde717184abb075112d3ad4495dcd9b032653bc3c7272b9f4a182
|
||||
SIZE (Passage_v3_UnixSource.tar.gz) = 424772
|
13
games/passage/files/patch-Makefile.all
Normal file
13
games/passage/files/patch-Makefile.all
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- Makefile.all.orig 2007-12-11 21:44:49.000000000 +0300
|
||||
+++ Makefile.all 2008-04-23 20:47:45.000000000 +0400
|
||||
@@ -1,8 +1,8 @@
|
||||
|
||||
ROOT_PATH = ../..
|
||||
|
||||
-COMPILE = g++ ${PLATFORM_COMPILE_FLAGS} -Wall -g -I${ROOT_PATH} -c
|
||||
-LINK = g++ -I${ROOT_PATH}
|
||||
+COMPILE = ${CXX} ${CXXFLAGS} `${SDL_CONFIG} --cflags` -Wall -I${ROOT_PATH} -c
|
||||
+LINK = ${CXX} `${SDL_CONFIG} --libs`
|
||||
|
||||
|
||||
|
8
games/passage/pkg-descr
Normal file
8
games/passage/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
Passage is meant to be a memento mori game. It presents an entire
|
||||
life, from young adulthood through old age and death, in the span
|
||||
of five minutes. Of course, it's a game, not a painting or a film,
|
||||
so the choices that you make as the player are crucial. There's no
|
||||
"right" way to play Passage, just as there's no right way to interpret
|
||||
it.
|
||||
|
||||
WWW: http://hcsoftware.sourceforge.net/passage
|
19
games/passage/pkg-plist
Normal file
19
games/passage/pkg-plist
Normal file
|
@ -0,0 +1,19 @@
|
|||
bin/Passage
|
||||
%%DATADIR%%/graphics/characterSprite.tga
|
||||
%%DATADIR%%/graphics/characterSpriteSad.tga
|
||||
%%DATADIR%%/graphics/chest.tga
|
||||
%%DATADIR%%/graphics/chestDust.tga
|
||||
%%DATADIR%%/graphics/chestPrize.tga
|
||||
%%DATADIR%%/graphics/heart.tga
|
||||
%%DATADIR%%/graphics/numerals.tga
|
||||
%%DATADIR%%/graphics/spouseSprite.tga
|
||||
%%DATADIR%%/graphics/tileSet.tga
|
||||
%%DATADIR%%/graphics/title.tga
|
||||
%%DATADIR%%/music/music.tga
|
||||
%%DATADIR%%/settings/fullscreen.ini
|
||||
%%DATADIR%%/settings/screenHeight.ini
|
||||
%%DATADIR%%/settings/screenWidth.ini
|
||||
@dirrm %%DATADIR%%/settings
|
||||
@dirrm %%DATADIR%%/music
|
||||
@dirrm %%DATADIR%%/graphics
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in a new issue