upgrade to 0.5.3

This commit is contained in:
Ying-Chieh Liao 2004-04-05 02:05:46 +00:00
parent 4cf4a50229
commit e50209a594
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106161
4 changed files with 34 additions and 32 deletions

View file

@ -7,8 +7,8 @@
#
PORTNAME= gai
PORTVERSION= 0.5.2
PORTREVISION= 1
PORTVERSION= 0.5.3
PORTREVISION= 0
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -26,7 +26,7 @@ USE_GNOME= gnomehack gnomeprefix gdkpixbuf gtk20 pango gnomepanel
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDLCONF=${SDL_CONFIG}
PLIST_FILES= include/gai/gai.h lib/libgai.so.0.5.2 lib/libgai.so.0 \
PLIST_FILES= include/gai/gai.h lib/libgai.so.0.5.3 lib/libgai.so.0 \
lib/libgai.so libdata/pkgconfig/gai.pc
PLIST_DIRS= include/gai
INSTALLS_SHLIB= yes
@ -37,17 +37,17 @@ CFLAGS+= -fPIC
post-patch:
@${REINPLACE_CMD} -e "s|sdl-config --|${SDL_CONFIG} --|g" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|lib/pkgconfig/|libdata/pkgconfig/|" ${WRKSRC}/gai/Makefile.in
${REINPLACE_CMD} -e "s|-O2|${CFLAGS}|g" ${WRKSRC}/gai/Makefile.in
@${REINPLACE_CMD} -e "s|lib/pkgconfig|libdata/pkgconfig|g" \
-e "s|-O2|${CFLAGS}|g" ${WRKSRC}/gai/Makefile.in
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
.for file in FAQ.html referenceguide.html
${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
@${ECHO_CMD} "${DOCSDIR:S,^${PREFIX}/,,}/${file}" >> ${TMPPLIST}
.endfor
@${ECHO_CMD} "@dirrm ${DOCSDIR:S,^${PREFIX}/,,}" >> ${TMPPLIST}
@${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
@${FIND} ${DOCSDIR} -type f | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
@${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
@${MKDIR} ${EXAMPLESDIR}
.for dir in docking examples templates
${CP} -R ${WRKSRC}/${dir} ${EXAMPLESDIR}

View file

@ -1,2 +1,2 @@
MD5 (gai-0.5.2.tar.bz2) = a9d53513b002cedabf2a1ee29ad2d712
SIZE (gai-0.5.2.tar.bz2) = 185549
MD5 (gai-0.5.3.tar.bz2) = 732016d4cf133a50d2226153db395b85
SIZE (gai-0.5.3.tar.bz2) = 233198

View file

@ -1,12 +0,0 @@
--- gai/gai-gnome.c.orig Mon Mar 15 10:36:46 2004
+++ gai/gai-gnome.c Mon Mar 15 10:37:15 2004
@@ -537,8 +537,8 @@
void gai_gnome_about_show (void)
{
char *authors[3];
- GAI_ENTER;
GdkPixbuf *pixbuf;
+ GAI_ENTER;
if (GAI.about!=NULL)
{

View file

@ -1,10 +1,24 @@
GAI, The General Applet Interface library is a library that will help applet
programmers a lot. The goal of this library is to give programmers a simple yet
powerful applet interface. This library supports both Dockapps and Gnome 2
Panel Applets. The applet program doesn't have to care about if the applet
will be used on the Gnome panel or in the dock. The library handles that.
Over 50% of the code in a Dockapp and a Gnome 2 Panel applet does actually
only one thing, setting up the applet window. With GAI, this can be reduced
to just a few lines of code.
This library is intended to simplify the development and use of Dockapps, ROX
panel applets and Gnome 2 Panel Applets. With this library the programmer can
focus on what the applet shall do, not on the interface.
What this library provides:
- Dockapp support.
- Gnome 2 Panel support.
- ROX panel support.
- Handling of all sizes of the Gnome Panel.
- Handle Gnome Panel rotation.
- Simple image file handeling via gdk_pixbuf.
- Loading and storing of configuration values and strings.
- A simple structual way of making preferences window.
- Generates images from ascii text based upon fonts.
- Support for both Gnome 2 Panel Applets, ROX panel applets and
Dockaps/wmapplets.
- Support for OpenGL applets.
- Simple interface to connect events, like mouse button clicks, joystick
events and so on.
- Easy to add support for other panels.
- Nice configure and makefile scripts that generates the needed files
for ROX and Gnome.
WWW: http://gai.sourceforge.net/