add pdftohtml

A command-line tool for converting pdf-files into html

PR:		27824
Submitted by:	Soeren Boll Overgaard <boll@tolkien.dk>
This commit is contained in:
Ying-Chieh Liao 2001-08-06 12:15:55 +00:00
parent 782e8b968b
commit e555a1dbc3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=45874
8 changed files with 69 additions and 0 deletions

View file

@ -138,6 +138,7 @@
SUBDIR += p5-libxml
SUBDIR += par
SUBDIR += pardiff
SUBDIR += pdftohtml
SUBDIR += perl2html
SUBDIR += pspell
SUBDIR += pspell-ispell

View file

@ -0,0 +1,25 @@
# ex:ts=8
# New ports collection makefile for: pdftohtml
# Date created: 1 Jun 2001
# Whom: Soeren Boll Overgaard <boll@tolkien.dk>
#
# $FreeBSD$
#
PORTNAME= pdftohtml
PORTVERSION= 0.31
CATEGORIES= textproc
MASTER_SITES= http://www.ra.informatik.uni-stuttgart.de/~gosho/pdftohtml/Download/ \
http://ports.tolkien.dk/pdftohtml/
DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}_test
MAINTAINER= boll@tolkien.dk
ONLY_FOR_ARCHS= i386
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION:S/./_/}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pdftohtml.bin ${PREFIX}/bin/pdftohtml
${INSTALL_PROGRAM} ${WRKSRC}/pdftops.bin ${PREFIX}/bin/pdftops
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (pdftohtml_0_31_test.tar.gz) = 04debc9f08233cb501f7b2e417a25397

View file

@ -0,0 +1,16 @@
--- goo/Makefile.orig Mon Aug 6 20:03:55 2001
+++ goo/Makefile Mon Aug 6 20:04:26 2001
@@ -2,11 +2,9 @@
srcdir = .
-CFLAGS = -g -O2 -DHAVE_DIRENT_H=1 -DHAVE_REWINDDIR=1 -DHAVE_POPEN=1 -I$(srcdir)
-CXXFLAGS = -g -O2 -DHAVE_DIRENT_H=1 -DHAVE_REWINDDIR=1 -DHAVE_POPEN=1 -I$(srcdir)
+CFLAGS += -DHAVE_DIRENT_H=1 -DHAVE_REWINDDIR=1 -DHAVE_POPEN=1 -I$(srcdir)
+CXXFLAGS += -DHAVE_DIRENT_H=1 -DHAVE_REWINDDIR=1 -DHAVE_POPEN=1 -I$(srcdir)
-CC = gcc
-CXX = c++
AR = ar rc
RANLIB = ranlib

View file

@ -0,0 +1,17 @@
--- xpdf/Makefile.orig Mon Aug 6 20:04:59 2001
+++ xpdf/Makefile Mon Aug 6 20:05:29 2001
@@ -8,13 +8,11 @@
GOOLIBDIR = ../goo
-CXXFLAGS = -g -DHAVE_DIRENT_H=1 -DHAVE_REWINDDIR=1 -DHAVE_POPEN=1 -I$(GOOSRCDIR) -I$(srcdir)
+CXXFLAGS += -DHAVE_DIRENT_H=1 -DHAVE_REWINDDIR=1 -DHAVE_POPEN=1 -I$(GOOSRCDIR) -I$(srcdir)
LDFLAGS =
OTHERLIBS =
-
-CXX = c++
LIBPREFIX = lib
EXE =

View file

@ -0,0 +1 @@
A command-line tool for converting pdf-files into html

View file

@ -0,0 +1,6 @@
This is a port of pdftohtml, which converts pdf-files into nicely formatted
html, combined with png-images.
The HTML generated uses frames to emulate the contentlisting from the pdf.
WWW: http://www.ra.informatik.uni-stuttgart.de/~gosho/pdftohtml/
Author: Gueorgui Ovtcharov <pdftohtml@ralf.informatik.uni-stuttgart.de>

View file

@ -0,0 +1,2 @@
bin/pdftohtml
bin/pdftops