Update to 5.1

PR:		90925
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Emanuel Haupt 2005-12-27 10:04:54 +00:00
parent 8cfdd44de0
commit e55777922b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=152170
7 changed files with 164 additions and 47 deletions

View file

@ -7,33 +7,39 @@
#
PORTNAME= ragel
PORTVERSION= 4.1
PORTVERSION= 5.1
CATEGORIES= devel
MASTER_SITES= http://www.elude.ca/ragel/
MAINTAINER= ports@FreeBSD.org
COMMENT= Compile regular languages into executable C/C++ code
BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
USE_REINPLACE= yes
USE_BISON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= AWK="${AWK}"
MAKE_ENV= GPERF="${LOCALBASE}/bin/gperf"
MAN1= ragel.1
PLIST_FILES= bin/ragel
MAN1= ragel.1 rlcodegen.1
PLIST_FILES= bin/ragel bin/rlcodegen
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|$$(CFLAGS)|$$(CXXFLAGS)|g'
's|$$(CFLAGS)|$$(CXXFLAGS)|g ; \
s|gperf -L|$$(GPERF) -L|g'
post-build:
@cd ${WRKSRC}/doc && ${SETENV} ${MAKE_ENV} \
${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ragel.1
${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} \
ragel.1 rlcodegen.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ragel ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/ragel/ragel ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/rlcodegen/rlcodegen ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/ragel.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/rlcodegen.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (ragel-4.1.tar.gz) = f37efaa3244a4fd22479a3a32d9ebaac
SHA256 (ragel-4.1.tar.gz) = 7ccd16c17153543b720d9a6b8a76311a4d838e25bf33f99298732718fe440ed5
SIZE (ragel-4.1.tar.gz) = 451133
MD5 (ragel-5.1.tar.gz) = 2d2d8989914c735d775f19267af39ad2
SHA256 (ragel-5.1.tar.gz) = 203258ed99b9816f5ff91c3ee612f74615ede5e957590f0b0c8c8580ccb95ef2
SIZE (ragel-5.1.tar.gz) = 500674

View file

@ -0,0 +1,10 @@
--- ragel/ragel.h.orig Sat Dec 17 12:50:57 2005
+++ ragel/ragel.h Mon Dec 26 13:12:58 2005
@@ -25,6 +25,7 @@
#include <stdio.h>
#include <iostream>
#include <fstream>
+#include <string>
#include "config.h"
#define PROGNAME "ragel"

View file

@ -0,0 +1,10 @@
--- rlcodegen/fsmcodegen.cpp.orig Wed Dec 21 15:15:28 2005
+++ rlcodegen/fsmcodegen.cpp Mon Dec 26 13:36:08 2005
@@ -25,6 +25,7 @@
#include "fsmcodegen.h"
#include "redfsm.h"
#include "gendata.h"
+#include <climits>
#include <sstream>
/* Determine if a string is only whitespace. Code blocks that are only

View file

@ -0,0 +1,10 @@
--- rlcodegen/gendata.cpp.orig Thu Dec 22 16:04:14 2005
+++ rlcodegen/gendata.cpp Mon Dec 26 13:21:36 2005
@@ -31,6 +31,7 @@
#include "fgotocodegen.h"
#include "ipgotocodegen.h"
+#include <climits>
#include <iostream>
using std::endl;

View file

@ -0,0 +1,118 @@
--- rlcodegen/xmlparse.y.orig Thu Dec 22 16:04:14 2005
+++ rlcodegen/xmlparse.y Mon Dec 26 13:20:03 2005
@@ -175,7 +175,7 @@
else
sourceFileName = fileNameAttr->value;
openOutput( sourceFileName );
- }
+ };
AttributeList:
AttributeList Attribute {
@@ -190,7 +190,7 @@
XML_Word '=' XML_Literal {
attrKey = $1;
attrValue = $3;
- }
+ };
HostOrDefList:
HostOrDefList HostOrDef |
@@ -204,7 +204,7 @@
'<' '/' TAG_host '>' {
if ( outputFormat == OutCCode || outputFormat == OutDCode )
*outStream << xmlData.data;
- }
+ };
TagHostHead:
'<' TAG_host AttributeList '>' {
@@ -216,14 +216,14 @@
if ( outputFormat == OutCCode || outputFormat == OutDCode )
lineDirective( *outStream, sourceFileName, line );
}
- }
+ };
TagRagelDef:
RagelDefHead
RagelDefItemList
'<' '/' TAG_ragel_def '>' {
cgd->generate();
- }
+ };
RagelDefHead:
'<' TAG_ragel_def AttributeList '>' {
@@ -303,7 +303,7 @@
else {
warning() << "unrecognized write option" << endl;
}
- }
+ };
TagAlphType:
@@ -361,7 +361,7 @@
'<' '/' TAG_start_state '>' {
unsigned long startState = strtoul( xmlData.data, 0, 10 );
cgd->setStartState( startState );
- }
+ };
TagEntryPoints:
'<' TAG_entry_points AttributeList '>'
@@ -370,7 +370,7 @@
Attribute *errorAttr = $3->find( "error" );
if ( errorAttr != 0 )
cgd->setForcedErrorState();
- }
+ };
EntryPointList:
EntryPointList TagEntry |
@@ -462,7 +462,7 @@
cgd->initTransList( curState, length );
curTrans = 0;
}
- }
+ };
TransList:
TransList TagTrans |
@@ -531,7 +531,7 @@
/* Nothing */ {
/* Start with empty list. */
$$ = new InlineList;
- }
+ };
InlineItem:
TagText |
@@ -564,7 +564,7 @@
'<' '/' TAG_text '>' {
$$ = new InlineItem( InputLoc(), InlineItem::Text );
$$->data = strdup(xmlData.data);
- }
+ };
TagGoto:
'<' TAG_goto '>'
@@ -772,7 +772,7 @@
cgd->initActionTableList( length );
curActionTable = 0;
}
- }
+ };
ActionTableList:
ActionTableList TagActionTable |
@@ -806,7 +806,7 @@
}
curActionTable += 1;
- }
+ };
%%

View file

@ -1,37 +0,0 @@
--- rlparse.y.orig Sat Jun 25 07:56:54 2005
+++ rlparse.y Wed Sep 7 00:48:58 2005
@@ -470,14 +470,14 @@
id->sawInterface = true;
}
id->sectionEndLoc = @2;
- }
+ };
/* Include statements are processed by both the scanner and the parser. */
Include:
IncludeKeyword OptSection OptFileName ';' {
if ( id->active )
doInclude( @1, $2, $3 );
- }
+ };
IncludeKeyword:
KW_Include {
@@ -607,7 +607,7 @@
NoNameSep:
/* Nothing */ {
id->nameRef.empty();
- }
+ };
/* A qualified state reference. */
StateRef:
@@ -622,7 +622,7 @@
} |
/* Nothing. */ {
id->nameRef.empty();
- }
+ };
/* List of names separated by :: */
StateRefNames: