deskutils/coregarage: Settings manager for C Suite
Coregarage is a settings manager for C Suite, part of the CuboCore suite of simple, lighweight Qt applications. Coregarage is a centralized tool that manages settings for a variety of CuboCore apps.
This commit is contained in:
parent
6f4cee7a82
commit
e562107239
5 changed files with 64 additions and 0 deletions
|
@ -37,6 +37,7 @@
|
|||
SUBDIR += conkyforecast
|
||||
SUBDIR += coolreader
|
||||
SUBDIR += copyq
|
||||
SUBDIR += coregarage
|
||||
SUBDIR += countdown
|
||||
SUBDIR += dailystrips
|
||||
SUBDIR += deforaos-todo
|
||||
|
|
36
deskutils/coregarage/Makefile
Normal file
36
deskutils/coregarage/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
|||
PORTNAME= coregarage
|
||||
DISTVERSION= 4.3.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= deskutils
|
||||
|
||||
MAINTAINER= jwb@FreeBSD.org
|
||||
COMMENT= Settings manager for C Suite
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
LIB_DEPENDS= libarchiveqt5.so:archivers/libarchive-qt \
|
||||
libcprime-core.so:deskutils/libcprime
|
||||
|
||||
USES= cmake localbase:ldflags qt:5
|
||||
USE_QT= buildtools_build core gui qmake_build widgets
|
||||
USE_GITLAB= yes
|
||||
|
||||
GL_ACCOUNT= CuboCore
|
||||
GL_COMMIT= 684e579b4a03914b77ceccd6efcfc490c53ad730
|
||||
|
||||
PLIST_FILES= bin/coregarage \
|
||||
share/applications/org.cubocore.CoreGarage.desktop \
|
||||
share/icons/hicolor/scalable/apps/org.cubocore.CoreGarage.svg
|
||||
|
||||
pre-configure:
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|/usr/bin|${PREFIX}/bin|g' \
|
||||
-e 's|/usr/lib|${PREFIX}/lib|g' \
|
||||
-e 's|/usr/share|${PREFIX}/share|g' \
|
||||
${WRKSRC}/coregarage.cpp \
|
||||
${WRKSRC}/coregarage.h \
|
||||
${WRKSRC}/org.cubocore.CoreGarage.desktop \
|
||||
${WRKSRC}/settings.cpp
|
||||
|
||||
.include <bsd.port.mk>
|
3
deskutils/coregarage/distinfo
Normal file
3
deskutils/coregarage/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1629410694
|
||||
SHA256 (CuboCore-coregarage-684e579b4a03914b77ceccd6efcfc490c53ad730_GL0.tar.gz) = 871e8513176cf54fb1b5de3c90569d012270c3f55d35d20d68564e4813780e56
|
||||
SIZE (CuboCore-coregarage-684e579b4a03914b77ceccd6efcfc490c53ad730_GL0.tar.gz) = 102003
|
19
deskutils/coregarage/files/patch-settings.cpp
Normal file
19
deskutils/coregarage/files/patch-settings.cpp
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- settings.cpp.orig 2021-08-19 22:05:32 UTC
|
||||
+++ settings.cpp
|
||||
@@ -75,13 +75,13 @@ void settings::setDefaultSettings()
|
||||
QFont genFont = QFontDatabase::systemFont(QFontDatabase::GeneralFont);
|
||||
QFont monoFont = QFontDatabase::systemFont(QFontDatabase::FixedFont);
|
||||
if ( not genFont.family().count() )
|
||||
- genFont = QFont("Cantarell", 9);
|
||||
+ genFont = QFont("Cantarell", 12);
|
||||
|
||||
if ( not monoFont.family().count() )
|
||||
- monoFont = QFont("monospace", 9);
|
||||
+ monoFont = QFont("monospace", 12);
|
||||
|
||||
if (monoFont.styleHint() != QFont::Monospace) {
|
||||
- monoFont = QFont("monospace", 9);
|
||||
+ monoFont = QFont("monospace", 12);
|
||||
}
|
||||
|
||||
// CoreAction
|
5
deskutils/coregarage/pkg-descr
Normal file
5
deskutils/coregarage/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
Coregarage is a settings manager for C Suite, part of the CuboCore
|
||||
suite of simple, lighweight Qt applications. Coregarage is a
|
||||
centralized tool that manages settings for a variety of CuboCore apps.
|
||||
|
||||
WWW: https://gitlab.com/cubocore/coregarage
|
Loading…
Reference in a new issue