Upgrade to 4.2, from the GNU master site, since the gnu directory

(and sharutils-4.1.4 with it) disappeared from the master site.
Also use install-info on the info files.

Found by:	distfile checker
This commit is contained in:
Bill Fenner 1997-06-09 07:12:57 +00:00
parent 66866e84fb
commit e5696019fa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=6814
10 changed files with 270 additions and 224 deletions

View file

@ -1,22 +1,31 @@
# New ports collection makefile for: gshar+gunshar
# Version required: 4.1.4
# Version required: 4.2
# Date created: 28 Dec 1994
# Whom: ache
#
# $Id: Makefile,v 1.9 1996/11/18 13:55:45 asami Exp $
# $Id: Makefile,v 1.10 1997/05/28 22:36:58 ache Exp $
#
DISTNAME= sharutils-4.1.4
DISTNAME= sharutils-4.2
CATEGORIES= archivers
MASTER_SITES= ftp://ftp.iro.umontreal.ca/pub/contrib/pinard/gnu/
MASTER_SITES= ${MASTER_SITE_GNU}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g --disable-uucode --prefix=${PREFIX}
CONFIGURE_ARGS= --program-prefix=g --disable-uucode
INSTALL_TARGET= install install-man
MAN1= gshar.1 gunshar.1
post-patch:
@touch ${WRKSRC}/stamp-cod
@touch ${WRKSRC}/sharutils.cod
@touch ${WRKSRC}/locale.c
@touch ${WRKSRC}/po/sharutils.pot
post-install:
.for file in gshar gunshar
strip ${PREFIX}/bin/${file}
.endfor
if [ ! -f ${PREFIX}/info/dir ]; then \
sed -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
fi
.for info in remsync.info sharutils.info
install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
.endfor
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (sharutils-4.1.4.tar.gz) = 9efe11708a9c869189a4efb918b0916c
MD5 (sharutils-4.2.tar.gz) = b1ab1d10d88e8dcb8ee5b0d06b2fc073

View file

@ -1,89 +1,90 @@
*** Makefile.in.orig Wed Feb 22 22:31:33 1995
--- Makefile.in Sun Mar 26 05:58:40 1995
***************
*** 18,24 ****
PACKAGE = @PACKAGE@
VERSION = @VERSION@
! PROGRAMS = @PROGRAMS@
CATALOGS = de.msg fr.msg nl.msg sv.msg
@SET_MAKE@
--- 18,25 ----
PACKAGE = @PACKAGE@
VERSION = @VERSION@
! PROGRAMS = shar unshar
! SCRIPTS = mail-files mailshar remsync
CATALOGS = de.msg fr.msg nl.msg sv.msg
@SET_MAKE@
***************
*** 167,176 ****
getopt.o getopt1.o: getopt.h
xgetcwd.o: pathmax.h
! .SUFFIXES: .msg .tt
! .tt.msg:
! cd $(srcdir) && \
! make-msg $*.tt $(PACKAGE).cod > $*.tmp && mv $*.tmp $@
$(CATALOGS): $(PACKAGE).cod
--- 168,177 ----
getopt.o getopt1.o: getopt.h
xgetcwd.o: pathmax.h
! #.SUFFIXES: .msg .tt
! #.tt.msg:
! # cd $(srcdir) && \
! # make-msg $*.tt $(PACKAGE).cod > $*.tmp && mv $*.tmp $@
$(CATALOGS): $(PACKAGE).cod
***************
*** 215,220 ****
--- 216,225 ----
$(INSTALL_PROGRAM) $$name \
$(bindir)/`echo $$name | sed '$(transform)'`; \
done
+ for name in $(SCRIPTS); do \
+ $(INSTALL_DATA) $$name $(bindir); \
+ chmod 755 $(bindir)/$$name; \
+ done
for name in $(CATALOGS); do \
lang=`echo $$name | sed 's/.msg$$//'`; \
$(srcdir)/mkinstalldirs $(localedir)/$$lang; \
***************
*** 237,251 ****
install-man:
$(srcdir)/mkinstalldirs $(man1dir) $(man5dir)
! for name in shar unshar uuencode; do \
$(INSTALL_DATA) $(srcdir)/$$name.1 \
$(man1dir)/`echo $$name | sed '$(transform)'`$(man1ext); \
done
! rm -f $(man1dir)/`echo uudecode | sed '$(transform)'`$(man1ext)
! ln $(man1dir)/`echo uuencode | sed '$(transform)'`$(man1ext) \
! $(man1dir)/`echo uudecode | sed '$(transform)'`$(man1ext)
! $(INSTALL_DATA) $(srcdir)/uuencode.5 \
! $(man5dir)/`echo uuencode | sed '$(transform)'`$(man5ext)
uninstall-man:
for name in shar unshar uudecode uuencode; do \
--- 242,256 ----
install-man:
$(srcdir)/mkinstalldirs $(man1dir) $(man5dir)
! for name in shar unshar; do \
$(INSTALL_DATA) $(srcdir)/$$name.1 \
$(man1dir)/`echo $$name | sed '$(transform)'`$(man1ext); \
done
! # rm -f $(man1dir)/`echo uudecode | sed '$(transform)'`$(man1ext)
! # ln $(man1dir)/`echo uuencode | sed '$(transform)'`$(man1ext) \
! # $(man1dir)/`echo uudecode | sed '$(transform)'`$(man1ext)
! # $(INSTALL_DATA) $(srcdir)/uuencode.5 \
! # $(man5dir)/`echo uuencode | sed '$(transform)'`$(man5ext)
uninstall-man:
for name in shar unshar uudecode uuencode; do \
--- doc/remsync.texi.orig Sun Jun 8 22:59:35 1997
+++ doc/remsync.texi Sun Jun 8 23:02:50 1997
@@ -2,6 +2,10 @@
@c %**start of header
@setfilename remsync.info
@settitle @code{remsync} reference manual
+@dircategory File transfer and archiving tools
+@direntry
+* remsync: (remsync). Synchronize remote directory trees using email.
+@end direntry
@finalout
@setchapternewpage odd
@c %**end of header
--- doc/sharutils.texi.orig Sun Jun 8 22:59:41 1997
+++ doc/sharutils.texi Sun Jun 8 23:10:37 1997
@@ -2,6 +2,17 @@
@c %**start of header
@setfilename sharutils.info
@settitle GNU @code{shar} utilities
+@dircategory File transfer and archiving tools
+@direntry
+* Shar utilities: (sharutils). GNU shar utilities.
+* mail-files: (sharutils)mail-files invocation. Send files to remote site.
+* mailshar: (sharutils)mailshar invocation. Make and send a shell archive.
+* remsync: (sharutils)remsync invocation. Synchronize remote files.
+* shar: (sharutils)shar invocation. Make a shell archive.
+* unshar: (sharutils)unshar invocation. Explode a shell archive.
+* uudecode: (sharutils)uudecode invocation. Restore file from 7-bits.
+* uuencode: (sharutils)uuencode invocation. Force binary file to 7-bits.
+@end direntry
@finalout
@c %**end of header
@@ -15,21 +26,6 @@
@end tex
@ifinfo
-@format
-START-INFO-DIR-ENTRY
-* Shar utilities: (sharutils). GNU shar utilities.
-* mail-files: (sharutils)mail-files invocation. Send files to remote site.
-* mailshar: (sharutils)mailshar invocation. Make and send a shell archive.
-* remsync: (sharutils)remsync invocation. Synchronize remote files.
-* shar: (sharutils)shar invocation. Make a shell archive.
-* unshar: (sharutils)unshar invocation. Explode a shell archive.
-* uudecode: (sharutils)uudecode invocation. Restore file from 7-bits.
-* uuencode: (sharutils)uuencode invocation. Force binary file to 7-bits.
-END-INFO-DIR-ENTRY
-@end format
-@end ifinfo
-
-@ifinfo
This file documents the GNU set of shar utilities.
Copyright (C) 1994 Free Software Foundation, Inc.
@@ -157,8 +153,8 @@
The format of the @code{shar} command is one of:
@example
-shar [ @var{option} ] @dots{} @var{file} @dots{}
-shar -S [ @var{option} ] @dots{}
+gshar [ @var{option} ] @dots{} @var{file} @dots{}
+gshar -S [ @var{option} ] @dots{}
@end example
In the first form, the file list is given as command arguments. In the
@@ -548,7 +544,7 @@
The format of the @code{unshar} command is:
@example
-unshar [ @var{option} ] @dots{} [ @var{file} @dots{} ]
+gunshar [ @var{option} ] @dots{} [ @var{file} @dots{} ]
@end example
Each @var{file} is processed in turn, as a shell archive or a
@@ -635,10 +631,10 @@
Let us conclude by a showing a few examples of @code{shar} usage:
@example
-shar *.c > cprog.shar
-shar -Q *.[ch] > cprog.shar
-shar -B -l28 -oarc.sh. *.arc
-shar -f /lcl/src/u*.c > u.sh
+gshar *.c > cprog.shar
+gshar -Q *.[ch] > cprog.shar
+gshar -B -l28 -oarc.sh. *.arc
+gshar -f /lcl/src/u*.c > u.sh
@end example
@noindent

View file

@ -1,8 +1,8 @@
--- shar.c.dist Fri Aug 16 22:19:04 1996
+++ shar.c Fri Aug 16 22:19:36 1996
@@ -589,7 +589,7 @@
static int
generate_one_header_line (const char *local_name, const char *restore_name)
--- src/shar.c.orig Sun Jun 8 22:47:22 1997
+++ src/shar.c Sun Jun 8 22:47:37 1997
@@ -688,7 +688,7 @@
const char *local_name;
const char *restore_name;
{
- fprintf (output, "# %6ld %s %s\n", struct_stat.st_size,
+ fprintf (output, "# %6ld %s %s\n", (long)struct_stat.st_size,

View file

@ -1,13 +1,26 @@
info/sharutils.info
info/remsync.info
bin/gmail-files
bin/gmailshar
bin/gremsync
bin/gshar
bin/gunshar
bin/mailshar
bin/mail-files
bin/remsync
@unexec install-info --delete %D/info/sharutils.info %D/info/dir
@unexec install-info --delete %D/info/remsync.info %D/info/dir
info/sharutils.info
info/remsync.info
@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
@exec install-info %D/info/sharutils.info %D/info/dir
@exec install-info %D/info/remsync.info %D/info/dir
lib/locale/de/LC_MESSAGES/sharutils.cat
lib/locale/fr/LC_MESSAGES/sharutils.cat
lib/locale/ja_JP.EUC/LC_MESSAGES/sharutils.cat
lib/locale/nl/LC_MESSAGES/sharutils.cat
lib/locale/pt/LC_MESSAGES/sharutils.cat
lib/locale/sv/LC_MESSAGES/sharutils.cat
man/man1/gshar.1.gz
man/man1/gunshar.1.gz
share/locale/de/sharutils.msg
share/locale/fr/sharutils.msg
share/locale/sv/sharutils.msg
share/locale/nl/sharutils.msg
share/locale/de.gmo/LC_MESSAGES/sharutils.cat
share/locale/fr.gmo/LC_MESSAGES/sharutils.cat
share/locale/ja_JP.EUC.gmo/LC_MESSAGES/sharutils.cat
share/locale/nl.gmo/LC_MESSAGES/sharutils.cat
share/locale/pt.gmo/LC_MESSAGES/sharutils.cat
share/locale/sv.gmo/LC_MESSAGES/sharutils.cat

View file

@ -1,22 +1,31 @@
# New ports collection makefile for: gshar+gunshar
# Version required: 4.1.4
# Version required: 4.2
# Date created: 28 Dec 1994
# Whom: ache
#
# $Id: Makefile,v 1.9 1996/11/18 13:55:45 asami Exp $
# $Id: Makefile,v 1.10 1997/05/28 22:36:58 ache Exp $
#
DISTNAME= sharutils-4.1.4
DISTNAME= sharutils-4.2
CATEGORIES= archivers
MASTER_SITES= ftp://ftp.iro.umontreal.ca/pub/contrib/pinard/gnu/
MASTER_SITES= ${MASTER_SITE_GNU}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g --disable-uucode --prefix=${PREFIX}
CONFIGURE_ARGS= --program-prefix=g --disable-uucode
INSTALL_TARGET= install install-man
MAN1= gshar.1 gunshar.1
post-patch:
@touch ${WRKSRC}/stamp-cod
@touch ${WRKSRC}/sharutils.cod
@touch ${WRKSRC}/locale.c
@touch ${WRKSRC}/po/sharutils.pot
post-install:
.for file in gshar gunshar
strip ${PREFIX}/bin/${file}
.endfor
if [ ! -f ${PREFIX}/info/dir ]; then \
sed -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
fi
.for info in remsync.info sharutils.info
install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
.endfor
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (sharutils-4.1.4.tar.gz) = 9efe11708a9c869189a4efb918b0916c
MD5 (sharutils-4.2.tar.gz) = b1ab1d10d88e8dcb8ee5b0d06b2fc073

View file

@ -1,89 +1,90 @@
*** Makefile.in.orig Wed Feb 22 22:31:33 1995
--- Makefile.in Sun Mar 26 05:58:40 1995
***************
*** 18,24 ****
PACKAGE = @PACKAGE@
VERSION = @VERSION@
! PROGRAMS = @PROGRAMS@
CATALOGS = de.msg fr.msg nl.msg sv.msg
@SET_MAKE@
--- 18,25 ----
PACKAGE = @PACKAGE@
VERSION = @VERSION@
! PROGRAMS = shar unshar
! SCRIPTS = mail-files mailshar remsync
CATALOGS = de.msg fr.msg nl.msg sv.msg
@SET_MAKE@
***************
*** 167,176 ****
getopt.o getopt1.o: getopt.h
xgetcwd.o: pathmax.h
! .SUFFIXES: .msg .tt
! .tt.msg:
! cd $(srcdir) && \
! make-msg $*.tt $(PACKAGE).cod > $*.tmp && mv $*.tmp $@
$(CATALOGS): $(PACKAGE).cod
--- 168,177 ----
getopt.o getopt1.o: getopt.h
xgetcwd.o: pathmax.h
! #.SUFFIXES: .msg .tt
! #.tt.msg:
! # cd $(srcdir) && \
! # make-msg $*.tt $(PACKAGE).cod > $*.tmp && mv $*.tmp $@
$(CATALOGS): $(PACKAGE).cod
***************
*** 215,220 ****
--- 216,225 ----
$(INSTALL_PROGRAM) $$name \
$(bindir)/`echo $$name | sed '$(transform)'`; \
done
+ for name in $(SCRIPTS); do \
+ $(INSTALL_DATA) $$name $(bindir); \
+ chmod 755 $(bindir)/$$name; \
+ done
for name in $(CATALOGS); do \
lang=`echo $$name | sed 's/.msg$$//'`; \
$(srcdir)/mkinstalldirs $(localedir)/$$lang; \
***************
*** 237,251 ****
install-man:
$(srcdir)/mkinstalldirs $(man1dir) $(man5dir)
! for name in shar unshar uuencode; do \
$(INSTALL_DATA) $(srcdir)/$$name.1 \
$(man1dir)/`echo $$name | sed '$(transform)'`$(man1ext); \
done
! rm -f $(man1dir)/`echo uudecode | sed '$(transform)'`$(man1ext)
! ln $(man1dir)/`echo uuencode | sed '$(transform)'`$(man1ext) \
! $(man1dir)/`echo uudecode | sed '$(transform)'`$(man1ext)
! $(INSTALL_DATA) $(srcdir)/uuencode.5 \
! $(man5dir)/`echo uuencode | sed '$(transform)'`$(man5ext)
uninstall-man:
for name in shar unshar uudecode uuencode; do \
--- 242,256 ----
install-man:
$(srcdir)/mkinstalldirs $(man1dir) $(man5dir)
! for name in shar unshar; do \
$(INSTALL_DATA) $(srcdir)/$$name.1 \
$(man1dir)/`echo $$name | sed '$(transform)'`$(man1ext); \
done
! # rm -f $(man1dir)/`echo uudecode | sed '$(transform)'`$(man1ext)
! # ln $(man1dir)/`echo uuencode | sed '$(transform)'`$(man1ext) \
! # $(man1dir)/`echo uudecode | sed '$(transform)'`$(man1ext)
! # $(INSTALL_DATA) $(srcdir)/uuencode.5 \
! # $(man5dir)/`echo uuencode | sed '$(transform)'`$(man5ext)
uninstall-man:
for name in shar unshar uudecode uuencode; do \
--- doc/remsync.texi.orig Sun Jun 8 22:59:35 1997
+++ doc/remsync.texi Sun Jun 8 23:02:50 1997
@@ -2,6 +2,10 @@
@c %**start of header
@setfilename remsync.info
@settitle @code{remsync} reference manual
+@dircategory File transfer and archiving tools
+@direntry
+* remsync: (remsync). Synchronize remote directory trees using email.
+@end direntry
@finalout
@setchapternewpage odd
@c %**end of header
--- doc/sharutils.texi.orig Sun Jun 8 22:59:41 1997
+++ doc/sharutils.texi Sun Jun 8 23:10:37 1997
@@ -2,6 +2,17 @@
@c %**start of header
@setfilename sharutils.info
@settitle GNU @code{shar} utilities
+@dircategory File transfer and archiving tools
+@direntry
+* Shar utilities: (sharutils). GNU shar utilities.
+* mail-files: (sharutils)mail-files invocation. Send files to remote site.
+* mailshar: (sharutils)mailshar invocation. Make and send a shell archive.
+* remsync: (sharutils)remsync invocation. Synchronize remote files.
+* shar: (sharutils)shar invocation. Make a shell archive.
+* unshar: (sharutils)unshar invocation. Explode a shell archive.
+* uudecode: (sharutils)uudecode invocation. Restore file from 7-bits.
+* uuencode: (sharutils)uuencode invocation. Force binary file to 7-bits.
+@end direntry
@finalout
@c %**end of header
@@ -15,21 +26,6 @@
@end tex
@ifinfo
-@format
-START-INFO-DIR-ENTRY
-* Shar utilities: (sharutils). GNU shar utilities.
-* mail-files: (sharutils)mail-files invocation. Send files to remote site.
-* mailshar: (sharutils)mailshar invocation. Make and send a shell archive.
-* remsync: (sharutils)remsync invocation. Synchronize remote files.
-* shar: (sharutils)shar invocation. Make a shell archive.
-* unshar: (sharutils)unshar invocation. Explode a shell archive.
-* uudecode: (sharutils)uudecode invocation. Restore file from 7-bits.
-* uuencode: (sharutils)uuencode invocation. Force binary file to 7-bits.
-END-INFO-DIR-ENTRY
-@end format
-@end ifinfo
-
-@ifinfo
This file documents the GNU set of shar utilities.
Copyright (C) 1994 Free Software Foundation, Inc.
@@ -157,8 +153,8 @@
The format of the @code{shar} command is one of:
@example
-shar [ @var{option} ] @dots{} @var{file} @dots{}
-shar -S [ @var{option} ] @dots{}
+gshar [ @var{option} ] @dots{} @var{file} @dots{}
+gshar -S [ @var{option} ] @dots{}
@end example
In the first form, the file list is given as command arguments. In the
@@ -548,7 +544,7 @@
The format of the @code{unshar} command is:
@example
-unshar [ @var{option} ] @dots{} [ @var{file} @dots{} ]
+gunshar [ @var{option} ] @dots{} [ @var{file} @dots{} ]
@end example
Each @var{file} is processed in turn, as a shell archive or a
@@ -635,10 +631,10 @@
Let us conclude by a showing a few examples of @code{shar} usage:
@example
-shar *.c > cprog.shar
-shar -Q *.[ch] > cprog.shar
-shar -B -l28 -oarc.sh. *.arc
-shar -f /lcl/src/u*.c > u.sh
+gshar *.c > cprog.shar
+gshar -Q *.[ch] > cprog.shar
+gshar -B -l28 -oarc.sh. *.arc
+gshar -f /lcl/src/u*.c > u.sh
@end example
@noindent

View file

@ -1,8 +1,8 @@
--- shar.c.dist Fri Aug 16 22:19:04 1996
+++ shar.c Fri Aug 16 22:19:36 1996
@@ -589,7 +589,7 @@
static int
generate_one_header_line (const char *local_name, const char *restore_name)
--- src/shar.c.orig Sun Jun 8 22:47:22 1997
+++ src/shar.c Sun Jun 8 22:47:37 1997
@@ -688,7 +688,7 @@
const char *local_name;
const char *restore_name;
{
- fprintf (output, "# %6ld %s %s\n", struct_stat.st_size,
+ fprintf (output, "# %6ld %s %s\n", (long)struct_stat.st_size,

View file

@ -1,13 +1,26 @@
info/sharutils.info
info/remsync.info
bin/gmail-files
bin/gmailshar
bin/gremsync
bin/gshar
bin/gunshar
bin/mailshar
bin/mail-files
bin/remsync
@unexec install-info --delete %D/info/sharutils.info %D/info/dir
@unexec install-info --delete %D/info/remsync.info %D/info/dir
info/sharutils.info
info/remsync.info
@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
@exec install-info %D/info/sharutils.info %D/info/dir
@exec install-info %D/info/remsync.info %D/info/dir
lib/locale/de/LC_MESSAGES/sharutils.cat
lib/locale/fr/LC_MESSAGES/sharutils.cat
lib/locale/ja_JP.EUC/LC_MESSAGES/sharutils.cat
lib/locale/nl/LC_MESSAGES/sharutils.cat
lib/locale/pt/LC_MESSAGES/sharutils.cat
lib/locale/sv/LC_MESSAGES/sharutils.cat
man/man1/gshar.1.gz
man/man1/gunshar.1.gz
share/locale/de/sharutils.msg
share/locale/fr/sharutils.msg
share/locale/sv/sharutils.msg
share/locale/nl/sharutils.msg
share/locale/de.gmo/LC_MESSAGES/sharutils.cat
share/locale/fr.gmo/LC_MESSAGES/sharutils.cat
share/locale/ja_JP.EUC.gmo/LC_MESSAGES/sharutils.cat
share/locale/nl.gmo/LC_MESSAGES/sharutils.cat
share/locale/pt.gmo/LC_MESSAGES/sharutils.cat
share/locale/sv.gmo/LC_MESSAGES/sharutils.cat