- Fix install from non-root
- Strip binary - Drop @dirrm* from plist
This commit is contained in:
parent
eb676bdc85
commit
e569f7626e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=398711
3 changed files with 15 additions and 7 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= qmailadmin
|
||||
PORTVERSION= 1.2.15
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 7
|
||||
PORTEPOCH= 2
|
||||
CATEGORIES= mail www
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTVERSION} \
|
||||
|
@ -104,7 +104,8 @@ LIBS+= -L${LOCALBASE}/lib -lcrack
|
|||
|
||||
VPOPMAIL_DIR?= ${LOCALBASE}/vpopmail
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
# Notes and comments:
|
||||
#
|
||||
|
|
11
mail/qmailadmin/files/patch-Makefile.am
Normal file
11
mail/qmailadmin/files/patch-Makefile.am
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.am.orig 2010-03-26 06:08:58 UTC
|
||||
+++ Makefile.am
|
||||
@@ -14,7 +14,7 @@ VERSION=@QA_VERSION@
|
||||
#
|
||||
# Install qmailadmin setuid to @vpopuser@
|
||||
#
|
||||
-INSTALL_PROGRAM=${INSTALL} -o @vpopuser@ -m 6755 -g @vpopgroup@ $(AM_INSTALL_PROGRAM_FLAGS)
|
||||
+INSTALL_PROGRAM=${INSTALL} $(AM_INSTALL_PROGRAM_FLAGS)
|
||||
INSTALL_STRIP_PROGRAM=${INSTALL_PROGRAM} -s
|
||||
|
||||
bindir=@cgibindir@
|
|
@ -54,7 +54,7 @@
|
|||
%%DATADIR%%/lang/tr
|
||||
%%DATADIR%%/lang/zh-cn
|
||||
@cwd %%WEBPREFIX%%
|
||||
%%CGIBINDIR%%/%%CGIBINSUBDIR%%/qmailadmin
|
||||
@(vpopmail,vchkpw,6755) %%CGIBINDIR%%/%%CGIBINSUBDIR%%/qmailadmin
|
||||
%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/delete.png
|
||||
%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/disabled.png
|
||||
%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/lowerleft.png
|
||||
|
@ -76,12 +76,8 @@
|
|||
%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/uppermiddle1.png
|
||||
%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/uppermiddle2.png
|
||||
%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/upperright.png
|
||||
@dirrm %%WEBDATADIR%%/%%WEBDATASUBDIR%%/images
|
||||
@unexec rmdir %%WEBPREFIX%%/%%WEBDATADIR%%/%%WEBDATASUBDIR%% 2> /dev/null || true
|
||||
@unexec rmdir %%WEBPREFIX%%/%%WEBDATADIR%% 2> /dev/null || true
|
||||
@unexec rmdir %%WEBPREFIX%%/%%CGIBINDIR%%/%%CGIBINSUBDIR%% 2> /dev/null || true
|
||||
@unexec rmdir %%WEBPREFIX%%/%%CGIBINDIR%% 2> /dev/null || true
|
||||
@cwd %%REAL_PREFIX%%
|
||||
@dirrm %%DATADIR%%/html
|
||||
@dirrm %%DATADIR%%/lang
|
||||
@dirrm %%DATADIR%%
|
||||
|
|
Loading…
Reference in a new issue