parent
75ff47915c
commit
e58d77f020
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=462008
4 changed files with 22 additions and 14 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= frei0r
|
||||
PORTVERSION= 1.5.0
|
||||
PORTVERSION= 1.6.1
|
||||
DISTVERSIONPREFIX= plugins-
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES?= https://files.dyne.org/frei0r/releases/
|
||||
|
@ -12,8 +12,8 @@ COMMENT?= Minimalistic plugin API for video effects
|
|||
|
||||
.if !defined(BUILDING_FREI0R_METAPORT)
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING.txt
|
||||
|
||||
USES= cmake:outsource pkgconfig
|
||||
|
||||
|
@ -29,10 +29,11 @@ USES+= localbase
|
|||
.endif
|
||||
|
||||
.if defined(BUILDING_FREI0R_OPENCV)
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 0
|
||||
COMMENT= Frei0r OpenCV plugins
|
||||
PKGNAMESUFFIX= -plugins-opencv
|
||||
LIB_DEPENDS+= libopencv_legacy.so:graphics/opencv
|
||||
LIB_DEPENDS+= libopencv_core.so:graphics/opencv-core \
|
||||
libopencv_legacy.so:graphics/opencv
|
||||
FREI0R_PLUGINS= facebl0r facedetect
|
||||
|
||||
CMAKE_ARGS+= -DWITHOUT_OPENCV:BOOL=OFF \
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (frei0r-plugins-1.5.0.tar.gz) = 781cf84a6c2a9a3252f54d2967b57f6de75a31fc1684371e112638c981f72b60
|
||||
SIZE (frei0r-plugins-1.5.0.tar.gz) = 1519006
|
||||
TIMESTAMP = 1518779363
|
||||
SHA256 (frei0r-plugins-1.6.1.tar.gz) = e0c24630961195d9bd65aa8d43732469e8248e8918faa942cfb881769d11515e
|
||||
SIZE (frei0r-plugins-1.6.1.tar.gz) = 1103969
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- CMakeLists.txt.orig 2016-04-02 00:29:38 UTC
|
||||
--- CMakeLists.txt.orig 2017-05-31 05:57:25 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -10,8 +10,6 @@ if (NOT WITHOUT_OPENCV)
|
||||
find_package (OpenCV)
|
||||
|
@ -9,17 +9,17 @@
|
|||
include(FindPkgConfig)
|
||||
option (WITHOUT_GAVL "Disable plugins dependent upon gavl" OFF)
|
||||
if (PKG_CONFIG_FOUND AND NOT WITHOUT_GAVL)
|
||||
@@ -45,16 +43,8 @@ set (FREI0R_1_1_DEF ${CMAKE_SOURCE_DIR}/
|
||||
@@ -45,16 +43,8 @@ set (FREI0R_1_1_DEF ${CMAKE_SOURCE_DIR}/msvc/frei0r_1_
|
||||
# --- custom targets: ---
|
||||
INCLUDE( cmake/modules/TargetDistclean.cmake OPTIONAL)
|
||||
|
||||
-# See this thread for a ridiculous discussion about the simple question how to install a header file with CMake: http://www.cmake.org/pipermail/cmake/2009-October/032874.html
|
||||
-install (DIRECTORY include DESTINATION . FILES_MATCHING PATTERN "frei0r.h" PATTERN "msvc" EXCLUDE)
|
||||
-
|
||||
-add_subdirectory (doc)
|
||||
-add_subdirectory (src)
|
||||
+add_subdirectory (src/filter)
|
||||
|
||||
-add_subdirectory (doc)
|
||||
-add_subdirectory (src)
|
||||
-
|
||||
-# Generate frei0r.pc and install it.
|
||||
set (prefix "${CMAKE_INSTALL_PREFIX}")
|
||||
set (exec_prefix "${CMAKE_INSTALL_PREFIX}")
|
||||
|
@ -27,9 +27,9 @@
|
|||
-set (includedir "${CMAKE_INSTALL_PREFIX}/include")
|
||||
-configure_file ("frei0r.pc.in" "frei0r.pc" @ONLY)
|
||||
-install (FILES "${CMAKE_CURRENT_BINARY_DIR}/frei0r.pc" DESTINATION lib/pkgconfig)
|
||||
--- src/filter/CMakeLists.txt.orig 2016-04-02 00:29:38 UTC
|
||||
--- src/filter/CMakeLists.txt.orig 2017-05-31 05:57:25 UTC
|
||||
+++ src/filter/CMakeLists.txt
|
||||
@@ -8,86 +8,3 @@ if (${OpenCV_FOUND})
|
||||
@@ -8,89 +8,3 @@ if (${OpenCV_FOUND})
|
||||
add_subdirectory (facebl0r)
|
||||
add_subdirectory (facedetect)
|
||||
endif (${OpenCV_FOUND})
|
||||
|
@ -44,6 +44,7 @@
|
|||
-add_subdirectory (balanc0r)
|
||||
-add_subdirectory (baltan)
|
||||
-add_subdirectory (bluescreen0r)
|
||||
-add_subdirectory (bgsubtract0r)
|
||||
-add_subdirectory (blur)
|
||||
-add_subdirectory (brightness)
|
||||
-add_subdirectory (bw0r)
|
||||
|
@ -71,6 +72,7 @@
|
|||
-add_subdirectory (flippo)
|
||||
-add_subdirectory (gamma)
|
||||
-add_subdirectory (glow)
|
||||
-add_subdirectory (glitch0r)
|
||||
-#add_subdirectory (host_param_test)
|
||||
-add_subdirectory (hueshift0r)
|
||||
-add_subdirectory (invert0r)
|
||||
|
@ -95,6 +97,7 @@
|
|||
-add_subdirectory (primaries)
|
||||
-add_subdirectory (RGB)
|
||||
-add_subdirectory (rgbnoise)
|
||||
-add_subdirectory (rgbsplit0r)
|
||||
-add_subdirectory (saturat0r)
|
||||
-add_subdirectory (scanline0r)
|
||||
-add_subdirectory (select0r)
|
||||
|
|
|
@ -18,6 +18,7 @@ lib/frei0r-1/alphaspot.so
|
|||
lib/frei0r-1/alphaxor.so
|
||||
lib/frei0r-1/balanc0r.so
|
||||
lib/frei0r-1/baltan.so
|
||||
lib/frei0r-1/bgsubtract0r.so
|
||||
lib/frei0r-1/blend.so
|
||||
lib/frei0r-1/bluescreen0r.so
|
||||
lib/frei0r-1/brightness.so
|
||||
|
@ -55,6 +56,7 @@ lib/frei0r-1/emboss.so
|
|||
lib/frei0r-1/equaliz0r.so
|
||||
lib/frei0r-1/flippo.so
|
||||
lib/frei0r-1/gamma.so
|
||||
lib/frei0r-1/glitch0r.so
|
||||
lib/frei0r-1/glow.so
|
||||
lib/frei0r-1/grain_extract.so
|
||||
lib/frei0r-1/grain_merge.so
|
||||
|
@ -90,6 +92,7 @@ lib/frei0r-1/pr0be.so
|
|||
lib/frei0r-1/pr0file.so
|
||||
lib/frei0r-1/primaries.so
|
||||
lib/frei0r-1/rgbnoise.so
|
||||
lib/frei0r-1/rgbsplit0r.so
|
||||
lib/frei0r-1/saturat0r.so
|
||||
lib/frei0r-1/saturation.so
|
||||
lib/frei0r-1/scanline0r.so
|
||||
|
|
Loading…
Reference in a new issue