2009-07-28 games/amy: mastersite disappeared, does not build on recent version
2009-07-28 security/hashish: "does not compile" 2009-07-19 security/smtpmap: depends on GCC 2.95 which has not been available for 9+ months
This commit is contained in:
parent
0969c23a4e
commit
e5b7d01def
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=238491
19 changed files with 3 additions and 262 deletions
3
MOVED
3
MOVED
|
@ -4122,3 +4122,6 @@ R-sp|R-cran-sp|2009-07-17|Port was renamed
|
||||||
lang/gcc-ooo|lang/gcc43|2009-07-18|Not used by OpenOffice any more, superseded by gcc43
|
lang/gcc-ooo|lang/gcc43|2009-07-18|Not used by OpenOffice any more, superseded by gcc43
|
||||||
security/altivore||2009-07-19|Removed
|
security/altivore||2009-07-19|Removed
|
||||||
editors/openoffice.org-2-devel||2009-07-21|Removed
|
editors/openoffice.org-2-devel||2009-07-21|Removed
|
||||||
|
games/amy||2009-07-28|Has expired: mastersite disappeared, does not build on recent version
|
||||||
|
security/hashish||2009-07-28|Has expired: "does not compile"
|
||||||
|
security/smtpmap||2009-07-28|Has expired: depends on GCC 2.95 which has not been available for 9+ months
|
||||||
|
|
|
@ -38,7 +38,6 @@
|
||||||
SUBDIR += allacrost
|
SUBDIR += allacrost
|
||||||
SUBDIR += amoebax
|
SUBDIR += amoebax
|
||||||
SUBDIR += amphetamine
|
SUBDIR += amphetamine
|
||||||
SUBDIR += amy
|
|
||||||
SUBDIR += an
|
SUBDIR += an
|
||||||
SUBDIR += anagramarama
|
SUBDIR += anagramarama
|
||||||
SUBDIR += angband
|
SUBDIR += angband
|
||||||
|
|
|
@ -1,49 +0,0 @@
|
||||||
# New ports collection makefile for: amy
|
|
||||||
# Date created: 30 Jan 2003
|
|
||||||
# Whom: Thorsten Greiner <thorsten.greiner@web.de>
|
|
||||||
#
|
|
||||||
# $FreeBSD$
|
|
||||||
#
|
|
||||||
|
|
||||||
PORTNAME= amy
|
|
||||||
PORTVERSION= 0.8.7
|
|
||||||
CATEGORIES= games
|
|
||||||
MASTER_SITES= http://tgreiner.net/
|
|
||||||
DISTFILES= amy-${PORTVERSION}.tar.gz ClassicGames.pgn.bz2
|
|
||||||
EXTRACT_ONLY= amy-${PORTVERSION}.tar.gz
|
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
|
||||||
COMMENT= A chess program for playing and analyzing games
|
|
||||||
|
|
||||||
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2:install
|
|
||||||
|
|
||||||
DEPRECATED= mastersite disappeared, does not build on recent version
|
|
||||||
EXPIRATION_DATE= 2009-07-28
|
|
||||||
|
|
||||||
NOT_FOR_ARCHS= sparc64 alpha
|
|
||||||
|
|
||||||
MAN6= Amy.6
|
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
|
||||||
|
|
||||||
.if ${OSVERSION} >= 700042
|
|
||||||
BROKEN= Does not compile with GCC 4.2
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if ${ARCH} == "amd64"
|
|
||||||
BROKEN= Segfault during build on amd64
|
|
||||||
.endif
|
|
||||||
|
|
||||||
post-extract:
|
|
||||||
${BZCAT} ${DISTDIR}/ClassicGames.pgn.bz2 > \
|
|
||||||
${WRKSRC}/PGN/ClassicGames.pgn
|
|
||||||
|
|
||||||
post-install:
|
|
||||||
.if !defined(NOPORTDOCS)
|
|
||||||
${MKDIR} ${DOCSDIR}
|
|
||||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.include <bsd.port.post.mk>
|
|
|
@ -1,6 +0,0 @@
|
||||||
MD5 (amy-0.8.7.tar.gz) = cce5f5ecb043cb66ec55d3ac1658dc3a
|
|
||||||
SHA256 (amy-0.8.7.tar.gz) = 66cf918caa87b7818613fceafeba428fe02c2d1d8c41591e98e3921436e2e6e3
|
|
||||||
SIZE (amy-0.8.7.tar.gz) = 250455
|
|
||||||
MD5 (ClassicGames.pgn.bz2) = 87a741347572c2f616e5228bdd0e637b
|
|
||||||
SHA256 (ClassicGames.pgn.bz2) = 1a81b5e575c806de556dc23b963a814179f49d2b4f3340f5c0f3977ad3b748bd
|
|
||||||
SIZE (ClassicGames.pgn.bz2) = 1621810
|
|
|
@ -1,9 +0,0 @@
|
||||||
A chess program for playing and analyzing games. Amy comes complete with
|
|
||||||
an opening book build from about 12000 master games. Please read the
|
|
||||||
README file to find out how build your own book or use endgame tablebases.
|
|
||||||
|
|
||||||
The user interface is command line based. For a graphical user interface
|
|
||||||
install xboard (xboard) and use the '-fcp Amy' switch to play
|
|
||||||
against Amy.
|
|
||||||
|
|
||||||
WWW: http://www.tgreiner.net/software.html
|
|
|
@ -1,18 +0,0 @@
|
||||||
bin/Amy
|
|
||||||
%%DATADIR%%/Book.db
|
|
||||||
%%DATADIR%%/Eco.db
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/amy.css
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ch01.html
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ch01s02.html
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ch01s03.html
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ch01s04.html
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ch02.html
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ch03.html
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ch03s02.html
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ch03s03.html
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ch03s04.html
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ch04.html
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
|
||||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
|
||||||
@dirrm %%DATADIR%%
|
|
|
@ -178,7 +178,6 @@
|
||||||
SUBDIR += hackbot
|
SUBDIR += hackbot
|
||||||
SUBDIR += hafiye
|
SUBDIR += hafiye
|
||||||
SUBDIR += hamachi
|
SUBDIR += hamachi
|
||||||
SUBDIR += hashish
|
|
||||||
SUBDIR += heimdal
|
SUBDIR += heimdal
|
||||||
SUBDIR += hlfl
|
SUBDIR += hlfl
|
||||||
SUBDIR += hmap
|
SUBDIR += hmap
|
||||||
|
@ -757,7 +756,6 @@
|
||||||
SUBDIR += slurpie
|
SUBDIR += slurpie
|
||||||
SUBDIR += slush
|
SUBDIR += slush
|
||||||
SUBDIR += smap
|
SUBDIR += smap
|
||||||
SUBDIR += smtpmap
|
|
||||||
SUBDIR += smtpscan
|
SUBDIR += smtpscan
|
||||||
SUBDIR += smurflog
|
SUBDIR += smurflog
|
||||||
SUBDIR += sniff
|
SUBDIR += sniff
|
||||||
|
|
|
@ -1,33 +0,0 @@
|
||||||
# ex:ts=8
|
|
||||||
# Ports collection makefile for: hashish
|
|
||||||
# Date Created: May 7, 2002
|
|
||||||
# Whom: ijliao
|
|
||||||
#
|
|
||||||
# $FreeBSD$
|
|
||||||
#
|
|
||||||
|
|
||||||
PORTNAME= hashish
|
|
||||||
PORTVERSION= 1.1a
|
|
||||||
PORTREVISION= 7
|
|
||||||
CATEGORIES= security
|
|
||||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
|
||||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
|
||||||
DISTNAME= Hashish-${PORTVERSION}
|
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
|
||||||
COMMENT= GUI file and string hashing utility
|
|
||||||
|
|
||||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
|
|
||||||
|
|
||||||
USE_WX= 2.4
|
|
||||||
GNU_CONFIGURE= yes
|
|
||||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
|
||||||
LDFLAGS="-L${LOCALBASE}/lib"
|
|
||||||
USE_GMAKE= yes
|
|
||||||
PLIST_FILES= bin/hashish
|
|
||||||
|
|
||||||
BROKEN= does not compile
|
|
||||||
DEPRECATED= "${BROKEN}"
|
|
||||||
EXPIRATION_DATE= 2009-07-28
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
|
|
@ -1,3 +0,0 @@
|
||||||
MD5 (Hashish-1.1a.tar.gz) = a35ca32d919127f413f4c035e88b58b3
|
|
||||||
SHA256 (Hashish-1.1a.tar.gz) = 9771ae8eca93c15c21042212ef19191553c565abdc20c3dbe2f783e428dc6fcb
|
|
||||||
SIZE (Hashish-1.1a.tar.gz) = 73594
|
|
|
@ -1,14 +0,0 @@
|
||||||
--- src/main.cpp.orig Sun Dec 12 21:15:50 2004
|
|
||||||
+++ src/main.cpp Sun Dec 12 21:16:30 2004
|
|
||||||
@@ -398,9 +398,9 @@
|
|
||||||
hashFilter = new HashFilter(*hash, new Base64Encoder(new StringSink(outstring), false));
|
|
||||||
|
|
||||||
if ((m_rbox->GetSelection() == 0))
|
|
||||||
- FileSource file1(m_filename->GetValue().c_str(), true, new Redirector(*hashFilter, false));
|
|
||||||
+ FileSource file1(m_filename->GetValue().c_str(), true, new Redirector(*hashFilter));
|
|
||||||
else
|
|
||||||
- StringSource string1(m_string->GetValue().c_str(), true, new Redirector(*hashFilter, false));
|
|
||||||
+ StringSource string1(m_string->GetValue().c_str(), true, new Redirector(*hashFilter));
|
|
||||||
|
|
||||||
hashFilter->MessageEnd();
|
|
||||||
|
|
|
@ -1,8 +0,0 @@
|
||||||
Hashish is a file and string hashing utility that computes cryptograhpic
|
|
||||||
hashes. It is cross platform and includes a gui front end. Supports drag
|
|
||||||
and drop file hashing. Hex and Base64.
|
|
||||||
|
|
||||||
Hashing algorithms: MD5, SHA-1, SHA-2 (256/384/512), RIPEMD-160,
|
|
||||||
HAVAL (3/4/5), Tiger, CRC32, Panama.
|
|
||||||
|
|
||||||
WWW: http://hashish.sourceforge.net/
|
|
|
@ -1,36 +0,0 @@
|
||||||
# New ports collection makefile for: smtpmap
|
|
||||||
# Date created: 26 decembre 2002
|
|
||||||
# Whom: Hubert Tournier <hubert@frbsd.org>
|
|
||||||
#
|
|
||||||
# $FreeBSD$
|
|
||||||
#
|
|
||||||
|
|
||||||
PORTNAME= smtpmap
|
|
||||||
PORTVERSION= 0.8
|
|
||||||
PORTREVISION= 3
|
|
||||||
CATEGORIES= security mail net
|
|
||||||
MASTER_SITES= http://www.frbsd.org/dist/
|
|
||||||
|
|
||||||
MAINTAINER= hubert@frbsd.org
|
|
||||||
COMMENT= An SMTP software identifier
|
|
||||||
|
|
||||||
DEPRECATED= depends on GCC 2.95 which has not been available for 9+ months
|
|
||||||
IGNORE= ${DEPRECATED}
|
|
||||||
EXPIRATION_DATE=2009-07-19
|
|
||||||
|
|
||||||
MAKE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
|
|
||||||
USE_BZIP2= yes
|
|
||||||
USE_GMAKE= yes
|
|
||||||
MAKEFILE= makefile
|
|
||||||
|
|
||||||
post-patch:
|
|
||||||
@${REINPLACE_CMD} -e 's|-j 5||g' ${WRKSRC}/makefile
|
|
||||||
|
|
||||||
do-install:
|
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/src/smtpmap ${PREFIX}/bin
|
|
||||||
${INSTALL} -d ${DATADIR}
|
|
||||||
.for file in fingerprints-conf fingerprints-return fingerprints-rfc
|
|
||||||
${INSTALL_DATA} ${WRKSRC}/share/${file} ${DATADIR}
|
|
||||||
.endfor
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
|
|
@ -1,3 +0,0 @@
|
||||||
MD5 (smtpmap-0.8.tar.bz2) = d01a24967d55290a1564251cef8f8cb4
|
|
||||||
SHA256 (smtpmap-0.8.tar.bz2) = c99d570e88cf1f5819fd4a8370bf107083c2d1253edb30db80602275f9b3d0f6
|
|
||||||
SIZE (smtpmap-0.8.tar.bz2) = 55699
|
|
|
@ -1,12 +0,0 @@
|
||||||
--- include/small_socket.h.orig Tue Oct 29 19:16:01 2002
|
|
||||||
+++ include/small_socket.h Tue Jun 17 01:30:21 2003
|
|
||||||
@@ -8,8 +8,8 @@
|
|
||||||
#define __SMALL_SOCKET_H
|
|
||||||
|
|
||||||
extern "C" {
|
|
||||||
-#include <sys/socket.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
+#include <sys/socket.h>
|
|
||||||
#include <sys/time.h> // For NetBSD compatibility
|
|
||||||
#include <netinet/in.h>
|
|
||||||
#include <fcntl.h>
|
|
|
@ -1,20 +0,0 @@
|
||||||
--- include/types.h.orig Wed Dec 25 23:26:52 2002
|
|
||||||
+++ include/types.h Wed Dec 25 23:27:14 2002
|
|
||||||
@@ -13,7 +13,7 @@
|
|
||||||
#ifndef __TYPES_H
|
|
||||||
#define __TYPES_H
|
|
||||||
|
|
||||||
-#ifdef __linux__
|
|
||||||
+#ifdef __FreeBSD__
|
|
||||||
typedef bool BOOL;
|
|
||||||
typedef float double32;
|
|
||||||
typedef double double64;
|
|
||||||
@@ -29,7 +29,7 @@
|
|
||||||
|
|
||||||
typedef signed short sint16;
|
|
||||||
typedef unsigned short uint16;
|
|
||||||
-#endif // __linux__
|
|
||||||
+#endif // __FreeBSD__
|
|
||||||
|
|
||||||
#ifdef __sparc__
|
|
||||||
typedef bool BOOL;
|
|
|
@ -1,15 +0,0 @@
|
||||||
--- makefile.conf.orig Thu Oct 31 23:37:00 2002
|
|
||||||
+++ makefile.conf Tue Jun 17 01:20:41 2003
|
|
||||||
@@ -4,9 +4,6 @@
|
|
||||||
# Internal Configuration, do not touch
|
|
||||||
TMPDIR=.smtpmap-$(VERSION)
|
|
||||||
-CC=g++
|
|
||||||
-#CFLAGS=-O -Wall -pg -g -D_PREFIX=\"$(PREFIX)\"
|
|
||||||
-CFLAGS=-O -Wall -g3 -D_PREFIX=\"$(PREFIX)\"
|
|
||||||
-INC=-I ../include
|
|
||||||
-LIBS=
|
|
||||||
+CC=$(CXX)
|
|
||||||
+CFLAGS+=-D_PREFIX=\"$(PREFIX)\"
|
|
||||||
+INC+=-I../include -I/usr/include
|
|
||||||
DEPFLAG=-M $(INC)
|
|
||||||
-PREFIX=/usr
|
|
|
@ -1,16 +0,0 @@
|
||||||
--- src/makefile.orig Wed Aug 14 22:12:02 2002
|
|
||||||
+++ src/makefile Sun Oct 24 10:39:46 2004
|
|
||||||
@@ -5,11 +5,11 @@
|
|
||||||
include $(TOPDIR)/makefile.conf
|
|
||||||
|
|
||||||
all smtpmap-sub: small_socket.o mstring.o mfile.o scanner_smtp.o smtpmap.o fp_return.o fp_rfc.o fp.o fp_conf.o scanner_server.o
|
|
||||||
- $(CC) $(CFLAGS) $(INC) small_socket.o mstring.o mfile.o scanner_smtp.o fp_return.o fp_rfc.o fp.o fp_conf.o scanner_server.o smtpmap.o -o smtpmap
|
|
||||||
+ $(CC) $(CFLAGS) $(LDFLAGS) $(INC) small_socket.o mstring.o mfile.o scanner_smtp.o fp_return.o fp_rfc.o fp.o fp_conf.o scanner_server.o smtpmap.o -o smtpmap
|
|
||||||
|
|
||||||
|
|
||||||
%.o:%.cpp
|
|
||||||
- $(CC) $(CFLAGS) $(INC) -c $*.cpp
|
|
||||||
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(INC) -c $*.cpp
|
|
||||||
|
|
||||||
clean::
|
|
||||||
@echo Cleaning up
|
|
|
@ -1,12 +0,0 @@
|
||||||
Smtpmap is able to identify the running smtp software on a given host.
|
|
||||||
It shows the probability of the server version, and uses three
|
|
||||||
different fingerprinting technologies to maximize the probabilities.
|
|
||||||
It can also be used to look if there is any smtp service running on
|
|
||||||
the given port.
|
|
||||||
|
|
||||||
Smtpmap is a program from Dennis Lubert <plasmahh@gmx.net>.
|
|
||||||
|
|
||||||
WWW: http://web.archive.org/web/20050309080404/http://plasmahh.hopto.org/down_tool
|
|
||||||
|
|
||||||
- Hubert Tournier
|
|
||||||
hubert@frbsd.org
|
|
|
@ -1,5 +0,0 @@
|
||||||
bin/smtpmap
|
|
||||||
%%DATADIR%%/fingerprints-conf
|
|
||||||
%%DATADIR%%/fingerprints-return
|
|
||||||
%%DATADIR%%/fingerprints-rfc
|
|
||||||
@dirrm %%DATADIR%%
|
|
Loading…
Reference in a new issue