Initial import of grpn version 1.1.0.
A GTK+-based reverse polish notation (RPN) calculator. PR: 14526 Submitted by: Chris D. Faulhaber <jedgar@fxp.org>
This commit is contained in:
parent
2d09300ec5
commit
e5df249586
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=23410
6 changed files with 73 additions and 0 deletions
26
math/grpn/Makefile
Normal file
26
math/grpn/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# New ports collection makefile for: grpn
|
||||
# Version required: 1.1.0
|
||||
# Date created: 25 October 1999
|
||||
# Whom: Chris D. Faulhaber <jedgar@fxp.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= grpn-1.1.0
|
||||
CATEGORIES= math gnome
|
||||
MASTER_SITES= http://wilkins.ne.mediaone.net/grpn/
|
||||
|
||||
MAINTAINER= jedgar@fxp.org
|
||||
|
||||
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
|
||||
|
||||
ALL_TARGET=
|
||||
USE_X_PREFIX= yes
|
||||
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
|
||||
MAKE_ENV+= GTK_CONFIG=${GTK_CONFIG} \
|
||||
X11BASE=${X11BASE}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/grpn ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
math/grpn/distinfo
Normal file
1
math/grpn/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (grpn-1.1.0.tar.gz) = 64379257b174f5ad98dcc25c847b6e5d
|
32
math/grpn/files/patch-aa
Normal file
32
math/grpn/files/patch-aa
Normal file
|
@ -0,0 +1,32 @@
|
|||
--- Makefile.orig Mon May 31 21:46:31 1999
|
||||
+++ Makefile Mon Oct 25 19:52:03 1999
|
||||
@@ -3,7 +3,7 @@
|
||||
# Please read the next few lines and enter the correct values.
|
||||
|
||||
# What compiler should be used
|
||||
-CC = gcc
|
||||
+CC?= gcc
|
||||
|
||||
# Where to find the gtk-config script
|
||||
GTK_DIR =
|
||||
@@ -17,9 +17,9 @@
|
||||
# add -DUSE_GNOME if you want to make grpn GNOME compliant.
|
||||
|
||||
|
||||
-CFLAGS = -g -O2 -I/usr/X11/include `$(GTK_DIR)gtk-config --cflags` -DGTK_VER_1_1
|
||||
+CFLAGS+= -I${X11BASE}/include -I${PREFIX}/include `${GTK_CONFIG} --cflags` -DGTK_VER_1_1
|
||||
|
||||
-DFLAGS = -L/usr/X11/lib
|
||||
+DFLAGS = -L${X11BASE}/lib -L${PREFIX}/lib
|
||||
|
||||
# end of user configurable section
|
||||
|
||||
@@ -34,7 +34,7 @@
|
||||
|
||||
|
||||
|
||||
-LIBS = `$(GTK_DIR)gtk-config --libs` -lX11 -lm
|
||||
+LIBS = `${GTK_CONFIG} --libs` -lX11 -lm
|
||||
|
||||
|
||||
grpn: $(OBJS)
|
1
math/grpn/pkg-comment
Normal file
1
math/grpn/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
GTK+-based reverse polish notation (RPN) calculator
|
12
math/grpn/pkg-descr
Normal file
12
math/grpn/pkg-descr
Normal file
|
@ -0,0 +1,12 @@
|
|||
GRPN is a RPN calculator for the X Window system built using
|
||||
the GIMP Toolkit (GTK).
|
||||
|
||||
GRPN works with real numbers, complex numbers, matrices, and
|
||||
complex matrices. Numbers can be displayed in 4 different
|
||||
radix modes, and complex numbers can be displayed in either
|
||||
Cartesian or polar form.
|
||||
|
||||
WWW: http://wilkins.ne.mediaone.net/grpn.html
|
||||
|
||||
- Chris D. Faulhaber
|
||||
jedgar@fxp.org
|
1
math/grpn/pkg-plist
Normal file
1
math/grpn/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/grpn
|
Loading…
Reference in a new issue