Update audio/musescore to 3.0.0, the latest release

This skips over 18 months of musescore development to get to
what's new. This version uses WebEngine, although I don't know
what it uses it for; a PORTREVISION should be able to clear that
up and make it available for aarch64 and ppc64.

All the local patches have been dropped, except for some extra
CMake-futzing in order to get it to build with ninja and not
duplicate whole chunks of WebEngine.

PR:		234801
Reported by:	kunda
This commit is contained in:
Adriaan de Groot 2019-01-10 20:30:47 +00:00
parent 624a5cad8c
commit e61398a09f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=489895
9 changed files with 184 additions and 182 deletions

View file

@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= musescore
PORTVERSION= 2.1
PORTREVISION= 4
DISTVERSION= 3.0.0
CATEGORIES= audio
MASTER_SITES= http://ftp.osuosl.org/pub/musescore/releases/MuseScore-${PORTVERSION}/
DISTNAME= MuseScore-${PORTVERSION}
MASTER_SITES= http://ftp.osuosl.org/pub/musescore/releases/MuseScore-${DISTVERSION}/
DISTNAME= MuseScore-${DISTVERSION}
NO_WRKSUBDIR= yes
MAINTAINER= adridg@FreeBSD.org
COMMENT= Free music composition & notation software
@ -14,7 +14,8 @@ COMMENT= Free music composition & notation software
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.GPL
BROKEN_aarch64= Fails to compile: error: constant expression evaluates to -1
# Because of webengine
ONLY_FOR_ARCHS= i386 amd64
LIB_DEPENDS= libmp3lame.so:audio/lame \
libsndfile.so:audio/libsndfile \
@ -25,14 +26,14 @@ LIB_DEPENDS= libmp3lame.so:audio/lame \
USES= cmake compiler:c++11-lib desktop-file-utils \
pkgconfig qt:5 shared-mime-info zip
USE_QT= core declarative gui widgets opengl concurrent designer help network \
scripttools svg sql printsupport testlib webkit \
scripttools svg sql printsupport testlib webengine \
xml xmlpatterns \
buildtools_build linguisttools_build qmake_build uitools_build
ALL_TARGET= lrelease manpages all
INSTALLS_ICONS= yes
CMAKE_ARGS+= -DUSE_SYSTEM_FREETYPE="ON"
CMAKE_ARGS+= -DUSE_SYSTEM_FREETYPE="ON" -DBUILD_PORTMIDI=OFF
DATADIR= ${PREFIX}/share/mscore-${PORTVERSION}
DATADIR= ${PREFIX}/share/mscore-${PORTVERSION:R}
OPTIONS_DEFINE= ALSA JACK PORTAUDIO PULSEAUDIO OCR
OPTIONS_DEFAULT= PORTAUDIO

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1502602140
SHA256 (MuseScore-2.1.zip) = 51b2fd09d8d0afff84ce6aee0e14854465462616b0ef92ad8dd2325257d3bc12
SIZE (MuseScore-2.1.zip) = 55072555
TIMESTAMP = 1547127510
SHA256 (MuseScore-3.0.0.zip) = 8a764a1f8911502cb9887c84cde4a8dda193a766337b8e477e89185cbf3722c6
SIZE (MuseScore-3.0.0.zip) = 116183004

View file

@ -0,0 +1,18 @@
The custom precompiled-headers handling causes dependency
loops in Ninja. I don't see much value in the PCH here, so
just zero them out. (Neither do I understand how ninja ends
up with the dependency loop; make handles this without complaint)
--- CMakeLists.txt.orig 2018-12-24 13:27:49 UTC
+++ CMakeLists.txt
@@ -727,8 +727,8 @@ precompiled_header(QT_INCLUDES all ${BUILD_PCH})
# MSVC does not require these targets, as all.h is not copied and the
# PCH generation is done per-project
if (NOT MSVC)
- ADD_CUSTOM_TARGET(mops1 DEPENDS ${PROJECT_BINARY_DIR}/all.h)
- ADD_CUSTOM_TARGET(mops2 DEPENDS ${PCH})
+ ADD_CUSTOM_TARGET(mops1 DEPENDS ) # ${PROJECT_BINARY_DIR}/all.h)
+ ADD_CUSTOM_TARGET(mops2 DEPENDS ) # ${PCH})
endif (NOT MSVC)
##

View file

@ -1,22 +0,0 @@
From 9c8a8ffe0cbb00ee93a10fe245da01a4d32ca086 Mon Sep 17 00:00:00 2001
From: Orcan Ogetbil <orcan@localhost.localdomain>
Date: Thu, 31 May 2018 21:04:51 -0400
Subject: [PATCH] added missing #include <QButtonGroup> required by qt >= 5.11
---
all.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/all.h b/all.h
index 72db72b0ec..2ee0e8e807 100644
--- all.h
+++ all.h
@@ -131,6 +131,7 @@
#include <QProgressBar>
#include <QProgressDialog>
#include <QRadioButton>
+#include <QButtonGroup>
#include <QSplashScreen>
#include <QFontComboBox>
#include <QApplication>

View file

@ -1,20 +0,0 @@
--- mscore/CMakeLists.txt.orig 2017-04-27 04:14:22 UTC
+++ mscore/CMakeLists.txt
@@ -493,7 +493,6 @@ else (MINGW)
${ALSA_LIB}
${QT_LIBRARIES}
z
- dl
pthread
)
@@ -550,9 +549,6 @@ else (MINGW)
# gold does not use indirect shared libraries for symbol resolution, Linux only
if (NOT APPLE)
- if (USE_JACK)
- target_link_libraries(mscore dl)
- endif (USE_JACK)
target_link_libraries(mscore rt)
endif (NOT APPLE)

View file

@ -1,22 +0,0 @@
--- mscore/editstringdata.cpp.orig 2018-12-11 15:55:46 UTC
+++ mscore/editstringdata.cpp
@@ -52,7 +52,8 @@ EditStringData::EditStringData(QWidget *parent, QList<
strg = (*_strings)[numOfStrings - i - 1];
_stringsLoc.append(strg);
QTableWidgetItem *newCheck = new QTableWidgetItem();
- newCheck->setFlags(Qt::ItemFlag(Qt::ItemIsUserCheckable | Qt::ItemIsEnabled));
+ Qt::ItemFlags flags(Qt::ItemIsUserCheckable | Qt::ItemIsEnabled);
+ newCheck->setFlags(flags);
newCheck->setCheckState(strg.open ? Qt::Checked : Qt::Unchecked);
stringList->setItem(i, 0, newCheck);
QTableWidgetItem *newPitch = new QTableWidgetItem(midiCodeToStr(strg.pitch));
@@ -168,7 +169,8 @@ void EditStringData::newStringClicked()
_stringsLoc.insert(i, strg);
stringList->insertRow(i);
QTableWidgetItem *newCheck = new QTableWidgetItem();
- newCheck->setFlags(Qt::ItemFlag(Qt::ItemIsUserCheckable | Qt::ItemIsEnabled));
+ Qt::ItemFlags flags(Qt::ItemIsUserCheckable | Qt::ItemIsEnabled);
+ newCheck->setFlags(flags);
newCheck->setCheckState(strg.open ? Qt::Checked : Qt::Unchecked);
stringList->setItem(i, 0, newCheck);
QTableWidgetItem *newPitch = new QTableWidgetItem(midiCodeToStr(strg.pitch));

View file

@ -1,11 +0,0 @@
--- mscore/prefsdialog.ui.orig 2018-12-11 15:47:09 UTC
+++ mscore/prefsdialog.ui
@@ -4058,7 +4058,7 @@
</item>
</layout>
</widget>
- <pixmapfunction>getPixmap</pixmapfunction>
+ <pixmapfunction></pixmapfunction>
<customwidgets>
<customwidget>
<class>Awl::ColorLabel</class>

View file

@ -1,12 +0,0 @@
--- thirdparty/qzip/qzip.cpp.orig 2015-07-16 21:02:34 UTC
+++ thirdparty/qzip/qzip.cpp
@@ -45,6 +45,9 @@
#include "qzipreader_p.h"
#include "qzipwriter_p.h"
+#include <sys/types.h>
+#include <sys/stat.h>
+
#include <zlib.h>
#if defined(Q_OS_WIN) or defined(Q_OS_ANDROID)

View file

@ -2,6 +2,7 @@ bin/mscore
bin/musescore
man/man1/mscore.1.gz
man/man1/musescore.1.gz
share/appdata/mscore.appdata.xml
share/applications/mscore.desktop
share/icons/hicolor/128x128/apps/mscore.png
share/icons/hicolor/16x16/apps/mscore.png
@ -21,10 +22,23 @@ share/icons/hicolor/scalable/mimetypes/application-vnd.recordare.musicxml.svg
share/icons/hicolor/scalable/mimetypes/application-x-musescore+xml.svg
share/icons/hicolor/scalable/mimetypes/application-x-musescore.svg
share/mime/packages/musescore.xml
%%DATADIR%%/demos/All_Dudes.mscz
%%DATADIR%%/demos/Fugue_1.mscx
%%DATADIR%%/demos/Reunion.mscz
%%DATADIR%%/demos/Triumph.mscz
%%DATADIR%%/demos/Unclaimed_Gift.mscx
%%DATADIR%%/instruments/instruments.xml
%%DATADIR%%/locale/qt_bg.qm
%%DATADIR%%/locale/qt_el.qm
%%DATADIR%%/locale/qt_eu.qm
%%DATADIR%%/locale/qt_gd.qm
%%DATADIR%%/locale/qt_id.qm
%%DATADIR%%/locale/qt_lv.qm
%%DATADIR%%/locale/qt_nb.qm
%%DATADIR%%/locale/qt_nl.qm
%%DATADIR%%/locale/qt_nl_BE.qm
%%DATADIR%%/locale/qt_pt_BR.qm
%%DATADIR%%/locale/qt_ro.qm
%%DATADIR%%/locale/qt_tr.qm
%%DATADIR%%/locale/qt_vi.qm
%%DATADIR%%/locale/instruments_af.qm
%%DATADIR%%/locale/instruments_ar.qm
%%DATADIR%%/locale/instruments_ar_DZ.qm
@ -57,10 +71,13 @@ share/mime/packages/musescore.xml
%%DATADIR%%/locale/instruments_hi_IN.qm
%%DATADIR%%/locale/instruments_hr.qm
%%DATADIR%%/locale/instruments_hu.qm
%%DATADIR%%/locale/instruments_hy.qm
%%DATADIR%%/locale/instruments_id.qm
%%DATADIR%%/locale/instruments_ig.qm
%%DATADIR%%/locale/instruments_it.qm
%%DATADIR%%/locale/instruments_ja.qm
%%DATADIR%%/locale/instruments_ka.qm
%%DATADIR%%/locale/instruments_kab.qm
%%DATADIR%%/locale/instruments_ko.qm
%%DATADIR%%/locale/instruments_lt.qm
%%DATADIR%%/locale/instruments_lv.qm
@ -119,10 +136,13 @@ share/mime/packages/musescore.xml
%%DATADIR%%/locale/mscore_hi_IN.qm
%%DATADIR%%/locale/mscore_hr.qm
%%DATADIR%%/locale/mscore_hu.qm
%%DATADIR%%/locale/mscore_hy.qm
%%DATADIR%%/locale/mscore_id.qm
%%DATADIR%%/locale/mscore_ig.qm
%%DATADIR%%/locale/mscore_it.qm
%%DATADIR%%/locale/mscore_ja.qm
%%DATADIR%%/locale/mscore_ka.qm
%%DATADIR%%/locale/mscore_kab.qm
%%DATADIR%%/locale/mscore_ko.qm
%%DATADIR%%/locale/mscore_lt.qm
%%DATADIR%%/locale/mscore_lv.qm
@ -148,40 +168,70 @@ share/mime/packages/musescore.xml
%%DATADIR%%/locale/mscore_vi.qm
%%DATADIR%%/locale/mscore_zh_CN.qm
%%DATADIR%%/locale/mscore_zh_TW.qm
%%DATADIR%%/locale/qt_ar.qm
%%DATADIR%%/locale/qt_ca.qm
%%DATADIR%%/locale/qt_cs.qm
%%DATADIR%%/locale/qt_da.qm
%%DATADIR%%/locale/qt_de.qm
%%DATADIR%%/locale/qt_el.qm
%%DATADIR%%/locale/qt_es.qm
%%DATADIR%%/locale/qt_eu.qm
%%DATADIR%%/locale/qt_fa.qm
%%DATADIR%%/locale/qt_fi.qm
%%DATADIR%%/locale/qt_fr.qm
%%DATADIR%%/locale/qt_gl.qm
%%DATADIR%%/locale/qt_he.qm
%%DATADIR%%/locale/qt_hu.qm
%%DATADIR%%/locale/qt_id.qm
%%DATADIR%%/locale/qt_it.qm
%%DATADIR%%/locale/qt_ja.qm
%%DATADIR%%/locale/qt_ko.qm
%%DATADIR%%/locale/qt_lt.qm
%%DATADIR%%/locale/qt_nb.qm
%%DATADIR%%/locale/qt_nl.qm
%%DATADIR%%/locale/qt_nl_BE.qm
%%DATADIR%%/locale/qt_pl.qm
%%DATADIR%%/locale/qt_pt.qm
%%DATADIR%%/locale/qt_pt_BR.qm
%%DATADIR%%/locale/qt_ro.qm
%%DATADIR%%/locale/qt_ru.qm
%%DATADIR%%/locale/qt_sk.qm
%%DATADIR%%/locale/qt_sv.qm
%%DATADIR%%/locale/qt_tr.qm
%%DATADIR%%/locale/qt_uk.qm
%%DATADIR%%/locale/qt_vi.qm
%%DATADIR%%/locale/qt_zh_CN.qm
%%DATADIR%%/locale/qt_zh_TW.qm
%%DATADIR%%/locale/tours_af.qm
%%DATADIR%%/locale/tours_ar.qm
%%DATADIR%%/locale/tours_ar_DZ.qm
%%DATADIR%%/locale/tours_ar_EG.qm
%%DATADIR%%/locale/tours_ar_SD.qm
%%DATADIR%%/locale/tours_ast.qm
%%DATADIR%%/locale/tours_be.qm
%%DATADIR%%/locale/tours_bg.qm
%%DATADIR%%/locale/tours_ca.qm
%%DATADIR%%/locale/tours_ca@valencia.qm
%%DATADIR%%/locale/tours_cs.qm
%%DATADIR%%/locale/tours_cy.qm
%%DATADIR%%/locale/tours_da.qm
%%DATADIR%%/locale/tours_de.qm
%%DATADIR%%/locale/tours_el.qm
%%DATADIR%%/locale/tours_en.qm
%%DATADIR%%/locale/tours_en_GB.qm
%%DATADIR%%/locale/tours_en_US.qm
%%DATADIR%%/locale/tours_eo.qm
%%DATADIR%%/locale/tours_es.qm
%%DATADIR%%/locale/tours_et.qm
%%DATADIR%%/locale/tours_eu.qm
%%DATADIR%%/locale/tours_fa.qm
%%DATADIR%%/locale/tours_fi.qm
%%DATADIR%%/locale/tours_fo.qm
%%DATADIR%%/locale/tours_ga.qm
%%DATADIR%%/locale/tours_gd.qm
%%DATADIR%%/locale/tours_gl.qm
%%DATADIR%%/locale/tours_he.qm
%%DATADIR%%/locale/tours_hi_IN.qm
%%DATADIR%%/locale/tours_hr.qm
%%DATADIR%%/locale/tours_hu.qm
%%DATADIR%%/locale/tours_hy.qm
%%DATADIR%%/locale/tours_id.qm
%%DATADIR%%/locale/tours_ig.qm
%%DATADIR%%/locale/tours_it.qm
%%DATADIR%%/locale/tours_ja.qm
%%DATADIR%%/locale/tours_ka.qm
%%DATADIR%%/locale/tours_kab.qm
%%DATADIR%%/locale/tours_ko.qm
%%DATADIR%%/locale/tours_lt.qm
%%DATADIR%%/locale/tours_lv.qm
%%DATADIR%%/locale/tours_ml.qm
%%DATADIR%%/locale/tours_mn_MN.qm
%%DATADIR%%/locale/tours_nb.qm
%%DATADIR%%/locale/tours_nl.qm
%%DATADIR%%/locale/tours_nn.qm
%%DATADIR%%/locale/tours_pl.qm
%%DATADIR%%/locale/tours_pt.qm
%%DATADIR%%/locale/tours_pt_BR.qm
%%DATADIR%%/locale/tours_ro.qm
%%DATADIR%%/locale/tours_ru.qm
%%DATADIR%%/locale/tours_sk.qm
%%DATADIR%%/locale/tours_sl.qm
%%DATADIR%%/locale/tours_sr.qm
%%DATADIR%%/locale/tours_sr_RS.qm
%%DATADIR%%/locale/tours_sv.qm
%%DATADIR%%/locale/tours_th.qm
%%DATADIR%%/locale/tours_tr.qm
%%DATADIR%%/locale/tours_uk.qm
%%DATADIR%%/locale/tours_uz@Latn.qm
%%DATADIR%%/locale/tours_vi.qm
%%DATADIR%%/locale/tours_zh_CN.qm
%%DATADIR%%/locale/tours_zh_TW.qm
%%DATADIR%%/manual/plugins/accidental.html
%%DATADIR%%/manual/plugins/ambitus.html
%%DATADIR%%/manual/plugins/arpeggio.html
@ -198,6 +248,9 @@ share/mime/packages/musescore.xml
%%DATADIR%%/manual/plugins/chordrest.html
%%DATADIR%%/manual/plugins/clef.html
%%DATADIR%%/manual/plugins/compound.html
%%DATADIR%%/manual/plugins/connectorinfo.html
%%DATADIR%%/manual/plugins/connectorinforeader.html
%%DATADIR%%/manual/plugins/connectorinfowriter.html
%%DATADIR%%/manual/plugins/cursor.html
%%DATADIR%%/manual/plugins/durationelement.html
%%DATADIR%%/manual/plugins/dynamic.html
@ -210,7 +263,6 @@ share/mime/packages/musescore.xml
%%DATADIR%%/manual/plugins/fingering.html
%%DATADIR%%/manual/plugins/fretdiagram.html
%%DATADIR%%/manual/plugins/fsymbol.html
%%DATADIR%%/manual/plugins/glissando.html
%%DATADIR%%/manual/plugins/glissandosegment.html
%%DATADIR%%/manual/plugins/groups.html
%%DATADIR%%/manual/plugins/hairpin.html
@ -224,15 +276,14 @@ share/mime/packages/musescore.xml
%%DATADIR%%/manual/plugins/keysig.html
%%DATADIR%%/manual/plugins/layoutbreak.html
%%DATADIR%%/manual/plugins/ledgerline.html
%%DATADIR%%/manual/plugins/line.html
%%DATADIR%%/manual/plugins/letring.html
%%DATADIR%%/manual/plugins/letringsegment.html
%%DATADIR%%/manual/plugins/linesegment.html
%%DATADIR%%/manual/plugins/lyrics.html
%%DATADIR%%/manual/plugins/manual.css
%%DATADIR%%/manual/plugins/marker.html
%%DATADIR%%/manual/plugins/measure.html
%%DATADIR%%/manual/plugins/measurebase.html
%%DATADIR%%/manual/plugins/mscore.png
%%DATADIR%%/manual/plugins/mtext.html
%%DATADIR%%/manual/plugins/musescore.html
%%DATADIR%%/manual/plugins/note.html
%%DATADIR%%/manual/plugins/notedot.html
@ -243,6 +294,8 @@ share/mime/packages/musescore.xml
%%DATADIR%%/manual/plugins/ottavasegment.html
%%DATADIR%%/manual/plugins/page.html
%%DATADIR%%/manual/plugins/pageformat.html
%%DATADIR%%/manual/plugins/palmmute.html
%%DATADIR%%/manual/plugins/palmmutesegment.html
%%DATADIR%%/manual/plugins/part.html
%%DATADIR%%/manual/plugins/pedal.html
%%DATADIR%%/manual/plugins/pedalsegment.html
@ -263,17 +316,19 @@ share/mime/packages/musescore.xml
%%DATADIR%%/manual/plugins/spannersegment.html
%%DATADIR%%/manual/plugins/stafflines.html
%%DATADIR%%/manual/plugins/staffstate.html
%%DATADIR%%/manual/plugins/stafftext.html
%%DATADIR%%/manual/plugins/stafftypechange.html
%%DATADIR%%/manual/plugins/stem.html
%%DATADIR%%/manual/plugins/stemslash.html
%%DATADIR%%/manual/plugins/svggenerator.html
%%DATADIR%%/manual/plugins/symbol.html
%%DATADIR%%/manual/plugins/system.html
%%DATADIR%%/manual/plugins/tbox.html
%%DATADIR%%/manual/plugins/tempotext.html
%%DATADIR%%/manual/plugins/textline.html
%%DATADIR%%/manual/plugins/textlinebase.html
%%DATADIR%%/manual/plugins/textlinebasesegment.html
%%DATADIR%%/manual/plugins/textlinesegment.html
%%DATADIR%%/manual/plugins/tie.html
%%DATADIR%%/manual/plugins/tiesegment.html
%%DATADIR%%/manual/plugins/timesig.html
%%DATADIR%%/manual/plugins/tremolo.html
%%DATADIR%%/manual/plugins/tremolobar.html
@ -281,6 +336,7 @@ share/mime/packages/musescore.xml
%%DATADIR%%/manual/plugins/trillsegment.html
%%DATADIR%%/manual/plugins/tuplet.html
%%DATADIR%%/manual/plugins/vbox.html
%%DATADIR%%/manual/plugins/vibratosegment.html
%%DATADIR%%/manual/plugins/volta.html
%%DATADIR%%/manual/plugins/voltasegment.html
%%DATADIR%%/plugins/abc_import.qml
@ -297,8 +353,8 @@ share/mime/packages/musescore.xml
%%DATADIR%%/plugins/scorelist.qml
%%DATADIR%%/plugins/view.qml
%%DATADIR%%/plugins/walk.qml
%%DATADIR%%/sound/FluidR3Mono_GM.sf3
%%DATADIR%%/sound/FluidR3Mono_License.md
%%DATADIR%%/sound/MuseScore_General-License.md
%%DATADIR%%/sound/MuseScore_General.sf3
%%DATADIR%%/styles/MuseJazz.mss
%%DATADIR%%/styles/cchords_muse.xml
%%DATADIR%%/styles/cchords_nrb.xml
@ -309,50 +365,64 @@ share/mime/packages/musescore.xml
%%DATADIR%%/styles/chords_std.xml
%%DATADIR%%/styles/jazzchords.xml
%%DATADIR%%/styles/stdchords.xml
%%DATADIR%%/templates/01-General/00-Blank.mscz
%%DATADIR%%/templates/01-General/01-Treble_Clef.mscz
%%DATADIR%%/templates/01-General/02-Bass_Clef.mscz
%%DATADIR%%/templates/01-General/03-Grand_Staff.mscz
%%DATADIR%%/templates/02-Choral/01-SATB.mscz
%%DATADIR%%/templates/02-Choral/02-SATB_+_Organ.mscz
%%DATADIR%%/templates/02-Choral/03-SATB_+_Piano.mscz
%%DATADIR%%/templates/02-Choral/04-SATB_Closed_Score.mscz
%%DATADIR%%/templates/02-Choral/05-SATB_Closed_Score_+_Organ.mscz
%%DATADIR%%/templates/02-Choral/06-SATB_Closed_Score_+_Piano.mscz
%%DATADIR%%/templates/02-Choral/07-Voice_+_Piano.mscz
%%DATADIR%%/templates/02-Choral/08-Barbershop_Quartet.mscz
%%DATADIR%%/templates/02-Choral/09-Liturgical_Unmetrical.mscz
%%DATADIR%%/templates/02-Choral/10-Liturgical_Unmetrical_+_Organ.mscz
%%DATADIR%%/templates/03-Chamber_Music/01-String_Quartet.mscz
%%DATADIR%%/templates/03-Chamber_Music/02-Wind_Quartet.mscz
%%DATADIR%%/templates/03-Chamber_Music/03-Wind_Quintet.mscz
%%DATADIR%%/templates/03-Chamber_Music/04-Saxophone_Quartet.mscz
%%DATADIR%%/templates/03-Chamber_Music/05-Brass_Quartet.mscz
%%DATADIR%%/templates/03-Chamber_Music/06-Brass_Quintet.mscz
%%DATADIR%%/templates/04-Solo/01-Guitar.mscz
%%DATADIR%%/templates/04-Solo/02-Guitar_+_Tablature.mscz
%%DATADIR%%/templates/04-Solo/03-Guitar_Tablature.mscz
%%DATADIR%%/templates/04-Solo/04-Piano.mscz
%%DATADIR%%/templates/05-Jazz/01-Jazz_Lead_Sheet.mscz
%%DATADIR%%/templates/05-Jazz/02-Big_Band.mscz
%%DATADIR%%/templates/05-Jazz/03-Jazz_Combo.mscz
%%DATADIR%%/templates/06-Popular/01-Rock_Band.mscz
%%DATADIR%%/templates/06-Popular/02-Bluegrass_Band.mscz
%%DATADIR%%/templates/07-Band_and_Percussion/01-Concert_Band.mscz
%%DATADIR%%/templates/07-Band_and_Percussion/02-Small_Concert_Band.mscz
%%DATADIR%%/templates/07-Band_and_Percussion/03-Brass_Band.mscz
%%DATADIR%%/templates/07-Band_and_Percussion/04-Marching_Band.mscz
%%DATADIR%%/templates/07-Band_and_Percussion/05-Small_Marching_Band.mscz
%%DATADIR%%/templates/07-Band_and_Percussion/06-Battery_Percussion.mscz
%%DATADIR%%/templates/07-Band_and_Percussion/07-Large_Pit_Percussion.mscz
%%DATADIR%%/templates/07-Band_and_Percussion/08-Small_Pit_Percussion.mscz
%%DATADIR%%/templates/08-Orchestral/01-Classical_Orchestra.mscz
%%DATADIR%%/templates/08-Orchestral/02-Concert_Orchestra.mscz
%%DATADIR%%/templates/08-Orchestral/03-String_Orchestra.mscz
%%DATADIR%%/templates/01-General/00-Blank.mscx
%%DATADIR%%/templates/01-General/01-Treble_Clef.mscx
%%DATADIR%%/templates/01-General/02-Bass_Clef.mscx
%%DATADIR%%/templates/01-General/03-Grand_Staff.mscx
%%DATADIR%%/templates/02-Choral/01-SATB.mscx
%%DATADIR%%/templates/02-Choral/02-SATB_+_Organ.mscx
%%DATADIR%%/templates/02-Choral/03-SATB_+_Piano.mscx
%%DATADIR%%/templates/02-Choral/04-SATB_Closed_Score.mscx
%%DATADIR%%/templates/02-Choral/05-SATB_Closed_Score_+_Organ.mscx
%%DATADIR%%/templates/02-Choral/06-SATB_Closed_Score_+_Piano.mscx
%%DATADIR%%/templates/02-Choral/07-Voice_+_Piano.mscx
%%DATADIR%%/templates/02-Choral/08-Barbershop_Quartet.mscx
%%DATADIR%%/templates/02-Choral/09-Liturgical_Unmetrical.mscx
%%DATADIR%%/templates/02-Choral/10-Liturgical_Unmetrical_+_Organ.mscx
%%DATADIR%%/templates/03-Chamber_Music/01-String_Quartet.mscx
%%DATADIR%%/templates/03-Chamber_Music/02-Wind_Quartet.mscx
%%DATADIR%%/templates/03-Chamber_Music/03-Wind_Quintet.mscx
%%DATADIR%%/templates/03-Chamber_Music/04-Saxophone_Quartet.mscx
%%DATADIR%%/templates/03-Chamber_Music/05-Brass_Quartet.mscx
%%DATADIR%%/templates/03-Chamber_Music/06-Brass_Quintet.mscx
%%DATADIR%%/templates/04-Solo/01-Guitar.mscx
%%DATADIR%%/templates/04-Solo/02-Guitar_+_Tablature.mscx
%%DATADIR%%/templates/04-Solo/03-Guitar_Tablature.mscx
%%DATADIR%%/templates/04-Solo/04-Piano.mscx
%%DATADIR%%/templates/05-Jazz/01-Jazz_Lead_Sheet.mscx
%%DATADIR%%/templates/05-Jazz/02-Big_Band.mscx
%%DATADIR%%/templates/05-Jazz/03-Jazz_Combo.mscx
%%DATADIR%%/templates/06-Popular/01-Rock_Band.mscx
%%DATADIR%%/templates/06-Popular/02-Bluegrass_Band.mscx
%%DATADIR%%/templates/07-Band_and_Percussion/01-Concert_Band.mscx
%%DATADIR%%/templates/07-Band_and_Percussion/02-Small_Concert_Band.mscx
%%DATADIR%%/templates/07-Band_and_Percussion/03-Brass_Band.mscx
%%DATADIR%%/templates/07-Band_and_Percussion/04-Marching_Band.mscx
%%DATADIR%%/templates/07-Band_and_Percussion/05-Small_Marching_Band.mscx
%%DATADIR%%/templates/07-Band_and_Percussion/06-Battery_Percussion.mscx
%%DATADIR%%/templates/07-Band_and_Percussion/07-Large_Pit_Percussion.mscx
%%DATADIR%%/templates/07-Band_and_Percussion/08-Small_Pit_Percussion.mscx
%%DATADIR%%/templates/08-Orchestral/01-Classical_Orchestra.mscx
%%DATADIR%%/templates/08-Orchestral/02-Symphony_Orchestra.mscx
%%DATADIR%%/templates/08-Orchestral/03-String_Orchestra.mscx
%%DATADIR%%/templates/drumset_fr.drm
%%DATADIR%%/templates/orchestral.drm
%%DATADIR%%/tours/autoplace.tour
%%DATADIR%%/tours/inspector.tour
%%DATADIR%%/tours/mmrest.tour
%%DATADIR%%/tours/navigate.tour
%%DATADIR%%/tours/noteinput.tour
%%DATADIR%%/tours/palette.tour
%%DATADIR%%/tours/select.tour
%%DATADIR%%/tours/timeline.tour
%%DATADIR%%/tours/welcome.tour
%%DATADIR%%/wallpaper/background1.png
%%DATADIR%%/wallpaper/paper1.png
%%DATADIR%%/wallpaper/paper2.png
%%DATADIR%%/wallpaper/paper3.png
%%DATADIR%%/wallpaper/paper4.png
%%DATADIR%%/wallpaper/paper5.png
%%DATADIR%%/wallpaper/paper6.png
%%DATADIR%%/wallpaper/paper7.png
%%DATADIR%%/workspaces/Advanced.workspace
%%DATADIR%%/workspaces/Basic.workspace