- Update to 0.7.1.
Approved by: tabthorpe (mentor)
This commit is contained in:
parent
a1f556ae41
commit
e627262944
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=265876
8 changed files with 35 additions and 421 deletions
|
@ -5,7 +5,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= speech-dispatcher
|
||||
PORTVERSION= 0.7
|
||||
PORTVERSION= 0.7.1
|
||||
CATEGORIES= accessibility audio
|
||||
MASTER_SITES= http://www.freebsoft.org/pub/projects/speechd/
|
||||
|
||||
|
@ -36,7 +36,7 @@ CONFFILES= clients/emacs.conf clients/gnome-speech.conf \
|
|||
|
||||
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
|
||||
|
||||
INFO= spd-say ${PORTNAME}-cs ${PORTNAME} ssip
|
||||
INFO= spd-say ${PORTNAME} ssip
|
||||
|
||||
OPTIONS= ALSA "ALSA support" off \
|
||||
ESPEAK "eSpeak output module" on \
|
||||
|
@ -95,9 +95,11 @@ CONFIGURE_ARGS+= --without-nas
|
|||
.endif
|
||||
|
||||
.ifdef(WITH_PYTHON)
|
||||
USE_PYTHON= yes
|
||||
USE_PYTHON= 2.4+
|
||||
CONFIGURE_ARGS+= --enable-python
|
||||
PLIST_SUB+= PYTHON=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-python
|
||||
PLIST_SUB+= PYTHON="@comment "
|
||||
.endif
|
||||
|
||||
|
@ -112,22 +114,9 @@ CONFIGURE_ARGS+= --without-pulse
|
|||
PLIST_SUB+= GNOMEHIER=""
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 800067
|
||||
.if ${ARCH} == "amd64"
|
||||
.if ${OSVERSION} < 800067 && ${ARCH} == "amd64"
|
||||
CFLAGS+= -fPIC
|
||||
.endif
|
||||
EXTRA_PATCHES= ${FILESDIR}/extrapatch-*
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
.if ${OSVERSION} < 800067
|
||||
${CP} ${FILESDIR}/getline.h ${WRKSRC}/src
|
||||
.if ${OSVERSION} < 701101
|
||||
${CP} ${FILESDIR}/getline_strndup.c ${WRKSRC}/src/freebsd.c
|
||||
.else
|
||||
${CP} ${FILESDIR}/getline.c ${WRKSRC}/src/freebsd.c
|
||||
.endif
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/g' \
|
||||
|
@ -139,10 +128,6 @@ post-patch:
|
|||
${WRKSRC}/src/c/clients/spdsend/Makefile.in \
|
||||
${WRKSRC}/src/modules/Makefile.in \
|
||||
${WRKSRC}/src/server/Makefile.in
|
||||
.ifndef(WITH_PYTHON)
|
||||
${REINPLACE_CMD} -e 's/python[^ ]*//g' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.for f in ${CONFFILES}
|
||||
|
|
|
@ -1,3 +1,2 @@
|
|||
MD5 (speech-dispatcher-0.7.tar.gz) = 8e0d833c680c8217cc40d88c68c5265f
|
||||
SHA256 (speech-dispatcher-0.7.tar.gz) = b7976b4c325b792156cc60c21442cced03f6d0e89dec6b3b78148eab52e42ae6
|
||||
SIZE (speech-dispatcher-0.7.tar.gz) = 1115738
|
||||
SHA256 (speech-dispatcher-0.7.1.tar.gz) = a8a9cf299447df4645d36c649977e007a3050ccaecb7f77e2165001ec5794a51
|
||||
SIZE (speech-dispatcher-0.7.1.tar.gz) = 1144818
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/c/api/Makefile.in.orig 2010-01-15 19:51:09.284466853 +0100
|
||||
+++ src/c/api/Makefile.in 2010-01-15 19:51:42.602485219 +0100
|
||||
@@ -54,7 +54,7 @@
|
||||
libLTLIBRARIES_INSTALL = $(INSTALL)
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
libspeechd_la_DEPENDENCIES =
|
||||
-am_libspeechd_la_OBJECTS = libspeechd.lo
|
||||
+am_libspeechd_la_OBJECTS = libspeechd.lo ../../freebsd.$(OBJEXT)
|
||||
libspeechd_la_OBJECTS = $(am_libspeechd_la_OBJECTS)
|
||||
libspeechd_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
|
||||
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
|
@ -1,11 +0,0 @@
|
|||
--- src/c/clients/say/Makefile.in.orig 2010-01-15 19:45:48.339555703 +0100
|
||||
+++ src/c/clients/say/Makefile.in 2010-01-15 19:46:05.488979035 +0100
|
||||
@@ -45,7 +45,7 @@
|
||||
am__installdirs = "$(DESTDIR)$(bindir)"
|
||||
binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
|
||||
PROGRAMS = $(bin_PROGRAMS)
|
||||
-am_spd_say_OBJECTS = say.$(OBJEXT) options.$(OBJEXT)
|
||||
+am_spd_say_OBJECTS = say.$(OBJEXT) options.$(OBJEXT) ../../../freebsd.$(OBJEXT)
|
||||
spd_say_OBJECTS = $(am_spd_say_OBJECTS)
|
||||
spd_say_DEPENDENCIES = $(c_api)/libspeechd.la
|
||||
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
|
|
@ -1,165 +0,0 @@
|
|||
/* Copyright (C) 1993 Free Software Foundation, Inc.
|
||||
|
||||
This program is free software; you can redistribute it and/or
|
||||
modify it under the terms of the GNU General Public License as
|
||||
published by the Free Software Foundation; either version 2 of the
|
||||
License, or (at your option) any later version.
|
||||
|
||||
This program is distributed in the hope that it will be useful, but
|
||||
WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
General Public License for more details. */
|
||||
|
||||
#ifdef HAVE_CONFIG_H
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <assert.h>
|
||||
#include <errno.h>
|
||||
#include "getline.h"
|
||||
|
||||
/* Always add at least this many bytes when extending the buffer. */
|
||||
#define MIN_CHUNK 64
|
||||
|
||||
/* Read up to (and including) a TERMINATOR from STREAM into *LINEPTR
|
||||
+ OFFSET (and null-terminate it). If LIMIT is non-negative, then
|
||||
read no more than LIMIT chars.
|
||||
|
||||
*LINEPTR is a pointer returned from malloc (or NULL), pointing to
|
||||
*N characters of space. It is realloc'd as necessary.
|
||||
|
||||
Return the number of characters read (not including the null
|
||||
terminator), or -1 on error or EOF. On a -1 return, the caller
|
||||
should check feof(), if not then errno has been set to indicate the
|
||||
error. */
|
||||
|
||||
int
|
||||
getstr (lineptr, n, stream, terminator, offset, limit)
|
||||
char **lineptr;
|
||||
size_t *n;
|
||||
FILE *stream;
|
||||
int terminator;
|
||||
int offset;
|
||||
int limit;
|
||||
{
|
||||
int nchars_avail; /* Allocated but unused chars in *LINEPTR. */
|
||||
char *read_pos; /* Where we're reading into *LINEPTR. */
|
||||
int ret;
|
||||
|
||||
if (!lineptr || !n || !stream)
|
||||
{
|
||||
errno = EINVAL;
|
||||
return -1;
|
||||
}
|
||||
|
||||
if (!*lineptr)
|
||||
{
|
||||
*n = MIN_CHUNK;
|
||||
*lineptr = malloc (*n);
|
||||
if (!*lineptr)
|
||||
{
|
||||
errno = ENOMEM;
|
||||
return -1;
|
||||
}
|
||||
*lineptr[0] = '\0';
|
||||
}
|
||||
|
||||
nchars_avail = *n - offset;
|
||||
read_pos = *lineptr + offset;
|
||||
|
||||
for (;;)
|
||||
{
|
||||
int save_errno;
|
||||
register int c;
|
||||
|
||||
if (limit == 0)
|
||||
break;
|
||||
else
|
||||
{
|
||||
c = getc (stream);
|
||||
|
||||
/* If limit is negative, then we shouldn't pay attention to
|
||||
it, so decrement only if positive. */
|
||||
if (limit > 0)
|
||||
limit--;
|
||||
}
|
||||
|
||||
save_errno = errno;
|
||||
|
||||
/* We always want at least one char left in the buffer, since we
|
||||
always (unless we get an error while reading the first char)
|
||||
NUL-terminate the line buffer. */
|
||||
|
||||
assert((*lineptr + *n) == (read_pos + nchars_avail));
|
||||
if (nchars_avail < 2)
|
||||
{
|
||||
if (*n > MIN_CHUNK)
|
||||
*n *= 2;
|
||||
else
|
||||
*n += MIN_CHUNK;
|
||||
|
||||
nchars_avail = *n + *lineptr - read_pos;
|
||||
*lineptr = realloc (*lineptr, *n);
|
||||
if (!*lineptr)
|
||||
{
|
||||
errno = ENOMEM;
|
||||
return -1;
|
||||
}
|
||||
read_pos = *n - nchars_avail + *lineptr;
|
||||
assert((*lineptr + *n) == (read_pos + nchars_avail));
|
||||
}
|
||||
|
||||
if (ferror (stream))
|
||||
{
|
||||
/* Might like to return partial line, but there is no
|
||||
place for us to store errno. And we don't want to just
|
||||
lose errno. */
|
||||
errno = save_errno;
|
||||
return -1;
|
||||
}
|
||||
|
||||
if (c == EOF)
|
||||
{
|
||||
/* Return partial line, if any. */
|
||||
if (read_pos == *lineptr)
|
||||
return -1;
|
||||
else
|
||||
break;
|
||||
}
|
||||
|
||||
*read_pos++ = c;
|
||||
nchars_avail--;
|
||||
|
||||
if (c == terminator)
|
||||
/* Return the line. */
|
||||
break;
|
||||
}
|
||||
|
||||
/* Done - NUL terminate and return the number of chars read. */
|
||||
*read_pos = '\0';
|
||||
|
||||
ret = read_pos - (*lineptr + offset);
|
||||
return ret;
|
||||
}
|
||||
|
||||
int
|
||||
getline (lineptr, n, stream)
|
||||
char **lineptr;
|
||||
size_t *n;
|
||||
FILE *stream;
|
||||
{
|
||||
return getstr (lineptr, n, stream, '\n', 0, GETLINE_NO_LIMIT);
|
||||
}
|
||||
|
||||
int
|
||||
getline_safe (lineptr, n, stream, limit)
|
||||
char **lineptr;
|
||||
size_t *n;
|
||||
FILE *stream;
|
||||
int limit;
|
||||
{
|
||||
return getstr (lineptr, n, stream, '\n', 0, limit);
|
||||
}
|
|
@ -1,23 +0,0 @@
|
|||
#ifndef _getline_h_
|
||||
#define _getline_h_ 1
|
||||
|
||||
#include <stdio.h>
|
||||
|
||||
#if defined (__GNUC__) || (defined (__STDC__) && __STDC__)
|
||||
#define __PROTO(args) args
|
||||
#else
|
||||
#define __PROTO(args) ()
|
||||
#endif /* GCC. */
|
||||
|
||||
#define GETLINE_NO_LIMIT -1
|
||||
|
||||
int
|
||||
getline __PROTO ((char **_lineptr, size_t *_n, FILE *_stream));
|
||||
int
|
||||
getline_safe __PROTO ((char **_lineptr, size_t *_n, FILE *_stream,
|
||||
int limit));
|
||||
int
|
||||
getstr __PROTO ((char **_lineptr, size_t *_n, FILE *_stream,
|
||||
int _terminator, int _offset, int limit));
|
||||
|
||||
#endif /* _getline_h_ */
|
|
@ -1,184 +0,0 @@
|
|||
/* Copyright (C) 1993 Free Software Foundation, Inc.
|
||||
|
||||
This program is free software; you can redistribute it and/or
|
||||
modify it under the terms of the GNU General Public License as
|
||||
published by the Free Software Foundation; either version 2 of the
|
||||
License, or (at your option) any later version.
|
||||
|
||||
This program is distributed in the hope that it will be useful, but
|
||||
WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
General Public License for more details. */
|
||||
|
||||
#ifdef HAVE_CONFIG_H
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <assert.h>
|
||||
#include <errno.h>
|
||||
#include "getline.h"
|
||||
|
||||
/* Always add at least this many bytes when extending the buffer. */
|
||||
#define MIN_CHUNK 64
|
||||
|
||||
/* Read up to (and including) a TERMINATOR from STREAM into *LINEPTR
|
||||
+ OFFSET (and null-terminate it). If LIMIT is non-negative, then
|
||||
read no more than LIMIT chars.
|
||||
|
||||
*LINEPTR is a pointer returned from malloc (or NULL), pointing to
|
||||
*N characters of space. It is realloc'd as necessary.
|
||||
|
||||
Return the number of characters read (not including the null
|
||||
terminator), or -1 on error or EOF. On a -1 return, the caller
|
||||
should check feof(), if not then errno has been set to indicate the
|
||||
error. */
|
||||
|
||||
int
|
||||
getstr (lineptr, n, stream, terminator, offset, limit)
|
||||
char **lineptr;
|
||||
size_t *n;
|
||||
FILE *stream;
|
||||
int terminator;
|
||||
int offset;
|
||||
int limit;
|
||||
{
|
||||
int nchars_avail; /* Allocated but unused chars in *LINEPTR. */
|
||||
char *read_pos; /* Where we're reading into *LINEPTR. */
|
||||
int ret;
|
||||
|
||||
if (!lineptr || !n || !stream)
|
||||
{
|
||||
errno = EINVAL;
|
||||
return -1;
|
||||
}
|
||||
|
||||
if (!*lineptr)
|
||||
{
|
||||
*n = MIN_CHUNK;
|
||||
*lineptr = malloc (*n);
|
||||
if (!*lineptr)
|
||||
{
|
||||
errno = ENOMEM;
|
||||
return -1;
|
||||
}
|
||||
*lineptr[0] = '\0';
|
||||
}
|
||||
|
||||
nchars_avail = *n - offset;
|
||||
read_pos = *lineptr + offset;
|
||||
|
||||
for (;;)
|
||||
{
|
||||
int save_errno;
|
||||
register int c;
|
||||
|
||||
if (limit == 0)
|
||||
break;
|
||||
else
|
||||
{
|
||||
c = getc (stream);
|
||||
|
||||
/* If limit is negative, then we shouldn't pay attention to
|
||||
it, so decrement only if positive. */
|
||||
if (limit > 0)
|
||||
limit--;
|
||||
}
|
||||
|
||||
save_errno = errno;
|
||||
|
||||
/* We always want at least one char left in the buffer, since we
|
||||
always (unless we get an error while reading the first char)
|
||||
NUL-terminate the line buffer. */
|
||||
|
||||
assert((*lineptr + *n) == (read_pos + nchars_avail));
|
||||
if (nchars_avail < 2)
|
||||
{
|
||||
if (*n > MIN_CHUNK)
|
||||
*n *= 2;
|
||||
else
|
||||
*n += MIN_CHUNK;
|
||||
|
||||
nchars_avail = *n + *lineptr - read_pos;
|
||||
*lineptr = realloc (*lineptr, *n);
|
||||
if (!*lineptr)
|
||||
{
|
||||
errno = ENOMEM;
|
||||
return -1;
|
||||
}
|
||||
read_pos = *n - nchars_avail + *lineptr;
|
||||
assert((*lineptr + *n) == (read_pos + nchars_avail));
|
||||
}
|
||||
|
||||
if (ferror (stream))
|
||||
{
|
||||
/* Might like to return partial line, but there is no
|
||||
place for us to store errno. And we don't want to just
|
||||
lose errno. */
|
||||
errno = save_errno;
|
||||
return -1;
|
||||
}
|
||||
|
||||
if (c == EOF)
|
||||
{
|
||||
/* Return partial line, if any. */
|
||||
if (read_pos == *lineptr)
|
||||
return -1;
|
||||
else
|
||||
break;
|
||||
}
|
||||
|
||||
*read_pos++ = c;
|
||||
nchars_avail--;
|
||||
|
||||
if (c == terminator)
|
||||
/* Return the line. */
|
||||
break;
|
||||
}
|
||||
|
||||
/* Done - NUL terminate and return the number of chars read. */
|
||||
*read_pos = '\0';
|
||||
|
||||
ret = read_pos - (*lineptr + offset);
|
||||
return ret;
|
||||
}
|
||||
|
||||
int
|
||||
getline (lineptr, n, stream)
|
||||
char **lineptr;
|
||||
size_t *n;
|
||||
FILE *stream;
|
||||
{
|
||||
return getstr (lineptr, n, stream, '\n', 0, GETLINE_NO_LIMIT);
|
||||
}
|
||||
|
||||
int
|
||||
getline_safe (lineptr, n, stream, limit)
|
||||
char **lineptr;
|
||||
size_t *n;
|
||||
FILE *stream;
|
||||
int limit;
|
||||
{
|
||||
return getstr (lineptr, n, stream, '\n', 0, limit);
|
||||
}
|
||||
|
||||
char *
|
||||
strndup (str, n)
|
||||
const char *str;
|
||||
size_t n;
|
||||
{
|
||||
size_t len;
|
||||
char *copy;
|
||||
|
||||
len = strlen(str);
|
||||
if (n < len)
|
||||
len = n;
|
||||
copy = malloc(len + 1);
|
||||
if (copy == NULL)
|
||||
return NULL;
|
||||
memcpy(copy, str, len);
|
||||
copy[len] = '\0';
|
||||
return copy;
|
||||
}
|
|
@ -3,6 +3,7 @@ bin/clibrary2
|
|||
bin/connection_recovery
|
||||
bin/long_message
|
||||
bin/run_test
|
||||
%%PYTHON%%bin/spd-conf
|
||||
bin/spd-say
|
||||
bin/spdsend
|
||||
bin/speech-dispatcher
|
||||
|
@ -55,7 +56,28 @@ include/libspeechd.h
|
|||
lib/libspeechd.a
|
||||
lib/libspeechd.la
|
||||
lib/libspeechd.so
|
||||
lib/libspeechd.so.4
|
||||
lib/libspeechd.so.5
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/__init__.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/__init__.pyc
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/__init__.pyo
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/_test.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/_test.pyc
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/_test.pyo
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/client.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/client.pyc
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/client.pyo
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/paths.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/paths.pyc
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/paths.pyo
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd_config/__init__.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd_config/__init__.pyc
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd_config/__init__.pyo
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd_config/config.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd_config/config.pyc
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd_config/config.pyo
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd_config/paths.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd_config/paths.pyc
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd_config/paths.pyo
|
||||
lib/speech-dispatcher-modules/sd_cicero
|
||||
lib/speech-dispatcher-modules/sd_dummy
|
||||
%%ESPEAK%%lib/speech-dispatcher-modules/sd_espeak
|
||||
|
@ -70,7 +92,6 @@ share/sounds/speech-dispatcher/dummy-message.wav
|
|||
%%PYTHON%%share/sounds/speech-dispatcher/test.wav
|
||||
%%DATADIR%%/conf/clients/emacs.conf
|
||||
%%DATADIR%%/conf/clients/gnome-speech.conf
|
||||
%%PYTHON%%%%DATADIR%%/conf/desktop/speechd.desktop
|
||||
%%DATADIR%%/conf/modules/cicero.conf
|
||||
%%DATADIR%%/conf/modules/dtk-generic.conf
|
||||
%%DATADIR%%/conf/modules/epos-generic.conf
|
||||
|
@ -85,7 +106,6 @@ share/sounds/speech-dispatcher/dummy-message.wav
|
|||
%%DATADIR%%/conf/modules/swift-generic.conf
|
||||
%%DATADIR%%/conf/speechd.conf
|
||||
@dirrm %%DATADIR%%/conf/modules
|
||||
%%PYTHON%%@dirrm %%DATADIR%%/conf/desktop
|
||||
@dirrm %%DATADIR%%/conf/clients
|
||||
@dirrm %%DATADIR%%/conf
|
||||
@dirrm %%DATADIR%%
|
||||
|
@ -93,6 +113,10 @@ share/sounds/speech-dispatcher/dummy-message.wav
|
|||
%%GNOMEHIER%%@dirrmtry share/sounds
|
||||
@dirrm lib/speech-dispatcher-modules
|
||||
@dirrm lib/speech-dispatcher
|
||||
%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/speechd_config
|
||||
%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/speechd
|
||||
%%PYTHON%%@dirrmtry %%PYTHON_SITELIBDIR%%
|
||||
%%PYTHON%%@dirrmtry %%PYTHON_LIBDIR%%
|
||||
@dirrmtry %%ETCDIR%%/modules
|
||||
@dirrmtry %%ETCDIR%%/clients
|
||||
@dirrmtry %%ETCDIR%%
|
||||
|
|
Loading…
Reference in a new issue