Update to 0.25. Also make work with older perls (not part of the PR).

PR:		102952
Submitted by:	gslin@gslin.org
This commit is contained in:
Anton Berezin 2006-09-21 11:28:02 +00:00
parent 24c23be75d
commit e689d7ec65
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=173529
3 changed files with 30 additions and 6 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= IPC-Cmd
PORTVERSION= 0.24
PORTVERSION= 0.25
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= IPC
@ -15,14 +15,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= IPC::Cmd - finding and running system commands made easy
BUILD_DEPENDS= ${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
RUN_DEPENDS= ${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
${SITE_PERL}/Module/Load/Conditional.pm:${PORTSDIR}/devel/p5-Module-Load-Conditional \
${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
${SITE_PERL}/Params/Check.pm:${PORTSDIR}/devel/p5-Params-Check
RUN_DEPENDS= ${BUILD_DEPENDS}
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= IPC::Cmd.3
post-patch:
${RM} -f ${WRKSRC}/lib/IPC/Cmd.pm.orig
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (IPC-Cmd-0.24.tar.gz) = 9061bd187defad873432f91fa6de9f9b
SHA256 (IPC-Cmd-0.24.tar.gz) = c2227c2b07c00eb44b268c11beeff9361b4ff84828b6e9c601c8736a264f3ecc
SIZE (IPC-Cmd-0.24.tar.gz) = 8158
MD5 (IPC-Cmd-0.25.tar.gz) = 69bb014822594266ca2cbd01aae54912
SHA256 (IPC-Cmd-0.25.tar.gz) = a5dc8190cfd34ee55e5979eb501d04239470e73fdf2699b19f34640ec5056778
SIZE (IPC-Cmd-0.25.tar.gz) = 9969

View file

@ -0,0 +1,21 @@
--- lib/IPC/Cmd.pm Wed Sep 6 17:34:32 2006
+++ lib/IPC/Cmd.pm Thu Sep 21 13:15:15 2006
@@ -260,8 +260,7 @@ sub _open3_run {
### child process. This stops us from having to pump input
### from ourselves to the childprocess. However, we will need
### to revive the FH afterwards, as IPC::Open3 closes it.
- my $save_stdin;
- open $save_stdin, "<&STDIN" or (
+ open IPC_CMD_SAVE_STDIN, "<&STDIN" or (
warn(loc("Could not dup STDIN: %1",$!)),
return
);
@@ -317,7 +316,7 @@ sub _open3_run {
### restore STDIN after duping, or STDIN will be closed for
### this current perl process!
- open STDIN, "<&", $save_stdin or (
+ open STDIN, "<& IPC_CMD_SAVE_STDIN" or (
warn(loc("Could not restore STDIN: %1", $!)),
return
);