- Roll back my path. It fixes nothing but magicaly breaks build on 6.0.
- Unbreak on 6.0
This commit is contained in:
parent
4b826d98ce
commit
e6afd8cb7f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=146580
2 changed files with 2 additions and 102 deletions
|
@ -65,8 +65,8 @@ MAN7= fsf-funding.7 gfdl.7 gpl.7
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
.if ${OSVERSION} >= 600034
|
.if ${OSVERSION} >= 70000
|
||||||
BROKEN= "Does not build on FreeBSD >= 6.0"
|
BROKEN= "Does not build on FreeBSD >= 7.0"
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.if ${PERL_LEVEL} < 500600
|
.if ${PERL_LEVEL} < 500600
|
||||||
|
@ -80,7 +80,6 @@ post-extract:
|
||||||
|
|
||||||
pre-patch:
|
pre-patch:
|
||||||
${MKDIR} ${WRKSRC}/empty
|
${MKDIR} ${WRKSRC}/empty
|
||||||
@cd ${WRKDIR}/prc-tools-2.3 && ${PATCH} < ${FILESDIR}/pre-patch-gcc3-gcc-3.3.1.palmos.diff
|
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
@(cd ${WRKDIR} && \
|
@(cd ${WRKDIR} && \
|
||||||
|
|
|
@ -1,99 +0,0 @@
|
||||||
--- gcc-3.3.1.palmos.diff.orig Wed Sep 17 21:11:42 2003
|
|
||||||
+++ gcc-3.3.1.palmos.diff Mon Oct 17 22:01:48 2005
|
|
||||||
@@ -1,25 +1,24 @@
|
|
||||||
-diff -urN orig-gcc-3.3.1/configure.in gcc-3.3.1/configure.in
|
|
||||||
---- orig-gcc-3.3.1/configure.in Fri Jun 27 13:44:14 2003
|
|
||||||
-+++ gcc-3.3.1/configure.in Tue Aug 26 21:12:31 2003
|
|
||||||
-@@ -66,7 +66,7 @@
|
|
||||||
- target-newlib \
|
|
||||||
- ${libstdcxx_version} \
|
|
||||||
- target-libf2c \
|
|
||||||
-- ${libgcj}
|
|
||||||
-+ ${libgcj} \
|
|
||||||
- target-libobjc"
|
|
||||||
-
|
|
||||||
- # these tools are built using the target libs, and are intended to run only
|
|
||||||
-@@ -361,6 +361,9 @@
|
|
||||||
- arm-*-riscix*)
|
|
||||||
- noconfigdirs="$noconfigdirs ld target-libgloss ${libgcj}"
|
|
||||||
- ;;
|
|
||||||
-+ arm-*-palmos*)
|
|
||||||
-+ noconfigdirs="$noconfigdirs ${target_libs} ${target_tools}"
|
|
||||||
-+ ;;
|
|
||||||
- avr-*-*)
|
|
||||||
- noconfigdirs="$noconfigdirs target-libiberty ${libstdcxx_version} ${libgcj}"
|
|
||||||
- ;;
|
|
||||||
+--- orig-gcc-3.3.1/gcc/config.gcc Fri Jun 27 15:44:22 2003
|
|
||||||
++++ gcc-3.3.1/gcc/config.gcc Mon Oct 17 21:11:21 2005
|
|
||||||
+@@ -475,6 +475,7 @@
|
|
||||||
+ *-*-freebsd4 | *-*-freebsd[4].*) fbsd_tm_file="freebsd4.h";;
|
|
||||||
+ *-*-freebsd5 | *-*-freebsd[5].*) fbsd_tm_file="freebsd5.h";;
|
|
||||||
+ *-*-freebsd6 | *-*-freebsd[6].*) fbsd_tm_file="freebsd6.h";;
|
|
||||||
++ *-*-freebsd7 | *-*-freebsd[7].*) fbsd_tm_file="freebsd7.h";;
|
|
||||||
+ *) echo 'Please update *-*-freebsd* in gcc/config.gcc'; exit 1;;
|
|
||||||
+ esac
|
|
||||||
+ tmake_file="t-slibgcc-elf-ver t-freebsd"
|
|
||||||
+@@ -739,6 +740,10 @@
|
|
||||||
+ arm*-*-oabi)
|
|
||||||
+ tm_file="arm/unknown-elf-oabi.h dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/aout.h arm/arm.h"
|
|
||||||
+ tmake_file=arm/t-arm-elf
|
|
||||||
++ ;;
|
|
||||||
++arm*-*-palmos*)
|
|
||||||
++ tm_file="dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/aout.h arm/arm.h palmos.h arm/palmos.h"
|
|
||||||
++ tmake_file="arm/t-arm-elf t-palmos"
|
|
||||||
+ ;;
|
|
||||||
+ arm-*-pe*)
|
|
||||||
+ tm_file="arm/semi.h arm/aout.h arm/arm.h arm/coff.h arm/pe.h"
|
|
||||||
diff -urN orig-gcc-3.3.1/gcc/Makefile.in gcc-3.3.1/gcc/Makefile.in
|
|
||||||
--- orig-gcc-3.3.1/gcc/Makefile.in Sun Aug 3 17:48:36 2003
|
|
||||||
+++ gcc-3.3.1/gcc/Makefile.in Tue Sep 9 23:30:26 2003
|
|
||||||
@@ -32,20 +31,6 @@
|
|
||||||
-DTOOL_INCLUDE_DIR=\"$(gcc_tooldir)/include\"
|
|
||||||
|
|
||||||
LIBCPP_OBJS = cpplib.o cpplex.o cppmacro.o cppexp.o cppfiles.o cpptrad.o \
|
|
||||||
-diff -urN orig-gcc-3.3.1/gcc/config.gcc gcc-3.3.1/gcc/config.gcc
|
|
||||||
---- orig-gcc-3.3.1/gcc/config.gcc Fri Jun 27 13:44:22 2003
|
|
||||||
-+++ gcc-3.3.1/gcc/config.gcc Tue Aug 26 21:12:32 2003
|
|
||||||
-@@ -740,6 +740,10 @@
|
|
||||||
- tm_file="arm/unknown-elf-oabi.h dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/aout.h arm/arm.h"
|
|
||||||
- tmake_file=arm/t-arm-elf
|
|
||||||
- ;;
|
|
||||||
-+arm*-*-palmos*)
|
|
||||||
-+ tm_file="dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/aout.h arm/arm.h palmos.h arm/palmos.h"
|
|
||||||
-+ tmake_file="arm/t-arm-elf t-palmos"
|
|
||||||
-+ ;;
|
|
||||||
- arm-*-pe*)
|
|
||||||
- tm_file="arm/semi.h arm/aout.h arm/arm.h arm/coff.h arm/pe.h"
|
|
||||||
- tmake_file=arm/t-pe
|
|
||||||
diff -urN orig-gcc-3.3.1/gcc/config/arm/palmos.h gcc-3.3.1/gcc/config/arm/palmos.h
|
|
||||||
--- orig-gcc-3.3.1/gcc/config/arm/palmos.h Thu Jan 1 00:00:00 1970
|
|
||||||
+++ gcc-3.3.1/gcc/config/arm/palmos.h Tue Sep 16 01:07:33 2003
|
|
||||||
@@ -177,3 +162,28 @@
|
|
||||||
|
|
||||||
/* This is the location of the online document giving instructions for
|
|
||||||
reporting bugs. If you distribute a modified version of GCC,
|
|
||||||
+--- gcc-3.3.1/gcc/config/freebsd7.h.orig Mon Oct 17 21:15:35 2005
|
|
||||||
++++ gcc-3.3.1/gcc/config/freebsd7.h Mon Oct 17 21:14:54 2005
|
|
||||||
+@@ -0,0 +1,22 @@
|
|
||||||
++/* FreeBSD version number setting for FreeBSD 6.x systems.
|
|
||||||
++ Copyright (C) 2001 Free Software Foundation, Inc.
|
|
||||||
++ Contributed by David E. O'Brien <obrien@FreeBSD.org> and BSDi.
|
|
||||||
++
|
|
||||||
++This file is part of GNU CC.
|
|
||||||
++
|
|
||||||
++GNU CC is free software; you can redistribute it and/or modify
|
|
||||||
++it under the terms of the GNU General Public License as published by
|
|
||||||
++the Free Software Foundation; either version 2, or (at your option)
|
|
||||||
++any later version.
|
|
||||||
++
|
|
||||||
++GNU CC is distributed in the hope that it will be useful,
|
|
||||||
++but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
||||||
++MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
||||||
++GNU General Public License for more details.
|
|
||||||
++
|
|
||||||
++You should have received a copy of the GNU General Public License
|
|
||||||
++along with GNU CC; see the file COPYING. If not, write to
|
|
||||||
++the Free Software Foundation, 59 Temple Place - Suite 330,
|
|
||||||
++Boston, MA 02111-1307, USA. */
|
|
||||||
++
|
|
||||||
++#define FBSD_MAJOR 7
|
|
Loading…
Reference in a new issue