* Update to 5.0.0

Summary of changes made in new version is as fllows;
 - emacs22 or newer version of emacsen can handle UNIX domain socket
 by using 'make-network-process' without any helper program.
 Thus, 'icanna' program is no longer included in yc.el.
 (For those who still requires 'icanna' (ex. older-emacs users),
 I'll submit japanese/icanna separately as a new ports.)

PR:		ports/130290
Submitted by:	Takayuki Nakao(maintainer)
This commit is contained in:
Andrey Slusar 2009-01-31 11:31:54 +00:00
parent 8581502f2b
commit e6b40ee990
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=227250
5 changed files with 74 additions and 56 deletions

View file

@ -6,29 +6,48 @@
#
PORTNAME= yc.el
PORTVERSION= 4.0.13
PORTREVISION= 2
PORTVERSION= 5.0.0
PORTEPOCH= 1
CATEGORIES= japanese elisp
MASTER_SITES= http://www.ceres.dti.ne.jp/~knak/
DISTNAME= yc-${PORTVERSION}
DISTFILES= ${DISTNAME}.el.gz
MAINTAINER= t@nakao.org
COMMENT= Yet another Canna client for Emacs/XEmacs
NO_WRKSUBDIR= yes
USE_EMACS= yes
YC_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/yc
YC_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/yc
MAKE_ARGS+= LISPDIR=${YC_LISPDIR}
MAKE_ARGS+= INSTALL_PROGRAM="${INSTALL_PROGRAM}"
MAKE_ARGS+= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
PLIST_FILES= bin/icanna \
%%EMACS_VERSION_SITE_LISPDIR%%/yc/yc.el \
PLIST_FILES= %%EMACS_VERSION_SITE_LISPDIR%%/yc/yc.el \
%%EMACS_VERSION_SITE_LISPDIR%%/yc/yc.elc
PLIST_DIRS= %%EMACS_VERSION_SITE_LISPDIR%%/yc
OPTIONS= ICANNA "Enable icanna support" off
.include <bsd.port.pre.mk>
.if defined(WITH_ICANNA)
RUN_DEPENDS+= ${LOCALBASE}/bin/icanna:${PORTSDIR}/japanese/icanna
.endif
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
@cd ${WRKDIR} && ${GZCAT} ${DISTDIR}/${DISTNAME}.el.gz >yc.el
do-build:
@cd ${WRKDIR} && \
${EMACS_CMD} -batch -f batch-byte-compile yc.el
do-install:
@${TEST} -f ${YC_LISPDIR} || ${MKDIR} ${YC_LISPDIR}
@cd ${WRKDIR} && \
${INSTALL_SCRIPT} yc.el yc.elc ${YC_LISPDIR}
post-install:
@${CAT} ${MASTERDIR}/pkg-message
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1,3 +1,6 @@
MD5 (yc-5.0.0.el.gz) = 46e30679981c4daeefc8bae688728820
SHA256 (yc-5.0.0.el.gz) = fc7c08b686efd420b0c674298d85158d16fda6277c0062eca778919c44d95a89
SIZE (yc-5.0.0.el.gz) = 33202
MD5 (yc-4.0.13.tar.gz) = 5cc5f04346b806d4157b4b66d7eba69f
SHA256 (yc-4.0.13.tar.gz) = 5afd06ea819bbf20f5cbfbcd3c60eb58a50b2ef093defc4c93bfdf8ab69444f3
SIZE (yc-4.0.13.tar.gz) = 43916

View file

@ -1,44 +0,0 @@
--- Makefile.orig Tue Apr 20 00:16:34 2004
+++ Makefile Thu Apr 22 16:31:02 2004
@@ -1,10 +1,10 @@
-prefix = /usr/local
+prefix = $(PREFIX)
#exesuffix = .exe # for Windows
-EMACS = emacs
+#EMACS = emacs
#EMACS = xemacs
-elispdir = $(prefix)/share/emacs/site-lisp
+elispdir = $(LISPDIR)
#elispdir = $(prefix)/lib/$(EMACS)/site-lisp
#elispdir = $(prefix)/lib/emacs
@@ -12,8 +12,8 @@
elc = yc.elc
PROGRAM = icanna$(exesuffix)
OBJS = icanna.o
-CC = gcc
-INSTALL = install
+#CC = gcc
+#INSTALL = install
.SUFFIXES: .el .elc
@@ -31,11 +31,13 @@
install: install-bin install-el
install-bin: $(PROGRAM)
- $(INSTALL) -m 755 -s $(PROGRAM) $(INSTALL_PATH)/$(PROGRAM)
+ test -f $(INSTALL_PATH) || mkdir -p $(INSTALL_PATH)
+ $(INSTALL_PROGRAM) $(PROGRAM) $(INSTALL_PATH)/$(PROGRAM)
install-el: $(ELCS) $(SRCS)
- $(INSTALL) -m 755 $(elc) $(elispdir)/$(elc)
- $(INSTALL) -m 755 $(elc:.elc=.el) $(elispdir)/$(elc:.elc=.el)
+ test -f $(elispdir) || mkdir -p $(elispdir)
+ $(INSTALL_SCRIPT) $(elc) $(elispdir)/$(elc)
+ $(INSTALL_SCRIPT) $(elc:.elc=.el) $(elispdir)/$(elc:.elc=.el)
uninstall: uninstall-bin uninstall-el

View file

@ -0,0 +1,34 @@
--- yc.el.orig 2008-02-17 00:37:39.000000000 +0900
+++ yc.el 2008-02-17 00:38:16.000000000 +0900
@@ -393,7 +393,7 @@
(error nil)))))))
(when (processp yc-server)
(put 'yc-server 'init nil)
- (process-kill-without-query yc-server)
+ (set-process-query-on-exit-flag yc-server nil)
(when yc-debug
(unwind-protect
(progn
@@ -4046,14 +4046,15 @@
"japanese-yc" "Japanese" 'yc-activate
"$B$"(B" "Romaji -> Hiragana -> Kanji&Kana"
nil)
-(set-language-info "Japanese" 'input-method "japanese-yc")
-;(setq default-input-method "japanese-yc"))
+(defun force-yc-input-mode ()
+ (set-language-info "Japanese" 'input-method "japanese-yc")
+ (setq default-input-method "japanese-yc"))
-;(yc-setup)
-;(when (and yc-connect-server-at-startup (yc-server-check))
-; (yc-init)
-; (force-yc-input-mode)
-; )
+(yc-setup)
+(when (and yc-connect-server-at-startup (yc-server-check))
+ (yc-init)
+ (force-yc-input-mode)
+ )
(defconst yc-version "5.0.0")
(provide 'yc)

View file

@ -1,4 +1,4 @@
************************************************************
**********************************************************************
Quick Setup:
(1) Add the following two lines in your $HOME/.emacs file;
@ -13,4 +13,10 @@ Quick Setup:
These values are also configurable in .emacs by setting variables
'yc-server-host' and 'yc-canna-lib-path'.
************************************************************
**********************************************************************
Note:
If you want to use UNIX-domain socket for communication with cannaserver
in emacs21 or former version of emacsen, define WITH_ICANNA to add
dependency to ports ja-icanna.
**********************************************************************