devel/tup: new port had been added (file-based build system)

It inputs a list of file changes and a directed acyclic graph (DAG),
then processes the DAG to execute the appropriate commands required
to update dependent files.

WWW: https://gittup.org/tup/
This commit is contained in:
Alexey Dokuchaev 2022-06-01 02:09:00 +00:00
parent 1e94e52737
commit e6b4d19773
5 changed files with 58 additions and 0 deletions

View file

@ -7256,6 +7256,7 @@
SUBDIR += trellis
SUBDIR += trio
SUBDIR += truc
SUBDIR += tup
SUBDIR += ua_parser-core
SUBDIR += uclcmd
SUBDIR += ucommon

35
devel/tup/Makefile Normal file
View file

@ -0,0 +1,35 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= tup
PORTVERSION= 0.7.11
DISTVERSIONPREFIX= v
CATEGORIES= devel
MASTER_SITES= https://gittup.org/tup/releases/
MAINTAINER= danfe@FreeBSD.org
COMMENT= Fast and smart file-based build system
LICENSE= GPLv2
LIB_DEPENDS= libpcre.so:devel/pcre
USES= fuse pkgconfig
DO_MAKE_BUILD= ${SETENV} ${MAKE_ENV} ${SH} bootstrap-nofuse.sh
PLIST_FILES= bin/${PORTNAME} share/man/man1/${PORTNAME}.1.gz \
share/vim/vimfiles/syntax/${PORTNAME}.vim
post-patch:
@${REINPLACE_CMD} -e 's,-Os,${CFLAGS},' ${WRKSRC}/Tuprules.tup
do-install:
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${PORTNAME} \
${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${INSTALL_WRKSRC}/${PORTNAME}.1 \
${STAGEDIR}${MAN1PREFIX}/share/man/man1
@${MKDIR} ${STAGEDIR}${PREFIX}/share/vim/vimfiles/syntax
${INSTALL_DATA} ${INSTALL_WRKSRC}/contrib/syntax/*.vim \
${STAGEDIR}${PREFIX}/share/vim/vimfiles/syntax
.include <bsd.port.mk>

3
devel/tup/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1621101608
SHA256 (tup-v0.7.11.tar.gz) = ebfb5e28afd7eb6c1718930c17e703c5142e3345031e7f001c752a09adc3a784
SIZE (tup-v0.7.11.tar.gz) = 4683364

View file

@ -0,0 +1,11 @@
--- src/tup/platform.c.orig 2021-05-14 16:20:52 UTC
+++ src/tup/platform.c
@@ -58,6 +58,8 @@ const char *tup_arch = "arm64";
const char *tup_arch = "arm";
#elif __aarch64__
const char *tup_arch = "arm64";
+#elif __riscv
+const char *tup_arch = "riscv";
#else
#error Unsupported cpu architecture. Please add support in tup/platform.c
#endif

8
devel/tup/pkg-descr Normal file
View file

@ -0,0 +1,8 @@
Tup is a file-based build system for Unix and Windows. It takes as input
a list of file changes and a directed acyclic graph (DAG). It then
processes the DAG to execute the appropriate commands required to update
dependent files. Updates are performed with very little overhead since
tup implements powerful build algorithms to avoid doing unnecessary work,
so you can stay focused on your project rather than on your build system.
WWW: https://gittup.org/tup/