Remove ports-mgmt/portbrowser. It is no longer actively maintained and
broken for years. Feature safe: yes PR: ports/143667
This commit is contained in:
parent
ac0aac97f4
commit
e6b7c82e60
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=249973
5 changed files with 0 additions and 60 deletions
|
@ -37,7 +37,6 @@
|
|||
SUBDIR += port-maintenance-tools
|
||||
SUBDIR += portaudit
|
||||
SUBDIR += portaudit-db
|
||||
SUBDIR += portbrowser
|
||||
SUBDIR += portcheck
|
||||
SUBDIR += portcheckout
|
||||
SUBDIR += portconf
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
# New ports collection makefile for: portbrowser
|
||||
# Date created: 8 November, 2004
|
||||
# Whom: hrs
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= portbrowser
|
||||
PORTVERSION= 0.5.20050618
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= ports-mgmt
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= hrs
|
||||
DISTNAME= pb-browser-current-20050618
|
||||
#MASTER_SITES= http://www.bytelabs.org/
|
||||
|
||||
MAINTAINER= hrs@FreeBSD.org
|
||||
COMMENT= Graphical frontend for the BSD ports system
|
||||
|
||||
USE_GNOME= gtk20
|
||||
MAKE_ENV= MANDIR=${PREFIX}/man/man \
|
||||
BINDIR=${PREFIX}/bin \
|
||||
NO_MANCOMPRESS=YES
|
||||
CFLAGS+= -DINDEXFILE=\\\"${PORTSDIR}/${INDEXFILE}\\\" \
|
||||
-DPORTS_DIR=\\\"${PORTSDIR}\\\"
|
||||
PLIST_FILES= bin/pbrowser
|
||||
|
||||
MAN1= pbrowser.1
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} 's|gram-obsd.y|gram-fbsd.y|' \
|
||||
${WRKSRC}/src/Makefile
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (pb-browser-current-20050618.tar.gz) = c959fc5d224084809d97e68d14e54042
|
||||
SHA256 (pb-browser-current-20050618.tar.gz) = 7b9a2ac79da28501ea8c9db9c40c1bfd465261a18532bc3e0588cb49aebaadb5
|
||||
SIZE (pb-browser-current-20050618.tar.gz) = 49032
|
|
@ -1,19 +0,0 @@
|
|||
--- src/pkgobject.h.orig Sat Jun 18 07:29:56 2005
|
||||
+++ src/pkgobject.h Mon Jun 25 01:20:20 2007
|
||||
@@ -31,12 +31,16 @@
|
||||
|
||||
#include "pkgquery.h"
|
||||
|
||||
+#ifndef PORTS_DIR
|
||||
#define PORTS_DIR "/usr/ports/" /* standard place for the ports dir */
|
||||
+#endif
|
||||
|
||||
+#ifndef INDEXFILE
|
||||
#if (defined __FreeBSD__) && (__FreeBSD_version >= 500036)
|
||||
#define INDEXFILE PORTS_DIR"INDEX-5" /* this is kind of weird but thats the way it's done on FreeBSD */
|
||||
#else
|
||||
#define INDEXFILE PORTS_DIR"INDEX" /* where is the INDEX File located? */
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
#ifdef __OpenBSD__
|
|
@ -1,4 +0,0 @@
|
|||
The PortBrowser is a FREE, easy to use implementation
|
||||
of a frontend written for the BSD ports system.
|
||||
|
||||
WWW: http://www.bytelabs.org/devel.html
|
Loading…
Reference in a new issue