New port OQTEncoder version 0.1: A simple encoder using
OpenQuicktime (TM)
This commit is contained in:
parent
83e89b827a
commit
e6eb54334e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48176
13 changed files with 129 additions and 0 deletions
|
@ -177,6 +177,7 @@
|
|||
SUBDIR += opendx-samples
|
||||
SUBDIR += opengl-man
|
||||
SUBDIR += openquicktime
|
||||
SUBDIR += oqtencoder
|
||||
SUBDIR += oqtplayer
|
||||
SUBDIR += osg
|
||||
SUBDIR += p5-Chart-PNGgraph
|
||||
|
|
35
graphics/oqtencoder/Makefile
Normal file
35
graphics/oqtencoder/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: oqtplayer
|
||||
# Date created: Mon Sep 24 16:26:33 BRT 2001
|
||||
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= OQTEncoder
|
||||
PORTVERSION= 0.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= openquicktime
|
||||
DISTNAME= ${PORTNAME:L}-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= openquicktime.0:${PORTSDIR}/graphics/openquicktime
|
||||
|
||||
MAKE_ENV= SDL_CONFIG=${SDL_CONFIG}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s/
//" ${WRKSRC}/readme
|
||||
|
||||
do-install:
|
||||
.ifndef(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}
|
||||
.endif
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:L} ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/oqtencoder/distinfo
Normal file
1
graphics/oqtencoder/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (oqtencoder-0.1.tgz) = 9e4e3c5eb87e106144dff52dcb6c8ccd
|
11
graphics/oqtencoder/files/patch-Makefile
Normal file
11
graphics/oqtencoder/files/patch-Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.orig Mon Sep 24 20:53:00 2001
|
||||
+++ Makefile Mon Sep 24 20:53:21 2001
|
||||
@@ -2,7 +2,7 @@
|
||||
all: oqtencoder
|
||||
|
||||
oqtencoder: oqtencoder.c
|
||||
- gcc -g -o oqtencoder oqtencoder.c -lopenquicktime $(CFLAGS) $(LDFLAGS)
|
||||
+ $(CC) -o oqtencoder oqtencoder.c -I$(LOCALBASE)/include -L$(LOCALBASE)/lib -lopenquicktime $(CFLAGS) $(LDFLAGS)
|
||||
|
||||
clean:
|
||||
rm -f *~
|
1
graphics/oqtencoder/pkg-comment
Normal file
1
graphics/oqtencoder/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A simple encoder using OpenQuicktime (TM)
|
13
graphics/oqtencoder/pkg-descr
Normal file
13
graphics/oqtencoder/pkg-descr
Normal file
|
@ -0,0 +1,13 @@
|
|||
[ from developer's readme ]
|
||||
OQTEncoder is just here to show how simple it is to realize an
|
||||
encoder using OpenQuicktime... It is simple, new and doesn't have
|
||||
a lot of functionality but it shoud soon be better and it's already
|
||||
usable ;)
|
||||
|
||||
Just launch it without options and it will explain you how to use
|
||||
it ;). Here follows a simple example to encode any mpeg file using
|
||||
the great program mpeg2dec from Aaron Holzman:
|
||||
|
||||
mpeg2dec -s -o pgmpipe test.mpg | oqtencoder -V jpeg test.mov
|
||||
|
||||
WWW: http://openquicktime.sourceforge.net/
|
3
graphics/oqtencoder/pkg-plist
Normal file
3
graphics/oqtencoder/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/oqtencoder
|
||||
%%PORTDOCS%%share/doc/OQTEncoder/readme
|
||||
%%PORTDOCS%%@dirrm share/doc/OQTEncoder
|
35
multimedia/oqtencoder/Makefile
Normal file
35
multimedia/oqtencoder/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: oqtplayer
|
||||
# Date created: Mon Sep 24 16:26:33 BRT 2001
|
||||
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= OQTEncoder
|
||||
PORTVERSION= 0.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= openquicktime
|
||||
DISTNAME= ${PORTNAME:L}-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= openquicktime.0:${PORTSDIR}/graphics/openquicktime
|
||||
|
||||
MAKE_ENV= SDL_CONFIG=${SDL_CONFIG}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s/
//" ${WRKSRC}/readme
|
||||
|
||||
do-install:
|
||||
.ifndef(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}
|
||||
.endif
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:L} ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
multimedia/oqtencoder/distinfo
Normal file
1
multimedia/oqtencoder/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (oqtencoder-0.1.tgz) = 9e4e3c5eb87e106144dff52dcb6c8ccd
|
11
multimedia/oqtencoder/files/patch-Makefile
Normal file
11
multimedia/oqtencoder/files/patch-Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.orig Mon Sep 24 20:53:00 2001
|
||||
+++ Makefile Mon Sep 24 20:53:21 2001
|
||||
@@ -2,7 +2,7 @@
|
||||
all: oqtencoder
|
||||
|
||||
oqtencoder: oqtencoder.c
|
||||
- gcc -g -o oqtencoder oqtencoder.c -lopenquicktime $(CFLAGS) $(LDFLAGS)
|
||||
+ $(CC) -o oqtencoder oqtencoder.c -I$(LOCALBASE)/include -L$(LOCALBASE)/lib -lopenquicktime $(CFLAGS) $(LDFLAGS)
|
||||
|
||||
clean:
|
||||
rm -f *~
|
1
multimedia/oqtencoder/pkg-comment
Normal file
1
multimedia/oqtencoder/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A simple encoder using OpenQuicktime (TM)
|
13
multimedia/oqtencoder/pkg-descr
Normal file
13
multimedia/oqtencoder/pkg-descr
Normal file
|
@ -0,0 +1,13 @@
|
|||
[ from developer's readme ]
|
||||
OQTEncoder is just here to show how simple it is to realize an
|
||||
encoder using OpenQuicktime... It is simple, new and doesn't have
|
||||
a lot of functionality but it shoud soon be better and it's already
|
||||
usable ;)
|
||||
|
||||
Just launch it without options and it will explain you how to use
|
||||
it ;). Here follows a simple example to encode any mpeg file using
|
||||
the great program mpeg2dec from Aaron Holzman:
|
||||
|
||||
mpeg2dec -s -o pgmpipe test.mpg | oqtencoder -V jpeg test.mov
|
||||
|
||||
WWW: http://openquicktime.sourceforge.net/
|
3
multimedia/oqtencoder/pkg-plist
Normal file
3
multimedia/oqtencoder/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/oqtencoder
|
||||
%%PORTDOCS%%share/doc/OQTEncoder/readme
|
||||
%%PORTDOCS%%@dirrm share/doc/OQTEncoder
|
Loading…
Reference in a new issue