- Update to 1.1.1
- Add files/patch-generator__CMakeLists.txt [1] - Remove apiextractor, generatorrunner from LIB_DEPENDS, add xml2, and xslt - Add gui, xml, and xmlpatterns to USE_QT4 - Convert to the new options framework - Define option DOCS and MANPAGES - Add textproc/py-sphinx to BUILD_DEPENDS only when the DOCS option is on - Add post-patch target (fix build: see http://goo.gl/EEPgQ [1]) - Add regression-test target Buildlog: http://goo.gl/tPsRF
This commit is contained in:
parent
c22a822e0f
commit
e7010356ea
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=301273
4 changed files with 143 additions and 10 deletions
|
@ -6,8 +6,8 @@
|
|||
#
|
||||
|
||||
PORTNAME= shiboken
|
||||
PORTVERSION= 1.1.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.1.1
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.pyside.org/files/
|
||||
|
||||
|
@ -17,24 +17,49 @@ COMMENT= C++ code generator for CPython extensions
|
|||
LICENSE= GPLv2 LGPL21
|
||||
LICENSE_COMB= multi
|
||||
|
||||
BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
|
||||
LIB_DEPENDS= apiextractor.0:${PORTSDIR}/devel/apiextractor \
|
||||
genrunner.0:${PORTSDIR}/devel/generatorrunner
|
||||
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
|
||||
xslt:${PORTSDIR}/textproc/libxslt
|
||||
|
||||
PLIST_SUB= PORTVERSION=${PORTVERSION} \
|
||||
PYTHON_VERSION=${PYTHON_VERSION}
|
||||
|
||||
USE_QT4= corelib qmake_build moc_build uic_build rcc_build
|
||||
USE_QT4= gui qmake_build qtestlib moc_build \
|
||||
uic_build rcc_build xml xmlpatterns
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_CMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_PYTHON= yes
|
||||
|
||||
.if !defined(NO_INSTALL_MANPAGES)
|
||||
ALL_TARGET= all
|
||||
|
||||
OPTIONS_DEFINE= DOCS MANPAGES
|
||||
OPTIONS_DEFAULT= MANPAGES
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MMANPAGES}
|
||||
MAN1= shiboken.1
|
||||
.else
|
||||
CMAKE_ARGS= -DNO_INSTALL_MANPAGES:BOOL="ON"
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
BUILD_DEPENDS+= sphinx-build:${PORTSDIR}/textproc/py-sphinx
|
||||
ALL_TARGET+= doc
|
||||
post-install:
|
||||
if [ -d ${WRKSRC}/doc/html ]; then \
|
||||
${MKDIR} ${DOCSDIR} && \
|
||||
cd ${WRKSRC}/doc/html && ${COPYTREE_SHARE} . ${DOCSDIR}; \
|
||||
fi
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@cd ${WRKSRC}/generator && \
|
||||
${MV} ${PORTNAME} ${PORTNAME}.dir
|
||||
|
||||
regression-test: build
|
||||
@${ECHO_MSG} "===> Running shiboken regression tests"
|
||||
@cd ${WRKSRC} && ${MAKE} test
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (shiboken-1.1.0.tar.bz2) = 99d26ee5982580a76826ca4c523736aa7853c694943d56208185ea62c6dc76c9
|
||||
SIZE (shiboken-1.1.0.tar.bz2) = 628866
|
||||
SHA256 (shiboken-1.1.1.tar.bz2) = 1cedad65d5d12e1b81a487b6aa7a1cb0a494934cb39c34f3cffcbc6c645d7e3f
|
||||
SIZE (shiboken-1.1.1.tar.bz2) = 1065920
|
||||
|
|
28
devel/shiboken/files/patch-generator__CMakeLists.txt
Normal file
28
devel/shiboken/files/patch-generator__CMakeLists.txt
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- ./generator/CMakeLists.txt.orig 2012-07-20 19:49:38.000000000 +0200
|
||||
+++ ./generator/CMakeLists.txt 2012-07-20 19:50:21.000000000 +0200
|
||||
@@ -2,11 +2,11 @@
|
||||
|
||||
set(shiboken_SRC
|
||||
generator.cpp
|
||||
-shiboken/cppgenerator.cpp
|
||||
-shiboken/headergenerator.cpp
|
||||
-shiboken/overloaddata.cpp
|
||||
-shiboken/shibokengenerator.cpp
|
||||
-shiboken/shibokennormalize.cpp
|
||||
+shiboken.dir/cppgenerator.cpp
|
||||
+shiboken.dir/headergenerator.cpp
|
||||
+shiboken.dir/overloaddata.cpp
|
||||
+shiboken.dir/shibokengenerator.cpp
|
||||
+shiboken.dir/shibokennormalize.cpp
|
||||
main.cpp
|
||||
)
|
||||
|
||||
@@ -15,7 +15,7 @@
|
||||
add_definitions(-DDOCSTRINGS_ENABLED)
|
||||
endif()
|
||||
|
||||
-include_directories(${CMAKE_CURRENT_SOURCE_DIR}/shiboken
|
||||
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/shiboken.dir
|
||||
${CMAKE_CURRENT_SOURCE_DIR}/qtdoc
|
||||
${CMAKE_CURRENT_SOURCE_DIR}
|
||||
${CMAKE_CURRENT_BINARY_DIR}
|
|
@ -22,10 +22,90 @@ include/shiboken/typeresolver.h
|
|||
lib/cmake/Shiboken-%%PORTVERSION%%/ShibokenConfig-%%PYTHON_VERSION%%.cmake
|
||||
lib/cmake/Shiboken-%%PORTVERSION%%/ShibokenConfig.cmake
|
||||
lib/cmake/Shiboken-%%PORTVERSION%%/ShibokenConfigVersion.cmake
|
||||
lib/generatorrunner/shiboken_generator.so
|
||||
lib/libshiboken-%%PYTHON_VERSION%%.so
|
||||
lib/libshiboken-%%PYTHON_VERSION%%.so.1
|
||||
lib/libshiboken-%%PYTHON_VERSION%%.so.%%PORTVERSION%%
|
||||
libdata/pkgconfig/shiboken.pc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.buildinfo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/codeinjectionsemantics.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/commandlineoptions.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/contents.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/environment.pickle
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/faq.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/overview.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/ownership.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/projectfile.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/sequenceprotocol.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/shibokenmodule.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/typeconverters.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/typesystemvariables.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/.doctrees/wordsofadvice.doctree
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_images/bindinggen-development.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_images/boostqtarch.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_images/converter.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/codeinjectionsemantics.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/commandlineoptions.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/contents.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/faq.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/overview.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/ownership.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/projectfile.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/sequenceprotocol.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/shibokenmodule.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/typeconverters.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/typesystemvariables.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_sources/wordsofadvice.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/ajax-loader.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/basic.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/bg_header.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/bg_topo.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/comment-bright.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/comment-close.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/comment.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/default.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/doctools.js
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/down-pressed.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/down.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/fakebar.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/file.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/jquery.js
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/logo_indt.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/logo_openbossa.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/logo_python.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/logo_qt.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/minus.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/plus.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/pygments.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/pysidedocs.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/pysidelogo.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/relbar_bg.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/searchtools.js
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/sidebar.js
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/underscore.js
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/up-pressed.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/up.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/_static/websupport.js
|
||||
%%PORTDOCS%%%%DOCSDIR%%/codeinjectionsemantics.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/commandlineoptions.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/contents.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/faq.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/objects.inv
|
||||
%%PORTDOCS%%%%DOCSDIR%%/overview.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ownership.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/projectfile.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/search.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/searchindex.js
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sequenceprotocol.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/shibokenmodule.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/typeconverters.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/typesystemvariables.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/wordsofadvice.html
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/_static
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/_sources
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/_images
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/.doctrees
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm lib/cmake/Shiboken-%%PORTVERSION%%
|
||||
@dirrm lib/cmake
|
||||
@dirrm include/shiboken
|
||||
|
|
Loading…
Reference in a new issue