Update to 3.5.0
2015-09-29 Kamil Ignacak * bugfix: fixing code that resets tone queue on flushing. A bug was found on FreeBSD: after pressing Ctrl+C, application that wanted to stop and delete generator as part of SIGINT handling procedure, got stuck in cw_tq_flush_internal() function, waiting for tone queue to go idle. This never happened. Resetting all tone queue state variables in flush function ensures that the function completes and returns, and that client application can exit. 2015-09-12 Kamil Ignacak * xcwcp: the application souce code files are now ported to Qt5. Build system files have been modified to use Qt5 to build xcwcp. Discovery and adding -fPIC to compiler flags for xcwcp is right now very naive, perhaps that will have to be improved in the future.
This commit is contained in:
parent
d851b5f395
commit
e7302b2f89
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=399012
5 changed files with 30 additions and 20 deletions
|
@ -4,7 +4,7 @@
|
|||
# it still works as well.
|
||||
|
||||
PORTNAME?= unixcw
|
||||
PORTVERSION= 3.4.2
|
||||
PORTVERSION= 3.5.0
|
||||
CATEGORIES= comms hamradio
|
||||
MASTER_SITES= SF/unixcw/unixcw-${PORTVERSION}
|
||||
DISTNAME= unixcw_${PORTVERSION}.orig
|
||||
|
@ -13,9 +13,10 @@ MAINTAINER= hamradio@FreeBSD.org
|
|||
COMMENT?= Libs for cw on unix
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
.ifndef CONFIGURE_ARGS
|
||||
.ifndef CONFIGURE_ARGS
|
||||
CONFIGURE_ARGS= --disable-xcwcp
|
||||
.endif
|
||||
CONFIGURE_ARGS+= --includedir="${LOCALBASE}/include" \
|
||||
|
@ -23,11 +24,17 @@ CONFIGURE_ARGS+= --includedir="${LOCALBASE}/include" \
|
|||
--disable-alsa --disable-pulseaudio
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
USES= gmake libtool pkgconfig
|
||||
USES+= gmake libtool pkgconfig
|
||||
USE_CSTD= gnu99
|
||||
WRKSRC= ${WRKDIR}/unixcw-${PORTVERSION}
|
||||
MAJOR_LIB_VER= 6
|
||||
MINOR_LIB_VER= 5.1
|
||||
PLIST_SUB= MAJOR_LIB_VER=${MAJOR_LIB_VER}
|
||||
PLIST_SUB+= MINOR_LIB_VER=${MINOR_LIB_VER}
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcw.so.6.4.1
|
||||
.ifndef XCWCP
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcw.so.${MAJOR_LIB_VER}.${MINOR_LIB_VER}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (unixcw_3.4.2.orig.tar.gz) = 8c26f80861cb88de7554f1d693fb6288cf49ab5c7a6af31ee727860f56d76075
|
||||
SIZE (unixcw_3.4.2.orig.tar.gz) = 710813
|
||||
SHA256 (unixcw_3.5.0.orig.tar.gz) = ca94e54ce7e6da458aba13ecdea05e4ec7db50c482abf78201403c718680ac0c
|
||||
SIZE (unixcw_3.5.0.orig.tar.gz) = 719974
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- src/libcw/Makefile.in.orig 2015-06-10 20:55:54 UTC
|
||||
--- src/libcw/Makefile.in.orig 2015-10-06 17:17:18 UTC
|
||||
+++ src/libcw/Makefile.in
|
||||
@@ -690,7 +690,7 @@ libcw_test_simple_gen_LDADD = -lm -lpthr
|
||||
libcw_test_simple_gen_CFLAGS = -rdynamic
|
||||
@@ -676,7 +676,7 @@ libcw_test_internal_LDADD = -lm -lpthrea
|
||||
libcw_test_internal_CFLAGS = -rdynamic
|
||||
|
||||
# target: libcw.pc
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
|
|
|
@ -5,8 +5,8 @@ include/libcw.h
|
|||
include/libcw_debug.h
|
||||
lib/libcw.a
|
||||
lib/libcw.so
|
||||
lib/libcw.so.6
|
||||
lib/libcw.so.6.4.1
|
||||
lib/libcw.so.%%MAJOR_LIB_VER%%
|
||||
lib/libcw.so.%%MAJOR_LIB_VER%%.%%MINOR_LIB_VER%%
|
||||
libdata/pkgconfig/libcw.pc
|
||||
man/man1/cw.1.gz
|
||||
man/man1/cwgen.1.gz
|
||||
|
|
|
@ -1,25 +1,28 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xcwcp
|
||||
|
||||
COMMENT= X11 CW Tutor using unixcw
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libcw.so:${PORTSDIR}/comms/unixcw
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../unixcw
|
||||
|
||||
PLIST= ${.CURDIR}/pkg-plist
|
||||
USE_QT4= gui moc_build qmake_build rcc_build uic_build designer
|
||||
USE_AUTOTOOLS= autoconf
|
||||
USE_QT5= buildtools gui widgets qmake_build
|
||||
USES= gettext
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-xcwcp
|
||||
XCWCP= yes
|
||||
PLIST_FILES= bin/xcwcp \
|
||||
man/man1/xcwcp.1.gz
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -lintl
|
||||
|
||||
post-stage:
|
||||
# Remove files from the unixcw plist
|
||||
for plistfile in `cat ${MASTERDIR}/pkg-plist`; \
|
||||
do \
|
||||
cleanfile=`echo $${plistfile} | ${SED} -E 's|man/man(.*).gz|man/man\1|'`; \
|
||||
${RM} ${STAGEDIR}${PREFIX}/$${cleanfile}; \
|
||||
done
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/xcwcp/xcwcp ${STAGEDIR}${PREFIX}/bin/
|
||||
${INSTALL_DATA} ${WRKSRC}/src/xcwcp/xcwcp.1 ${STAGEDIR}${MANPREFIX}/man/man1
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
|
Loading…
Reference in a new issue