devel/py-poetry-semver: Add py-poetry-semver 0.1.0
Poetry SemVer provides a semantic versioning library for Python. It is initially part of the Poetry codebase.
This commit is contained in:
parent
5c7ee226ff
commit
e732c3906a
5 changed files with 36 additions and 0 deletions
|
@ -5091,6 +5091,7 @@
|
|||
SUBDIR += py-poetry-core
|
||||
SUBDIR += py-poetry-dynamic-versioning
|
||||
SUBDIR += py-poetry-plugin-export
|
||||
SUBDIR += py-poetry-semver
|
||||
SUBDIR += py-poetry2setup
|
||||
SUBDIR += py-polib
|
||||
SUBDIR += py-pooch
|
||||
|
|
20
devel/py-poetry-semver/Makefile
Normal file
20
devel/py-poetry-semver/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
PORTNAME= poetry-semver
|
||||
PORTVERSION= 0.1.0
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Semantic versioning library for Python
|
||||
WWW= https://github.com/python-poetry/semver
|
||||
|
||||
LICENSE= MIT
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
|
||||
|
||||
USES= python:3.7+
|
||||
USE_PYTHON= autoplist concurrent pep517
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/py-poetry-semver/distinfo
Normal file
3
devel/py-poetry-semver/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1679498498
|
||||
SHA256 (poetry-semver-0.1.0.tar.gz) = d809b612aa27b39bf2d0fc9d31b4f4809b0e972646c5f19cfa46c725b7638810
|
||||
SIZE (poetry-semver-0.1.0.tar.gz) = 11985
|
10
devel/py-poetry-semver/files/patch-pyproject.toml
Normal file
10
devel/py-poetry-semver/files/patch-pyproject.toml
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- pyproject.toml.orig 2019-12-02 20:19:34 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -44,5 +44,5 @@ known_third_party = [
|
||||
|
||||
|
||||
[build-system]
|
||||
-requires = ["poetry>=1.0.0b8"]
|
||||
-build-backend = "poetry.masonry.api"
|
||||
+requires = ["poetry-core>=1.0.0"]
|
||||
+build-backend = "poetry.core.masonry.api"
|
2
devel/py-poetry-semver/pkg-descr
Normal file
2
devel/py-poetry-semver/pkg-descr
Normal file
|
@ -0,0 +1,2 @@
|
|||
Poetry SemVer provides a semantic versioning library for Python. It is initially
|
||||
part of the Poetry codebase.
|
Loading…
Reference in a new issue