Remove the sftp port as it is no longer supported by its author.

May it rest in peace.
This commit is contained in:
Cy Schubert 2005-12-20 19:46:03 +00:00
parent e90c21eb05
commit e75be9baa9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=151668
6 changed files with 0 additions and 134 deletions

View file

@ -87,7 +87,6 @@
SUBDIR += py-curl
SUBDIR += quftp
SUBDIR += rexx-curl
SUBDIR += sftp
SUBDIR += spegla
SUBDIR += tftp-hpa
SUBDIR += tnftp

View file

@ -1,51 +0,0 @@
# New ports collection makefile for: sftp
# Date created: 30 December 1999
# Whom: Cy Shubert <Cy.Shubert@uumail.gov.bc.ca>
#
# $FreeBSD$
#
PORTNAME= sftp
PORTVERSION= 0.9.9
CATEGORIES= ftp security
MASTER_SITES= http://www.komquats.com/distfiles/
MAINTAINER= cy@FreeBSD.org
COMMENT= An ftp replacement that runs over an ssh tunnel
DEPRECATED= yes
EXPIRATION_DATE= 2005-12-16
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400014
RUN_DEPENDS= ssh:${PORTSDIR}/security/openssh
.endif
GNU_CONFIGURE= yes
MAN1= secftp.1
PLIST= ${WRKDIR}/.PLIST
pre-install:
@${CP} ${PKGDIR}/pkg-plist.in ${PLIST}.unsorted
@if [ ! -f ${PREFIX}/bin/sftp ]; then \
${ECHO_CMD} bin/sftp >> ${PLIST}.unsorted; \
${ECHO_CMD} man/man1/sftp.1.gz >> ${PLIST}.unsorted; \
fi
@${SORT} -u ${PLIST}.unsorted > ${PLIST}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sftp ${PREFIX}/bin/secftp
${LN} -s ${PREFIX}/bin/secftp ${PREFIX}/bin/rsftp
${INSTALL_PROGRAM} ${WRKSRC}/sftpserv ${PREFIX}/bin/sftpserv
${INSTALL_MAN} ${WRKSRC}/sftp.1 ${PREFIX}/man/man1/secftp.1
@if [ ! -f ${PREFIX}/bin/sftp ]; then \
${ECHO} "No other sftp found, linking sftp to secftp"; \
${LN} -s ${PREFIX}/bin/secftp ${PREFIX}/bin/sftp; \
${LN} -s ${PREFIX}/man/man1/secftp.1.gz ${PREFIX}/man/man1/sftp.1.gz; \
else \
${ECHO} "Other sftp found, not linking sftp to secftp"; \
fi
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
MD5 (sftp-0.9.9.tar.gz) = 9880c86ed928997da069bdb108bf4ad9
SHA256 (sftp-0.9.9.tar.gz) = fe369383503192da004217ae7601c34ee15a1c2e1b963d6fc5da98b533f0e863
SIZE (sftp-0.9.9.tar.gz) = 37632

View file

@ -1,40 +0,0 @@
--- sftp.1.orig Tue Dec 28 11:44:39 1999
+++ sftp.1 Tue Jan 11 11:14:23 2000
@@ -1,11 +1,19 @@
.Dd November 26, 1999
-.Dt sftp 1
+.Dt secftp 1
.Os POSIX
.Sh NAME
+.Nm secftp
.Nm sftp
.Nd
ftp replacement over ssh/rsh
.Sh SYNOPSIS
+.Nm secftp
+.Op Ar -P remotepath
+.Op Ar -l user
+.Op Ar -p port
+.Op Ar -C
+.Op Ar -s sshargs
+.Op Ar hostname
.Nm sftp
.Op Ar -P remotepath
.Op Ar -l user
@@ -18,6 +26,7 @@
.Op Ar -l user
.Op Ar hostname
.Sh DESCRIPTION
+.Nm secftp,
.Nm sftp
and
.Nm rsftp
@@ -25,7 +34,7 @@
programs allows files to be transferred to and from remote servers.
Authentication is provided by the underlying ssh/rsh connection.
.Pp
-When sftp or rsftp is run, the server
+When secftp, sftp or rsftp is run, the server
.Nm (sftpserv)
is automatically run on the remote end.
.Pp

View file

@ -1,36 +0,0 @@
sftp is an ftp replacement that runs over an ssh tunnel. Two programs are
included - sftp and sftpserv. When sftp is run and a host is connected to
(either by running 'sftp remotehost' or 'open remotehost' from the sftp
prompt), an ssh connection is initiated to the remote host, and sftpserv is
run. So, sftpserv must be in your path on the remote host. Note that since
sftpserv is run from ssh, no root privileges are necessary. By default,
sftpserv is expected to be in $PATH on the remote host. This can be overriden
by passing '--enable-remotepath=<path>' to configure or using the
'-P remotepath' option to sftp. To run as a different user, use the
'-l remoteuser' option. To connect to an alternate port with ssh,
use the '-p remoteport' option. To enable ssh compression, use '-C'.
From within sftp, all of the normal ftp commands are present: open, close, get,
put, mget, mput, cd, ls, dir, lcd, delete, rm, pwd, quit. There's also exec,
which runs a program on the remote end. This program must not accept input
('exec ls' is ok, but 'exec vi' is not). To run local commands, precede them
with a '!'.
When building sftp, a link is made to rsftp, which uses rsh instead of ssh.
sftp has been tested with rsh (with and without .rhosts) and ssh1 (with
ssh-agent, password, and RSA authentication). I haven't tested ssh2, but it
should work. The login process is a bit of a hack, so if logging in doesn't
work, it's a bug and should be fixed.
sftp uses a fairly simple multiplexed protocol over an SSH channel. The server
is a state machine, and is far more capable than the client. As an example,
the server theoretically could handle multiple concurrent file transfers, but
the client will only send one.
This was mostly written during the summer of 1998, and resurrected in October,
1999. I don't know how much time I want to spend adding new features, but
bugs will be fixed.
sftp is distributed under the GNU General Public License (GPL), Version 2.
Author: Brian Wellington (bwelling@xbill.org)

View file

@ -1,3 +0,0 @@
bin/secftp
bin/rsftp
bin/sftpserv