- fix packaging when WITH_ICU is off [1]

- fix applications hanging issue (deluge and qbittorrent at least) [2]
- fix interprocess communication (upstream svn revision 76181) [3]
- bump PORTREVISION

PR:		168661 [1]
PR:     169755 [2]
PR:     169806 [3]
Submitted by:	Alexey Markov <redrat at mail dot ru> [1],
                Mario Lobo <lobo@bsd.com.br> [2],
                Martin Matuska <mm at FreeBSD dot org> [3]
Approved by:	maintainer timeout (1 month)
This commit is contained in:
Ruslan Makhmatkhanov 2012-07-13 20:09:11 +00:00
parent cd57934a70
commit e77a8c104f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=300882
4 changed files with 54 additions and 7 deletions

View file

@ -1,5 +1,6 @@
PORTVERSION= 1.48.0 PORTVERSION= 1.48.0
PORTREVISION= 1
PORTVERSUFFIX= ${PORTVERSION:C/\.[0-9]+$//} PORTVERSUFFIX= ${PORTVERSION:C/\.[0-9]+$//}
DISTNAME= boost_${PORTVERSION:S/./_/g} DISTNAME= boost_${PORTVERSION:S/./_/g}

View file

@ -26,9 +26,12 @@ BOOST_LIBS= date_time filesystem graph iostreams\
.include "${PORTSDIR}/devel/boost-all/common.mk" .include "${PORTSDIR}/devel/boost-all/common.mk"
.include "${PORTSDIR}/devel/boost-all/compiled.mk" .include "${PORTSDIR}/devel/boost-all/compiled.mk"
.if defined (WITH_ICU) .if defined(WITH_ICU)
LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu
BJAM_OPTIONS+= -sICU_PATH=${LOCALBASE} BJAM_OPTIONS+= -sICU_PATH=${LOCALBASE}
.else
USE_ICONV= yes
BJAM_OPTIONS+= -sICONV_PATH=${LOCALBASE}
.endif .endif
.if ${ARCH} == "sparc64" .if ${ARCH} == "sparc64"

View file

@ -0,0 +1,37 @@
--- boost/interprocess/shared_memory_object.hpp.orig 2012-07-12 15:27:30.607506166 +0200
+++ boost/interprocess/shared_memory_object.hpp 2012-07-12 15:30:22.481507868 +0200
@@ -1,6 +1,6 @@
//////////////////////////////////////////////////////////////////////////////
//
-// (C) Copyright Ion Gaztanaga 2005-2009. Distributed under the Boost
+// (C) Copyright Ion Gaztanaga 2005-2011. Distributed under the Boost
// Software License, Version 1.0. (See accompanying file
// LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
//
@@ -251,7 +251,7 @@
#if defined(__FreeBSD__)
-inline bool use_filesistem_based_posix()
+inline bool use_filesystem_based_posix()
{
int jailed = 0;
std::size_t len = sizeof(jailed);
@@ -275,7 +275,7 @@
#if defined(BOOST_INTERPROCESS_FILESYSTEM_BASED_POSIX_SHARED_MEMORY)
const bool add_leading_slash = false;
#elif defined(BOOST_INTERPROCESS_RUNTIME_FILESYSTEM_BASED_POSIX_SHARED_MEMORY)
- const bool add_leading_slash = !shared_memory_object_ipcdetail::use_filesistem_based_posix();
+ const bool add_leading_slash = !shared_memory_object_detail::use_filesystem_based_posix();
#else
const bool add_leading_slash = true;
#endif
@@ -361,7 +361,7 @@
#if defined(BOOST_INTERPROCESS_FILESYSTEM_BASED_POSIX_SHARED_MEMORY)
const bool add_leading_slash = false;
#elif defined(BOOST_INTERPROCESS_RUNTIME_FILESYSTEM_BASED_POSIX_SHARED_MEMORY)
- const bool add_leading_slash = !shared_memory_object_ipcdetail::use_filesistem_based_posix();
+ const bool add_leading_slash = !shared_memory_object_detail::use_filesystem_based_posix();
#else
const bool add_leading_slash = true;
#endif

View file

@ -1,23 +1,29 @@
--- boost/asio/detail/io_control.hpp.orig 2010-12-06 01:32:39.000000000 +0300 --- boost/asio/detail/io_control.hpp.orig 2011-06-06 03:21:43.000000000 +0400
+++ boost/asio/detail/io_control.hpp 2010-12-06 01:37:34.000000000 +0300 +++ boost/asio/detail/io_control.hpp 2012-07-10 13:24:45.000000000 +0400
@@ -44,7 +44,7 @@ @@ -44,9 +44,9 @@
} }
// Get the name of the IO control command. // Get the name of the IO control command.
- int name() const - int name() const
+ ioctl_cmd_type name() const + ioctl_cmd_type name() const
{ {
return FIONBIO; - return static_cast<int>(FIONBIO);
+ return static_cast<ioctl_cmd_type>(FIONBIO);
} }
@@ -94,7 +94,7 @@
// Set the value of the I/O control command.
@@ -94,9 +94,9 @@
} }
// Get the name of the IO control command. // Get the name of the IO control command.
- int name() const - int name() const
+ ioctl_cmd_type name() const + ioctl_cmd_type name() const
{ {
return FIONREAD; - return static_cast<int>(FIONREAD);
+ return static_cast<ioctl_cmd_type>(FIONREAD);
} }
// Set the value of the I/O control command.
--- boost/asio/detail/descriptor_ops.hpp.orig 2010-12-06 01:55:08.000000000 +0300 --- boost/asio/detail/descriptor_ops.hpp.orig 2010-12-06 01:55:08.000000000 +0300
+++ boost/asio/detail/descriptor_ops.hpp 2010-12-06 01:55:39.000000000 +0300 +++ boost/asio/detail/descriptor_ops.hpp 2010-12-06 01:55:39.000000000 +0300
@@ -79,7 +79,7 @@ @@ -79,7 +79,7 @@