- Update multimedia/miro to 6.0

- change ffmpeg dependency to ffmpeg1
- update maintainer to swills@ (suggested and accepted over irc)

PR:           ports/181348
Submitted by: Steve Wills <swills _AT_ FreeBSD.org>
Approved by:  decke (mentor)
This commit is contained in:
Armin Pirkovitsch 2013-09-01 12:37:56 +00:00
parent 3c02a4fa33
commit e78916e3b1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=325851
7 changed files with 1154 additions and 1129 deletions

View file

@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= miro
PORTVERSION= 5.0
PORTREVISION= 1
PORTVERSION= 6.0
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.osuosl.org/pub/pculture.org/miro/src/ \
http://ftp.osuosl.org/pub/pculture.org/miro/src/
MAINTAINER= sperber@FreeBSD.org
MAINTAINER= swills@FreeBSD.org
COMMENT= A video player to get internet TV broadcasts
LICENSE= GPLv2
@ -18,12 +17,13 @@ BUILD_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex \
update-mime-database:${PORTSDIR}/misc/shared-mime-info \
${LOCALBASE}/include/boost/numeric/ublas/matrix.hpp:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/include/taglib/taglib.h:${PORTSDIR}/audio/taglib
LIB_DEPENDS= avutil.1:${PORTSDIR}/multimedia/ffmpeg
LIB_DEPENDS= avutil1:${PORTSDIR}/multimedia/ffmpeg1 \
sqlite3:${PORTSDIR}/databases/sqlite3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:${PORTSDIR}/databases/py-bsddb \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_SITELIBDIR}/dbus/glib.py:${PORTSDIR}/devel/py-dbus \
${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify \
${PYTHON_SITELIBDIR}/libtorrent.so:${PORTSDIR}/net-p2p/libtorrent-rasterbar-15-python \
${PYTHON_SITELIBDIR}/libtorrent.so:${PORTSDIR}/net-p2p/libtorrent-rasterbar-16-python \
${PYTHON_SITELIBDIR}/webkit/webkit.so:${PORTSDIR}/www/py-webkitgtk \
${PYTHON_SITELIBDIR}/gtk-2.0/gconf.so:${PORTSDIR}/x11-toolkits/py-gnome2 \
${PYTHON_SITELIBDIR}/pycurl.so:${PORTSDIR}/ftp/py-curl \

View file

@ -1,2 +1,2 @@
SHA256 (miro-5.0.tar.gz) = ff529e5846b6c7e24298cfd1e1cac29feeb4b49ff019151da90a5a955fa39090
SIZE (miro-5.0.tar.gz) = 12938978
SHA256 (miro-6.0.tar.gz) = 558d194278fe5d602ba4d5d6737035b150e907c57da3344afa2ec462062f026b
SIZE (miro-6.0.tar.gz) = 13121803

View file

@ -1,6 +1,6 @@
--- ./lib/startup.py.orig 2011-05-25 00:30:12.000000000 +0200
+++ ./lib/startup.py 2011-05-25 17:53:57.000000000 +0200
@@ -407,8 +407,8 @@
--- lib/startup.py.orig 2013-08-17 02:48:00.884785831 +0000
+++ lib/startup.py 2013-08-17 02:48:27.966783822 +0000
@@ -501,8 +501,8 @@
yield None
commandline.startup()
yield None
@ -8,6 +8,6 @@
- yield None
+ # autoupdate.check_for_updates()
+ # yield None
app.local_metadata_manager.schedule_retry_net_lookup()
# Delay running high CPU/IO operations for a bit
eventloop.add_timeout(5, downloader.startup_downloader,
"start downloader daemon")
eventloop.add_timeout(5, app.download_state_manager.startup_downloader,

View file

@ -1,6 +1,6 @@
--- ./linux/plat/options.py.orig 2011-05-25 17:56:13.000000000 +0200
+++ ./linux/plat/options.py 2011-05-25 17:56:57.000000000 +0200
@@ -51,13 +51,13 @@
--- ./linux/plat/options.py.orig 2013-08-17 02:50:01.620777937 +0000
+++ ./linux/plat/options.py 2013-08-17 02:50:48.339773948 +0000
@@ -51,7 +51,7 @@
FFMPEG_BINARY = LinuxPref(
key="ffmpegBinary",
@ -9,10 +9,3 @@
alias="ffmpeg",
helptext="Absolute path for ffmpeg binary.")
FFMPEG2THEORA_BINARY = LinuxPref(
key="ffmpeg2TheoraBinary",
- default="/usr/bin/ffmpeg2theora",
+ default="%%LOCALBASE%%/bin/ffmpeg2theora",
alias="ffmpeg2theora",
helptext="Absolute path for ffmpeg2theora binary.")

View file

@ -1,6 +1,6 @@
--- linux/setup.py.orig 2012-04-30 16:25:50.000000000 +0200
+++ linux/setup.py 2012-05-12 08:50:18.990985060 +0200
@@ -243,7 +243,7 @@
--- linux/setup.py.orig 2013-04-05 16:02:42.000000000 +0000
+++ linux/setup.py 2013-08-17 04:32:00.154355610 +0000
@@ -249,7 +249,7 @@
xlib_ext = \
Extension("miro.plat.xlibhelper",
[os.path.join(platform_package_dir, 'xlibhelper.pyx')],
@ -9,7 +9,15 @@
libraries=['X11'],
)
@@ -291,7 +291,7 @@
@@ -264,6 +264,7 @@
namecollation_ext = \
Extension("miro.data.namecollation",
[os.path.join(portable_dir, 'data', 'namecollation.cpp')],
+ library_dirs=['/usr/local/lib'],
libraries=['sqlite3'],
)
@@ -300,16 +301,16 @@
# filter out app.config.template (which is handled specially)
files = [f for f in listfiles(resource_dir) \
if os.path.basename(f) != 'app.config.template']
@ -17,17 +25,19 @@
+data_files.append(('/usr/local/share/miro/resources/', files))
# handle the sub directories.
for dir in ('searchengines',
@@ -310,7 +310,7 @@
os.path.join('testdata', 'metadata'),
os.path.join('testdata', 'locale', 'fr', 'LC_MESSAGES')):
for dir in ('searchengines', 'images', 'conversions', 'devices'):
source_dir = os.path.join(resource_dir, dir)
- dest_dir = os.path.join('/usr/share/miro/resources/', dir)
+ dest_dir = os.path.join('/usr/local/share/miro/resources/', dir)
data_files.append((dest_dir, listfiles(source_dir)))
data_files.append((dest_dir, [os.path.join(resource_dir, 'donate.html')]))
for path, dirs, files in os.walk(os.path.join(resource_dir, 'testdata')):
relpath = os.path.relpath(path, resource_dir)
- dest_dir = os.path.join('/usr/share/miro/resources/', relpath)
+ dest_dir = os.path.join('/usr/local/share/miro/resources/', relpath)
files = [os.path.join(resource_dir, relpath, f) for f in files]
data_files.append((dest_dir, files))
@@ -320,7 +320,7 @@
@@ -321,7 +322,7 @@
files = [os.path.join(root, f) for f in files
if (not f.endswith("~") and not "#" in f)]
data_files.append((
@ -36,7 +46,7 @@
files))
# add core platform extension files
@@ -329,28 +329,28 @@
@@ -330,28 +331,28 @@
files = [os.path.join(root, f) for f in files
if (not f.endswith("~") and not "#" in f)]
data_files.append((
@ -73,7 +83,7 @@
[os.path.join(platform_dir, 'miro.real.1.gz')]),
]
@@ -376,7 +376,7 @@
@@ -377,7 +378,7 @@
def install_app_config(self):
source = os.path.join(resource_dir, 'app.config.template')
@ -82,7 +92,7 @@
config_file = buildutils.read_simple_config_file(source)
print "Trying to figure out the git revision...."
@@ -418,7 +418,7 @@
@@ -419,7 +420,7 @@
lang = os.path.basename(source)[:-3]
if 'LINGUAS' in os.environ and lang not in os.environ['LINGUAS']:
continue
@ -91,18 +101,27 @@
if self.root:
dest = change_root(self.root, dest)
self.mkpath(os.path.dirname(dest))
@@ -438,7 +438,9 @@
cc.add_library('avcodec')
@@ -434,12 +435,15 @@
def build_segmenter(self):
segmenter_src = os.path.join(platform_dir, 'miro-segmenter.c')
cc = ccompiler.new_compiler()
- cc.add_library('avutil')
- cc.add_library('avformat')
- cc.add_library('avcodec')
+ cc.add_library('avutil1')
+ cc.add_library('avformat1')
+ cc.add_library('avcodec1')
# Fedora places ffmpeg include into this directory rather than
# root /usr/include.
- cc.add_include_dir('/usr/include/ffmpeg')
+ cc.add_include_dir('/usr/local/include/ffmpeg1')
+ cc.add_include_dir('/usr/local/include')
+ cc.add_include_dir('/usr/local/include/ffmpeg')
+ cc.add_library_dir('/usr/local/lib/ffmpeg1')
+ cc.add_library_dir('/usr/local/lib')
output_dir = os.path.join(self.build_base, 'miro-segmenter')
segmenter_objs = cc.compile([segmenter_src],
output_dir=output_dir,
@@ -449,7 +451,7 @@
@@ -450,7 +454,7 @@
self.distribution.scripts.append(segmenter_exe)
def build_echoprint_codegen(self):
@ -111,7 +130,7 @@
src_binary = os.path.join(echoprint_dir, 'echoprint-codegen')
dest_dir = os.path.join(self.build_base, 'echoprint-codegen')
dest_binary = os.path.join(dest_dir, 'echoprint-codegen')
@@ -488,7 +490,7 @@
@@ -490,7 +494,7 @@
#### install_theme installs a specified theme .zip
class install_theme(Command):
@ -120,7 +139,7 @@
user_options = [("theme=", None, 'ZIP file containing the theme')]
def initialize_options(self):
@@ -516,7 +518,7 @@
@@ -518,7 +522,7 @@
raise DistutilsOptionError("invalid theme file")
self.zipfile = zf
self.theme_name = themeName

View file

@ -1,7 +1,13 @@
--- linux/contrib/echoprint-codegen/src/Makefile.orig 2012-05-17 08:26:52.738877942 +0200
+++ linux/contrib/echoprint-codegen/src/Makefile 2012-05-17 08:27:18.755880033 +0200
@@ -9,7 +9,7 @@
CC=gcc
--- linux/contrib/echoprint-codegen/src/Makefile.orig 2013-04-05 16:02:42.000000000 +0000
+++ linux/contrib/echoprint-codegen/src/Makefile 2013-08-17 03:52:32.669519516 +0000
@@ -5,11 +5,11 @@
VERSION_MAJ := $(word 1, $(EP_VERSION))
VERSION_COMPAT := $(word 1, $(EP_VERSION)).$(word 2, $(EP_VERSION))
UNAME := $(shell uname -s)
-CXX=g++
-CC=gcc
+CXX=c++
+CC=cc
#OPTFLAGS=-g -O0
OPTFLAGS=-O3 -DBOOST_UBLAS_NDEBUG -DNDEBUG
-BOOST_CFLAGS=-I/usr/local/include/boost-1_35

File diff suppressed because it is too large Load diff