- update to 2.3
This commit is contained in:
parent
e8231ee6b6
commit
e7b619c74c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=272129
6 changed files with 40 additions and 57 deletions
|
@ -5,8 +5,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= vice
|
||||
PORTVERSION= 2.2
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 2.3
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://www.viceteam.org/online/ \
|
||||
http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/ \
|
||||
|
@ -68,6 +67,19 @@ MLINKS= vice.1 x64.1 \
|
|||
vice.1 xplus4.1 \
|
||||
vice.1 xcbm2.1
|
||||
|
||||
FIX_XAW= src/arch/unix/x11/xaw/about.c \
|
||||
src/arch/unix/x11/xaw/uicartridge.c \
|
||||
src/arch/unix/x11/xaw/uiedisk.c \
|
||||
src/arch/unix/x11/xaw/uimenu.c \
|
||||
src/arch/unix/x11/xaw/uiscreenshot.c \
|
||||
src/arch/unix/x11/xaw/uisnapshot.c \
|
||||
src/arch/unix/x11/xaw/x11ui.c \
|
||||
src/arch/unix/x11/xaw/widgets/FileSel.c \
|
||||
src/arch/unix/x11/xaw/widgets/FileSelP.h \
|
||||
src/arch/unix/x11/xaw/widgets/MultiList.h \
|
||||
src/arch/unix/x11/xaw/widgets/MultiListP.h \
|
||||
src/arch/unix/x11/xaw/widgets/ScrList.c \
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
INFO= vice
|
||||
.endif
|
||||
|
@ -90,10 +102,6 @@ PLIST_SUB+= FCCACHE="@comment "
|
|||
PLIST_SUB+= NOFCCACHE=""
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/include/esd.h) && !defined(WITHOUT_ESOUND)
|
||||
WITH_ESOUND?=yes
|
||||
.endif
|
||||
|
||||
# will be picked up by configure
|
||||
.if exists(${LOCALBASE}/include/ffmpeg/avformat.h)
|
||||
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
|
||||
|
@ -113,17 +121,10 @@ PLIST_SUB+= NLS="@comment "
|
|||
|
||||
.if !defined(WITHOUT_SDL)
|
||||
USE_SDL= sdl
|
||||
CONFIGURE_ARGS+= --with-sdl --with-sdlsound
|
||||
CONFIGURE_ARGS+= --with-sdlsound
|
||||
CPPFLAGS+= -I${LOCALBASE}/include/SDL
|
||||
.endif
|
||||
|
||||
.if defined(WITH_ESOUND)
|
||||
LIB_DEPENDS+= esd.2:${PORTSDIR}/audio/esound
|
||||
CONFIGURE_ARGS+= --with-esd
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-esd
|
||||
.endif
|
||||
|
||||
.if defined(VICE_WITH_ASOUND)
|
||||
LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
|
||||
.endif
|
||||
|
@ -146,6 +147,13 @@ post-patch:
|
|||
.if defined(NOPORTDOCS)
|
||||
${REINPLACE_CMD} -e 's| doc||' ${WRKSRC}/Makefile.in
|
||||
.endif
|
||||
.if defined(NOPORTDOCS)
|
||||
.if defined(VICE_WITH_XAW3D)
|
||||
.for i in ${FIX_XAW}
|
||||
${REINPLACE_CMD} -e 's|X11/Xaw/|X11/Xaw3d/|' ${WRKSRC}/${i}
|
||||
.endfor
|
||||
.endif
|
||||
.endif
|
||||
|
||||
pre-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
|
|
|
@ -1,3 +1,2 @@
|
|||
MD5 (vice-2.2.tar.gz) = 6737f540806205384e9129026898b0a1
|
||||
SHA256 (vice-2.2.tar.gz) = 5d581bf817c97f1887651f92e73dd1f5e3c14627fa86fc70732491be7cba1551
|
||||
SIZE (vice-2.2.tar.gz) = 9597027
|
||||
SHA256 (vice-2.3.tar.gz) = b1817c8dce023069d5c15234c2b4da0a152d297ee8ed01f0b361795c4beeb50e
|
||||
SIZE (vice-2.3.tar.gz) = 11602378
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- src/arch/unix/x11/xaw/widgets/RegExp.c.orig 2009-10-21 18:46:45.000000000 +0200
|
||||
+++ src/arch/unix/x11/xaw/widgets/RegExp.c 2010-08-02 19:58:49.000000000 +0200
|
||||
@@ -120,7 +120,6 @@
|
||||
/* Dummy for system that don't have neither <regex.h> and <regexp.h>. */
|
||||
|
||||
void RegExpInit(fwf_regex_t *r)
|
||||
- ;
|
||||
{
|
||||
return;
|
||||
}
|
|
@ -1,12 +0,0 @@
|
|||
--- src/arch/unix/x11/xaw/widgets/RegExp.h.orig Sat Dec 4 19:31:32 1999
|
||||
+++ src/arch/unix/x11/xaw/widgets/RegExp.h Fri Sep 17 07:49:53 2004
|
||||
@@ -34,6 +34,9 @@
|
||||
#if defined __FreeBSD__ || defined __NetBSD__
|
||||
#undef HAVE_REGEXP_H
|
||||
#endif
|
||||
+#if defined __FreeBSD__
|
||||
+#undef HAVE_REGEX_H
|
||||
+#endif
|
||||
|
||||
#if defined HAVE_REGEX_H /* POSIX */
|
||||
|
|
@ -1,16 +0,0 @@
|
|||
--- src/arch/unix/joy_usb.c.orig 2009-10-21 18:46:46.000000000 +0200
|
||||
+++ src/arch/unix/joy_usb.c 2009-12-25 18:32:15.000000000 +0100
|
||||
@@ -179,11 +179,9 @@
|
||||
found = 0;
|
||||
is_joy = 0;
|
||||
#if !defined(HAVE_USBHID_H) && !defined(HAVE_LIBUSB_H) && defined(HAVE_LIBUSBHID)
|
||||
- for (d = hid_start_parse(report, id) {
|
||||
- }
|
||||
+ for (d = hid_start_parse(report, id);
|
||||
#else
|
||||
- for (d = hid_start_parse(report, 1 << hid_input, id) {
|
||||
- }
|
||||
+ for (d = hid_start_parse(report, 1 << hid_input, id);
|
||||
#endif
|
||||
hid_get_item(d, &h);
|
||||
)
|
|
@ -5,10 +5,12 @@ bin/vsid
|
|||
bin/x128
|
||||
bin/x64
|
||||
bin/x64dtv
|
||||
bin/x64sc
|
||||
bin/xcbm2
|
||||
bin/xpet
|
||||
bin/xplus4
|
||||
bin/xvic
|
||||
info/vice.txt
|
||||
%%NLS%%share/locale/da/LC_MESSAGES/vice.mo
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/vice.mo
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/vice.mo
|
||||
|
@ -95,6 +97,7 @@ lib/vice/CBM-II/rom256l.vrs
|
|||
lib/vice/CBM-II/rom500.vrs
|
||||
lib/vice/CBM-II/white.vpl
|
||||
lib/vice/CBM-II/x11_buks.vkm
|
||||
lib/vice/CBM-II/x11_buks_de.vkm
|
||||
lib/vice/DRIVES/d1541II
|
||||
lib/vice/DRIVES/d1571cr
|
||||
lib/vice/DRIVES/dos1001
|
||||
|
@ -131,9 +134,17 @@ lib/vice/PET/rom4b80.vrs
|
|||
lib/vice/PET/rom4g40.vrs
|
||||
lib/vice/PET/white.vpl
|
||||
lib/vice/PET/x11_bdep.vkm
|
||||
lib/vice/PET/x11_bdep_de.vkm
|
||||
lib/vice/PET/x11_bdes.vkm
|
||||
lib/vice/PET/x11_bdes_de.vkm
|
||||
lib/vice/PET/x11_bgrs.vkm
|
||||
lib/vice/PET/x11_bgrs_de.vkm
|
||||
lib/vice/PET/x11_buks.vkm
|
||||
lib/vice/PET/x11_buks_de.vkm
|
||||
lib/vice/PET/x11_bgrp.vkm
|
||||
lib/vice/PET/x11_bgrp_de.vkm
|
||||
lib/vice/PET/x11_bukp.vkm
|
||||
lib/vice/PET/x11_bukp_de.vkm
|
||||
lib/vice/PLUS4/3plus1hi
|
||||
lib/vice/PLUS4/3plus1lo
|
||||
lib/vice/PLUS4/basic
|
||||
|
@ -143,6 +154,7 @@ lib/vice/PLUS4/kernal
|
|||
lib/vice/PLUS4/vice.vpl
|
||||
lib/vice/PLUS4/x11_pos.vkm
|
||||
lib/vice/PLUS4/x11_sym.vkm
|
||||
lib/vice/PLUS4/x11_sym_de.vkm
|
||||
lib/vice/PRINTER/cbm1526
|
||||
lib/vice/PRINTER/mps801
|
||||
lib/vice/PRINTER/mps803
|
||||
|
@ -161,6 +173,7 @@ lib/vice/fonts/CBM.ttf
|
|||
%%NOFCCACHE%%lib/vice/fonts/fonts.dir
|
||||
%%PORTDOCS%%%%DOCSDIR%%/64doc.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/BUGS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CIA-README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CommodoreInnovationPriceSoftware2008.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/GP2X-Howto.txt
|
||||
|
@ -178,19 +191,20 @@ lib/vice/fonts/CBM.ttf
|
|||
%%PORTDOCS%%%%DOCSDIR%%/ReadmeMacOSX.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ReadmeSDL.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/VIC-Addendum.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/VIC-Article.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/VIC-Artikel.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Walkthrough-Howto.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Win32-Cygwin-HOWTO.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Win32-Howto.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/amigaos.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/beos.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cartconv.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cbm_basic_tokens.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/coding-guidelines.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/drive_info.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/iec-bus.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/macosx.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mon.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/new.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/openGLsync-howto.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/qnx.html
|
||||
|
|
Loading…
Reference in a new issue