Deorbit devel/sdl10 - it has been superseded by devel/sdl12.
Burn baby, burn!
This commit is contained in:
parent
eda03dc080
commit
e7d4e7d2d2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57822
11 changed files with 0 additions and 514 deletions
|
@ -624,7 +624,6 @@
|
|||
SUBDIR += scandoc
|
||||
SUBDIR += scons
|
||||
SUBDIR += sdcc
|
||||
SUBDIR += sdl10
|
||||
SUBDIR += sdl12
|
||||
SUBDIR += sdlmm
|
||||
SUBDIR += sdts++
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
# New ports collection makefile for: SDL
|
||||
# Date created: 8 August 1999
|
||||
# Whom: Andrey Zakhvatov
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= sdl
|
||||
PORTVERSION= 1.0.8
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.libsdl.org/release/ \
|
||||
http://www.devolution.com/~slouken/SDL/release/
|
||||
DISTNAME= SDL-${PORTVERSION}
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib
|
||||
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_XLIB= yes
|
||||
USE_ESOUND= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm" \
|
||||
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
|
||||
PTHREAD_LIBS="${PTHREAD_LIBS}"
|
||||
CONFIGURE_ARGS= --enable-video-svga
|
||||
|
||||
CFLAGS+= ${PTHREAD_CFLAGS}
|
||||
|
||||
post-configure:
|
||||
@${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
|
||||
${WRKSRC}/libtool
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${PREFIX}/share/examples/SDL
|
||||
${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/SDL
|
||||
.for file in BUGS COPYING CREDITS README WhatsNew docs.html
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL
|
||||
.endfor
|
||||
cd ${WRKSRC}/docs; ${TAR} cf - `${ECHO_CMD} [^M]*` | \
|
||||
(cd ${PREFIX}/share/doc/SDL; ${TAR} --unlink -xf - )
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1 +0,0 @@
|
|||
MD5 (SDL-1.0.8.tar.gz) = c58bcf59d41181c492a06cd10ce97a6a
|
|
@ -1,55 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig Sat Mar 4 04:58:00 2000
|
||||
+++ configure Fri Mar 30 17:04:33 2001
|
||||
@@ -604,9 +604,9 @@
|
||||
|
||||
# libtool versioning
|
||||
LT_RELEASE=$SDL_MAJOR_VERSION.$SDL_MINOR_VERSION
|
||||
-LT_CURRENT=`expr $SDL_MICRO_VERSION - $SDL_INTERFACE_AGE`
|
||||
+LT_CURRENT=$SDL_INTERFACE_AGE
|
||||
LT_REVISION=$SDL_INTERFACE_AGE
|
||||
-LT_AGE=`expr $SDL_BINARY_AGE - $SDL_INTERFACE_AGE`
|
||||
+LT_AGE=$SDL_INTERFACE_AGE
|
||||
|
||||
|
||||
|
||||
@@ -4279,8 +4279,6 @@
|
||||
#include <vga.h>
|
||||
#include <vgamouse.h>
|
||||
#include <vgakeyboard.h>
|
||||
- #include <linux/kd.h>
|
||||
- #include <linux/keyboard.h>
|
||||
|
||||
int main() {
|
||||
|
||||
@@ -4324,7 +4322,7 @@
|
||||
ac_save_libs="$LIBS"
|
||||
case "$target" in
|
||||
*-*-freebsd*)
|
||||
- pthread_lib="-lc_r"
|
||||
+ pthread_lib="${PTHREAD_LIBS}"
|
||||
;;
|
||||
*-*-openbsd*)
|
||||
pthread_lib="-lc_r"
|
||||
@@ -4364,7 +4362,7 @@
|
||||
echo "$ac_t""$use_pthreads" 1>&6
|
||||
if test x$use_pthreads = xyes; then
|
||||
CFLAGS="$CFLAGS -D_REENTRANT -DSDL_USE_PTHREADS"
|
||||
- SDL_CFLAGS="$SDL_CFLAGS -D_REENTRANT"
|
||||
+ SDL_CFLAGS="$SDL_CFLAGS -D_REENTRANT ${PTHREAD_CFLAGS}"
|
||||
SDL_LIBS="$SDL_LIBS $pthread_lib"
|
||||
fi
|
||||
fi
|
||||
@@ -4953,8 +4951,10 @@
|
||||
;;
|
||||
*-*-freebsd*)
|
||||
ARCH=freebsd
|
||||
+ CheckNASM
|
||||
CheckESD
|
||||
CheckX11
|
||||
+ CheckSVGA
|
||||
CheckPTHREAD
|
||||
# Set up files for the main() stub
|
||||
|
|
@ -1,82 +0,0 @@
|
|||
--- src/thread/SDL_thread.c.orig Fri Mar 3 01:24:35 2000
|
||||
+++ src/thread/SDL_thread.c Mon Apr 17 21:05:52 2000
|
||||
@@ -30,6 +30,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include "SDL_error.h"
|
||||
#include "SDL_mutex.h"
|
||||
@@ -175,7 +176,7 @@
|
||||
int (*func)(void *);
|
||||
void *data;
|
||||
SDL_Thread *info;
|
||||
- SDL_mutex *wait;
|
||||
+ int wait;
|
||||
} thread_args;
|
||||
|
||||
void SDL_RunThread(void *data)
|
||||
@@ -199,8 +200,8 @@
|
||||
userdata = args->data;
|
||||
statusloc = &args->info->status;
|
||||
|
||||
/* Wake up the parent thread */
|
||||
- SDL_mutexV(args->wait);
|
||||
+ args->wait = 1;
|
||||
|
||||
/* Run the function */
|
||||
*statusloc = userfunc(userdata);
|
||||
@@ -213,16 +214,16 @@
|
||||
int ret;
|
||||
|
||||
/* Allocate memory for the thread info structure */
|
||||
- thread = (SDL_Thread *)malloc(sizeof(*thread));
|
||||
+ thread = (SDL_Thread *)malloc(sizeof(thread));
|
||||
if ( thread == NULL ) {
|
||||
SDL_OutOfMemory();
|
||||
return(NULL);
|
||||
}
|
||||
- memset(thread, 0, (sizeof *thread));
|
||||
+ memset(thread, 0, (sizeof thread));
|
||||
thread->status = -1;
|
||||
|
||||
/* Set up the arguments for the thread */
|
||||
- args = (thread_args *)malloc(sizeof(*args));
|
||||
+ args = (thread_args *)malloc(sizeof(args));
|
||||
if ( args == NULL ) {
|
||||
SDL_OutOfMemory();
|
||||
free(thread);
|
||||
@@ -231,14 +232,7 @@
|
||||
args->func = fn;
|
||||
args->data = data;
|
||||
args->info = thread;
|
||||
- args->wait = SDL_CreateMutex();
|
||||
- if ( args->wait == NULL ) {
|
||||
- free(thread);
|
||||
- free(args);
|
||||
- SDL_OutOfMemory();
|
||||
- return(NULL);
|
||||
- }
|
||||
- SDL_mutexP(args->wait); /* We will block later */
|
||||
+ args->wait = 0;
|
||||
|
||||
/* Add the thread to the list of available threads */
|
||||
SDL_AddThread(thread);
|
||||
@@ -247,14 +241,14 @@
|
||||
ret = SDL_SYS_CreateThread(thread, args);
|
||||
if ( ret >= 0 ) {
|
||||
/* Wait for the thread function to use arguments */
|
||||
- SDL_mutexP(args->wait);
|
||||
+ while (args->wait == 0)
|
||||
+ usleep(20000);
|
||||
} else {
|
||||
/* Oops, failed. Gotta free everything */
|
||||
SDL_DelThread(thread);
|
||||
free(thread);
|
||||
thread = NULL;
|
||||
}
|
||||
- SDL_DestroyMutex(args->wait);
|
||||
free(args);
|
||||
|
||||
/* Everything is running now */
|
|
@ -1,45 +0,0 @@
|
|||
--- src/thread/linux/SDL_mutex.c.orig Tue Nov 23 20:01:41 1999
|
||||
+++ src/thread/linux/SDL_mutex.c Mon Apr 17 21:08:57 2000
|
||||
@@ -42,6 +42,7 @@
|
||||
|
||||
#ifdef SDL_USE_PTHREADS
|
||||
|
||||
+#include <errno.h>
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
#include <pthread.h>
|
||||
@@ -60,14 +61,14 @@
|
||||
SDL_mutex *mutex;
|
||||
|
||||
/* Allocate the structure */
|
||||
- mutex = (SDL_mutex *)malloc(sizeof(*mutex));
|
||||
+ mutex = (SDL_mutex *)malloc(sizeof(mutex));
|
||||
if ( mutex == NULL ) {
|
||||
SDL_OutOfMemory();
|
||||
return(NULL);
|
||||
}
|
||||
|
||||
if ( pthread_mutex_init(&mutex->id, NULL) != 0 ) {
|
||||
- SDL_SetError("Couldn't create mutex");
|
||||
+ SDL_SetError("Couldn't create mutex; reason: %d", errno);
|
||||
free(mutex);
|
||||
return(NULL);
|
||||
}
|
||||
@@ -82,7 +83,7 @@
|
||||
return(-1);
|
||||
}
|
||||
if ( pthread_mutex_lock(&mutex->id) != 0 ) {
|
||||
- SDL_SetError("Couldn't lock mutex");
|
||||
+ SDL_SetError("Couldn't lock mutex; reason: %d", errno);
|
||||
return(-1);
|
||||
}
|
||||
return(0);
|
||||
@@ -96,7 +97,7 @@
|
||||
return(-1);
|
||||
}
|
||||
if ( pthread_mutex_unlock(&mutex->id) != 0 ) {
|
||||
- SDL_SetError("Couldn't unlock mutex");
|
||||
+ SDL_SetError("Couldn't unlock mutex; reason: %d", errno);
|
||||
return(-1);
|
||||
}
|
||||
return(0);
|
|
@ -1,147 +0,0 @@
|
|||
--- src/video/svga/SDL_svgaevents.c.orig Wed Nov 24 01:46:25 1999
|
||||
+++ src/video/svga/SDL_svgaevents.c Sun Sep 24 00:28:45 2000
|
||||
@@ -28,12 +28,14 @@
|
||||
/* Handle the event stream, converting X11 events into SDL events */
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
#include <vga.h>
|
||||
#include <vgamouse.h>
|
||||
#include <vgakeyboard.h>
|
||||
#include <linux/kd.h>
|
||||
#include <linux/keyboard.h>
|
||||
+#include <sys/kbio.h>
|
||||
|
||||
#include "SDL.h"
|
||||
#include "SDL_sysevents.h"
|
||||
@@ -42,9 +44,8 @@
|
||||
#include "SDL_svgaevents_c.h"
|
||||
|
||||
/* The translation tables from a console scancode to a SDL keysym */
|
||||
-#define NUM_VGAKEYMAPS (1<<KG_CAPSSHIFT)
|
||||
-static Uint16 vga_keymap[NUM_VGAKEYMAPS][NR_KEYS];
|
||||
static SDLKey keymap[128];
|
||||
+keymap_t *vga_keymap = NULL;
|
||||
static SDL_keysym *TranslateKey(int scancode, SDL_keysym *keysym);
|
||||
|
||||
/* Ugh, we have to duplicate the kernel's keysym mapping code...
|
||||
@@ -54,69 +55,10 @@
|
||||
*/
|
||||
void SVGA_initkeymaps(int fd)
|
||||
{
|
||||
- struct kbentry entry;
|
||||
- int map, i;
|
||||
-
|
||||
- /* Load all the keysym mappings */
|
||||
- for ( map=0; map<NUM_VGAKEYMAPS; ++map ) {
|
||||
- memset(vga_keymap[map], 0, NR_KEYS*sizeof(Uint16));
|
||||
- for ( i=0; i<NR_KEYS; ++i ) {
|
||||
- entry.kb_table = map;
|
||||
- entry.kb_index = i;
|
||||
- if ( ioctl(fd, KDGKBENT, &entry) == 0 ) {
|
||||
- /* The "Enter" key is a special case */
|
||||
- if ( entry.kb_value == K_ENTER ) {
|
||||
- entry.kb_value = K(KT_ASCII,13);
|
||||
- }
|
||||
- /* Handle numpad specially as well */
|
||||
- if ( KTYP(entry.kb_value) == KT_PAD ) {
|
||||
- switch ( entry.kb_value ) {
|
||||
- case K_P0:
|
||||
- case K_P1:
|
||||
- case K_P2:
|
||||
- case K_P3:
|
||||
- case K_P4:
|
||||
- case K_P5:
|
||||
- case K_P6:
|
||||
- case K_P7:
|
||||
- case K_P8:
|
||||
- case K_P9:
|
||||
- vga_keymap[map][i]=entry.kb_value;
|
||||
- vga_keymap[map][i]+= '0';
|
||||
- break;
|
||||
- case K_PPLUS:
|
||||
- vga_keymap[map][i]=K(KT_ASCII,'+');
|
||||
- break;
|
||||
- case K_PMINUS:
|
||||
- vga_keymap[map][i]=K(KT_ASCII,'-');
|
||||
- break;
|
||||
- case K_PSTAR:
|
||||
- vga_keymap[map][i]=K(KT_ASCII,'*');
|
||||
- break;
|
||||
- case K_PSLASH:
|
||||
- vga_keymap[map][i]=K(KT_ASCII,'/');
|
||||
- break;
|
||||
- case K_PENTER:
|
||||
- vga_keymap[map][i]=K(KT_ASCII,'\r');
|
||||
- break;
|
||||
- case K_PCOMMA:
|
||||
- vga_keymap[map][i]=K(KT_ASCII,',');
|
||||
- break;
|
||||
- case K_PDOT:
|
||||
- vga_keymap[map][i]=K(KT_ASCII,'.');
|
||||
- break;
|
||||
- default:
|
||||
- break;
|
||||
- }
|
||||
- }
|
||||
- /* Do the normal key translation */
|
||||
- if ( (KTYP(entry.kb_value) == KT_LATIN) ||
|
||||
- (KTYP(entry.kb_value) == KT_ASCII) ||
|
||||
- (KTYP(entry.kb_value) == KT_LETTER) ) {
|
||||
- vga_keymap[map][i] = entry.kb_value;
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
+ vga_keymap = malloc(sizeof(keymap_t));
|
||||
+ if (ioctl(fd, GIO_KEYMAP, vga_keymap) == -1) {
|
||||
+ free(vga_keymap);
|
||||
+ vga_keymap = NULL;
|
||||
}
|
||||
}
|
||||
|
||||
@@ -312,38 +254,24 @@
|
||||
keysym->sym = keymap[scancode];
|
||||
keysym->mod = KMOD_NONE;
|
||||
|
||||
- /* If UNICODE is on, get the UNICODE value for the key */
|
||||
keysym->unicode = 0;
|
||||
- if ( SDL_TranslateUNICODE ) {
|
||||
+ if ( (SDL_TranslateUNICODE) && (vga_keymap != NULL) ) {
|
||||
int map;
|
||||
SDLMod modstate;
|
||||
|
||||
modstate = SDL_GetModState();
|
||||
map = 0;
|
||||
if ( modstate & KMOD_SHIFT ) {
|
||||
- map |= (1<<KG_SHIFT);
|
||||
+ map += 1;
|
||||
}
|
||||
if ( modstate & KMOD_CTRL ) {
|
||||
- map |= (1<<KG_CTRL);
|
||||
+ map += 2;
|
||||
}
|
||||
if ( modstate & KMOD_ALT ) {
|
||||
- map |= (1<<KG_ALT);
|
||||
- }
|
||||
- if ( modstate & KMOD_MODE ) {
|
||||
- map |= (1<<KG_ALTGR);
|
||||
- }
|
||||
- if ( KTYP(vga_keymap[map][scancode]) == KT_LETTER ) {
|
||||
- if ( modstate & KMOD_CAPS ) {
|
||||
- map ^= (1<<KG_SHIFT);
|
||||
- }
|
||||
- }
|
||||
- if ( KTYP(vga_keymap[map][scancode]) == KT_PAD ) {
|
||||
- if ( modstate & KMOD_NUM ) {
|
||||
- keysym->unicode=KVAL(vga_keymap[map][scancode]);
|
||||
- }
|
||||
- } else {
|
||||
- keysym->unicode = KVAL(vga_keymap[map][scancode]);
|
||||
+ map += 4;
|
||||
}
|
||||
+ if ( !(vga_keymap->key[scancode].spcl & (0x80 >> map)) )
|
||||
+ keysym->unicode = vga_keymap->key[scancode].map[map];
|
||||
}
|
||||
return(keysym);
|
||||
}
|
|
@ -1,20 +0,0 @@
|
|||
--- src/video/svga/SDL_svgavideo.c.orig Wed Nov 24 01:46:25 1999
|
||||
+++ src/video/svga/SDL_svgavideo.c Wed Sep 6 13:32:37 2000
|
||||
@@ -33,7 +33,7 @@
|
||||
#include <unistd.h>
|
||||
#include <sys/stat.h>
|
||||
|
||||
-#include <linux/vt.h>
|
||||
+#include <sys/consio.h>
|
||||
#include <vga.h>
|
||||
#include <vgamouse.h>
|
||||
#include <vgakeyboard.h>
|
||||
@@ -328,7 +328,7 @@
|
||||
vga_modeinfo *modeinfo;
|
||||
|
||||
/* Since SVGAlib 1.40 leaks the mouse here, we have to close it */
|
||||
- mouse_close();
|
||||
+ /* mouse_close(); */
|
||||
|
||||
/* Try to set the requested linear video mode */
|
||||
bpp = (bpp+7)/8-1;
|
|
@ -1 +0,0 @@
|
|||
Cross-platform multi-media development API
|
|
@ -1,7 +0,0 @@
|
|||
This library is designed to make it easy to write games that run on UNIX,
|
||||
Win32 and BeOS using the various native high-performance media interfaces,
|
||||
(for video, audio, etc) and presenting a single source-code level API to
|
||||
your application. This is a fairly low level API, but using this, completely
|
||||
portable applications can be written with a great deal of flexibility.
|
||||
|
||||
WWW: http://www.libsdl.org/
|
|
@ -1,106 +0,0 @@
|
|||
bin/sdl-config
|
||||
include/SDL/SDL.h
|
||||
include/SDL/SDL_active.h
|
||||
include/SDL/SDL_audio.h
|
||||
include/SDL/SDL_byteorder.h
|
||||
include/SDL/SDL_cdrom.h
|
||||
include/SDL/SDL_copying.h
|
||||
include/SDL/SDL_endian.h
|
||||
include/SDL/SDL_error.h
|
||||
include/SDL/SDL_events.h
|
||||
include/SDL/SDL_keyboard.h
|
||||
include/SDL/SDL_keysym.h
|
||||
include/SDL/SDL_main.h
|
||||
include/SDL/SDL_mouse.h
|
||||
include/SDL/SDL_mutex.h
|
||||
include/SDL/SDL_quit.h
|
||||
include/SDL/SDL_rwops.h
|
||||
include/SDL/SDL_syswm.h
|
||||
include/SDL/SDL_thread.h
|
||||
include/SDL/SDL_timer.h
|
||||
include/SDL/SDL_types.h
|
||||
include/SDL/SDL_version.h
|
||||
include/SDL/SDL_video.h
|
||||
include/SDL/begin_code.h
|
||||
include/SDL/close_code.h
|
||||
lib/libSDL-1.0.so.2
|
||||
lib/libSDL.a
|
||||
lib/libSDL.so
|
||||
lib/libSDLmain.a
|
||||
share/aclocal/sdl.m4
|
||||
share/doc/SDL/BUGS
|
||||
share/doc/SDL/COPYING
|
||||
share/doc/SDL/CREDITS
|
||||
share/doc/SDL/README
|
||||
share/doc/SDL/WhatsNew
|
||||
share/doc/SDL/audio/examples.html
|
||||
share/doc/SDL/audio/funclist.html
|
||||
share/doc/SDL/audio/functions.html
|
||||
share/doc/SDL/audio/index.html
|
||||
share/doc/SDL/cdrom/examples.html
|
||||
share/doc/SDL/cdrom/funclist.html
|
||||
share/doc/SDL/cdrom/functions.html
|
||||
share/doc/SDL/cdrom/index.html
|
||||
share/doc/SDL/docs.html
|
||||
share/doc/SDL/events/examples.html
|
||||
share/doc/SDL/events/functions.html
|
||||
share/doc/SDL/events/index.html
|
||||
share/doc/SDL/events/keysym.html
|
||||
share/doc/SDL/images/rainbow.gif
|
||||
share/doc/SDL/index.html
|
||||
share/doc/SDL/threads/index.html
|
||||
share/doc/SDL/time/examples.html
|
||||
share/doc/SDL/time/funclist.html
|
||||
share/doc/SDL/time/functions.html
|
||||
share/doc/SDL/time/index.html
|
||||
share/doc/SDL/video/examples.html
|
||||
share/doc/SDL/video/funclist.html
|
||||
share/doc/SDL/video/functions.html
|
||||
share/doc/SDL/video/index.html
|
||||
share/examples/SDL/COPYING
|
||||
share/examples/SDL/Makefile.am
|
||||
share/examples/SDL/Makefile.in
|
||||
share/examples/SDL/README
|
||||
share/examples/SDL/acinclude.m4
|
||||
share/examples/SDL/aclocal.m4
|
||||
share/examples/SDL/autogen.sh
|
||||
share/examples/SDL/checkkeys.c
|
||||
share/examples/SDL/config.guess
|
||||
share/examples/SDL/config.sub
|
||||
share/examples/SDL/configure
|
||||
share/examples/SDL/configure.in
|
||||
share/examples/SDL/graywin.c
|
||||
share/examples/SDL/icon.bmp
|
||||
share/examples/SDL/install-sh
|
||||
share/examples/SDL/loopwave.c
|
||||
share/examples/SDL/missing
|
||||
share/examples/SDL/mkinstalldirs
|
||||
share/examples/SDL/picture.xbm
|
||||
share/examples/SDL/sample.bmp
|
||||
share/examples/SDL/sample.wav
|
||||
share/examples/SDL/testalpha.c
|
||||
share/examples/SDL/testbitmap.c
|
||||
share/examples/SDL/testcdrom.c
|
||||
share/examples/SDL/testerror.c
|
||||
share/examples/SDL/testhread.c
|
||||
share/examples/SDL/testkeys.c
|
||||
share/examples/SDL/testlock.c
|
||||
share/examples/SDL/testsprite.c
|
||||
share/examples/SDL/testtimer.c
|
||||
share/examples/SDL/testtypes.c
|
||||
share/examples/SDL/testver.c
|
||||
share/examples/SDL/testvidinfo.c
|
||||
share/examples/SDL/testwin.c
|
||||
share/examples/SDL/testwm.c
|
||||
share/examples/SDL/threadwin.c
|
||||
@dirrm share/examples/SDL
|
||||
@dirrm share/doc/SDL/video
|
||||
@dirrm share/doc/SDL/time
|
||||
@dirrm share/doc/SDL/threads
|
||||
@dirrm share/doc/SDL/opengl
|
||||
@dirrm share/doc/SDL/images
|
||||
@dirrm share/doc/SDL/events
|
||||
@dirrm share/doc/SDL/cdrom
|
||||
@dirrm share/doc/SDL/audio
|
||||
@dirrm share/doc/SDL
|
||||
@dirrm include/SDL
|
Loading…
Reference in a new issue