sysutils/p5-Quota: unbreak build on 12.x

PR:		235450
Reported by:	Scott Loga <cres24@mac.com>
This commit is contained in:
Kurt Jaeger 2019-02-03 10:33:55 +00:00
parent 80134f3d6f
commit e7e5512f4b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=492044
3 changed files with 26 additions and 7 deletions

View file

@ -16,10 +16,4 @@ LICENSE_COMB= dual
USES= perl5
USE_PERL5= configure
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200072
BROKEN= Fails to build.
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,11 @@
--- Quota.xs.orig 2013-08-15 04:56:35 UTC
+++ Quota.xs
@@ -309,7 +309,7 @@ struct rquota *rqp;
#endif /* MY_XDR */
#ifdef USE_EXT_RQUOTA
-bool_t
+int
xdr_ext_getquota_args(xdrs, objp)
XDR *xdrs;
ext_getquota_args *objp;

View file

@ -0,0 +1,14 @@
--- hints/bsd.h.orig 2013-08-15 04:56:14 UTC
+++ hints/bsd.h
@@ -71,8 +71,9 @@
#define NO_MNTENT
-#define GQA_TYPE_USR RQUOTA_USRQUOTA
-#define GQA_TYPE_GRP RQUOTA_GRPQUOTA
+/* from https://opensource.apple.com/source/NFS/NFS-63/rpc.rquotad/rquota.h.auto.html */
+#define GQA_TYPE_USR 0x00
+#define GQA_TYPE_GRP 0x01
#define GQR_STATUS status
#define GQR_RQUOTA getquota_rslt_u.gqr_rquota