Upgrade to 2.2.1, add a startup script.

PR:		ports/4620
This commit is contained in:
Vanilla I. Shu 1997-12-04 03:41:07 +00:00
parent 1c1ed248e8
commit e8319f569d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=8980
5 changed files with 80 additions and 9 deletions

View file

@ -1,27 +1,32 @@
# New ports collection makefile for: xinetd
# Version required: 2.1.7-freebsd.4
# Version required: 2.2.1
# Date created: 28 June 1996
# Whom: markm
#
# $Id: Makefile,v 1.2 1996/11/17 07:58:10 obrien Exp $
# $Id: Makefile,v 1.3 1996/11/18 14:13:43 asami Exp $
#
DISTNAME= xinetd.2.1.7.4
DISTNAME= xinetd-2.2.1
CATEGORIES= security
MASTER_SITES= ftp://ftp.telebase.com/pub/security/
DISTFILES= xinetd.2.1.7-freebsd.4.tar.gz
MASTER_SITES= ftp://coast.cs.purdue.edu/pub/tools/unix/xinetd/
MAINTAINER= markm@FreeBSD.ORG
WRKSRC= ${WRKDIR}/xinetd.2.1.7-freebsd.4
MAN1= xinetd.1
MAN5= xinetd.conf.5 xinetd.log.5
do-build:
cd ${WRKSRC} ; ./compile-src -os freebsd2 -sf has_SB
cd ${WRKSRC} ; ./compile-src -os freebsd2
do-install:
cd ${WRKSRC}/xinetd ; make install
cd ${WRKSRC}/xinetd ; make install.man
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/xinetd.sh ]; then \
${ECHO} "Install ${PREFIX}/etc/rc.d/xinetd.sh startup file."; \
${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/xinetd.sh; \
${ECHO} "[ -x ${PREFIX}/sbin/xinetd ] && ${PREFIX}/sbin/xinetd && echo -n' xinetd'" >> ${PREFIX}/etc/rc.d/xinetd.sh; \
chmod 751 ${PREFIX}/etc/rc.d/xinetd.sh; \
fi
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (xinetd.2.1.7-freebsd.4.tar.gz) = f2be3c9013e1100774c10d26715b445b
MD5 (xinetd-2.2.1.tar.gz) = e9385076bef59db0fc865b8718e4cfd9

View file

@ -16,4 +16,37 @@
! #define LISTEN_BACKLOG 64
/*
* When explicit values are given for enum's, that is because the structures
* When explicit values are given for enum's, that is because the structures
--- xinetd/Makefile.orig Mon Apr 14 05:29:01 1997
+++ xinetd/Makefile Wed Sep 24 04:54:21 1997
@@ -131,7 +131,8 @@
XMODE = -m 700 # mode for executables
FMODE = -m 640 # mode for anything but executables
-INSTALL = install -c
+INSTALL_PROGRAM = install -c -s
+INSTALL_DATA = install -c
LINT_FLAGS = -hbux
PAGER = less
@@ -178,16 +179,16 @@
rm -f $(OPT_SOURCE) $(OPT_HEADER)
install: $(PROGRAM)
- $(INSTALL) $(XMODE) $(PROGRAM) $(INSTALLDIR)
+ $(INSTALL_PROGRAM) $(XMODE) $(PROGRAM) $(INSTALLDIR)
install.man:
if test "$(MANPROGDIR)" ; then \
- $(INSTALL) $(FMODE) $(MANPROGFILE) $(MANPROGDIR)/$(MANPROGPAGE) ;\
+ $(INSTALL_DATA) $(FMODE) $(MANPROGFILE) $(MANPROGDIR)/$(MANPROGPAGE) ;\
fi
if test "$(MANDATADIR)" ; then \
for i in $(MANDATANAMES) ; do \
name=$(PROGRAM).$$i ; \
- $(INSTALL) $(FMODE) $$name.man $(MANDATADIR)/$$name.$(MANDATASECTION);\
+ $(INSTALL_DATA) $(FMODE) $$name.man $(MANDATADIR)/$$name.$(MANDATASECTION);\
done ;\
fi

View file

@ -0,0 +1,32 @@
--- compile-src.orig Thu Oct 16 09:06:46 1997
+++ compile-src Thu Oct 16 09:09:32 1997
@@ -43,7 +43,7 @@
# The default is optimization.
#
cc=
-ccopt=-O
+ccopt=-O2
lib_defs=
xinetd_defs=
@@ -677,13 +677,13 @@
case "$want_SB" in
yes) modify_manpages=yes ;;
no) modify_manpages= ;;
- *) echo -n "Convert .B -> .SB in man pages ? (if you are not sure, say no) -->"
- read x
- if test "$x" = "y" -o "$x" = "yes"; then
- modify_manpages=yes
- else
- modify_manpages=
- fi
+# *) echo -n "Convert .B -> .SB in man pages ? (if you are not sure, say no) -->"
+# read x
+# if test "$x" = "y" -o "$x" = "yes"; then
+# modify_manpages=yes
+# else
+# modify_manpages=
+# fi
esac
if test "$modify_manpages" ; then

View file

@ -1,3 +1,4 @@
etc/rc.d/xinetd.sh
man/man1/xinetd.1.gz
man/man5/xinetd.conf.5.gz
man/man5/xinetd.log.5.gz