Fix build with gcc34
PR: 69463 Submitted by: Michael Johnson <ahze@ahze.net> Remove gpg sig checking code, the key has expired and the code has too many flaws.
This commit is contained in:
parent
c7a556e470
commit
e84ed6adbf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115217
3 changed files with 12 additions and 24 deletions
|
@ -11,8 +11,7 @@ CATEGORIES+= irc
|
|||
MASTER_SITES= ftp://ftp.bitchx.org/pub/BitchX/source/ \
|
||||
ftp://ftp.cyberpunkz.org/pub/BitchX/source/ \
|
||||
ftp://ftp.cyberpunkz.org/pub/BitchX/tcl-o/:tcl
|
||||
DISTFILES= ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX} \
|
||||
ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}.sig
|
||||
DISTFILES= ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}
|
||||
EXTRACT_ONLY= ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER?= arved@FreeBSD.org
|
||||
|
@ -67,8 +66,7 @@ USE_OPENSSL= yes
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_TCL)
|
||||
DISTFILES+= freebsd4-tcl83-bx1.0c19-tcl.o:tcl \
|
||||
freebsd4-tcl83-bx1.0c19-tcl.o.sig:tcl
|
||||
DISTFILES+= freebsd4-tcl83-bx1.0c19-tcl.o:tcl
|
||||
.endif
|
||||
|
||||
.if defined(WITH_XMMS)
|
||||
|
@ -145,22 +143,6 @@ pre-fetch:
|
|||
.endif # WITH_TCL
|
||||
|
||||
pre-extract:
|
||||
.if exists(${PREFIX}/bin/gpg)
|
||||
@${MKDIR} ${WRKDIR}
|
||||
@${ECHO_CMD} "===> Verifying GnuPG Signatures."
|
||||
-gpg --keyserver pgp.mit.edu --no-default-keyring \
|
||||
--keyring ${WRKDIR}/keyring --recv-key 42D1F77C
|
||||
cd ${DISTDIR}; gpg --keyring ${WRKDIR}/keyring --verify \
|
||||
ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}.sig \
|
||||
ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}
|
||||
.if defined(WITH_TCL)
|
||||
cd ${DISTDIR}; gpg --keyring ${WRKDIR}/keyring --verify \
|
||||
freebsd4-tcl83-bx1.0c19-tcl.o.sig \
|
||||
freebsd4-tcl83-bx1.0c19-tcl.o
|
||||
.endif
|
||||
.else
|
||||
@${ECHO_CMD} "===> GnuPG not installed. Signatures can not be verified"
|
||||
.endif
|
||||
@${ECHO_CMD} "Available switches:"
|
||||
@${ECHO_CMD} "-------------------"
|
||||
.if !defined (WITH_XMMS)
|
||||
|
|
|
@ -1,8 +1,4 @@
|
|||
MD5 (ircii-pana-1.1-final.tar.gz) = 611d2dda222f00c10140236f4c331572
|
||||
SIZE (ircii-pana-1.1-final.tar.gz) = 2532476
|
||||
MD5 (ircii-pana-1.1-final.tar.gz.sig) = 8ac375a0ba463090843403442e446022
|
||||
SIZE (ircii-pana-1.1-final.tar.gz.sig) = 65
|
||||
MD5 (freebsd4-tcl83-bx1.0c19-tcl.o) = a49fd4cab976de64ea8b4215a50a9553
|
||||
SIZE (freebsd4-tcl83-bx1.0c19-tcl.o) = 46620
|
||||
MD5 (freebsd4-tcl83-bx1.0c19-tcl.o.sig) = e02a59d3eb4f3c9d50f0bf28312dd800
|
||||
SIZE (freebsd4-tcl83-bx1.0c19-tcl.o.sig) = 65
|
||||
|
|
10
irc/bitchx/files/patch-source_term_c
Normal file
10
irc/bitchx/files/patch-source_term_c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- source/term.c.orig Fri Jul 23 01:10:02 2004
|
||||
+++ source/term.c Fri Jul 23 01:11:02 2004
|
||||
@@ -92,7 +92,6 @@
|
||||
#endif
|
||||
|
||||
extern char *getenv();
|
||||
-extern char *tparm();
|
||||
|
||||
/*
|
||||
* The old code assumed termcap. termcap is almost always present, but on
|
Loading…
Reference in a new issue