Update to version 1.1.2.

PR:		204495
Submitted by:	kevin.bowling@kev009.com
This commit is contained in:
Dmitry Sivachenko 2015-11-19 15:21:15 +00:00
parent 3106f8e69f
commit e86d582cf9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=401951
10 changed files with 103 additions and 92 deletions

View file

@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= hbase
PORTVERSION= 0.98.9
PORTVERSION= 1.1.2
CATEGORIES= databases java
MASTER_SITES= APACHE/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
LOCAL/demon/:maven \
http://people.freebsd.org/~demon/:maven
MASTER_SITES= APACHE/${PORTNAME}/${PORTVERSION} \
LOCAL/demon/:maven
DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX} FreeBSD-hbase-${PORTVERSION}-maven-repository.tar.gz:maven
DIST_SUBDIR= hadoop
@ -24,7 +23,8 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
USES= cpe
CPE_VENDOR= apache
USE_JAVA= yes
JAVA_VERSION= 1.7+
JAVA_VERSION= 1.7
MAKE_ENV+= JAVA_HOME=${JAVA_HOME} MAVEN_OPTS="-XX:MaxPermSize=256m"
OPTIONS_DEFINE= DOCS
@ -55,8 +55,8 @@ PLIST_SUB= HBASE_USER=${HBASE_USER} \
.include <bsd.port.pre.mk>
.if ${JAVA_PORT_VERSION:M1.8.*}
EXTRA_PATCHES= ${FILESDIR}/extra-patch-PoolMap.java \
${FILESDIR}/extra-patch-pom.xml
EXTRA_PATCHES= ${FILESDIR}/extra-patch-hbase-annotations-pom.xml
MVN_JDK18= -DcompileSource=1.8
.endif
post-patch:
@ -64,9 +64,8 @@ post-patch:
${RM} ${WRKSRC}/conf/hbase-env.sh.bak ${WRKSRC}/conf/hbase-env.sh.orig
do-build:
cd ${WRKSRC} && bash dev-support/generate-hadoopX-poms.sh ${PORTVERSION}-RELEASE ${PORTVERSION}-hadoop2-RELEASE
cd ${WRKSRC} && ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/m2 --offline clean install -Prelease,native -DskipTests
cd ${WRKSRC} && ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/m2 --offline install -DskipTests site assembly:single -Prelease,native
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/m2 --offline clean install -Prelease,native -DskipTests ${MVN_JDK18}
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/m2 --offline install -DskipTests site assembly:single -Prelease,native ${MVN_JDK18}
post-build:
cd ${WRKSRC}/hbase-assembly/target && ${TAR} xf ${PORTNAME}-${PORTVERSION}-bin.tar.gz
@ -84,4 +83,7 @@ do-install:
${MKDIR} ${STAGEDIR}${HBASE_LOGDIR}
${MKDIR} ${STAGEDIR}${HBASE_RUNDIR}
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/hbase/lib/native/libmlockall_agent.so
.include <bsd.port.post.mk>

View file

@ -1,4 +1,4 @@
SHA256 (hadoop/hbase-0.98.9-src.tar.gz) = 351ea47325386323c9d9be6c0c7f01721b19924ffaf0471e962672bca1773846
SIZE (hadoop/hbase-0.98.9-src.tar.gz) = 7611646
SHA256 (hadoop/FreeBSD-hbase-0.98.9-maven-repository.tar.gz) = db6382b65a3aad48f9a42eece7ac498a9fe73ed1f06e10eb51e0bb959097c4db
SIZE (hadoop/FreeBSD-hbase-0.98.9-maven-repository.tar.gz) = 146124469
SHA256 (hadoop/hbase-1.1.2-src.tar.gz) = f107753b41786bdfa255d9fb2ba0ca2a3dc57c390a615b6677c8fcee644ddfd7
SIZE (hadoop/hbase-1.1.2-src.tar.gz) = 15625945
SHA256 (hadoop/FreeBSD-hbase-1.1.2-maven-repository.tar.gz) = 47a8560697a6716d5551a4facb4d4ad2ca814a5b86d5fdbfdd67cc17cdd25d63
SIZE (hadoop/FreeBSD-hbase-1.1.2-maven-repository.tar.gz) = 276578582

View file

@ -1,17 +0,0 @@
--- hbase-client/src/main/java/org/apache/hadoop/hbase/util/PoolMap.java.orig 2014-12-16 06:16:53 UTC
+++ hbase-client/src/main/java/org/apache/hadoop/hbase/util/PoolMap.java
@@ -93,14 +93,6 @@ public class PoolMap<K, V> implements Ma
return null;
}
- /**
- * @deprecated Will be removed for Java 8, use {@link #removeValue} instead
- */
- @Deprecated
- public boolean remove(K key, V value) {
- return removeValue(key, value);
- }
-
public boolean removeValue(K key, V value) {
Pool<V> pool = pools.get(key);
boolean res = false;

View file

@ -0,0 +1,11 @@
--- hbase-annotations/pom.xml.orig 2015-11-19 17:45:45.996448000 +0300
+++ hbase-annotations/pom.xml 2015-11-19 17:45:58.778797000 +0300
@@ -35,7 +35,7 @@
<dependency>
<groupId>jdk.tools</groupId>
<artifactId>jdk.tools</artifactId>
- <version>1.7</version>
+ <version>1.8</version>
<scope>system</scope>
<systemPath>${java.home}/../lib/tools.jar</systemPath>
</dependency>

View file

@ -1,10 +0,0 @@
--- pom.xml.orig 2015-10-02 13:51:13.974582000 +0000
+++ pom.xml 2015-10-02 13:51:17.416694000 +0000
@@ -2064,6 +2064,7 @@
<version>2.9.1</version>
<configuration>
<maxmemory>2048m</maxmemory>
+ <additionalparam>-Xdoclint:none</additionalparam>
</configuration>
<reportSets>
<reportSet>

View file

@ -1,6 +1,6 @@
--- bin/hbase.orig 2014-07-14 09:50:03.000000000 +0400
+++ bin/hbase 2014-11-17 15:26:40.000000000 +0300
@@ -55,6 +55,7 @@
--- bin/hbase.orig 2015-11-11 22:16:01.759936000 -0700
+++ bin/hbase 2015-11-11 22:17:30.695969000 -0700
@@ -57,6 +57,7 @@
bin=`dirname "$0"`
bin=`cd "$bin">/dev/null; pwd`

View file

@ -1,14 +1,14 @@
--- bin/hbase-daemon.sh.orig 2014-07-14 09:50:03.000000000 +0400
+++ bin/hbase-daemon.sh 2014-07-23 18:49:15.000000000 +0400
@@ -89,7 +89,6 @@
--- bin/hbase-daemon.sh.orig 2015-11-11 22:19:14.786233000 -0700
+++ bin/hbase-daemon.sh 2015-11-11 22:19:45.137538000 -0700
@@ -93,7 +93,6 @@
check_before_start(){
#ckeck if the process is not running
- mkdir -p "$HBASE_PID_DIR"
if [ -f $pid ]; then
if kill -0 `cat $pid` > /dev/null 2>&1; then
echo $command running as process `cat $pid`. Stop it first.
@@ -120,7 +119,6 @@
if [ -f $HBASE_PID ]; then
if kill -0 `cat $HBASE_PID` > /dev/null 2>&1; then
echo $command running as process `cat $HBASE_PID`. Stop it first.
@@ -124,7 +123,6 @@
if [ "$HBASE_LOG_DIR" = "" ]; then
export HBASE_LOG_DIR="$HBASE_HOME/logs"
fi

View file

@ -1,6 +1,6 @@
--- conf/hbase-env.sh.bak 2014-07-15 05:23:39.000000000 +0400
+++ conf/hbase-env.sh 2014-07-28 23:05:05.000000000 +0400
@@ -19,6 +19,8 @@
--- conf/hbase-env.sh.orig 2015-11-11 22:32:08.539865000 -0700
+++ conf/hbase-env.sh 2015-11-11 22:34:34.423285000 -0700
@@ -17,6 +17,8 @@
# * limitations under the License.
# */
@ -9,16 +9,16 @@
# Set environment variables here.
# This script sets variables multiple times over the course of starting an hbase process,
@@ -26,7 +28,7 @@
@@ -24,7 +26,7 @@
# into the startup scripts (bin/hbase, etc.)
# The java implementation to use. Java 1.6 required.
# The java implementation to use. Java 1.7+ required.
-# export JAVA_HOME=/usr/java/jdk1.6.0/
+# export JAVA_HOME=/usr/java/jdk1.6.0/ --> Defined in hbase-env-dist.sh
+# export JAVA_HOME=/usr/java/jdk1.6.0/ --> Defined in hbase-env-dist.sh
# Extra Java CLASSPATH elements. Optional.
# export HBASE_CLASSPATH=
@@ -121,7 +123,7 @@
@@ -125,7 +127,7 @@
# export HBASE_SLAVE_SLEEP=0.1
# Tell HBase whether it should manage it's own instance of Zookeeper or not.

View file

@ -0,0 +1,14 @@
--- pom.xml.orig 2015-11-11 22:13:24.366024000 -0700
+++ pom.xml 2015-11-12 02:03:55.927461000 -0700
@@ -1021,6 +1021,11 @@
<artifactId>asciidoctorj-pdf</artifactId>
<version>1.5.0-alpha.6</version>
</dependency>
+ <dependency>
+ <groupId>org.jruby</groupId>
+ <artifactId>jruby-complete</artifactId>
+ <version>9.0.3.0</version>
+ </dependency>
</dependencies>
<configuration>
<outputDirectory>target/site</outputDirectory>

View file

@ -25,6 +25,7 @@ hbase/hbase-webapps/master/WEB-INF/web.xml
hbase/hbase-webapps/master/index.html
hbase/hbase-webapps/regionserver/WEB-INF/web.xml
hbase/hbase-webapps/regionserver/index.html
hbase/hbase-webapps/rest/WEB-INF/web.xml
hbase/hbase-webapps/rest/index.html
hbase/hbase-webapps/static/css/bootstrap-theme.css
hbase/hbase-webapps/static/css/bootstrap-theme.min.css
@ -42,16 +43,21 @@ hbase/hbase-webapps/static/js/bootstrap.js
hbase/hbase-webapps/static/js/bootstrap.min.js
hbase/hbase-webapps/static/js/jquery.min.js
hbase/hbase-webapps/static/js/tab.js
hbase/hbase-webapps/static/jumping-orca_rotated_12percent.png
hbase/hbase-webapps/thrift/WEB-INF/web.xml
hbase/hbase-webapps/thrift/index.html
hbase/lib/activation-1.1.jar
hbase/lib/aopalliance-1.0.jar
hbase/lib/apacheds-i18n-2.0.0-M15.jar
hbase/lib/apacheds-kerberos-codec-2.0.0-M15.jar
hbase/lib/api-asn1-api-1.0.0-M20.jar
hbase/lib/api-util-1.0.0-M20.jar
hbase/lib/asm-3.1.jar
hbase/lib/avro-1.7.4.jar
hbase/lib/commons-beanutils-1.7.0.jar
hbase/lib/commons-beanutils-core-1.8.0.jar
hbase/lib/commons-cli-1.2.jar
hbase/lib/commons-codec-1.7.jar
hbase/lib/commons-codec-1.9.jar
hbase/lib/commons-collections-3.2.1.jar
hbase/lib/commons-compress-1.4.1.jar
hbase/lib/commons-configuration-1.6.jar
@ -61,22 +67,17 @@ hbase/lib/commons-el-1.0.jar
hbase/lib/commons-httpclient-3.1.jar
hbase/lib/commons-io-2.4.jar
hbase/lib/commons-lang-2.6.jar
hbase/lib/commons-logging-1.1.1.jar
hbase/lib/commons-math-2.1.jar
hbase/lib/commons-logging-1.2.jar
hbase/lib/commons-math-2.2.jar
hbase/lib/commons-math3-3.1.1.jar
hbase/lib/commons-net-3.1.jar
hbase/lib/disruptor-3.3.0.jar
hbase/lib/findbugs-annotations-1.3.9-1.jar
hbase/lib/gmbal-api-only-3.0.0-b023.jar
hbase/lib/grizzly-framework-2.1.2.jar
hbase/lib/grizzly-http-2.1.2.jar
hbase/lib/grizzly-http-server-2.1.2.jar
hbase/lib/grizzly-http-servlet-2.1.2.jar
hbase/lib/grizzly-rcm-2.1.2.jar
hbase/lib/guava-12.0.1.jar
hbase/lib/guice-3.0.jar
hbase/lib/guice-servlet-3.0.jar
hbase/lib/hamcrest-core-1.3.jar
hbase/lib/hbase-annotations-%%PORTVERSION%%.jar
hbase/lib/hbase-checkstyle-%%PORTVERSION%%.jar
hbase/lib/hbase-annotations-%%PORTVERSION%%-tests.jar
hbase/lib/hbase-client-%%PORTVERSION%%.jar
hbase/lib/hbase-common-%%PORTVERSION%%-tests.jar
hbase/lib/hbase-common-%%PORTVERSION%%.jar
@ -86,40 +87,36 @@ hbase/lib/hbase-hadoop2-compat-%%PORTVERSION%%.jar
hbase/lib/hbase-it-%%PORTVERSION%%-tests.jar
hbase/lib/hbase-it-%%PORTVERSION%%.jar
hbase/lib/hbase-prefix-tree-%%PORTVERSION%%.jar
hbase/lib/hbase-procedure-%%PORTVERSION%%.jar
hbase/lib/hbase-protocol-%%PORTVERSION%%.jar
hbase/lib/hbase-resource-bundle-%%PORTVERSION%%.jar
hbase/lib/hbase-rest-%%PORTVERSION%%.jar
hbase/lib/hbase-server-%%PORTVERSION%%-tests.jar
hbase/lib/hbase-server-%%PORTVERSION%%.jar
hbase/lib/hbase-shell-%%PORTVERSION%%.jar
hbase/lib/hbase-testing-util-%%PORTVERSION%%.jar
hbase/lib/hbase-thrift-%%PORTVERSION%%.jar
hbase/lib/high-scale-lib-1.1.1.jar
hbase/lib/htrace-core-2.04.jar
hbase/lib/httpclient-4.1.3.jar
hbase/lib/htrace-core-3.1.0-incubating.jar
hbase/lib/httpclient-4.2.5.jar
hbase/lib/httpcore-4.1.3.jar
hbase/lib/jackson-core-asl-1.8.8.jar
hbase/lib/jackson-jaxrs-1.8.8.jar
hbase/lib/jackson-mapper-asl-1.8.8.jar
hbase/lib/jackson-xc-1.8.8.jar
hbase/lib/jackson-core-asl-1.9.13.jar
hbase/lib/jackson-jaxrs-1.9.13.jar
hbase/lib/jackson-mapper-asl-1.9.13.jar
hbase/lib/jackson-xc-1.9.13.jar
hbase/lib/jamon-runtime-2.3.1.jar
hbase/lib/jasper-compiler-5.5.23.jar
hbase/lib/jasper-runtime-5.5.23.jar
hbase/lib/javax.inject-1.jar
hbase/lib/javax.servlet-3.1.jar
hbase/lib/javax.servlet-api-3.0.1.jar
hbase/lib/java-xmlbuilder-0.4.jar
hbase/lib/jaxb-api-2.2.2.jar
hbase/lib/jaxb-impl-2.2.3-1.jar
hbase/lib/jcodings-1.0.8.jar
hbase/lib/jersey-client-1.9.jar
hbase/lib/jersey-core-1.8.jar
hbase/lib/jersey-grizzly2-1.9.jar
hbase/lib/jersey-core-1.9.jar
hbase/lib/jersey-guice-1.9.jar
hbase/lib/jersey-json-1.8.jar
hbase/lib/jersey-server-1.8.jar
hbase/lib/jersey-test-framework-core-1.9.jar
hbase/lib/jersey-test-framework-grizzly2-1.9.jar
hbase/lib/jets3t-0.6.1.jar
hbase/lib/jettison-1.3.1.jar
hbase/lib/jersey-json-1.9.jar
hbase/lib/jersey-server-1.9.jar
hbase/lib/jets3t-0.9.0.jar
hbase/lib/jettison-1.3.3.jar
hbase/lib/jetty-6.1.26.jar
hbase/lib/jetty-sslengine-6.1.26.jar
hbase/lib/jetty-util-6.1.26.jar
@ -130,17 +127,19 @@ hbase/lib/jsp-2.1-6.1.14.jar
hbase/lib/jsp-api-2.1-6.1.14.jar
hbase/lib/jsr305-1.3.9.jar
hbase/lib/junit-4.11.jar
hbase/lib/leveldbjni-all-1.8.jar
hbase/lib/libthrift-0.9.0.jar
hbase/lib/log4j-1.2.17.jar
hbase/lib/management-api-3.0.0-b012.jar
hbase/lib/metrics-core-2.2.0.jar
hbase/lib/native/libmlockall_agent.so
hbase/lib/netty-3.6.6.Final.jar
hbase/lib/netty-3.2.4.Final.jar
hbase/lib/netty-all-4.0.23.Final.jar
hbase/lib/paranamer-2.3.jar
hbase/lib/protobuf-java-2.5.0.jar
hbase/lib/ruby/hbase.rb
hbase/lib/ruby/hbase/admin.rb
hbase/lib/ruby/hbase/hbase.rb
hbase/lib/ruby/hbase/quotas.rb
hbase/lib/ruby/hbase/replication_admin.rb
hbase/lib/ruby/hbase/security.rb
hbase/lib/ruby/hbase/table.rb
@ -155,9 +154,11 @@ hbase/lib/ruby/shell/commands/alter_async.rb
hbase/lib/ruby/shell/commands/alter_namespace.rb
hbase/lib/ruby/shell/commands/alter_status.rb
hbase/lib/ruby/shell/commands/append.rb
hbase/lib/ruby/shell/commands/append_peer_tableCFs.rb
hbase/lib/ruby/shell/commands/assign.rb
hbase/lib/ruby/shell/commands/balance_switch.rb
hbase/lib/ruby/shell/commands/balancer.rb
hbase/lib/ruby/shell/commands/balancer_enabled.rb
hbase/lib/ruby/shell/commands/catalogjanitor_enabled.rb
hbase/lib/ruby/shell/commands/catalogjanitor_run.rb
hbase/lib/ruby/shell/commands/catalogjanitor_switch.rb
@ -178,20 +179,22 @@ hbase/lib/ruby/shell/commands/describe_namespace.rb
hbase/lib/ruby/shell/commands/disable.rb
hbase/lib/ruby/shell/commands/disable_all.rb
hbase/lib/ruby/shell/commands/disable_peer.rb
hbase/lib/ruby/shell/commands/disable_table_replication.rb
hbase/lib/ruby/shell/commands/drop.rb
hbase/lib/ruby/shell/commands/drop_all.rb
hbase/lib/ruby/shell/commands/drop_namespace.rb
hbase/lib/ruby/shell/commands/enable.rb
hbase/lib/ruby/shell/commands/enable_all.rb
hbase/lib/ruby/shell/commands/enable_peer.rb
hbase/lib/ruby/shell/commands/enable_table_replication.rb
hbase/lib/ruby/shell/commands/exists.rb
hbase/lib/ruby/shell/commands/flush.rb
hbase/lib/ruby/shell/commands/get.rb
hbase/lib/ruby/shell/commands/get_auths.rb
hbase/lib/ruby/shell/commands/get_counter.rb
hbase/lib/ruby/shell/commands/get_splits.rb
hbase/lib/ruby/shell/commands/get_table.rb
hbase/lib/ruby/shell/commands/grant.rb
hbase/lib/ruby/shell/commands/hlog_roll.rb
hbase/lib/ruby/shell/commands/incr.rb
hbase/lib/ruby/shell/commands/is_disabled.rb
hbase/lib/ruby/shell/commands/is_enabled.rb
@ -200,6 +203,7 @@ hbase/lib/ruby/shell/commands/list_labels.rb
hbase/lib/ruby/shell/commands/list_namespace.rb
hbase/lib/ruby/shell/commands/list_namespace_tables.rb
hbase/lib/ruby/shell/commands/list_peers.rb
hbase/lib/ruby/shell/commands/list_quotas.rb
hbase/lib/ruby/shell/commands/list_replicated_tables.rb
hbase/lib/ruby/shell/commands/list_snapshots.rb
hbase/lib/ruby/shell/commands/major_compact.rb
@ -207,11 +211,13 @@ hbase/lib/ruby/shell/commands/merge_region.rb
hbase/lib/ruby/shell/commands/move.rb
hbase/lib/ruby/shell/commands/put.rb
hbase/lib/ruby/shell/commands/remove_peer.rb
hbase/lib/ruby/shell/commands/remove_peer_tableCFs.rb
hbase/lib/ruby/shell/commands/restore_snapshot.rb
hbase/lib/ruby/shell/commands/revoke.rb
hbase/lib/ruby/shell/commands/scan.rb
hbase/lib/ruby/shell/commands/set_auths.rb
hbase/lib/ruby/shell/commands/set_peer_tableCFs.rb
hbase/lib/ruby/shell/commands/set_quota.rb
hbase/lib/ruby/shell/commands/set_visibility.rb
hbase/lib/ruby/shell/commands/show_filters.rb
hbase/lib/ruby/shell/commands/show_peer_tableCFs.rb
@ -223,15 +229,20 @@ hbase/lib/ruby/shell/commands/trace.rb
hbase/lib/ruby/shell/commands/truncate.rb
hbase/lib/ruby/shell/commands/truncate_preserve.rb
hbase/lib/ruby/shell/commands/unassign.rb
hbase/lib/ruby/shell/commands/update_all_config.rb
hbase/lib/ruby/shell/commands/update_config.rb
hbase/lib/ruby/shell/commands/user_permission.rb
hbase/lib/ruby/shell/commands/version.rb
hbase/lib/ruby/shell/commands/wal_roll.rb
hbase/lib/ruby/shell/commands/whoami.rb
hbase/lib/ruby/shell/commands/zk_dump.rb
hbase/lib/ruby/shell/formatter.rb
hbase/lib/servlet-api-2.5.jar
hbase/lib/servlet-api-2.5-6.1.14.jar
hbase/lib/slf4j-api-1.6.4.jar
hbase/lib/slf4j-log4j12-1.6.4.jar
hbase/lib/slf4j-api-1.7.7.jar
hbase/lib/slf4j-log4j12-1.7.5.jar
hbase/lib/snappy-java-1.0.4.1.jar
hbase/lib/spymemcached-2.11.6.jar
hbase/lib/xmlenc-0.52.jar
hbase/lib/xz-1.0.jar
hbase/lib/zookeeper-3.4.6.jar