fcgiwrap is a simple server for running CGI applications over FastCGI. It hopes
to provide clean CGI support to Nginx (and other web servers that may need it). Features: * very lightweight (84KB of private memory per instance) * fixes broken CR/LF in headers * handles environment in a sane way (CGI scripts get HTTP-related env. vars * from FastCGI parameters and inherit all the others from fcgiwrap's * environment) * no configuration, so you can run several sites off the same fcgiwrap pool * passes CGI stderr output to fcgiwrap's stderr (this is by design but * stderr could be also passed to FastCGI stderr stream) WWW: http://nginx.localdomain.pl/wiki/FcgiWrap PR: ports/148649 Submitted by: Bapt <baptiste.daroussin at gmail.com>
This commit is contained in:
parent
93bedc3013
commit
e8882f0dbc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=257991
5 changed files with 60 additions and 0 deletions
|
@ -222,6 +222,7 @@
|
|||
SUBDIR += eyeos
|
||||
SUBDIR += eyeos-themes
|
||||
SUBDIR += fcgi
|
||||
SUBDIR += fcgiwrap
|
||||
SUBDIR += feedjack
|
||||
SUBDIR += feedonfeeds
|
||||
SUBDIR += ffproxy
|
||||
|
|
32
www/fcgiwrap/Makefile
Normal file
32
www/fcgiwrap/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# New ports collection makefile for: fcgiwrap
|
||||
# Date created: 2010-06-15
|
||||
# Whom: Bapt <baptiste.daroussin@gmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fcgiwrap
|
||||
PORTVERSION= 1.0.3
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://cloud.github.com/downloads/gnosek/fcgiwrap/
|
||||
|
||||
MAINTAINER= baptiste.daroussin@gmail.com
|
||||
COMMENT= Simple FastCGI wrapper for CGI scripts
|
||||
|
||||
LIB_DEPENDS= fcgi.0:${PORTSDIR}/www/fcgi
|
||||
|
||||
WRKSRC= ${WRKDIR}/gnosek-fcgiwrap-2e301c8
|
||||
LICENSE= MIT
|
||||
|
||||
USE_AUTOTOOLS= autoconf:262:env autoheader:262
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
MAN8= fcgiwrap.8
|
||||
PLIST_FILES= sbin/fcgiwrap
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} 's/@prefix@@mandir@/@mandir@/' ${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
3
www/fcgiwrap/distinfo
Normal file
3
www/fcgiwrap/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (fcgiwrap-1.0.3.tar.gz) = be73d90df7c4442084463e2815fc213d
|
||||
SHA256 (fcgiwrap-1.0.3.tar.gz) = 676015dd1e834fba76fba92ead512f9b13e73fde631cf6aaef6a207d600d6edf
|
||||
SIZE (fcgiwrap-1.0.3.tar.gz) = 8828
|
10
www/fcgiwrap/files/patch-fcgiwrap.c
Normal file
10
www/fcgiwrap/files/patch-fcgiwrap.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- ./fcgiwrap.c.orig 2010-06-03 16:18:21.000000000 +0200
|
||||
+++ ./fcgiwrap.c 2010-06-15 14:54:38.232029168 +0200
|
||||
@@ -43,6 +43,7 @@
|
||||
#include <ctype.h>
|
||||
|
||||
#include <arpa/inet.h>
|
||||
+#include <netinet/in.h>
|
||||
#include <sys/socket.h>
|
||||
#include <sys/un.h>
|
||||
|
14
www/fcgiwrap/pkg-descr
Normal file
14
www/fcgiwrap/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
|||
fcgiwrap is a simple server for running CGI applications over FastCGI. It hopes
|
||||
to provide clean CGI support to Nginx (and other web servers that may need it).
|
||||
|
||||
Features:
|
||||
* very lightweight (84KB of private memory per instance)
|
||||
* fixes broken CR/LF in headers
|
||||
* handles environment in a sane way (CGI scripts get HTTP-related env. vars
|
||||
* from FastCGI parameters and inherit all the others from fcgiwrap's
|
||||
* environment)
|
||||
* no configuration, so you can run several sites off the same fcgiwrap pool
|
||||
* passes CGI stderr output to fcgiwrap's stderr (this is by design but
|
||||
* stderr could be also passed to FastCGI stderr stream)
|
||||
|
||||
WWW: http://nginx.localdomain.pl/wiki/FcgiWrap
|
Loading…
Reference in a new issue