sysutils/rc_subr has not been needed for a long time, all supported
versions of FreeBSD now contain /etc/rc.subr in the base. Version 1.636 of bsd.port.mk removed support for the RC_SUBR and RC_SUBR_SUFFIX macros, so this is the last of the old infrastructure to go. R C D here now No longer is the N G Services rejoice
This commit is contained in:
parent
31ae7c69e0
commit
e8b0aab59c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=252778
6 changed files with 1 additions and 60 deletions
1
MOVED
1
MOVED
|
@ -4363,3 +4363,4 @@ graphics/php5-ming||2010-04-09|Removed from core php
|
|||
security/php5-mhash|security/php5-hash|2010-04-09|Wrapper in hash extension
|
||||
databases/php5-oci8||2010-04-11|Doesn't support Oracle8 client library
|
||||
databases/php5-pdo_oci||2010-04-11|Doesn't support Oracle8 client library
|
||||
sysutils/rc_subr||2010-04-16|No longer needed
|
||||
|
|
|
@ -661,7 +661,6 @@
|
|||
SUBDIR += radeontool
|
||||
SUBDIR += radmind
|
||||
SUBDIR += raincoat
|
||||
SUBDIR += rc_subr
|
||||
SUBDIR += rclean
|
||||
SUBDIR += rcsedit
|
||||
SUBDIR += rdate
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
# New ports collection makefile for: rc_subr
|
||||
# Date created: July 4, 2003
|
||||
# Whom: hetzels@westbend.net
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= rc_subr
|
||||
PORTVERSION= 1.31
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= eik
|
||||
|
||||
MAINTAINER= dougb@FreeBSD.org
|
||||
COMMENT= Common startup and shutdown subroutines used by scripts
|
||||
|
||||
USE_BZIP2= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
MAN8= rc.subr.8
|
||||
PLIST_FILES= etc/rc.subr \
|
||||
${EXAMPLESDIR:S,^${PREFIX}/,,}/README \
|
||||
${EXAMPLESDIR:S,^${PREFIX}/,,}/example.sh
|
||||
PLIST_DIRS= ${EXAMPLESDIR:S,^${PREFIX}/,,}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's, (/etc(/rc.subr| )), ${PREFIX}\1,g' \
|
||||
${WRKSRC}/rc.subr.8
|
||||
|
||||
do-install:
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/rc.subr ${PREFIX}/etc
|
||||
@${INSTALL_MAN} ${WRKSRC}/rc.subr.8 ${MAN8PREFIX}/man/man8
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/example.sh ${EXAMPLESDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (rc_subr-1.31.tar.bz2) = e4e162b67c57f95274aec61a2fbd8578
|
||||
SHA256 (rc_subr-1.31.tar.bz2) = c8997abfb987de84dc779a6b3ced5e2ee68eec0ae3b59fa8239f24ab204681c8
|
||||
SIZE (rc_subr-1.31.tar.bz2) = 15622
|
|
@ -1,11 +0,0 @@
|
|||
--- rc.subr.orig Tue Aug 10 14:26:29 2004
|
||||
+++ rc.subr Mon Jul 18 09:42:30 2005
|
||||
@@ -203,7 +203,7 @@
|
||||
fi
|
||||
read _pid _junk < $_pidfile
|
||||
if [ -z "$_pid" ]; then
|
||||
- debug "pid file {$_pidfile): no pid in file."
|
||||
+ debug "pid file ($_pidfile): no pid in file."
|
||||
return
|
||||
fi
|
||||
_find_processes $_procname ${_interpreter:-.} '-p '"$_pid"
|
|
@ -1,7 +0,0 @@
|
|||
With the change to a new rc system in FreeBSD 5.x, common routines for
|
||||
starting, stopping, and restarting daemons was placed into /etc/rc.subr.
|
||||
this makes it easier to write new startup/shutdown scripts and to have
|
||||
them ordered correctly with rcorder.
|
||||
|
||||
While FreeBSD < 5.x won't be able to take advantage of rcorder. We can
|
||||
take advantage of the simplified startup/shutdown scripts by using rc.subr.
|
Loading…
Reference in a new issue