Math::Int64 adds support for 64 bit integers, signed and unsigned, to Perl.
WWW: http://search.cpan.org/dist/Math-Int64/ PR: ports/174359 Submitted by: fbsd-ports@opsec.eu
This commit is contained in:
parent
06f984a30b
commit
e8f1c73d07
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=309299
6 changed files with 64 additions and 0 deletions
|
@ -413,6 +413,7 @@
|
|||
SUBDIR += p5-Math-Geometry-Planar-Offset
|
||||
SUBDIR += p5-Math-Geometry-Voronoi
|
||||
SUBDIR += p5-Math-Gradient
|
||||
SUBDIR += p5-Math-Int128
|
||||
SUBDIR += p5-Math-Int64
|
||||
SUBDIR += p5-Math-Interpolate
|
||||
SUBDIR += p5-Math-Intersection-StraightLine
|
||||
|
|
26
math/p5-Math-Int128/Makefile
Normal file
26
math/p5-Math-Int128/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# Created by: Kurt Jaeger <fbsd-ports@opsec.eu>
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= Math-Int128
|
||||
PORTVERSION= 0.07
|
||||
CATEGORIES= math perl5
|
||||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= fbsd-ports@opsec.eu
|
||||
COMMENT= Manipulate 128 bits integers in Perl
|
||||
|
||||
LICENSE= ART10
|
||||
|
||||
BUILD_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
|
||||
RUN_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
USE_GCC= 4.4+
|
||||
|
||||
MAN3= Math::Int128.3 \
|
||||
Math::Int128::die_on_overflow.3
|
||||
|
||||
.include <bsd.port.mk>
|
2
math/p5-Math-Int128/distinfo
Normal file
2
math/p5-Math-Int128/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (Math-Int128-0.07.tar.gz) = 5401691a22f723d3834c086b76e933b5bf01ff2c69d6e37b675e75cfc664efe9
|
||||
SIZE (Math-Int128-0.07.tar.gz) = 60412
|
23
math/p5-Math-Int128/files/patch-Makefile.PL
Normal file
23
math/p5-Math-Int128/files/patch-Makefile.PL
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- Makefile.PL 2012-12-10 21:27:04.000000000 +0100
|
||||
+++ /tmp/Makefile.PL 2012-12-11 07:17:41.000000000 +0100
|
||||
@@ -14,13 +14,14 @@
|
||||
OBJECT => '$(O_FILES)',
|
||||
);
|
||||
|
||||
-my $cc = (grep defined, $mm->{CC}, $Config{cc}, 'cc')[0];
|
||||
+# my $cc = (grep defined, $mm->{CC}, $Config{cc}, 'cc')[0];
|
||||
+my $cc = 'gcc44';
|
||||
my $cc_version = `$cc --version --verbose 2>&1`;
|
||||
-unless ($cc_version =~ /^GNU\s+C\s+\([^)]*\)\s+version\s+(4\.(\d+)\S*)/im and $2 >= 4) {
|
||||
- unlink $mm->{MAKEFILE};
|
||||
- die "This module requires version 4.4 or above of the GCC compiler.\nAborting!\n\n"
|
||||
-}
|
||||
-print "GNU C compiler version $1 found, good!\n";
|
||||
+#unless ($cc_version =~ /^GNU\s+C\s+\([^)]*\)\s+version\s+(4\.(\d+)\S*)/im and $2 >= 4) {
|
||||
+# unlink $mm->{MAKEFILE};
|
||||
+# die "This module requires version 4.4 or above of the GCC compiler.\nAborting!\n\n"
|
||||
+#}
|
||||
+#print "GNU C compiler version $1 found, good!\n";
|
||||
|
||||
package MY;
|
||||
|
3
math/p5-Math-Int128/pkg-descr
Normal file
3
math/p5-Math-Int128/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
Math::Int64 adds support for 64 bit integers, signed and unsigned, to Perl.
|
||||
|
||||
WWW: http://search.cpan.org/dist/Math-Int64/
|
9
math/p5-Math-Int128/pkg-plist
Normal file
9
math/p5-Math-Int128/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
%%SITE_PERL%%/%%PERL_ARCH%%/Math/Int128.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/Math/Int128/die_on_overflow.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128/.packlist
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128/Int128.bs
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128/Int128.so
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math/Int128
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math
|
Loading…
Reference in a new issue