elfutils: Update to latest 0.179
Bump portrevision in kcov, which depends on elfutils ABI. Discussed with: asomers, mat Approved by: jrm Differential Revision: https://reviews.freebsd.org/D24614
This commit is contained in:
parent
fbf1ac8981
commit
e94ef01405
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=534194
16 changed files with 81 additions and 189 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= elfutils
|
||||
PORTVERSION= 0.174
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 0.179
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://sourceware.org/elfutils/ftp/${PORTVERSION}/
|
||||
|
||||
|
@ -16,23 +15,25 @@ LICENSE_FILE_GPLv3+ = ${WRKSRC}/COPYING
|
|||
LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING-GPLV2
|
||||
LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING-LGPLV3
|
||||
|
||||
IGNORE_FreeBSD_11= fails to build: fails to compile dwarf_abbrev_hash.c
|
||||
BROKEN_armv6= fails to build: fails to compile i386_disasm.c
|
||||
BROKEN_armv7= fails to build: fails to compile i386_disasm.c
|
||||
BROKEN_sparc64= sparc patch does not apply cleanly to 0.172
|
||||
|
||||
LIB_DEPENDS= libargp.so:devel/argp-standalone
|
||||
PATCH_DEPENDS= ${NONEXISTENT}:devel/gnulib:extract
|
||||
BUILD_DEPENDS= gnulib>=0:devel/gnulib
|
||||
|
||||
PLIST_SUB= VERSION=${PORTVERSION}
|
||||
|
||||
OPTIONS_DEFINE= NLS
|
||||
OPTIONS_DEFINE= MANPAGES NLS
|
||||
OPTIONS_DEFAULT= MANPAGES
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
NLS_USES= gettext
|
||||
NLS_USES_OFF= gettext # used anyway
|
||||
NLS_CONFIGURE_ENABLE= nls
|
||||
|
||||
USES= autoreconf gmake libtool tar:bzip2
|
||||
USES= autoreconf gmake libtool pkgconfig tar:bzip2
|
||||
USE_GCC= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
@ -45,13 +46,14 @@ CFLAGS_i386+= -Wno-error
|
|||
|
||||
# Avoid conflict with binutils / elftoolchain programs with the same names:
|
||||
CONFIGURE_ARGS+= --program-prefix=eu-
|
||||
# Disable debuginfod until option support can be added:
|
||||
CONFIGURE_ARGS+= --disable-debuginfod
|
||||
|
||||
post-patch:
|
||||
@${LN} -s `${MAKE} -C ${PORTSDIR}/devel/gnulib -V WRKSRC` ${WRKDIR}/gnulib
|
||||
pre-configure:
|
||||
@${CP} -a \
|
||||
${WRKDIR}/gnulib/lib/obstack.c \
|
||||
${WRKDIR}/gnulib/lib/obstack.h \
|
||||
${WRKDIR}/gnulib/lib/obstack_printf.c \
|
||||
${LOCALBASE}/share/gnulib/lib/obstack.c \
|
||||
${LOCALBASE}/share/gnulib/lib/obstack.h \
|
||||
${LOCALBASE}/share/gnulib/lib/obstack_printf.c \
|
||||
${WRKSRC}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1536943739
|
||||
SHA256 (elfutils-0.174.tar.bz2) = cdf27e70076e10a29539d89e367101d516bc4aa11b0d7777fe52139e3fcad08a
|
||||
SIZE (elfutils-0.174.tar.bz2) = 8700793
|
||||
TIMESTAMP = 1585570776
|
||||
SHA256 (elfutils-0.179.tar.bz2) = 25a545566cbacaa37ae6222e58f1c48ea4570f53ba991886e2f5ce96e22a23a2
|
||||
SIZE (elfutils-0.179.tar.bz2) = 9057637
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
diff --git libelf/elf32_fsize.c libelf/elf32_fsize.c
|
||||
index fddae91e..16919daa 100644
|
||||
--- libelf/elf32_fsize.c
|
||||
+++ libelf/elf32_fsize.c
|
||||
@@ -64,5 +64,3 @@ elfw2(LIBELFBITS, fsize) (Elf_Type type, size_t count, unsigned int version)
|
||||
* __libelf_type_sizes[0][ELFW(ELFCLASS,LIBELFBITS) - 1][type]);
|
||||
#endif
|
||||
}
|
||||
-#define local_strong_alias(n1, n2) strong_alias (n1, n2)
|
||||
-local_strong_alias (elfw2(LIBELFBITS, fsize), __elfw2(LIBELFBITS, msize))
|
||||
diff --git libelf/libelfP.h libelf/libelfP.h
|
||||
index ed216c8c..c6bb992d 100644
|
||||
--- libelf/libelfP.h
|
||||
+++ libelf/libelfP.h
|
||||
@@ -454,17 +454,6 @@ extern const uint_fast8_t __libelf_type_aligns[EV_NUM - 1][ELFCLASSNUM - 1][ELF_
|
||||
be ELF_T_BYTE. */
|
||||
extern Elf_Type __libelf_data_type (Elf *elf, int sh_type) internal_function;
|
||||
|
||||
-/* The libelf API does not have such a function but it is still useful.
|
||||
- Get the memory size for the given type.
|
||||
-
|
||||
- These functions cannot be marked internal since they are aliases
|
||||
- of the export elfXX_fsize functions.*/
|
||||
-extern size_t __elf32_msize (Elf_Type __type, size_t __count,
|
||||
- unsigned int __version);
|
||||
-extern size_t __elf64_msize (Elf_Type __type, size_t __count,
|
||||
- unsigned int __version);
|
||||
-
|
||||
-
|
||||
/* Create Elf descriptor from memory image. */
|
||||
extern Elf *__libelf_read_mmaped_file (int fildes, void *map_address,
|
||||
off_t offset, size_t maxsize,
|
|
@ -1,6 +1,6 @@
|
|||
--- lib/Makefile.am.orig 2017-11-22 03:44:22.000000000 -0800
|
||||
--- lib/Makefile.am.orig 2020-03-30 12:17:45 UTC
|
||||
+++ lib/Makefile.am
|
||||
@@ -35,7 +35,8 @@
|
||||
@@ -35,7 +35,8 @@ noinst_LIBRARIES = libeu.a
|
||||
|
||||
libeu_a_SOURCES = xstrdup.c xstrndup.c xmalloc.c next_prime.c \
|
||||
crc32.c crc32_file.c \
|
||||
|
@ -9,4 +9,4 @@
|
|||
+ error.c obstack.c obstack_printf.c
|
||||
|
||||
noinst_HEADERS = fixedsizehash.h libeu.h system.h dynamicsizehash.h list.h \
|
||||
eu-config.h color.h printversion.h bpf.h
|
||||
eu-config.h color.h printversion.h bpf.h \
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- lib/eu-config.h.orig 2015-06-11 11:38:55 UTC
|
||||
--- lib/eu-config.h.orig 2020-03-30 12:17:45 UTC
|
||||
+++ lib/eu-config.h
|
||||
@@ -187,4 +187,180 @@ asm (".section predict_data, \"aw\"; .pr
|
||||
#endif
|
||||
@@ -176,6 +176,182 @@ asm (".section predict_data, \"aw\"; .previous\n"
|
||||
#define ELFUTILS_HEADER(name) <lib##name.h>
|
||||
|
||||
|
||||
+/* FreeBSD ports of glibcisms */
|
||||
|
@ -180,4 +180,6 @@
|
|||
+#define ngettext(s, p, n) (((n) == 1) ? (s) : (p))
|
||||
+#endif
|
||||
+
|
||||
#endif /* eu-config.h */
|
||||
#ifdef SYMBOL_VERSIONING
|
||||
# define OLD_VERSION(name, version) \
|
||||
asm (".globl _compat." #version "." #name "\n" \
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- libdw/Makefile.am.orig 2017-08-02 12:06:25 UTC
|
||||
--- libdw/Makefile.am.orig 2020-03-30 12:17:45 UTC
|
||||
+++ libdw/Makefile.am
|
||||
@@ -105,7 +105,7 @@ am_libdw_pic_a_OBJECTS = $(libdw_a_SOURC
|
||||
libdw_so_LIBS = libdw_pic.a ../libdwelf/libdwelf_pic.a \
|
||||
../libdwfl/libdwfl_pic.a ../libebl/libebl.a
|
||||
@@ -109,7 +109,7 @@ libdw_so_LIBS = ../libebl/libebl_pic.a ../backends/lib
|
||||
../libcpu/libcpu_pic.a libdw_pic.a ../libdwelf/libdwelf_pic.a \
|
||||
../libdwfl/libdwfl_pic.a
|
||||
libdw_so_DEPS = ../lib/libeu.a ../libelf/libelf.so
|
||||
-libdw_so_LDLIBS = $(libdw_so_DEPS) -ldl -lz $(argp_LDADD) $(zip_LIBS)
|
||||
+libdw_so_LDLIBS = $(libdw_so_DEPS) -lz $(argp_LDADD) $(zip_LIBS)
|
||||
-libdw_so_LDLIBS = $(libdw_so_DEPS) -ldl -lz $(argp_LDADD) $(zip_LIBS) -pthread
|
||||
+libdw_so_LDLIBS = $(libdw_so_DEPS) -lz $(argp_LDADD) $(zip_LIBS) -pthread
|
||||
libdw_so_SOURCES =
|
||||
libdw.so$(EXEEXT): $(srcdir)/libdw.map $(libdw_so_LIBS) $(libdw_so_DEPS)
|
||||
# The rpath is necessary for libebl because its $ORIGIN use will
|
||||
$(AM_V_CCLD)$(LINK) $(dso_LDFLAGS) -o $@ \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- libdw/dwarf_getsrclines.c.orig 2016-12-25 13:36:55 UTC
|
||||
--- libdw/dwarf_getsrclines.c.orig 2020-03-30 12:17:45 UTC
|
||||
+++ libdw/dwarf_getsrclines.c
|
||||
@@ -273,7 +273,7 @@ read_srclines (Dwarf *dbg,
|
||||
@@ -287,7 +287,7 @@ read_srclines (Dwarf *dbg,
|
||||
/* Remember array with the standard opcode length (-1 to account for
|
||||
the opcode with value zero not being mentioned). */
|
||||
const uint8_t *standard_opcode_lengths = linep - 1;
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- libelf/elf.h.orig 2017-08-02 12:06:25 UTC
|
||||
--- libelf/elf.h.orig 2020-03-30 12:17:45 UTC
|
||||
+++ libelf/elf.h
|
||||
@@ -54,6 +54,7 @@ typedef uint64_t Elf64_Off;
|
||||
/* Type for section indices, which are 16-bit quantities. */
|
||||
|
@ -8,7 +8,7 @@
|
|||
|
||||
/* Type for version symbol information. */
|
||||
typedef Elf32_Half Elf32_Versym;
|
||||
@@ -1110,6 +1111,7 @@ typedef struct
|
||||
@@ -1145,6 +1146,7 @@ typedef struct
|
||||
on 64-bit platforms and vice versa. */
|
||||
} a_un;
|
||||
} Elf64_auxv_t;
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- libelf/elf_update.c.orig 2018-09-14 03:23:36.000000000 -0700
|
||||
--- libelf/elf_update.c.orig 2020-03-30 12:17:45 UTC
|
||||
+++ libelf/elf_update.c
|
||||
@@ -106,9 +106,13 @@
|
||||
@@ -106,9 +106,13 @@ write_file (Elf *elf, int64_t size, int change_bo, siz
|
||||
if (elf->cmd == ELF_C_RDWR_MMAP
|
||||
&& (size_t) size > elf->maximum_size)
|
||||
{
|
|
@ -1,46 +1,11 @@
|
|||
--- src/Makefile.am.orig 2016-12-28 09:32:00 UTC
|
||||
--- src/Makefile.am.orig 2020-03-30 12:17:45 UTC
|
||||
+++ src/Makefile.am
|
||||
@@ -40,11 +40,11 @@ CLEANFILES += make-debug-archive
|
||||
@@ -41,7 +41,7 @@ CLEANFILES += make-debug-archive
|
||||
|
||||
if BUILD_STATIC
|
||||
libasm = ../libasm/libasm.a
|
||||
-libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl
|
||||
+libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) $(libeu)
|
||||
-libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) -ldl -lpthread
|
||||
+libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) -lpthread
|
||||
libelf = ../libelf/libelf.a -lz
|
||||
else
|
||||
libasm = ../libasm/libasm.so
|
||||
-libdw = ../libdw/libdw.so
|
||||
+libdw = ../libdw/libdw.so $(libeu)
|
||||
libelf = ../libelf/libelf.so
|
||||
endif
|
||||
libebl = ../libebl/libebl.a
|
||||
@@ -67,21 +67,21 @@ ranlib_no_Wstack_usage = yes
|
||||
ar_no_Wstack_usage = yes
|
||||
unstrip_no_Wstack_usage = yes
|
||||
|
||||
-readelf_LDADD = $(libdw) $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
|
||||
-nm_LDADD = $(libdw) $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl \
|
||||
+readelf_LDADD = $(libdw) $(libebl) $(libelf) $(libeu) $(argp_LDADD)
|
||||
+nm_LDADD = $(libdw) $(libebl) $(libelf) $(libeu) $(argp_LDADD) \
|
||||
$(demanglelib)
|
||||
size_LDADD = $(libelf) $(libeu) $(argp_LDADD)
|
||||
-strip_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD) -ldl
|
||||
-elflint_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
|
||||
+strip_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD)
|
||||
+elflint_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD)
|
||||
findtextrel_LDADD = $(libdw) $(libelf) $(libeu) $(argp_LDADD)
|
||||
addr2line_LDADD = $(libdw) $(libelf) $(libeu) $(argp_LDADD) $(demanglelib)
|
||||
-elfcmp_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
|
||||
-objdump_LDADD = $(libasm) $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
|
||||
+elfcmp_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD)
|
||||
+objdump_LDADD = $(libasm) $(libebl) $(libelf) $(libeu) $(argp_LDADD)
|
||||
ranlib_LDADD = libar.a $(libelf) $(libeu) $(argp_LDADD)
|
||||
strings_LDADD = $(libelf) $(libeu) $(argp_LDADD)
|
||||
ar_LDADD = libar.a $(libelf) $(libeu) $(argp_LDADD)
|
||||
-unstrip_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD) -ldl
|
||||
-stack_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD) -ldl $(demanglelib)
|
||||
+unstrip_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD)
|
||||
+stack_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD) $(demanglelib)
|
||||
elfcompress_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD)
|
||||
|
||||
installcheck-binPROGRAMS: $(bin_PROGRAMS)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- src/elfcompress.c.orig 2016-12-28 01:32:01.000000000 -0800
|
||||
+++ src/elfcompress.c 2017-01-18 16:21:03.680565000 -0800
|
||||
@@ -135,7 +135,10 @@
|
||||
--- src/elfcompress.c.orig 2020-03-30 12:17:45 UTC
|
||||
+++ src/elfcompress.c
|
||||
@@ -135,7 +135,10 @@ parse_opt (int key, char *arg __attribute__ ((unused))
|
||||
if (type == T_UNSET)
|
||||
type = T_COMPRESS_ZLIB;
|
||||
if (patterns == NULL)
|
||||
|
@ -12,7 +12,7 @@
|
|||
break;
|
||||
|
||||
case ARGP_KEY_NO_ARGS:
|
||||
@@ -162,7 +165,7 @@
|
||||
@@ -162,7 +165,7 @@ section_name_matches (const char *name)
|
||||
struct section_pattern *pattern = patterns;
|
||||
while (pattern != NULL)
|
||||
{
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- src/readelf.c.orig 2017-08-02 12:06:25 UTC
|
||||
--- src/readelf.c.orig 2020-03-30 12:17:45 UTC
|
||||
+++ src/readelf.c
|
||||
@@ -8130,6 +8130,7 @@ print_debug_exception_table (Dwfl_Module
|
||||
@@ -10744,6 +10744,7 @@ print_debug_exception_table (Dwfl_Module *dwflmod __at
|
||||
default:
|
||||
dsize = 0;
|
||||
error (1, 0, gettext ("invalid TType encoding"));
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- src/strip.c.orig 2017-08-02 12:06:25 UTC
|
||||
--- src/strip.c.orig 2020-03-30 12:17:45 UTC
|
||||
+++ src/strip.c
|
||||
@@ -85,8 +85,8 @@ static const struct argp_option options[
|
||||
N_("Resolve all trivial relocations between debug sections if the removed sections are placed in a debug file (only relevant for ET_REL files, operation is not reversable, needs -f)"), 0 },
|
||||
@@ -87,8 +87,8 @@ static const struct argp_option options[] =
|
||||
N_("Similar to --reloc-debug-sections, but resolve all trivial relocations between debug sections in place. No other stripping is performed (operation is not reversable, incompatible with -f, -g, --remove-comment and --remove-section)"), 0 },
|
||||
{ "remove-comment", OPT_REMOVE_COMMENT, NULL, 0,
|
||||
N_("Remove .comment section"), 0 },
|
||||
- { "remove-section", 'R', "SECTION", 0, N_("Remove the named section. SECTION is an extended wildcard pattern. May be given more than once. Only non-allocated sections can be removed."), 0 },
|
||||
|
@ -11,7 +11,7 @@
|
|||
{ "permissive", OPT_PERMISSIVE, NULL, 0,
|
||||
N_("Relax a few rules to handle slightly broken ELF files"), 0 },
|
||||
{ NULL, 0, NULL, 0, NULL, 0 }
|
||||
@@ -205,7 +205,7 @@ section_name_matches (struct section_pat
|
||||
@@ -210,7 +210,7 @@ section_name_matches (struct section_pattern *patterns
|
||||
struct section_pattern *pattern = patterns;
|
||||
while (pattern != NULL)
|
||||
{
|
||||
|
@ -20,7 +20,7 @@
|
|||
return true;
|
||||
pattern = pattern->next;
|
||||
}
|
||||
@@ -313,7 +313,7 @@ parse_opt (int key, char *arg, struct ar
|
||||
@@ -328,7 +328,7 @@ parse_opt (int key, char *arg, struct argp_state *stat
|
||||
break;
|
||||
|
||||
case 'R':
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- tests/Makefile.am.orig 2018-09-14 04:12:13.000000000 -0700
|
||||
--- tests/Makefile.am.orig 2020-03-30 12:17:45 UTC
|
||||
+++ tests/Makefile.am
|
||||
@@ -457,7 +457,7 @@
|
||||
@@ -537,7 +537,7 @@ libasm = -lasm
|
||||
libebl = -lebl
|
||||
else !STANDALONE
|
||||
if BUILD_STATIC
|
||||
-libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl
|
||||
+libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl)
|
||||
-libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl -lpthread
|
||||
+libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -lpthread
|
||||
libelf = ../libelf/libelf.a -lz
|
||||
libasm = ../libasm/libasm.a
|
||||
else
|
||||
@@ -472,16 +472,16 @@
|
||||
@@ -552,16 +552,16 @@ endif !STANDALONE
|
||||
arextract_LDADD = $(libelf)
|
||||
arsymtest_LDADD = $(libelf)
|
||||
newfile_LDADD = $(libelf)
|
||||
|
@ -30,7 +30,7 @@
|
|||
update1_LDADD = $(libelf)
|
||||
update2_LDADD = $(libelf)
|
||||
update3_LDADD = $(libdw) $(libelf)
|
||||
@@ -495,34 +495,34 @@
|
||||
@@ -575,12 +575,12 @@ get_files_LDADD = $(libdw) $(libelf)
|
||||
next_files_LDADD = $(libdw) $(libelf)
|
||||
get_aranges_LDADD = $(libdw) $(libelf)
|
||||
allfcts_LDADD = $(libdw) $(libelf)
|
||||
|
@ -47,61 +47,40 @@
|
|||
+allregs_LDADD = $(libeu) $(libdw) $(argp_LDADD)
|
||||
+find_prologues_LDADD = $(libeu) $(libdw) $(argp_LDADD)
|
||||
#show_ciefde_LDADD = ../libdwarf/libdwarf.so $(libelf)
|
||||
-asm_tst1_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
|
||||
-asm_tst2_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
|
||||
-asm_tst3_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
|
||||
-asm_tst4_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
|
||||
-asm_tst5_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
|
||||
-asm_tst6_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
|
||||
-asm_tst7_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
|
||||
-asm_tst8_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
|
||||
-asm_tst9_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
|
||||
-dwflmodtest_LDADD = $(libdw) $(libebl) $(libelf) $(argp_LDADD) -ldl
|
||||
asm_tst1_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
asm_tst2_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
@@ -592,13 +592,13 @@ asm_tst7_LDADD = $(libasm) $(libebl) $(libelf) $(libdw
|
||||
asm_tst8_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
asm_tst9_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
dwflmodtest_LDADD = $(libdw) $(libebl) $(libelf) $(argp_LDADD)
|
||||
-rdwrmmap_LDADD = $(libelf)
|
||||
-dwfl_bug_addr_overflow_LDADD = $(libdw) $(libebl) $(libelf) -ldl
|
||||
+asm_tst1_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
+asm_tst2_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
+asm_tst3_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
+asm_tst4_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
+asm_tst5_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
+asm_tst6_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
+asm_tst7_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
+asm_tst8_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
+asm_tst9_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
|
||||
+dwflmodtest_LDADD = $(libeu) $(libdw) $(libebl) $(libelf) $(argp_LDADD)
|
||||
+rdwrmmap_LDADD = $(libeu) $(libelf)
|
||||
+dwfl_bug_addr_overflow_LDADD = $(libdw) $(libebl) $(libelf)
|
||||
dwfl_bug_addr_overflow_LDADD = $(libdw) $(libebl) $(libelf)
|
||||
arls_LDADD = $(libelf)
|
||||
-dwfl_bug_fd_leak_LDADD = $(libdw) $(libebl) $(libelf) -ldl
|
||||
-dwfl_bug_report_LDADD = $(libdw) $(libebl) $(libelf) -ldl
|
||||
-dwfl_bug_getmodules_LDADD = $(libdw) $(libebl) $(libelf) -ldl
|
||||
-dwfl_addr_sect_LDADD = $(libdw) $(libebl) $(libelf) $(argp_LDADD) -ldl
|
||||
+dwfl_bug_fd_leak_LDADD = $(libdw) $(libebl) $(libelf)
|
||||
+dwfl_bug_report_LDADD = $(libdw) $(libebl) $(libelf)
|
||||
dwfl_bug_fd_leak_LDADD = $(libdw) $(libebl) $(libelf)
|
||||
dwfl_bug_report_LDADD = $(libdw) $(libebl) $(libelf)
|
||||
-dwfl_bug_getmodules_LDADD = $(libdw) $(libebl) $(libelf)
|
||||
-dwfl_addr_sect_LDADD = $(libdw) $(libebl) $(libelf) $(argp_LDADD)
|
||||
+dwfl_bug_getmodules_LDADD = $(libeu) $(libdw) $(libebl) $(libelf)
|
||||
+dwfl_addr_sect_LDADD = $(libeu) $(libdw) $(libebl) $(libelf) $(argp_LDADD)
|
||||
dwarf_getmacros_LDADD = $(libdw)
|
||||
dwarf_ranges_LDADD = $(libdw)
|
||||
dwarf_getstring_LDADD = $(libdw)
|
||||
-addrcfi_LDADD = $(libdw) $(libebl) $(libelf) $(argp_LDADD) -ldl
|
||||
+addrcfi_LDADD = $(libdw) $(libebl) $(libelf) $(argp_LDADD)
|
||||
dwarfcfi_LDADD = $(libdw) $(libelf)
|
||||
test_flag_nobits_LDADD = $(libelf)
|
||||
rerequest_tag_LDADD = $(libdw)
|
||||
@@ -532,9 +532,9 @@
|
||||
@@ -612,10 +612,10 @@ typeiter2_LDADD = $(libdw) $(libelf)
|
||||
low_high_pc_LDADD = $(libdw) $(libelf) $(argp_LDADD)
|
||||
test_elf_cntl_gelf_getshdr_LDADD = $(libelf)
|
||||
dwflsyms_LDADD = $(libdw) $(libelf) $(argp_LDADD)
|
||||
-dwfllines_LDADD = $(libdw) $(libelf) $(argp_LDADD)
|
||||
-dwfl_report_elf_align_LDADD = $(libdw)
|
||||
-varlocs_LDADD = $(libdw) $(libelf) $(argp_LDADD)
|
||||
+dwfllines_LDADD = $(libeu) $(libdw) $(libelf) $(argp_LDADD)
|
||||
+dwfl_report_elf_align_LDADD = $(libeu) $(libdw)
|
||||
dwfl_report_segment_contiguous_LDADD = $(libdw) $(libebl) $(libelf)
|
||||
-varlocs_LDADD = $(libdw) $(libelf) $(argp_LDADD)
|
||||
+varlocs_LDADD = $(libeu) $(libdw) $(libelf) $(argp_LDADD)
|
||||
backtrace_LDADD = $(libdw) $(libelf) $(argp_LDADD)
|
||||
# backtrace-child-biarch also uses those *_CFLAGS and *_LDLAGS variables:
|
||||
backtrace_child_CFLAGS = $(fpie_CFLAGS)
|
||||
@@ -543,23 +543,23 @@
|
||||
@@ -624,23 +624,23 @@ backtrace_child_biarch_SOURCES = backtrace-child.c
|
||||
backtrace_data_LDADD = $(libdw) $(libelf)
|
||||
backtrace_dwarf_CFLAGS = -Wno-unused-parameter
|
||||
backtrace_dwarf_LDADD = $(libdw) $(libelf)
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
bin/eu-addr2line
|
||||
bin/eu-ar
|
||||
bin/eu-elfclassify
|
||||
bin/eu-elfcmp
|
||||
bin/eu-elfcompress
|
||||
bin/eu-elflint
|
||||
|
@ -21,41 +22,10 @@ include/elfutils/libasm.h
|
|||
include/elfutils/libdw.h
|
||||
include/elfutils/libdwelf.h
|
||||
include/elfutils/libdwfl.h
|
||||
include/elfutils/libebl.h
|
||||
include/elfutils/version.h
|
||||
include/gelf.h
|
||||
include/libelf.h
|
||||
include/nlist.h
|
||||
lib/elfutils/libebl_aarch64-%%VERSION%%.so
|
||||
lib/elfutils/libebl_aarch64.so
|
||||
lib/elfutils/libebl_alpha-%%VERSION%%.so
|
||||
lib/elfutils/libebl_alpha.so
|
||||
lib/elfutils/libebl_arm-%%VERSION%%.so
|
||||
lib/elfutils/libebl_arm.so
|
||||
lib/elfutils/libebl_bpf-%%VERSION%%.so
|
||||
lib/elfutils/libebl_bpf.so
|
||||
lib/elfutils/libebl_i386-%%VERSION%%.so
|
||||
lib/elfutils/libebl_i386.so
|
||||
lib/elfutils/libebl_ia64-%%VERSION%%.so
|
||||
lib/elfutils/libebl_ia64.so
|
||||
lib/elfutils/libebl_m68k-%%VERSION%%.so
|
||||
lib/elfutils/libebl_m68k.so
|
||||
lib/elfutils/libebl_ppc-%%VERSION%%.so
|
||||
lib/elfutils/libebl_ppc.so
|
||||
lib/elfutils/libebl_ppc64-%%VERSION%%.so
|
||||
lib/elfutils/libebl_ppc64.so
|
||||
lib/elfutils/libebl_riscv-%%VERSION%%.so
|
||||
lib/elfutils/libebl_riscv.so
|
||||
lib/elfutils/libebl_s390-%%VERSION%%.so
|
||||
lib/elfutils/libebl_s390.so
|
||||
lib/elfutils/libebl_sh-%%VERSION%%.so
|
||||
lib/elfutils/libebl_sh.so
|
||||
lib/elfutils/libebl_sparc-%%VERSION%%.so
|
||||
lib/elfutils/libebl_sparc.so
|
||||
lib/elfutils/libebl_tilegx-%%VERSION%%.so
|
||||
lib/elfutils/libebl_tilegx.so
|
||||
lib/elfutils/libebl_x86_64-%%VERSION%%.so
|
||||
lib/elfutils/libebl_x86_64.so
|
||||
lib/libasm-%%VERSION%%.so
|
||||
lib/libasm.a
|
||||
lib/libasm.so
|
||||
|
@ -64,13 +34,18 @@ lib/libdw-%%VERSION%%.so
|
|||
lib/libdw.a
|
||||
lib/libdw.so
|
||||
lib/libdw.so.1
|
||||
lib/libebl.a
|
||||
lib/libelf-%%VERSION%%.so
|
||||
lib/libelf.a
|
||||
lib/libelf.so
|
||||
lib/libelf.so.1
|
||||
libdata/pkgconfig/libdw.pc
|
||||
libdata/pkgconfig/libelf.pc
|
||||
%%MANPAGES%%man/man1/eu-elfclassify.1.gz
|
||||
%%MANPAGES%%man/man1/eu-readelf.1.gz
|
||||
%%MANPAGES%%man/man3/elf_begin.3.gz
|
||||
%%MANPAGES%%man/man3/elf_clone.3.gz
|
||||
%%MANPAGES%%man/man3/elf_getdata.3.gz
|
||||
%%MANPAGES%%man/man3/elf_update.3.gz
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/elfutils.mo
|
||||
%%NLS%%share/locale/en@boldquot/LC_MESSAGES/elfutils.mo
|
||||
%%NLS%%share/locale/en@quot/LC_MESSAGES/elfutils.mo
|
||||
|
|
|
@ -3,6 +3,7 @@
|
|||
PORTNAME= kcov
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 37
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel
|
||||
|
||||
MAINTAINER= asomers@FreeBSD.org
|
||||
|
|
Loading…
Reference in a new issue