Add libexecinfo 1.0, a library for inspecting program's backtrace.
This commit is contained in:
parent
a357068811
commit
e99c8ea14d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86721
6 changed files with 52 additions and 0 deletions
|
@ -314,6 +314,7 @@
|
|||
SUBDIR += libedit
|
||||
SUBDIR += libelf
|
||||
SUBDIR += libevent
|
||||
SUBDIR += libexecinfo
|
||||
SUBDIR += libffi
|
||||
SUBDIR += libformat
|
||||
SUBDIR += libfs++
|
||||
|
|
25
devel/libexecinfo/Makefile
Normal file
25
devel/libexecinfo/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# New ports collection makefile for: libexecinfo
|
||||
# Date created: 10 August 2003
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libexecinfo
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://demo.portaone.com/~sobomax/freestuff/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A library for inspecting program's backtrace
|
||||
|
||||
USE_BZIP2= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
MAKE_FLAGS= LIBDIR=${PREFIX}/lib \
|
||||
INCLUDEDIR=${PREFIX}/include
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/libexecinfo/distinfo
Normal file
1
devel/libexecinfo/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libexecinfo-1.0.tar.bz2) = 745579b7705227c5c79cd7af391a005b
|
14
devel/libexecinfo/files/patch-Makefile
Normal file
14
devel/libexecinfo/files/patch-Makefile
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile 2003/08/10 05:00:23 1.1
|
||||
+++ Makefile 2003/08/10 05:00:34
|
||||
@@ -28,6 +28,8 @@
|
||||
|
||||
SRCS= stacktraverse.c stacktraverse.h execinfo.c execinfo.h
|
||||
|
||||
+INCS= execinfo.h
|
||||
+
|
||||
SHLIB_MAJOR= 1
|
||||
SHLIB_MINOR= 0
|
||||
|
6
devel/libexecinfo/pkg-descr
Normal file
6
devel/libexecinfo/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
This is a quick-n-dirty BSD licensed clone of backtrace facility found
|
||||
in the GNU libc, mainly intended for porting linuxish code to BSD
|
||||
platforms, however it can be used at any platform which has a gcc
|
||||
compiler.
|
||||
|
||||
WWW: http://www.gnu.org/manual/glibc-2.2.3/html_chapter/libc_33.html
|
5
devel/libexecinfo/pkg-plist
Normal file
5
devel/libexecinfo/pkg-plist
Normal file
|
@ -0,0 +1,5 @@
|
|||
include/execinfo.h
|
||||
lib/libexecinfo.a
|
||||
lib/libexecinfo.so
|
||||
lib/libexecinfo.so.1
|
||||
share/doc/libexecinfo/README
|
Loading…
Reference in a new issue