- Allow the configure script to use any zlib version rather than

requiring 1.1.3 or 1.1.4 (the program requires zlib >= 1.1.3, which
  was imported in January 1999) [1]
- Refactor pkg-plist as PLIST_FILES/PORTDOCS
- Polish the Makefile

[1]:
PR:		ports/82524
Submitted by:	Andrew McNaughton <andrew@scoop.co.nz>
This commit is contained in:
Jean-Yves Lefort 2005-06-25 14:15:32 +00:00
parent db00022b1a
commit e9a0a2d45b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138013
3 changed files with 12 additions and 14 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= httplog
PORTVERSION= 2.1
PORTREVISION= 1
CATEGORIES= sysutils www
MASTER_SITES= http://nutbar.chemlab.org/downloads/programs/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
@ -14,9 +15,10 @@ MASTER_SITES= http://nutbar.chemlab.org/downloads/programs/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Apache log rollover program with strftime(3) filename support
MAN8= httplog.8
MAN8= httplog.8
DOCS= ChangeLog README
PLIST_FILES= sbin/httplog
PORTDOCS= ChangeLog README
USE_REINPLACE= yes
HAS_CONFIGURE= yes
@ -33,12 +35,12 @@ do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} -o httplog httplog.c -lz)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/httplog ${PREFIX}/sbin/
${INSTALL_MAN} ${WRKSRC}/httplog.8 ${PREFIX}/man/man8/
${INSTALL_PROGRAM} ${WRKSRC}/httplog ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/httplog.8 ${MAN8PREFIX}/man/man8
.if !defined(NOPORTDOCS)
${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif

View file

@ -1,11 +1,11 @@
--- configure.orig Tue Dec 16 10:40:16 2003
+++ configure Tue Dec 16 10:41:45 2003
--- configure.orig Sat Jun 25 15:53:38 2005
+++ configure Sat Jun 25 16:00:31 2005
@@ -140,7 +140,7 @@
EOF
$CC -o ./dummy ./dummy.c -lz 1>/dev/null 2>&1
if [ $? -eq 0 ]; then
- if [ `./dummy` = "1.1.3" ]; then
+ if [ `./dummy` = "1.1.3" -o `./dummy` = "1.1.4" ]; then
+ if :; then
use_zlib=yes
LDFLAGS="$LDFLAGS -lz"
echo "Checking zlib version: `./dummy` found."

View file

@ -1,4 +0,0 @@
sbin/httplog
%%PORTDOCS%%share/doc/httplog/ChangeLog
%%PORTDOCS%%share/doc/httplog/README
%%PORTDOCS%%@dirrm share/doc/httplog