Apache::SSI - Implement Server Side Includes in Perl

This commit is contained in:
Vanilla I. Shu 2001-05-27 02:03:48 +00:00
parent b51c4219ad
commit eaa714d7b4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43095
7 changed files with 58 additions and 0 deletions

View file

@ -183,6 +183,7 @@
SUBDIR += p5-Apache-Peek
SUBDIR += p5-Apache-Radius
SUBDIR += p5-Apache-Reload
SUBDIR += p5-Apache-SSI
SUBDIR += p5-Apache-Session
SUBDIR += p5-Apache-Session-SharedMem
SUBDIR += p5-CGI

View file

@ -0,0 +1,25 @@
# New ports collection makefile for: p5-Apache-SSI
# Date created: May 27 2001
# Whom: vanilla
#
# $FreeBSD$
#
PORTNAME= Apache-SSI
PORTVERSION= 2.16
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/SimpleParse.pm:${PORTSDIR}/www/p5-HTML-SimpleParse
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Apache::SSI.3
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (Apache-SSI-2.16.tar.gz) = 341d1a126296d1b65cb38c5c921ff3a9

View file

@ -0,0 +1,24 @@
--- Makefile.PL.orig Sat May 26 17:38:41 2001
+++ Makefile.PL Sat May 26 17:39:28 2001
@@ -1,13 +1,13 @@
use ExtUtils::MakeMaker;
-use lib 't/lib';
-use Apache::test;
+#use lib 't/lib';
+#use Apache::test;
-my %params = Apache::test->get_test_params();
-chomp (my $cwd = `pwd`);
-Apache::test->write_httpd_conf
- (%params,
- include => join '', <DATA>);
-*MY::test = sub { Apache::test->MM_test(%params) };
+#my %params = Apache::test->get_test_params();
+#chomp (my $cwd = `pwd`);
+#Apache::test->write_httpd_conf
+# (%params,
+# include => join '', <DATA>);
+#*MY::test = sub { Apache::test->MM_test(%params) };
my $module = 'Apache::SSI';

View file

@ -0,0 +1 @@
Apache::SSI - Implement Server Side Includes in Perl

View file

@ -0,0 +1,2 @@
Apache::SSI implements the functionality of mod_include for handling
server-parsed html documents. It runs under Apache's mod_perl.

View file

@ -0,0 +1,4 @@
lib/perl5/site_perl/%%PERL_VER%%/Apache/SSI.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/SSI/.packlist
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/SSI
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Apache 2>/dev/null || true