Add mixmaster 2.9.1, a cryptographically secure anonymous remailer.
PR: ports/59813 Submitted by: Meyer Wolfsheim
This commit is contained in:
parent
89150f38cd
commit
eab25aec93
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111548
10 changed files with 212 additions and 0 deletions
|
@ -188,6 +188,7 @@
|
|||
SUBDIR += mini_sendmail
|
||||
SUBDIR += minimalist
|
||||
SUBDIR += missey
|
||||
SUBDIR += mixmaster
|
||||
SUBDIR += mixminion
|
||||
SUBDIR += ml
|
||||
SUBDIR += mls
|
||||
|
|
54
mail/mixmaster/Makefile
Normal file
54
mail/mixmaster/Makefile
Normal file
|
@ -0,0 +1,54 @@
|
|||
# New ports collection makefile for: mixmaster
|
||||
# Date created: 27 November 2003
|
||||
# Whom: Meyer Wolfsheim
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mixmaster
|
||||
PORTVERSION= 2.9.1
|
||||
CATEGORIES= mail security
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
|
||||
ftp://ftp.erisiandiscord.de/pub/misc/
|
||||
MASTER_SITE_SUBDIR= mixmaster
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
|
||||
mixmaster-update.pl.gz allpingers.txt.gz
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= wolf@priori.net
|
||||
COMMENT= A cryptographically secure anonymous remailer
|
||||
|
||||
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre \
|
||||
ncurses:${PORTSDIR}/devel/ncurses
|
||||
|
||||
USE_PERL5= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_OPENSSL= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/Src
|
||||
|
||||
CFLAGS+= -DGLOBALMIXCONF="\"${SYSCONFDIR}/mixmaster/client.cfg\"" -DHOMEMIXDIR="\".Mix\""
|
||||
MAKE_ARGS= CC=${CC}
|
||||
|
||||
MAN1= mixmaster.1
|
||||
WRKDIST= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
MIXMASTER_FILES= ${WRKDIST}/conf/* ${WRKDIST}/README ${WRKDIR}/allpingers.txt
|
||||
MIXMASTER_SCRIPTS= ${WRKDIR}/mixmaster-update.pl
|
||||
|
||||
post-patch:
|
||||
${CP} ${FILESDIR}/Makefile.in ${WRKSRC}/Makefile
|
||||
@${RM} ${WRKSRC}/../conf/mix.cfg.orig
|
||||
|
||||
pre-install:
|
||||
${GZCAT} ${DISTDIR}/mixmaster-update.pl.gz >${WRKDIR}/mixmaster-update.pl
|
||||
${GZCAT} ${DISTDIR}/allpingers.txt.gz >${WRKDIR}/allpingers.txt
|
||||
${REINPLACE_CMD} -e "s,/etc,${SYSCONFDIR},g" ${WRKDIR}/mixmaster-update.pl
|
||||
${MKDIR} ${PREFIX}/share/examples/mixmaster
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/mix ${PREFIX}/bin/mixmaster
|
||||
${INSTALL_SCRIPT} ${MIXMASTER_SCRIPTS} ${PREFIX}/bin/mixmaster-update.pl
|
||||
${INSTALL_DATA} ${MIXMASTER_FILES} ${PREFIX}/share/examples/mixmaster
|
||||
${INSTALL_MAN} ${WRKDIST}/mix.1 ${PREFIX}/man/man1/mixmaster.1
|
||||
|
||||
.include <bsd.port.mk>
|
3
mail/mixmaster/distinfo
Normal file
3
mail/mixmaster/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (allpingers.txt.gz) = faed6e2b322789008d9944ee19b0d67e
|
||||
MD5 (mixmaster-2.9.1.tar.gz) = 26052ff4112a2c185fd294b2bf5cb117
|
||||
MD5 (mixmaster-update.pl.gz) = 80ace5f85a7f4b8e2cf48a337e92a541
|
76
mail/mixmaster/files/Makefile.in
Normal file
76
mail/mixmaster/files/Makefile.in
Normal file
|
@ -0,0 +1,76 @@
|
|||
# Mixmaster version 2.9 -- (C) 1999 - 2003 Anonymizer Inc. and others.
|
||||
|
||||
# Mixmaster may be redistributed and modified under certain conditions.
|
||||
# This software is distributed on an "AS IS" basis, WITHOUT WARRANTY OF
|
||||
# ANY KIND, either express or implied. See the file COPYRIGHT for
|
||||
# details.
|
||||
|
||||
# Edit according to the libraries you want to use:
|
||||
INC = -I/usr/local/include -I/usr/include
|
||||
DEF = -DUSE_ZLIB -DUSE_PCRE -DUSE_NCURSES -DHAVE_NCURSES_H -DUSE_IDEA -DUSE_SOCK -DSPOOL='"/var/tmp/mixmaster"' -DGLOBALMIXCONF='"/usr/local/etc/mixmaster/client.cfg"' -DHOMEMIXDIR="\".Mix\""
|
||||
LIBS =
|
||||
LDFLAGS = -lz -L/usr/lib -lpcre -L/usr/local/lib -lcrypto -L/usr/lib -lncurses -L/usr/lib
|
||||
|
||||
OPT = -g -Wall
|
||||
# OPT = -g -pg -Wall -DDEBUG
|
||||
# OPT = -O2 -Wall
|
||||
|
||||
CFLAGS = $(INC) $(DEF) $(OPT)
|
||||
CC = gcc
|
||||
AR = ar rc
|
||||
RANLIB = ranlib
|
||||
#MAKE = make
|
||||
|
||||
OBJ = mix.o rem.o rem1.o rem2.o rem3.o chain.o chain1.o chain2.o chain3.o nym.o pgp.o pgpdb.o pgpdata.o pgpget.o pgpcreat.o pool.o mail.o rfc822.o mime.o keymgt.o compress.o stats.o crypto.o random.o util.o buffers.o
|
||||
|
||||
MIXOBJ = rndseed.o menu.o menusend.o menunym.o menuutil.o
|
||||
NOMENUOBJ = rndseed.o dummy.o
|
||||
WINOBJ = winmain.o winutil.o
|
||||
|
||||
all: mix
|
||||
|
||||
mix: $(OBJ) $(MIXOBJ) main.o $(LIBS)
|
||||
$(CC) $(OBJ) $(MIXOBJ) main.o $(LIBS) $(LDFLAGS) -o mix
|
||||
|
||||
libmix.a: $(OBJ) $(MIXOBJ) dllmain.o
|
||||
$(AR) libmix.a $(OBJ) $(MIXOBJ) dllmain.o
|
||||
|
||||
libmix32.a: libmix.a mixlib.def
|
||||
dllwrap --dllname mixlib.dll --def mixlib.def --output-lib libmix32.a libmix.a zlib-1.1.4/libz.a pcre-2.08/libpcre.a openssl/libeay32.a -lwsock32
|
||||
|
||||
dllmix: main.o libmix32.a
|
||||
$(CC) main.o libmix32.a -o dllmix
|
||||
|
||||
winmix.exe: $(WINOBJ) libmix32.a
|
||||
$(CC) $(WINOBJ) libmix32.a -lgdi32 -luser32 $(LDFLAGS) -o mix.exe
|
||||
|
||||
winmix: winmenu.res #winmix.exe
|
||||
rsrc winmenu.res mix.exe
|
||||
|
||||
winmenu.o: winmenu.rc winmenu.h
|
||||
windres winmenu.rc winmenu.o
|
||||
|
||||
remailer: $(OBJ) $(NOMENUOBJ) remailer.o $(LIBS)
|
||||
$(CC) $(OBJ) $(NOMENUOBJ) remailer.o $(LIBS) $(LDFLAGS) -o remailer
|
||||
|
||||
mpgp: $(OBJ) $(NOMENUOBJ) pgptest.o $(LIBS)
|
||||
$(CC) $(OBJ) $(NOMENUOBJ) pgptest.o $(LIBS) $(LDFLAGS) -o mpgp
|
||||
|
||||
test: $(OBJ) test.o $(NOMENUOBJ) $(LIBS)
|
||||
$(CC) $(OBJ) test.o $(NOMENUOBJ) $(LIBS) $(LDFLAGS) -o test
|
||||
|
||||
clean:
|
||||
-rm -f *.o *.a *.res *~ mix *.exe remailer test mpgp core gmon.out
|
||||
|
||||
allclean: clean
|
||||
-rm -f Makefile
|
||||
|
||||
ci: clean
|
||||
cd ~/mix3; ci -l * Mix/* Mix/Src/*; echo
|
||||
|
||||
include Makefile.deps
|
||||
|
||||
|
||||
|
||||
|
||||
|
11
mail/mixmaster/files/patch-aa
Normal file
11
mail/mixmaster/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- config.h.orig 2003-09-27 18:53:56.000000000 +0200
|
||||
+++ config.h 2003-09-27 18:54:08.000000000 +0200
|
||||
@@ -138,7 +138,7 @@
|
||||
/* Give up if a file is larger than BUFFER_MAX bytes: */
|
||||
/* #define BUFFER_MAX 64*1024*1024 */
|
||||
|
||||
-#define PATHMAX 512
|
||||
+#define PATHMAX 1024
|
||||
#define LINELEN 128
|
||||
#define BUFSIZE 4096
|
||||
|
11
mail/mixmaster/files/patch-ab
Normal file
11
mail/mixmaster/files/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- mix.c.orig 2003-09-27 19:42:28.000000000 +0200
|
||||
+++ mix.c 2003-09-27 19:42:47.000000000 +0200
|
||||
@@ -86,7 +86,7 @@ char POOLDIR[PATHMAX];
|
||||
#ifdef WIN32
|
||||
char SENDMAIL[LINELEN] = "outfile";
|
||||
#else /* end of WIN32 */
|
||||
-char SENDMAIL[LINELEN] = "/usr/lib/sendmail -t";
|
||||
+char SENDMAIL[LINELEN] = "/usr/sbin/sendmail -t";
|
||||
#endif /* else if not WIN32 */
|
||||
char SENDANONMAIL[LINELEN];
|
||||
char NEWS[LINELEN];
|
13
mail/mixmaster/files/patch-ac
Normal file
13
mail/mixmaster/files/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- pcre-2.08/Makefile.orig Fri Aug 30 09:36:52 2002
|
||||
+++ pcre-2.08/Makefile Fri Aug 30 09:37:14 2002
|
||||
@@ -51,8 +51,8 @@
|
||||
# into errlist.
|
||||
|
||||
AR = ar cq
|
||||
-CC = gcc -O2 -Wall
|
||||
-CFLAGS =
|
||||
+#CC = gcc -O2 -Wall
|
||||
+CFLAGS += -Wall
|
||||
RANLIB = @true
|
||||
|
||||
# If you are going to obey "make install", edit these settings for your
|
8
mail/mixmaster/files/patch-ad
Normal file
8
mail/mixmaster/files/patch-ad
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- ../conf/mix.cfg.orig Wed Oct 31 09:19:55 2001
|
||||
+++ ../conf/mix.cfg Mon Oct 28 13:17:39 2002
|
||||
@@ -1,3 +1,5 @@
|
||||
+SENDMAIL /usr/sbin/sendmail -t
|
||||
+POOL /var/spool/mixmaster
|
||||
######################## Client configuration: ##########################
|
||||
REMAIL n
|
||||
|
8
mail/mixmaster/pkg-descr
Normal file
8
mail/mixmaster/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
Mixmaster is an "Chaumian mix-net" anonymous remailer. Remailers provide
|
||||
protection against traffic analysis and allow sending email anonymously or
|
||||
pseudonymously.
|
||||
|
||||
This software comes in a client only configuration! If you want
|
||||
to setup a mixmaster server, read through the example files and man page.
|
||||
|
||||
WWW: http://mixmaster.sf.net
|
27
mail/mixmaster/pkg-plist
Normal file
27
mail/mixmaster/pkg-plist
Normal file
|
@ -0,0 +1,27 @@
|
|||
bin/mixmaster
|
||||
bin/mixmaster-update.pl
|
||||
%%EXAMPLESDIR%%/README
|
||||
%%EXAMPLESDIR%%/abuse.txt.in
|
||||
%%EXAMPLESDIR%%/adminkey.txt
|
||||
%%EXAMPLESDIR%%/allpingers.txt
|
||||
%%EXAMPLESDIR%%/blocked.txt.in
|
||||
%%EXAMPLESDIR%%/dest.alw
|
||||
%%EXAMPLESDIR%%/dest.blk
|
||||
%%EXAMPLESDIR%%/end.hlp
|
||||
%%EXAMPLESDIR%%/header.blk
|
||||
%%EXAMPLESDIR%%/intro.hlp
|
||||
%%EXAMPLESDIR%%/mix.cfg
|
||||
%%EXAMPLESDIR%%/mix.cfg.ex
|
||||
%%EXAMPLESDIR%%/mix.hlp
|
||||
%%EXAMPLESDIR%%/mlist.txt
|
||||
%%EXAMPLESDIR%%/news.hlp
|
||||
%%EXAMPLESDIR%%/pgp.hlp
|
||||
%%EXAMPLESDIR%%/pgponly.hlp
|
||||
%%EXAMPLESDIR%%/pubring.asc
|
||||
%%EXAMPLESDIR%%/pubring.mix
|
||||
%%EXAMPLESDIR%%/rab.blk
|
||||
%%EXAMPLESDIR%%/reply.txt.in
|
||||
%%EXAMPLESDIR%%/rlist.txt
|
||||
%%EXAMPLESDIR%%/type1.hlp
|
||||
%%EXAMPLESDIR%%/usage.txt.in
|
||||
@dirrm share/examples/mixmaster
|
Loading…
Reference in a new issue