databases/cassandra-cpp-driver: update to 2.3.0
Changelog: https://github.com/datastax/cpp-driver/blob/4335850/CHANGELOG.md
This commit is contained in:
parent
5c6280e6e3
commit
eaca169a14
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=411258
3 changed files with 7 additions and 17 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= cassandra-cpp-driver
|
||||
PORTVERSION= 2.1.0
|
||||
PORTVERSION= 2.3.0
|
||||
CATEGORIES= databases
|
||||
|
||||
MAINTAINER= gahr@FreeBSD.org
|
||||
|
@ -16,7 +16,7 @@ USE_GITHUB= nodefault
|
|||
GH_ACCOUNT= datastax
|
||||
GH_PROJECT= cpp-driver
|
||||
|
||||
USES= cmake:outsource
|
||||
USES= cmake:outsource pkgconfig pathfix
|
||||
CMAKE_ARGS= -DCMAKE_INSTALL_LIBDIR:STRING=lib \
|
||||
-DCASS_BUILD_STATIC:BOOL=ON
|
||||
|
||||
|
@ -27,6 +27,8 @@ PLIST_FILES= include/cassandra.h \
|
|||
lib/libcassandra.so \
|
||||
lib/libcassandra.so.2 \
|
||||
lib/libcassandra.so.${PORTVERSION} \
|
||||
lib/libcassandra_static.a
|
||||
lib/libcassandra_static.a \
|
||||
libdata/pkgconfig/cassandra.pc \
|
||||
libdata/pkgconfig/cassandra_static.pc
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (cassandra-cpp-driver-2.1.0_GH0.tar.gz) = f5968f9a6e067f04cf42dcc2c8f3adc068ffdadba48b5204612ceecc0a5f5a17
|
||||
SIZE (cassandra-cpp-driver-2.1.0_GH0.tar.gz) = 458887
|
||||
SHA256 (cassandra-cpp-driver-2.3.0_GH0.tar.gz) = 30072aa5308ac407a86d2fbe216639e6313c048046e31c33d93ecbcba01c8332
|
||||
SIZE (cassandra-cpp-driver-2.3.0_GH0.tar.gz) = 529823
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- CMakeLists.txt.orig 2015-05-18 16:31:48 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -421,6 +421,9 @@ elseif("${CMAKE_CXX_COMPILER_ID}" STREQU
|
||||
# Clang/Intel specific compiler options
|
||||
# I disabled long-long warning because boost generates about 50 such warnings
|
||||
set(WARNING_COMPILER_FLAGS "-Wall -pedantic -Wextra -Wno-long-long -Wno-unused-parameter -Wno-variadic-macros -Wno-zero-length-array")
|
||||
+ if(${CMAKE_CXX_COMPILER_VERSION} VERSION_GREATER "3.6")
|
||||
+ set(WARNING_COMPILER_FLAGS "${WARNING_COMPILER_FLAGS} -Wno-unused-local-typedef ")
|
||||
+ endif()
|
||||
|
||||
# OpenSSL is deprecated on later versions of Mac OS X. The long-term solution
|
||||
# is to provide a CommonCryto implementation.
|
Loading…
Reference in a new issue