Add repeater-0.08, the UltraVNC repeater which support both mode I and II.

There are two modes available with the UltraVNC repeater:
- mode I is used for UltraVNC Server and Viewer both in normal mode,
- mode II works with the server in listening mode.

WWW: http://ultravnc.sourceforge.net/addons/repeater.html
This commit is contained in:
Yen-Ming Lee 2005-12-18 02:09:32 +00:00
parent 245496aa12
commit eaddfc38fd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=151458
6 changed files with 93 additions and 0 deletions

View file

@ -642,6 +642,7 @@
SUBDIR += recvnet
SUBDIR += redir
SUBDIR += relay
SUBDIR += repeater
SUBDIR += rexx-sock
SUBDIR += rfbproxy
SUBDIR += rinetd

46
net/repeater/Makefile Normal file
View file

@ -0,0 +1,46 @@
# New ports collection makefile for: repeater
# Date created: 14 December 2005
# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= repeater
PORTVERSION= 0.08
CATEGORIES= net
MASTER_SITES= http://koti.mbnet.fi/jtko/uvncrepeater/
DISTNAME= repeater${PORTVERSION:C/\.//}
MAINTAINER= leeym@FreeBSD.org
COMMENT= UltraVNC repeater
USE_ZIP= yes
USE_REINPLACE= yes
USE_RC_SUBR= yes
WRKSRC= ${WRKDIR}/Ver${PORTVERSION:C/\.//}
ALL_TARGET= repeater
PLIST_FILES= sbin/repeater etc/rc.d/repeater.sh
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/repeater ${PREFIX}/sbin/repeater
${INSTALL_SCRIPT} ${FILESDIR}/repeater.sh ${PREFIX}/etc/rc.d
.if !defined(NOPORTDOCS)
PORTDOCS= changelog.txt readme.txt ultravncrepeaterlinuxport.html
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.pre.mk>
post-patch:
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's,%%LIMITS_H%%,machine/limits.h,g' ${WRKSRC}/repeater.cpp
.else
@${REINPLACE_CMD} -e 's,%%LIMITS_H%%,sys/limits.h,g' ${WRKSRC}/repeater.cpp
.endif
.include <bsd.port.post.mk>

3
net/repeater/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (repeater008.zip) = 5f0c6c34b44257b38e4d536f29c04d32
SHA256 (repeater008.zip) = d29bc8177f1c75e760813903dd346094b081e9f9fc03eee069dcdb6044584104
SIZE (repeater008.zip) = 23513

View file

@ -0,0 +1,10 @@
--- repeater.cpp.orig Wed Dec 14 14:49:03 2005
+++ repeater.cpp Wed Dec 14 14:49:16 2005
@@ -28,6 +28,7 @@
// Linux port (C) 2005 Jari Korhonen, jarit1.korhonen@dnainternet.net
// ///////////////////////////////////////////////////////////////////////////
+#include <%%LIMITS_H%%>
#include <sys/types.h>
#include <sys/wait.h>
#include <sys/stat.h>

View file

@ -0,0 +1,30 @@
#!/bin/sh
# PROVIDE: repeater
# REQUIRE: NETWORKING SERVERS
# BEFORE: DAEMON
# KEYWORD: FreeBSD shutdown
#
# Add the following lines to /etc/rc.conf to enable repeater:
#
# repeater_enable="YES"
#
. /etc/rc.subr
name=repeater
rcvar=`set_rcvar`
load_rc_config $name
repeater_enable=${repeater_enable:-"NO"}
repeater_server_port=${repeater_server_port:-5500}
repeater_viewer_port=${repeater_viewer_port:-5900}
repeater_log=${repeater_log:-"/var/run/repeater.log"}
command=/usr/local/sbin/repeater
procname=repeater
start_precmd="echo Starting ${procname}."
start_cmd="daemon ${procname} ${repeater_viewer_port} ${repeater_server_port} > ${repeater_log} 2>&1"
run_rc_command "$1"

3
net/repeater/pkg-descr Normal file
View file

@ -0,0 +1,3 @@
UltraVNC Repeater is an UltraVNC addon
WWW: http://ultravnc.sourceforge.net/addons/repeater.html