finance/libobx: Fix numerous issues

I came to fix only one problem with libofx, but when it failed to pass
stage-QA checks, I found others.

  1) CXXFLAGS not propagated (PHB 12.9) due to bug in configure (blanket)
  2) DragonFly iconv support (blanket, taken from DPorts)
  3) DOXYGEN option was no implemented
     * --disable-doxygen was set rather than DOXYGEN_CONFIGURE_ENABLE
     * DOXYGEN_BUILD_DEPENDS was not set
  4) disable doxygen setting, html documentation got installed
     unconditionally, but this was not reflected in plist

I decided that --disable-doxygen was the correct option because html files
were already provided an installed, so the DOXYGEN option was removed.  I
used PORTDOCS to fix the pkg-plist.  This port passes stage-QA now.

Approved by:	blanket and just-fix-it
This commit is contained in:
John Marino 2015-03-20 10:00:24 +00:00
parent 45ca777110
commit eb06a64599
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=381727
4 changed files with 18 additions and 19 deletions

View file

@ -3,6 +3,7 @@
PORTNAME= libofx
PORTVERSION= 0.9.10
PORTREVISION= 1
CATEGORIES= finance
MASTER_SITES= SF
@ -22,21 +23,14 @@ CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
PORTDOCS= *
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS DOXYGEN
.include <bsd.port.options.mk>
OPTIONS_DEFINE= DOCS
post-install:
${RM} -f ${STAGEDIR}${DOCSDIR}/COPYING
.if ${PORT_OPTIONS:MDOXYGEN}
@${FIND} -P ${STAGEDIR}${DOCSDIR}/html -type f 2>/dev/null | \
${SED} -ne 's|^${STAGEDIR}${PREFIX}/||p' >> ${TMPPLIST}
@${FIND} -P -d ${STAGEDIR}${DOCSDIR}/ -type d -empty 2>/dev/null | \
${SED} -ne 's|^${STAGEDIR}${PREFIX}/|@dir |p' >> ${TMPPLIST}
.endif
.include <bsd.port.mk>

View file

@ -0,0 +1,11 @@
--- configure.orig 2014-09-12 19:48:15 UTC
+++ configure
@@ -3791,7 +3791,7 @@ $as_echo "#define HAVE_GCC_VISIBILITY_EX
VISIBILITY_FLAGS="-fvisibility=hidden"
CFLAGS="$VISIBILITY_FLAGS $CFLAGS"
- CXXFLAGS="$VISIBILITY_FLAGS -fvisibility-inlines-hidden $CFLAGS"
+ CXXFLAGS="$VISIBILITY_FLAGS -fvisibility-inlines-hidden $CXXFLAGS"
fi
## Pass -DIN_LIBOFX to the compiler so we can detect it and include config.h

View file

@ -1,11 +1,11 @@
--- ./lib/ofx_preproc.cpp.orig 2013-04-25 14:06:29.000000000 -0400
+++ ./lib/ofx_preproc.cpp 2014-06-22 19:44:48.000000000 -0400
@@ -310,7 +310,7 @@
--- lib/ofx_preproc.cpp.orig 2014-09-12 19:26:30 UTC
+++ lib/ofx_preproc.cpp
@@ -310,7 +310,7 @@ int ofx_proc_file(LibofxContextPtr ctx,
size_t outbytesleft = inbytesleft * 2 - 1;
iconv_buffer = (char*) malloc (inbytesleft * 2);
memset(iconv_buffer, 0, inbytesleft * 2);
-#if defined(OS_WIN32) || defined(__sun)
+#if defined(OS_WIN32) || defined(__sun) || defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__DragonFly__)
const char * inchar = (const char *)s_buffer.c_str();
#else
char * inchar = (char *)s_buffer.c_str();

View file

@ -9,12 +9,6 @@ lib/libofx.so.6.0.0
libdata/pkgconfig/libofx.pc
man/man1/ofxconnect.1.gz
man/man1/ofxdump.1.gz
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/totest.txt
%%DATADIR%%/dtd/ofc.dtd
%%DATADIR%%/dtd/ofx160.dtd
%%DATADIR%%/dtd/ofx201.dtd