New port: math/py-pyipopt: Use ipopt (an optimization tool) via python
This commit is contained in:
parent
61c0c110b7
commit
eb0b973ac5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=467576
5 changed files with 50 additions and 0 deletions
|
@ -691,6 +691,7 @@
|
|||
SUBDIR += py-pycosat
|
||||
SUBDIR += py-pygsl
|
||||
SUBDIR += py-pyhull
|
||||
SUBDIR += py-pyipopt
|
||||
SUBDIR += py-pymc
|
||||
SUBDIR += py-pymc3
|
||||
SUBDIR += py-pyneqsys
|
||||
|
|
27
math/py-pyipopt/Makefile
Normal file
27
math/py-pyipopt/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pyipopt
|
||||
DISTVERSION= g20180409
|
||||
CATEGORIES= math python
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Use ipopt (an optimization tool) via python
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
BUILD_DEPENDS= ${PYNUMPY}
|
||||
LIB_DEPENDS= libipopt.so:math/ipopt
|
||||
RUN_DEPENDS= ${PYNUMPY}
|
||||
|
||||
USES= dos2unix python
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= xuy
|
||||
GH_TAGNAME= 36bcb7f
|
||||
DOS2UNIX_FILES= setup.py
|
||||
USE_PYTHON= distutils autoplist
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/pyipopt/pyipoptcore.so
|
||||
|
||||
.include <bsd.port.mk>
|
3
math/py-pyipopt/distinfo
Normal file
3
math/py-pyipopt/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1523951951
|
||||
SHA256 (xuy-pyipopt-g20180409-36bcb7f_GH0.tar.gz) = 4315e9911fda864ce5613518bc2ce8d22d2173fa519e487ab895ff099659498b
|
||||
SIZE (xuy-pyipopt-g20180409-36bcb7f_GH0.tar.gz) = 17677
|
16
math/py-pyipopt/files/patch-setup.py
Normal file
16
math/py-pyipopt/files/patch-setup.py
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- setup.py.orig 2018-04-17 07:40:56 UTC
|
||||
+++ setup.py
|
||||
@@ -48,11 +48,11 @@ pyipopt_extension = Extension(
|
||||
#extra_link_args=['-Wl,--rpath','-Wl,'+ IPOPT_LIB],
|
||||
library_dirs=[IPOPT_LIB],
|
||||
libraries=[
|
||||
- 'ipopt', 'coinblas',
|
||||
+ 'ipopt',
|
||||
#'coinhsl',
|
||||
'coinmumps',
|
||||
'coinmetis',
|
||||
- 'coinlapack','dl','m',
|
||||
+ 'm',
|
||||
],
|
||||
include_dirs=[numpy_include, IPOPT_INC],
|
||||
)
|
3
math/py-pyipopt/pkg-descr
Normal file
3
math/py-pyipopt/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
PyIpopt is a python module that allows you to use Ipopt in Python.
|
||||
|
||||
WWW: https://github.com/xuy/pyipopt
|
Loading…
Reference in a new issue