Update to 1.1. Fix MASTER_SITES, WWW and make it using javavmwrapper.

This commit is contained in:
Maxim Sobolev 2000-07-03 14:24:11 +00:00
parent 526d59b693
commit eb244dbc22
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30134
5 changed files with 583 additions and 42 deletions

View file

@ -6,32 +6,25 @@
#
PORTNAME= starlogo
PORTVERSION= 1.0
PORTVERSION= 1.1
CATEGORIES= lang java
MASTER_SITES= http://el.www.media.mit.edu/starlogo/download/
DISTNAME= java-starlogo-beta-2
MASTER_SITES= http://el.www.media.mit.edu/groups/el/Projects/starlogo/download/
MAINTAINER= noway@nohow.demon.co.uk
RUN_DEPENDS= ${LOCALBASE}/jdk${JDK_VERSION}/bin/java:${PORTSDIR}/java/jdk \
${LOCALBASE}/jdk${JDK_VERSION}/lib/i386/green_threads/libtya.so:${PORTSDIR}/java/tya
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
${LOCALBASE}/etc/javavms:${PORTSDIR}/java/jre
WRKSRC= ${WRKDIR}/starlogo-1.0b2
JDK_VERSION= 1.1.8
NO_BUILD= yes
post-patch:
@${CAT} ${WRKSRC}/starlogo-unix | ${SED} -e s,@@PREFIX@@,${PREFIX},g | ${SED} -e s,@@JDK_VERSION@@,${JDK_VERSION},g > ${WRKSRC}/starlogo
do-configure:
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g ; s|%%LOCALBASE%%|${LOCALBASE}|g" \
${WRKSRC}/starlogo-unix
do-install:
@${MKDIR} ${PREFIX}/share/java/starlogo
@${MKDIR} ${PREFIX}/share/java/starlogo/projects
@${MKDIR} ${PREFIX}/share/java/starlogo/sounds
@${INSTALL_SCRIPT} ${WRKSRC}/starlogo ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/starlogo.jar ${PREFIX}/share/java/starlogo
@${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/java/starlogo
@${INSTALL_DATA} ${WRKSRC}/reference.txt ${PREFIX}/share/java/starlogo
@${INSTALL_DATA} ${WRKSRC}/projects/* ${PREFIX}/share/java/starlogo/projects
@${INSTALL_DATA} ${WRKSRC}/sounds/* ${PREFIX}/share/java/starlogo/sounds
@${INSTALL_SCRIPT} ${WRKSRC}/starlogo-unix ${PREFIX}/bin/starlogo
@(cd ${WRKSRC} && ${TAR} -c -f - .) \
| (cd ${PREFIX}/share/java/starlogo && && ${TAR} --unlink -x -f -)
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (java-starlogo-beta-2.tar.gz) = 6a318fd37ed4c984ae9abc5220ee5284
MD5 (starlogo-1.1.tar.gz) = c2478d15890e29dc49e24e53b668115f

View file

@ -1,9 +1,10 @@
--- starlogo-unix.orig Wed Sep 22 08:15:23 1999
+++ starlogo-unix Sun Nov 14 19:52:57 1999
@@ -1,3 +1,3 @@
-echo Warning: You might need to make the native stack size bigger
-echo on the java command line in order to run StarLogo.
--- starlogo-unix.orig Mon Jul 3 16:39:10 2000
+++ starlogo-unix Mon Jul 3 16:40:55 2000
@@ -1,2 +1,6 @@
#!/bin/sh
-java -classpath .:./starlogo.jar starlogo.Toplevel compiler "init 100"
+#!/bin/sh
+cd @@PREFIX@@/share/java/starlogo/projects
+java -Djava.compiler=tya -classpath @@PREFIX@@/share/java/starlogo/starlogo.jar:@@PREFIX@@/share/java/starlogo:@@PREFIX@@/jdk@@JDK_VERSION@@/lib/classes.zip starlogo.Toplevel compiler "init 100"
+CLASSPATH=.:%%PREFIX%%/share/java/starlogo/starlogo.jar
+export CLASSPATH
+
+cd %%PREFIX%%/share/java/starlogo/sample-projects
+exec %%LOCALBASE%%/bin/javavm starlogo.Toplevel compiler "init 100"

View file

@ -1,5 +1,5 @@
StarLogo is a specialized version of the Logo programming language. See:
WWW: http://el.www.media.mit.edu/starlogo/
WWW: http://el.www.media.mit.edu/groups/el/Projects/starlogo/
For more details.

View file

@ -1,17 +1,545 @@
bin/starlogo
share/java/starlogo/starlogo.jar
share/java/starlogo/README
share/java/starlogo/reference.txt
share/java/starlogo/projects/ant-trails.slogo
share/java/starlogo/projects/circle.slogo
share/java/starlogo/projects/dla.slogo
share/java/starlogo/projects/firefly.slogo
share/java/starlogo/projects/gaussian.slogo
share/java/starlogo/projects/graphics.slogo
share/java/starlogo/projects/horn.slogo
share/java/starlogo/projects/rope.slogo
share/java/starlogo/projects/termites.slogo
share/java/starlogo/projects/tree.slogo
share/java/starlogo/documentation.html
share/java/starlogo/documentation/documentation.html
share/java/starlogo/documentation/documentation/all_commands.htm
share/java/starlogo/documentation/documentation/breeds.htm
share/java/starlogo/documentation/documentation/colors.htm
share/java/starlogo/documentation/documentation/commands_patches.htm
share/java/starlogo/documentation/documentation/commands_turtles.htm
share/java/starlogo/documentation/documentation/commandsboth/abs.htm
share/java/starlogo/documentation/documentation/commandsboth/ageat.htm
share/java/starlogo/documentation/documentation/commandsboth/ageof.htm
share/java/starlogo/documentation/documentation/commandsboth/agetowards.htm
share/java/starlogo/documentation/documentation/commandsboth/and.htm
share/java/starlogo/documentation/documentation/commandsboth/asklistofturtles.htm
share/java/starlogo/documentation/documentation/commandsboth/askpatchat.htm
share/java/starlogo/documentation/documentation/commandsboth/askturtle.htm
share/java/starlogo/documentation/documentation/commandsboth/at.htm
share/java/starlogo/documentation/documentation/commandsboth/atan.htm
share/java/starlogo/documentation/documentation/commandsboth/bf.htm
share/java/starlogo/documentation/documentation/commandsboth/bitand.htm
share/java/starlogo/documentation/documentation/commandsboth/bitnot.htm
share/java/starlogo/documentation/documentation/commandsboth/bitor.htm
share/java/starlogo/documentation/documentation/commandsboth/bitxor.htm
share/java/starlogo/documentation/documentation/commandsboth/bl.htm
share/java/starlogo/documentation/documentation/commandsboth/black.htm
share/java/starlogo/documentation/documentation/commandsboth/blue.htm
share/java/starlogo/documentation/documentation/commandsboth/breedat.htm
share/java/starlogo/documentation/documentation/commandsboth/breedof.htm
share/java/starlogo/documentation/documentation/commandsboth/breedtowards.htm
share/java/starlogo/documentation/documentation/commandsboth/brown.htm
share/java/starlogo/documentation/documentation/commandsboth/case.htm
share/java/starlogo/documentation/documentation/commandsboth/cc.htm
share/java/starlogo/documentation/documentation/commandsboth/clearplot.htm
share/java/starlogo/documentation/documentation/commandsboth/colorat.htm
share/java/starlogo/documentation/documentation/commandsboth/colorof.htm
share/java/starlogo/documentation/documentation/commandsboth/colortowards.htm
share/java/starlogo/documentation/documentation/commandsboth/comment.htm
share/java/starlogo/documentation/documentation/commandsboth/cos.htm
share/java/starlogo/documentation/documentation/commandsboth/countcolor.htm
share/java/starlogo/documentation/documentation/commandsboth/countfrogs.htm
share/java/starlogo/documentation/documentation/commandsboth/countfrogsat.htm
share/java/starlogo/documentation/documentation/commandsboth/countfrogstowards.htm
share/java/starlogo/documentation/documentation/commandsboth/countfrogswith.htm
share/java/starlogo/documentation/documentation/commandsboth/countpatcheswith.htm
share/java/starlogo/documentation/documentation/commandsboth/countpc.htm
share/java/starlogo/documentation/documentation/commandsboth/countturtles.htm
share/java/starlogo/documentation/documentation/commandsboth/countturtlesat.htm
share/java/starlogo/documentation/documentation/commandsboth/countturtlestowards.htm
share/java/starlogo/documentation/documentation/commandsboth/countturtleswith.htm
share/java/starlogo/documentation/documentation/commandsboth/cyan.htm
share/java/starlogo/documentation/documentation/commandsboth/distance.htm
share/java/starlogo/documentation/documentation/commandsboth/distancenowrap.htm
share/java/starlogo/documentation/documentation/commandsboth/div.htm
share/java/starlogo/documentation/documentation/commandsboth/dlist.htm
share/java/starlogo/documentation/documentation/commandsboth/e.htm
share/java/starlogo/documentation/documentation/commandsboth/empty.htm
share/java/starlogo/documentation/documentation/commandsboth/end.htm
share/java/starlogo/documentation/documentation/commandsboth/every.htm
share/java/starlogo/documentation/documentation/commandsboth/exp.htm
share/java/starlogo/documentation/documentation/commandsboth/first.htm
share/java/starlogo/documentation/documentation/commandsboth/food.htm
share/java/starlogo/documentation/documentation/commandsboth/foodat.htm
share/java/starlogo/documentation/documentation/commandsboth/foodtowards.htm
share/java/starlogo/documentation/documentation/commandsboth/fput.htm
share/java/starlogo/documentation/documentation/commandsboth/getrandomseed.htm
share/java/starlogo/documentation/documentation/commandsboth/grab.htm
share/java/starlogo/documentation/documentation/commandsboth/gray.htm
share/java/starlogo/documentation/documentation/commandsboth/green.htm
share/java/starlogo/documentation/documentation/commandsboth/headingat.htm
share/java/starlogo/documentation/documentation/commandsboth/headingof.htm
share/java/starlogo/documentation/documentation/commandsboth/headingtowards.htm
share/java/starlogo/documentation/documentation/commandsboth/if.htm
share/java/starlogo/documentation/documentation/commandsboth/ifelse.htm
share/java/starlogo/documentation/documentation/commandsboth/ignore.htm
share/java/starlogo/documentation/documentation/commandsboth/ilist.htm
share/java/starlogo/documentation/documentation/commandsboth/importpicture.htm
share/java/starlogo/documentation/documentation/commandsboth/importpicturename.htm
share/java/starlogo/documentation/documentation/commandsboth/index.html
share/java/starlogo/documentation/documentation/commandsboth/int.htm
share/java/starlogo/documentation/documentation/commandsboth/item.htm
share/java/starlogo/documentation/documentation/commandsboth/kill.htm
share/java/starlogo/documentation/documentation/commandsboth/last.htm
share/java/starlogo/documentation/documentation/commandsboth/length.htm
share/java/starlogo/documentation/documentation/commandsboth/let.htm
share/java/starlogo/documentation/documentation/commandsboth/lime.htm
share/java/starlogo/documentation/documentation/commandsboth/list.htm
share/java/starlogo/documentation/documentation/commandsboth/listoffrogs.htm
share/java/starlogo/documentation/documentation/commandsboth/listoffrogsat.htm
share/java/starlogo/documentation/documentation/commandsboth/listoffrogstowards.htm
share/java/starlogo/documentation/documentation/commandsboth/listoffrogswith.htm
share/java/starlogo/documentation/documentation/commandsboth/listofturtles.htm
share/java/starlogo/documentation/documentation/commandsboth/listofturtlesat.htm
share/java/starlogo/documentation/documentation/commandsboth/listofturtlestowards.htm
share/java/starlogo/documentation/documentation/commandsboth/listofturtleswith.htm
share/java/starlogo/documentation/documentation/commandsboth/listqu.htm
share/java/starlogo/documentation/documentation/commandsboth/ln.htm
share/java/starlogo/documentation/documentation/commandsboth/loop.htm
share/java/starlogo/documentation/documentation/commandsboth/lput.htm
share/java/starlogo/documentation/documentation/commandsboth/magenta.htm
share/java/starlogo/documentation/documentation/commandsboth/max.htm
share/java/starlogo/documentation/documentation/commandsboth/maxnum.htm
share/java/starlogo/documentation/documentation/commandsboth/maxoffrogswith.htm
share/java/starlogo/documentation/documentation/commandsboth/maxofpatcheswith.htm
share/java/starlogo/documentation/documentation/commandsboth/maxofturtleswith.htm
share/java/starlogo/documentation/documentation/commandsboth/memberqu.htm
share/java/starlogo/documentation/documentation/commandsboth/min.htm
share/java/starlogo/documentation/documentation/commandsboth/minnum.htm
share/java/starlogo/documentation/documentation/commandsboth/minoffrogswith.htm
share/java/starlogo/documentation/documentation/commandsboth/minofpatcheswith.htm
share/java/starlogo/documentation/documentation/commandsboth/minofturtleswith.htm
share/java/starlogo/documentation/documentation/commandsboth/mod.htm
share/java/starlogo/documentation/documentation/commandsboth/nobody.htm
share/java/starlogo/documentation/documentation/commandsboth/not.htm
share/java/starlogo/documentation/documentation/commandsboth/numberqu.htm
share/java/starlogo/documentation/documentation/commandsboth/oneoffrogs.htm
share/java/starlogo/documentation/documentation/commandsboth/oneoffrogsat.htm
share/java/starlogo/documentation/documentation/commandsboth/oneoffrogstowards.htm
share/java/starlogo/documentation/documentation/commandsboth/oneofturtles.htm
share/java/starlogo/documentation/documentation/commandsboth/oneofturtlesat.htm
share/java/starlogo/documentation/documentation/commandsboth/oneofturtlestowards.htm
share/java/starlogo/documentation/documentation/commandsboth/or.htm
share/java/starlogo/documentation/documentation/commandsboth/orange.htm
share/java/starlogo/documentation/documentation/commandsboth/output.htm
share/java/starlogo/documentation/documentation/commandsboth/partner.htm
share/java/starlogo/documentation/documentation/commandsboth/partners.htm
share/java/starlogo/documentation/documentation/commandsboth/patchesown.htm
share/java/starlogo/documentation/documentation/commandsboth/pc.htm
share/java/starlogo/documentation/documentation/commandsboth/pcat.htm
share/java/starlogo/documentation/documentation/commandsboth/pctowards.htm
share/java/starlogo/documentation/documentation/commandsboth/pendownquat.htm
share/java/starlogo/documentation/documentation/commandsboth/pendownquof.htm
share/java/starlogo/documentation/documentation/commandsboth/pendownqutowards.htm
share/java/starlogo/documentation/documentation/commandsboth/pi.htm
share/java/starlogo/documentation/documentation/commandsboth/pick.htm
share/java/starlogo/documentation/documentation/commandsboth/pink.htm
share/java/starlogo/documentation/documentation/commandsboth/playsound.htm
share/java/starlogo/documentation/documentation/commandsboth/plot.htm
share/java/starlogo/documentation/documentation/commandsboth/plottitle.htm
share/java/starlogo/documentation/documentation/commandsboth/plotxlabel.htm
share/java/starlogo/documentation/documentation/commandsboth/plotxmax.htm
share/java/starlogo/documentation/documentation/commandsboth/plotxmin.htm
share/java/starlogo/documentation/documentation/commandsboth/plotylabel.htm
share/java/starlogo/documentation/documentation/commandsboth/plotymax.htm
share/java/starlogo/documentation/documentation/commandsboth/plotymin.htm
share/java/starlogo/documentation/documentation/commandsboth/position.htm
share/java/starlogo/documentation/documentation/commandsboth/pp.htm
share/java/starlogo/documentation/documentation/commandsboth/ppc.htm
share/java/starlogo/documentation/documentation/commandsboth/ppd.htm
share/java/starlogo/documentation/documentation/commandsboth/ppreset.htm
share/java/starlogo/documentation/documentation/commandsboth/ppu.htm
share/java/starlogo/documentation/documentation/commandsboth/ppxcor.htm
share/java/starlogo/documentation/documentation/commandsboth/ppycor.htm
share/java/starlogo/documentation/documentation/commandsboth/predilist.htm
share/java/starlogo/documentation/documentation/commandsboth/random.htm
share/java/starlogo/documentation/documentation/commandsboth/randomgaussian.htm
share/java/starlogo/documentation/documentation/commandsboth/red.htm
share/java/starlogo/documentation/documentation/commandsboth/repeat.htm
share/java/starlogo/documentation/documentation/commandsboth/resett.htm
share/java/starlogo/documentation/documentation/commandsboth/round.htm
share/java/starlogo/documentation/documentation/commandsboth/screenhalfheight.htm
share/java/starlogo/documentation/documentation/commandsboth/screenhalfwidth.htm
share/java/starlogo/documentation/documentation/commandsboth/screenheight.htm
share/java/starlogo/documentation/documentation/commandsboth/screenwidth.htm
share/java/starlogo/documentation/documentation/commandsboth/se.htm
share/java/starlogo/documentation/documentation/commandsboth/seplotylabel.htm
share/java/starlogo/documentation/documentation/commandsboth/set.htm
share/java/starlogo/documentation/documentation/commandsboth/setageat.htm
share/java/starlogo/documentation/documentation/commandsboth/setageof.htm
share/java/starlogo/documentation/documentation/commandsboth/setagetowards.htm
share/java/starlogo/documentation/documentation/commandsboth/setbreedat.htm
share/java/starlogo/documentation/documentation/commandsboth/setbreedof.htm
share/java/starlogo/documentation/documentation/commandsboth/setbreedtowards.htm
share/java/starlogo/documentation/documentation/commandsboth/setcat.htm
share/java/starlogo/documentation/documentation/commandsboth/setcof.htm
share/java/starlogo/documentation/documentation/commandsboth/setctowards.htm
share/java/starlogo/documentation/documentation/commandsboth/setfood.htm
share/java/starlogo/documentation/documentation/commandsboth/setfoodat.htm
share/java/starlogo/documentation/documentation/commandsboth/setfoodtowards.htm
share/java/starlogo/documentation/documentation/commandsboth/sethat.htm
share/java/starlogo/documentation/documentation/commandsboth/sethof.htm
share/java/starlogo/documentation/documentation/commandsboth/sethtowards.htm
share/java/starlogo/documentation/documentation/commandsboth/setitem.htm
share/java/starlogo/documentation/documentation/commandsboth/setpc.htm
share/java/starlogo/documentation/documentation/commandsboth/setpendownquat.htm
share/java/starlogo/documentation/documentation/commandsboth/setpendownquof.htm
share/java/starlogo/documentation/documentation/commandsboth/setpendownqutowards.htm
share/java/starlogo/documentation/documentation/commandsboth/setplottitle.htm
share/java/starlogo/documentation/documentation/commandsboth/setplotxlabel.htm
share/java/starlogo/documentation/documentation/commandsboth/setplotxmax.htm
share/java/starlogo/documentation/documentation/commandsboth/setplotxmin.htm
share/java/starlogo/documentation/documentation/commandsboth/setplotxrange.htm
share/java/starlogo/documentation/documentation/commandsboth/setplotylabel.htm
share/java/starlogo/documentation/documentation/commandsboth/setplotymax.htm
share/java/starlogo/documentation/documentation/commandsboth/setplotymin.htm
share/java/starlogo/documentation/documentation/commandsboth/setplotyrange.htm
share/java/starlogo/documentation/documentation/commandsboth/setppc.htm
share/java/starlogo/documentation/documentation/commandsboth/setshownquat.htm
share/java/starlogo/documentation/documentation/commandsboth/setshownquof.htm
share/java/starlogo/documentation/documentation/commandsboth/setshownqutowards.htm
share/java/starlogo/documentation/documentation/commandsboth/setxcorat.htm
share/java/starlogo/documentation/documentation/commandsboth/setxcorof.htm
share/java/starlogo/documentation/documentation/commandsboth/setxcortowards.htm
share/java/starlogo/documentation/documentation/commandsboth/setycorat.htm
share/java/starlogo/documentation/documentation/commandsboth/setycorof.htm
share/java/starlogo/documentation/documentation/commandsboth/setycortowards.htm
share/java/starlogo/documentation/documentation/commandsboth/show.htm
share/java/starlogo/documentation/documentation/commandsboth/shownquat.htm
share/java/starlogo/documentation/documentation/commandsboth/shownquof.htm
share/java/starlogo/documentation/documentation/commandsboth/shownqutowards.htm
share/java/starlogo/documentation/documentation/commandsboth/sin.htm
share/java/starlogo/documentation/documentation/commandsboth/sky.htm
share/java/starlogo/documentation/documentation/commandsboth/sprout.htm
share/java/starlogo/documentation/documentation/commandsboth/sqrt.htm
share/java/starlogo/documentation/documentation/commandsboth/stamp.htm
share/java/starlogo/documentation/documentation/commandsboth/stampat.htm
share/java/starlogo/documentation/documentation/commandsboth/stop.htm
share/java/starlogo/documentation/documentation/commandsboth/stopall.htm
share/java/starlogo/documentation/documentation/commandsboth/sumoffrogs.htm
share/java/starlogo/documentation/documentation/commandsboth/sumoffrogswith.htm
share/java/starlogo/documentation/documentation/commandsboth/sumofpatches.htm
share/java/starlogo/documentation/documentation/commandsboth/sumofpatcheswith.htm
share/java/starlogo/documentation/documentation/commandsboth/sumofturtles.htm
share/java/starlogo/documentation/documentation/commandsboth/sumofturtleswith.htm
share/java/starlogo/documentation/documentation/commandsboth/symbols.htm
share/java/starlogo/documentation/documentation/commandsboth/symbolsequiv.htm
share/java/starlogo/documentation/documentation/commandsboth/symbolsmath.htm
share/java/starlogo/documentation/documentation/commandsboth/tan.htm
share/java/starlogo/documentation/documentation/commandsboth/timer.htm
share/java/starlogo/documentation/documentation/commandsboth/to.htm
share/java/starlogo/documentation/documentation/commandsboth/todelimitedstring.htm
share/java/starlogo/documentation/documentation/commandsboth/tostring.htm
share/java/starlogo/documentation/documentation/commandsboth/towards.htm
share/java/starlogo/documentation/documentation/commandsboth/towardsnowrap.htm
share/java/starlogo/documentation/documentation/commandsboth/turquoise.htm
share/java/starlogo/documentation/documentation/commandsboth/turtlesown.htm
share/java/starlogo/documentation/documentation/commandsboth/type.htm
share/java/starlogo/documentation/documentation/commandsboth/viewplot.htm
share/java/starlogo/documentation/documentation/commandsboth/violet.htm
share/java/starlogo/documentation/documentation/commandsboth/wait.htm
share/java/starlogo/documentation/documentation/commandsboth/waituntil.htm
share/java/starlogo/documentation/documentation/commandsboth/white.htm
share/java/starlogo/documentation/documentation/commandsboth/wordqu.htm
share/java/starlogo/documentation/documentation/commandsboth/xcorat.htm
share/java/starlogo/documentation/documentation/commandsboth/xcorof.htm
share/java/starlogo/documentation/documentation/commandsboth/xcortowards.htm
share/java/starlogo/documentation/documentation/commandsboth/xor.htm
share/java/starlogo/documentation/documentation/commandsboth/ycorat.htm
share/java/starlogo/documentation/documentation/commandsboth/ycorof.htm
share/java/starlogo/documentation/documentation/commandsboth/ycortowards.htm
share/java/starlogo/documentation/documentation/commandsboth/yellow.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/askfrogs.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/askpatches.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/askturtles.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/ca.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/cg.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/clearinfo.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/co.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/cp.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/createanddo.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/createfrogs.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/createfrogsanddo.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/crt.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/ct.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/diffuse.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/diffuse4.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/globals.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/index.html
share/java/starlogo/documentation/documentation/commandsobserveronly/infoname.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/inspectturtle.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/maxofpatcheswith.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/minofpatcheswith.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/nsum.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/nsum4.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/outputname.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/print.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/projectname.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/saveinfo.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/saveinfoas.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/saveoutput.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/saveoutputas.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/saveproject.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/saveprojectas.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/scalepc.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/setcountplotpens.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/setinfoname.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/setoutputname.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/setprojectname.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/setrandomseed.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/settime.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/startup.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/sumofpatcheswith.htm
share/java/starlogo/documentation/documentation/commandsobserveronly/time.htm
share/java/starlogo/documentation/documentation/control_flow.htm
share/java/starlogo/documentation/documentation/data_types.htm
share/java/starlogo/documentation/documentation/display.htm
share/java/starlogo/documentation/documentation/faq.htm
share/java/starlogo/documentation/documentation/files-page.htm
share/java/starlogo/documentation/documentation/getting_started.htm
share/java/starlogo/documentation/documentation/index.html
share/java/starlogo/documentation/documentation/java_tutorial.htm
share/java/starlogo/documentation/documentation/lists.htm
share/java/starlogo/documentation/documentation/math.htm
share/java/starlogo/documentation/documentation/others/breeds.htm
share/java/starlogo/documentation/documentation/others/colorref.htm
share/java/starlogo/documentation/documentation/others/ilist.htm
share/java/starlogo/documentation/documentation/others/intro.htm
share/java/starlogo/documentation/documentation/plotting.htm
share/java/starlogo/documentation/documentation/popups.js
share/java/starlogo/documentation/documentation/printable/breeds.htm
share/java/starlogo/documentation/documentation/printable/color.htm
share/java/starlogo/documentation/documentation/printable/commands_patches.htm
share/java/starlogo/documentation/documentation/printable/commands_turtles.htm
share/java/starlogo/documentation/documentation/printable/control_flow.htm
share/java/starlogo/documentation/documentation/printable/display.htm
share/java/starlogo/documentation/documentation/printable/files.htm
share/java/starlogo/documentation/documentation/printable/index.html
share/java/starlogo/documentation/documentation/printable/list.htm
share/java/starlogo/documentation/documentation/printable/math.htm
share/java/starlogo/documentation/documentation/printable/plotting.htm
share/java/starlogo/documentation/documentation/printable/variables.htm
share/java/starlogo/documentation/documentation/readme.txt
share/java/starlogo/documentation/documentation/turtlesonly/age.htm
share/java/starlogo/documentation/documentation/turtlesonly/bk.htm
share/java/starlogo/documentation/documentation/turtlesonly/breed.htm
share/java/starlogo/documentation/documentation/turtlesonly/color.htm
share/java/starlogo/documentation/documentation/turtlesonly/countfrogshere.htm
share/java/starlogo/documentation/documentation/turtlesonly/countturtleshere.htm
share/java/starlogo/documentation/documentation/turtlesonly/die.htm
share/java/starlogo/documentation/documentation/turtlesonly/dx.htm
share/java/starlogo/documentation/documentation/turtlesonly/dy.htm
share/java/starlogo/documentation/documentation/turtlesonly/fd.htm
share/java/starlogo/documentation/documentation/turtlesonly/hatch.htm
share/java/starlogo/documentation/documentation/turtlesonly/heading.htm
share/java/starlogo/documentation/documentation/turtlesonly/home.htm
share/java/starlogo/documentation/documentation/turtlesonly/ht.htm
share/java/starlogo/documentation/documentation/turtlesonly/ifbreedfrogs.htm
share/java/starlogo/documentation/documentation/turtlesonly/index.html
share/java/starlogo/documentation/documentation/turtlesonly/jump.htm
share/java/starlogo/documentation/documentation/turtlesonly/leap.htm
share/java/starlogo/documentation/documentation/turtlesonly/listoffrogshere.htm
share/java/starlogo/documentation/documentation/turtlesonly/listofturtleshere.htm
share/java/starlogo/documentation/documentation/turtlesonly/lt.htm
share/java/starlogo/documentation/documentation/turtlesonly/myself.htm
share/java/starlogo/documentation/documentation/turtlesonly/oneoffrogshere.htm
share/java/starlogo/documentation/documentation/turtlesonly/oneofturtleshere.htm
share/java/starlogo/documentation/documentation/turtlesonly/pc.htm
share/java/starlogo/documentation/documentation/turtlesonly/pcahead.htm
share/java/starlogo/documentation/documentation/turtlesonly/pd.htm
share/java/starlogo/documentation/documentation/turtlesonly/pendownqu.htm
share/java/starlogo/documentation/documentation/turtlesonly/pstamp.htm
share/java/starlogo/documentation/documentation/turtlesonly/pstampat.htm
share/java/starlogo/documentation/documentation/turtlesonly/pstamptowards.htm
share/java/starlogo/documentation/documentation/turtlesonly/pu.htm
share/java/starlogo/documentation/documentation/turtlesonly/rt.htm
share/java/starlogo/documentation/documentation/turtlesonly/scalecolor.htm
share/java/starlogo/documentation/documentation/turtlesonly/setage.htm
share/java/starlogo/documentation/documentation/turtlesonly/setbreed.htm
share/java/starlogo/documentation/documentation/turtlesonly/setc.htm
share/java/starlogo/documentation/documentation/turtlesonly/seth.htm
share/java/starlogo/documentation/documentation/turtlesonly/setx.htm
share/java/starlogo/documentation/documentation/turtlesonly/setxy.htm
share/java/starlogo/documentation/documentation/turtlesonly/sety.htm
share/java/starlogo/documentation/documentation/turtlesonly/shownqu.htm
share/java/starlogo/documentation/documentation/turtlesonly/st.htm
share/java/starlogo/documentation/documentation/turtlesonly/stamp.htm
share/java/starlogo/documentation/documentation/turtlesonly/stampat.htm
share/java/starlogo/documentation/documentation/turtlesonly/stamptowards.htm
share/java/starlogo/documentation/documentation/turtlesonly/step.htm
share/java/starlogo/documentation/documentation/turtlesonly/who.htm
share/java/starlogo/documentation/documentation/turtlesonly/xcor.htm
share/java/starlogo/documentation/documentation/turtlesonly/ycor.htm
share/java/starlogo/documentation/documentation/tutorial/button.gif
share/java/starlogo/documentation/documentation/tutorial/index.html
share/java/starlogo/documentation/documentation/tutorial/observcom.gif
share/java/starlogo/documentation/documentation/tutorial/paint.gif
share/java/starlogo/documentation/documentation/tutorial/setup.gif
share/java/starlogo/documentation/documentation/tutorial/termites.gif
share/java/starlogo/documentation/documentation/tutorial/turtlecom.gif
share/java/starlogo/documentation/documentation/variables.htm
share/java/starlogo/documentation/projects/index.html
share/java/starlogo/documentation/projects/samples/bees.htm
share/java/starlogo/documentation/projects/samples/bees_source.htm
share/java/starlogo/documentation/projects/samples/circle.htm
share/java/starlogo/documentation/projects/samples/circle_source.htm
share/java/starlogo/documentation/projects/samples/collisions.htm
share/java/starlogo/documentation/projects/samples/collisions_source.htm
share/java/starlogo/documentation/projects/samples/dla.htm
share/java/starlogo/documentation/projects/samples/dla_source.htm
share/java/starlogo/documentation/projects/samples/firefly.htm
share/java/starlogo/documentation/projects/samples/firefly_source.htm
share/java/starlogo/documentation/projects/samples/gaussian.htm
share/java/starlogo/documentation/projects/samples/gaussian_source.htm
share/java/starlogo/documentation/projects/samples/horn.htm
share/java/starlogo/documentation/projects/samples/horn_source.htm
share/java/starlogo/documentation/projects/samples/images/ant.1.gif
share/java/starlogo/documentation/projects/samples/images/ant.2.gif
share/java/starlogo/documentation/projects/samples/images/ant.3.gif
share/java/starlogo/documentation/projects/samples/images/ant.4.gif
share/java/starlogo/documentation/projects/samples/images/ant.5.gif
share/java/starlogo/documentation/projects/samples/images/bees1.GIF
share/java/starlogo/documentation/projects/samples/images/bees2.GIF
share/java/starlogo/documentation/projects/samples/images/bees3.GIF
share/java/starlogo/documentation/projects/samples/images/circle.1.gif
share/java/starlogo/documentation/projects/samples/images/circle.2.gif
share/java/starlogo/documentation/projects/samples/images/circle.3.gif
share/java/starlogo/documentation/projects/samples/images/circle_1.gif
share/java/starlogo/documentation/projects/samples/images/circle_2.gif
share/java/starlogo/documentation/projects/samples/images/circle_3.gif
share/java/starlogo/documentation/projects/samples/images/collisions1.gif
share/java/starlogo/documentation/projects/samples/images/collisions2.gif
share/java/starlogo/documentation/projects/samples/images/collisions3.gif
share/java/starlogo/documentation/projects/samples/images/dla.1.gif
share/java/starlogo/documentation/projects/samples/images/dla.2.gif
share/java/starlogo/documentation/projects/samples/images/dla.3.gif
share/java/starlogo/documentation/projects/samples/images/dla.4.gif
share/java/starlogo/documentation/projects/samples/images/dla2.gif
share/java/starlogo/documentation/projects/samples/images/dla3.gif
share/java/starlogo/documentation/projects/samples/images/dla4.gif
share/java/starlogo/documentation/projects/samples/images/firefly.gif
share/java/starlogo/documentation/projects/samples/images/firefly1.gif
share/java/starlogo/documentation/projects/samples/images/firefly2.gif
share/java/starlogo/documentation/projects/samples/images/firefly3.gif
share/java/starlogo/documentation/projects/samples/images/gaussian.1.gif
share/java/starlogo/documentation/projects/samples/images/gaussian.2.gif
share/java/starlogo/documentation/projects/samples/images/gaussian.3.gif
share/java/starlogo/documentation/projects/samples/images/gaussian.4.gif
share/java/starlogo/documentation/projects/samples/images/gaussian.5.gif
share/java/starlogo/documentation/projects/samples/images/gaussian1.gif
share/java/starlogo/documentation/projects/samples/images/gaussian2.gif
share/java/starlogo/documentation/projects/samples/images/gaussian3.gif
share/java/starlogo/documentation/projects/samples/images/graphics.1.gif
share/java/starlogo/documentation/projects/samples/images/graphics.2.gif
share/java/starlogo/documentation/projects/samples/images/graphics.3.gif
share/java/starlogo/documentation/projects/samples/images/home.gif
share/java/starlogo/documentation/projects/samples/images/horn.1.gif
share/java/starlogo/documentation/projects/samples/images/horn.2.gif
share/java/starlogo/documentation/projects/samples/images/horn.3.gif
share/java/starlogo/documentation/projects/samples/images/logogrn.gif
share/java/starlogo/documentation/projects/samples/images/perfume1.gif
share/java/starlogo/documentation/projects/samples/images/perfume2.gif
share/java/starlogo/documentation/projects/samples/images/perfume3.gif
share/java/starlogo/documentation/projects/samples/images/rabbits1.gif
share/java/starlogo/documentation/projects/samples/images/rabbits2.gif
share/java/starlogo/documentation/projects/samples/images/rabbits3.gif
share/java/starlogo/documentation/projects/samples/images/rope.1.gif
share/java/starlogo/documentation/projects/samples/images/rope.2.gif
share/java/starlogo/documentation/projects/samples/images/rope.3.gif
share/java/starlogo/documentation/projects/samples/images/rope.inter.gif
share/java/starlogo/documentation/projects/samples/images/sirpinski1.gif
share/java/starlogo/documentation/projects/samples/images/sirpinski2.gif
share/java/starlogo/documentation/projects/samples/images/sirpinski3.gif
share/java/starlogo/documentation/projects/samples/images/slime1.gif
share/java/starlogo/documentation/projects/samples/images/slime2.gif
share/java/starlogo/documentation/projects/samples/images/slime3.gif
share/java/starlogo/documentation/projects/samples/images/slyme.gif
share/java/starlogo/documentation/projects/samples/images/smlogo.gif
share/java/starlogo/documentation/projects/samples/images/ss_bees_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_circle_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_collisions_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_dla_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_firefly_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_gaussian_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_gobutton.GIF
share/java/starlogo/documentation/projects/samples/images/ss_horn_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_newbutton.GIF
share/java/starlogo/documentation/projects/samples/images/ss_paint_palette.GIF
share/java/starlogo/documentation/projects/samples/images/ss_perfume_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_rabbits_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_rope_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_sirpinski_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_slime_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_starlogo.gif
share/java/starlogo/documentation/projects/samples/images/ss_starlogo_bmp.BMP
share/java/starlogo/documentation/projects/samples/images/ss_sugarscape_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_termite_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_traffic_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_tree_interface.gif
share/java/starlogo/documentation/projects/samples/images/ss_turtle_interface1.gif
share/java/starlogo/documentation/projects/samples/images/ss_turtle_interface2.gif
share/java/starlogo/documentation/projects/samples/images/starlogo.gif
share/java/starlogo/documentation/projects/samples/images/sugarscape.gif
share/java/starlogo/documentation/projects/samples/images/sugarscape1.gif
share/java/starlogo/documentation/projects/samples/images/sugarscape2.gif
share/java/starlogo/documentation/projects/samples/images/sugarscape3.gif
share/java/starlogo/documentation/projects/samples/images/termite.1.gif
share/java/starlogo/documentation/projects/samples/images/termite.2.gif
share/java/starlogo/documentation/projects/samples/images/termite.3.gif
share/java/starlogo/documentation/projects/samples/images/termite.4.gif
share/java/starlogo/documentation/projects/samples/images/termite.5.gif
share/java/starlogo/documentation/projects/samples/images/termite.inter.gif
share/java/starlogo/documentation/projects/samples/images/termite.small.gif
share/java/starlogo/documentation/projects/samples/images/traffic1.gif
share/java/starlogo/documentation/projects/samples/images/traffic2.gif
share/java/starlogo/documentation/projects/samples/images/traffic3.gif
share/java/starlogo/documentation/projects/samples/images/trails3.gif
share/java/starlogo/documentation/projects/samples/images/tree.1.gif
share/java/starlogo/documentation/projects/samples/images/tree.2.gif
share/java/starlogo/documentation/projects/samples/images/tree.3.gif
share/java/starlogo/documentation/projects/samples/images/tree.small.gif
share/java/starlogo/documentation/projects/samples/index.html
share/java/starlogo/documentation/projects/samples/perfume.htm
share/java/starlogo/documentation/projects/samples/perfume_source.htm
share/java/starlogo/documentation/projects/samples/rabbits.htm
share/java/starlogo/documentation/projects/samples/rabbits_source.htm
share/java/starlogo/documentation/projects/samples/rope.htm
share/java/starlogo/documentation/projects/samples/rope_source.htm
share/java/starlogo/documentation/projects/samples/sirpinski.htm
share/java/starlogo/documentation/projects/samples/sirpinski_source.htm
share/java/starlogo/documentation/projects/samples/slime.htm
share/java/starlogo/documentation/projects/samples/slime_source.htm
share/java/starlogo/documentation/projects/samples/sugarscape.htm
share/java/starlogo/documentation/projects/samples/sugarscape_source.htm
share/java/starlogo/documentation/projects/samples/template_projects.htm
share/java/starlogo/documentation/projects/samples/termites.htm
share/java/starlogo/documentation/projects/samples/termites_source.htm
share/java/starlogo/documentation/projects/samples/traffic.htm
share/java/starlogo/documentation/projects/samples/traffic_source.htm
share/java/starlogo/documentation/projects/samples/trails.htm
share/java/starlogo/documentation/projects/samples/trails_source.htm
share/java/starlogo/documentation/projects/samples/tree.htm
share/java/starlogo/documentation/projects/samples/tree_source.htm
share/java/starlogo/documentation/projects/samples/turtle.htm
share/java/starlogo/documentation/projects/samples/turtle_source.htm
share/java/starlogo/documentation/style.css
share/java/starlogo/sample-projects/Biology/bees.slogo
share/java/starlogo/sample-projects/Biology/firefly.slogo
share/java/starlogo/sample-projects/Biology/rabbits.slogo
share/java/starlogo/sample-projects/Biology/slime.slogo
share/java/starlogo/sample-projects/Biology/termites.slogo
share/java/starlogo/sample-projects/Graphics/ant-trails.slogo
share/java/starlogo/sample-projects/Graphics/graphics.slogo
share/java/starlogo/sample-projects/Graphics/horn.slogo
share/java/starlogo/sample-projects/Math/circle.slogo
share/java/starlogo/sample-projects/Math/gaussian.slogo
share/java/starlogo/sample-projects/Math/sirpinksi.slogo
share/java/starlogo/sample-projects/Math/tree.slogo
share/java/starlogo/sample-projects/Physics/collisions.slogo
share/java/starlogo/sample-projects/Physics/dla.slogo
share/java/starlogo/sample-projects/Physics/perfume.slogo
share/java/starlogo/sample-projects/Physics/rope.slogo
share/java/starlogo/sample-projects/Social-Systems/sugarscape.slogo
share/java/starlogo/sample-projects/Social-Systems/traffic.slogo
share/java/starlogo/sounds/applause.au
share/java/starlogo/sounds/bark.au
share/java/starlogo/sounds/bong.au
@ -35,7 +563,26 @@ share/java/starlogo/sounds/spacemusic.au
share/java/starlogo/sounds/splat.au
share/java/starlogo/sounds/train.au
share/java/starlogo/sounds/whistle.au
@dirrm share/java/starlogo/projects
share/java/starlogo/starlogo-solaris
share/java/starlogo/starlogo-unix
share/java/starlogo/starlogo-unix.orig
share/java/starlogo/starlogo.jar
@dirrm share/java/starlogo/sounds
@dirrm share/java/starlogo/sample-projects/Social-Systems
@dirrm share/java/starlogo/sample-projects/Physics
@dirrm share/java/starlogo/sample-projects/Math
@dirrm share/java/starlogo/sample-projects/Graphics
@dirrm share/java/starlogo/sample-projects/Biology
@dirrm share/java/starlogo/sample-projects
@dirrm share/java/starlogo/documentation/projects/samples/images
@dirrm share/java/starlogo/documentation/projects/samples
@dirrm share/java/starlogo/documentation/projects
@dirrm share/java/starlogo/documentation/documentation/tutorial
@dirrm share/java/starlogo/documentation/documentation/turtlesonly
@dirrm share/java/starlogo/documentation/documentation/printable
@dirrm share/java/starlogo/documentation/documentation/others
@dirrm share/java/starlogo/documentation/documentation/commandsobserveronly
@dirrm share/java/starlogo/documentation/documentation/commandsboth
@dirrm share/java/starlogo/documentation/documentation
@dirrm share/java/starlogo/documentation
@dirrm share/java/starlogo
@unexec rmdir %D/share/java || true