Add cvstrac 1.1.2, a Web-Based Bug And Patch-Set Tracking

System For CVS.

PR:		51975
Submitted by:	Bruce M Simpson <bms@spc.org>
This commit is contained in:
Will Andrews 2003-06-03 05:01:12 +00:00
parent 8ffb4a9411
commit eb5d10f4aa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82161
7 changed files with 82 additions and 0 deletions

View file

@ -135,6 +135,7 @@
SUBDIR += cvsplot
SUBDIR += cvsps
SUBDIR += cvsstat
SUBDIR += cvstrac
SUBDIR += cvsutils
SUBDIR += cvsweb
SUBDIR += cvswrap

27
devel/cvstrac/Makefile Normal file
View file

@ -0,0 +1,27 @@
# New ports collection makefile for: cvstrac
# Date created: 29 August 2002
# Whom: Bruce M Simpson <bms@spc.org>
#
# $FreeBSD$
#
PORTNAME= cvstrac
PORTVERSION= 1.1.2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.cvstrac.org/cvstrac/
MAINTAINER= bms@spc.org
COMMENT= Web-Based Bug And Patch-Set Tracking System For CVS
LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite
USE_GMAKE= yes
MAKE_ARGS= SRCDIR=${WRKSRC} PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
NOMAN=
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cvstrac ${PREFIX}/bin
.include <bsd.port.mk>

1
devel/cvstrac/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (cvstrac-1.1.2.tar.gz) = d772b3b68ee74d4c1f9899112a64f121

View file

@ -0,0 +1,37 @@
--- Makefile.orig Thu May 8 10:58:17 2003
+++ Makefile Thu May 8 10:58:32 2003
@@ -0,0 +1,34 @@
+#!/usr/bin/make
+#
+#### The toplevel directory of the source tree.
+#
+#SRCDIR = /home/drh/cvstrac/cvstrac
+
+#### C Compiler and options for use in building executables that
+# will run on the platform that is doing the build.
+#
+BCC = gcc -g -O2 -I$(LOCALBASE)/include
+
+#### The suffix to add to executable files. ".exe" for windows.
+# Nothing for unix.
+#
+E =
+
+#### C Compile and options for use in building executables that
+# will run on the target platform. This is usually the same
+# as BCC, unless you are cross-compiling.
+#
+TCC = gcc -g -O0 -Wall -I$(LOCALBASE)/include
+
+#### Extra arguments for linking against SQLite
+#
+LIBSQLITE = -L$(LOCALBASE)/lib -lsqlite -lcrypt
+
+#### Installation directory
+#
+INSTALLDIR = $(PREFIX)/bin
+
+
+# You should not need to change anything below this line
+###############################################################################
+include $(SRCDIR)/main.mk

11
devel/cvstrac/pkg-descr Normal file
View file

@ -0,0 +1,11 @@
CVSTrac is a bug and patch-set tracking system for use with CVS
appropriate for use on projects with up to a few hundred developers.
CVSTrac is designed for low-ceremony development - it provides
mechanisms for tracking changes and bugs without unnecessary
restrictions. It has a built-in Wiki and ticketing system. Both
of these functions can be linked to the CVS tree.
WWW: http://www.cvstrac.org/
Bruce
bms@spc.org

View file

@ -0,0 +1,4 @@
This port will install the cvstrac binary in ${PREFIX}/bin. Please follow
the detailed installation instructions in the CVSTrac Wiki at
http://cvs.cvstrac.org/wiki?p=CvstracInstallation for information on how
to get CVSTrac up and running in your preferred configuration.

1
devel/cvstrac/pkg-plist Normal file
View file

@ -0,0 +1 @@
bin/cvstrac