Rename lang/ficl-devel to lang/ficl, doesn't make sense to have a -devel port

when we don't have a stable one, and since it's using a stable version
This commit is contained in:
Renato Botelho 2010-09-07 13:57:07 +00:00
parent ae520c4e86
commit eb6b6a7d15
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=260696
8 changed files with 2 additions and 187 deletions

1
MOVED
View file

@ -4529,3 +4529,4 @@ java/simplicity||2010-09-04|Distfile(s) no longer available
lang/icc7||2010-09-04|Distfile(s) no longer available
portuguese/staroffice52||2010-09-04|Distfile(s) no longer available
sysutils/linux-acu||2010-09-04|Distfile(s) no longer available
lang/ficl-devel|lang/ficl|2010-09-07|Moved to lang/ficl since it's a stable version

View file

@ -70,7 +70,7 @@
SUBDIR += fasm
SUBDIR += fbbi
SUBDIR += ferite
SUBDIR += ficl-devel
SUBDIR += ficl
SUBDIR += fpc
SUBDIR += fpc-base
SUBDIR += fpc-docs

View file

@ -1,59 +0,0 @@
# New ports collection makefile for: ficl
# Date created: 23 August 2002
# Whom: Bruce M Simpson
#
# $FreeBSD$
#
PORTNAME= ficl
PORTVERSION= 4.0.31
PORTREVISION= 1
CATEGORIES= lang devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-all/${PORTNAME}${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Forth Inspired Command Language
NO_WRKSUBDIR= defined
NOMAN= defined
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
ALL_TARGET= everything
DOCS= releases.html parsesteps.html oop.html locals.html links.html \
license.html index.html api.html ficl.html favicon.ico dpans.html \
debugger.html upgrading.html
DOCS_ARTICLES= sigplan9906.doc oo_in_c.html jwsforml.pdf ficlddj.pdf
DOCS_GRAPHICS= sourceforge.jpg ficl_top.jpg ficl_oop.jpg ficl.4.96.jpg \
ficl.4.64.jpg ficl.4.128.jpg 4ring.gif
DOCS_SOURCE= upgrading.ht releases.ht parsesteps.ht oop.ht locals.ht \
links.ht license.ht index.ht generate.py ficl.ht dpans.ht \
debugger.ht api.ht
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ficl ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/libficl.so.4 ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/libficl.a ${PREFIX}/lib
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${MKDIR} ${DOCSDIR}/source ${DOCSDIR}/articles ${DOCSDIR}/graphics
.for doc in ${DOCS}
${INSTALL_MAN} ${WRKSRC}/doc/${doc} ${DOCSDIR}
.endfor
.for doc in ${DOCS_ARTICLES}
${INSTALL_MAN} ${WRKSRC}/doc/articles/${doc} ${DOCSDIR}/articles
.endfor
.for doc in ${DOCS_GRAPHICS}
${INSTALL_MAN} ${WRKSRC}/doc/graphics/${doc} ${DOCSDIR}/graphics
.endfor
.for doc in ${DOCS_SOURCE}
${INSTALL_MAN} ${WRKSRC}/doc/source/${doc} ${DOCSDIR}/source
.endfor
.endif
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (ficl4.0.31.tar.gz) = 7f9ca6093730554f5f66beaa46a652d4
SHA256 (ficl4.0.31.tar.gz) = 386f642e5a945ddccc02997a59d0519055d6b9d6dbb8a6a2484884774dab3487
SIZE (ficl4.0.31.tar.gz) = 571596

View file

@ -1,59 +0,0 @@
--- Makefile.orig Mon Dec 8 18:32:26 2003
+++ Makefile Mon Dec 8 18:46:08 2003
@@ -0,0 +1,56 @@
+OBJECTS= dictionary.o system.o fileaccess.o float.o double.o prefix.o search.o softcore.o stack.o tools.o vm.o primitives.o bit.o lzuncompress.o unix.o utility.o hash.o callback.o word.o extras.o
+HEADERS= ficl.h ficlplatform/unix.h
+#
+# Flags for shared library
+TARGET= -DFREEBSD
+SHFLAGS = -fPIC
+CFLAGS= -O -c $(SHFLAGS) $(TARGET)
+CC=gcc
+LIB = ar cr
+RANLIB = ranlib
+
+MAJOR = 4
+
+everything: ficl lib
+
+ficl: main.o $(HEADERS) libficl.a
+ $(CC) main.o -o ficl -L. -lficl -lm
+
+lib: libficl.so.$(MAJOR)
+
+# static library build
+libficl.a: $(OBJECTS)
+ $(LIB) libficl.a $(OBJECTS)
+ $(RANLIB) libficl.a
+
+# shared library build
+libficl.so.$(MAJOR): $(OBJECTS)
+ $(CC) -shared -Wl,-soname,libficl.so.$(MAJOR) \
+ -o libficl.so.$(MAJOR) $(OBJECTS)
+ ln -sf libficl.so.$(MAJOR) libficl.so
+
+main: main.o ficl.h sysdep.h libficl.so.$(MAJOR).$(MINOR)
+ $(CC) main.o -o main -L. -lficl -lm
+ ln -sf libficl.so.$(MAJOR) libficl.so
+
+unix.o: ficlplatform/unix.c $(HEADERS)
+ $(CC) $(CFLAGS) -c ficlplatform/unix.c
+
+#
+# generic object code
+#
+.SUFFIXES: .cxx .cc .c .o
+
+.c.o:
+ $(CC) $(CFLAGS) -c $*.c
+
+.cxx.o:
+ $(CPP) $(CPFLAGS) -c $*.cxx
+
+.cc.o:
+ $(CPP) $(CPFLAGS) -c $*.cc
+#
+# generic cleanup code
+#
+clean:
+ rm -f *.o *.a libficl.*

View file

@ -1,11 +0,0 @@
--- ficl.h.orig Mon Dec 8 18:33:42 2003
+++ ficl.h Mon Dec 8 18:33:58 2003
@@ -163,6 +163,8 @@
#include "ficlplatform/ansi.h"
#elif defined(_WIN32)
#include "ficlplatform/win32.h"
+#elif defined (FREEBSD)
+ #include "ficlplatform/unix.h"
#elif defined (FREEBSD_ALPHA)
#include "ficlplatform/alpha.h"
#elif defined(linux)

View file

@ -1,10 +0,0 @@
FICL is an extremely lightweight, fast, portable implementation of FORTH
which can be bound to C functions or even embedded within C/assembler
programs. This is a port for the current version of FICL. Older versions
can typically be found in /usr/src/sys/boot/ficl on FreeBSD with the
bindings needed by the OS loader.
WWW: http://ficl.sourceforge.net/
Bruce
bms@spc.org

View file

@ -1,44 +0,0 @@
lib/libficl.a
lib/libficl.so.4
bin/ficl
%%PORTDOCS%%%%DOCSDIR%%/upgrading.html
%%PORTDOCS%%%%DOCSDIR%%/source/upgrading.ht
%%PORTDOCS%%%%DOCSDIR%%/source/releases.ht
%%PORTDOCS%%%%DOCSDIR%%/source/parsesteps.ht
%%PORTDOCS%%%%DOCSDIR%%/source/oop.ht
%%PORTDOCS%%%%DOCSDIR%%/source/locals.ht
%%PORTDOCS%%%%DOCSDIR%%/source/links.ht
%%PORTDOCS%%%%DOCSDIR%%/source/license.ht
%%PORTDOCS%%%%DOCSDIR%%/source/index.ht
%%PORTDOCS%%%%DOCSDIR%%/source/generate.py
%%PORTDOCS%%%%DOCSDIR%%/source/ficl.ht
%%PORTDOCS%%%%DOCSDIR%%/source/dpans.ht
%%PORTDOCS%%%%DOCSDIR%%/source/debugger.ht
%%PORTDOCS%%%%DOCSDIR%%/source/api.ht
%%PORTDOCS%%@dirrm %%DOCSDIR%%/source
%%PORTDOCS%%%%DOCSDIR%%/releases.html
%%PORTDOCS%%%%DOCSDIR%%/parsesteps.html
%%PORTDOCS%%%%DOCSDIR%%/oop.html
%%PORTDOCS%%%%DOCSDIR%%/locals.html
%%PORTDOCS%%%%DOCSDIR%%/links.html
%%PORTDOCS%%%%DOCSDIR%%/license.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/graphics/sourceforge.jpg
%%PORTDOCS%%%%DOCSDIR%%/graphics/ficl_top.jpg
%%PORTDOCS%%%%DOCSDIR%%/graphics/ficl_oop.jpg
%%PORTDOCS%%%%DOCSDIR%%/graphics/ficl.4.96.jpg
%%PORTDOCS%%%%DOCSDIR%%/graphics/ficl.4.64.jpg
%%PORTDOCS%%%%DOCSDIR%%/graphics/ficl.4.128.jpg
%%PORTDOCS%%%%DOCSDIR%%/graphics/4ring.gif
%%PORTDOCS%%@dirrm %%DOCSDIR%%/graphics
%%PORTDOCS%%%%DOCSDIR%%/ficl.html
%%PORTDOCS%%%%DOCSDIR%%/favicon.ico
%%PORTDOCS%%%%DOCSDIR%%/dpans.html
%%PORTDOCS%%%%DOCSDIR%%/debugger.html
%%PORTDOCS%%%%DOCSDIR%%/articles/sigplan9906.doc
%%PORTDOCS%%%%DOCSDIR%%/articles/oo_in_c.html
%%PORTDOCS%%%%DOCSDIR%%/articles/jwsforml.pdf
%%PORTDOCS%%%%DOCSDIR%%/articles/ficlddj.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%/articles
%%PORTDOCS%%%%DOCSDIR%%/api.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%