Fix things mucked up from the original port I committed:
* Change maintainer to submitter of ports/52446, Rui Lopes <rui@ruilopes.com> (I missed this when I committed this port) * Add libgtkhtml/remove gtk20 from USE_GNOME * Remove the REINPLACEs <debugger> adamw_: we also don't need that first REINPLACE in post-patch. <debugger> adamw_: and I don't known why you have placed the second REINPLACE there :/ * Remove the lib/devhelp dir in the pkg-plist * Add a patch to search for devhelp books in the standard FreeBSD places * Alphabetize the pkg-plist * PORTREVISION bump Submitted by: Rui Lopes <rui@ruilopes.com> (over IRC)
This commit is contained in:
parent
995888be22
commit
eb83fd8701
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82212
3 changed files with 17 additions and 12 deletions
|
@ -7,28 +7,22 @@
|
|||
|
||||
PORTNAME= devhelp
|
||||
PORTVERSION= 0.6.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES?= devel gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
|
||||
DIST_SUBDIR= gnome2
|
||||
|
||||
MAINTAINER?= adamw@FreeBSD.org
|
||||
MAINTAINER= rui@ruilopes.com
|
||||
COMMENT= Developer help browser for GNOME 2
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gtk20 gnomehack gnomeprefix
|
||||
USE_REINPLACE= yes
|
||||
USE_GNOME= gnomehack gnomeprefix libgtkhtml
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
|
||||
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|@LIBS@|@LIBS@ ${PTHREAD_LIBS}|' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
10
devel/devhelp/files/patch-src::dh-base.c
Normal file
10
devel/devhelp/files/patch-src::dh-base.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/dh-base.c.orig Tue Jun 3 12:21:34 2003
|
||||
+++ src/dh-base.c Tue Jun 3 12:23:04 2003
|
||||
@@ -155,6 +155,7 @@
|
||||
|
||||
/* Insert the books from default gtk-doc install path */
|
||||
base_add_books (base, DATADIR"/gtk-doc/html");
|
||||
+ base_add_books (base, DATADIR"/../doc"); // FreeBSD default doc path
|
||||
base_add_books (base, "/usr/share/gtk-doc/html");
|
||||
base_add_books (base, DATADIR"/devhelp/books");
|
||||
dir = g_strconcat (g_getenv ("HOME"), "/.devhelp/books", NULL);
|
|
@ -1,14 +1,14 @@
|
|||
bin/devhelp
|
||||
lib/devhelp/libdevhelp.so
|
||||
share/gnome/applications/devhelp.desktop
|
||||
share/gnome/devhelp/dtd/devhelp-1.dtd
|
||||
share/gnome/devhelp/images/book_open.png
|
||||
share/gnome/devhelp/images/book_closed.png
|
||||
share/gnome/devhelp/images/book_open.png
|
||||
share/gnome/devhelp/images/helpdoc.png
|
||||
share/gnome/devhelp/ui/window.ui
|
||||
share/gnome/pixmaps/devhelp.png
|
||||
share/gnome/applications/devhelp.desktop
|
||||
share/gnome/mime-info/devhelp.keys
|
||||
share/gnome/mime-info/devhelp.mime
|
||||
share/gnome/pixmaps/devhelp.png
|
||||
share/locale/am/LC_MESSAGES/devhelp.mo
|
||||
share/locale/az/LC_MESSAGES/devhelp.mo
|
||||
share/locale/be/LC_MESSAGES/devhelp.mo
|
||||
|
@ -43,3 +43,4 @@ share/locale/zh_TW/LC_MESSAGES/devhelp.mo
|
|||
@dirrm share/gnome/devhelp/images
|
||||
@dirrm share/gnome/devhelp/dtd
|
||||
@dirrm share/gnome/devhelp
|
||||
@dirrm lib/devhelp
|
||||
|
|
Loading…
Reference in a new issue