net/bredbandskollen: remove EXTRA_PATCHES for powerpc*

Now builds without it.
This commit is contained in:
Piotr Kubaj 2022-04-25 14:12:32 +00:00
parent a2d5ef79f6
commit eb9fbff79f
2 changed files with 1 additions and 19 deletions

View file

@ -25,12 +25,6 @@ OPTIONS_DEFINE= GNUTLS
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_MAKE_ARGS= GNUTLS=1
.include <bsd.port.pre.mk>
.if ${ARCH:Mpowerpc*}
EXTRA_PATCHES= ${FILESDIR}/extra-src_framework_socketreceiver.h
.endif
post-patch:
${REINPLACE_CMD} -e 's/CXX = c++/CXX ?= c++/g' \
${WRKSRC}/src/framework/mk.inc
@ -39,4 +33,4 @@ do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/cli ${STAGEDIR}/${PREFIX}/bin/bbk_cli
${LN} -sf bbk_cli ${STAGEDIR}/${PREFIX}/bin/bredbandskollen
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,12 +0,0 @@
--- src/framework/socketreceiver.h.orig 2019-07-05 19:04:13 UTC
+++ src/framework/socketreceiver.h
@@ -3,6 +3,9 @@
#pragma once
+// work around broken? _ALIGN/_ALIGNBYTES on FreeBSD powerpc
+#include <sys/types.h>
+
#include <sys/socket.h>
#include "serversocket.h"
class SocketConnection;